]> git.pld-linux.org Git - packages/python.git/blame - python.spec
- BR: ncurses-devel needed by ncurses-ext-devel required here too
[packages/python.git] / python.spec
CommitLineData
390a4bf0 1#
9ef7b464 2# Conditional build:
d6b7073f 3%bcond_without tkinter # disables tkinter module building
4%bcond_without tests # disables Python testing
5%bcond_with verbose_tests # runs tests in verbose mode
6%bcond_with noautosys # do not put sys.argv[0] directory in sys.path
390a4bf0 7#
ca0308fd
JK
8# tests which will not work on 64-bit platforms
9%define no64bit_tests test_audioop test_rgbimg test_imageop
10# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
717bd422 11%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale
390a4bf0 12# tests which fail because of some unknown/unresolved reason (this list should be empty)
717bd422 13%define broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport
ca0308fd 14
9d0d4238 15%define py_ver 2.3
d12ec25a 16%define py_prefix %{_prefix}
49d1a533 17%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
6c765af5 18%define py_scriptdir %{py_prefix}/share/python%{py_ver}
67c01d08 19%define py_incdir %{_includedir}/python%{py_ver}
d12ec25a 20%define py_sitedir %{py_libdir}/site-packages
6c765af5 21%define py_sitescriptdir %{py_scriptdir}/site-packages
d12ec25a 22%define py_dyndir %{py_libdir}/lib-dynload
23%define py_comp ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
24%define py_ocomp ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
a9ce5112 25
5b13880d 26Summary: Very high level scripting language with X interface
27