]> git.pld-linux.org Git - packages/python.git/blame - python.spec
- s/-{}-/--/ for `-{}-file' -> `--file' in liboptparse.tex
[packages/python.git] / python.spec
CommitLineData
55c63f85
ER
1# TODO
2# - test_distutils fails for unknown reason: (does it still do with new lib64 patch?)
3# AssertionError: '/tmp/tmpaomC0l/installation/share/python' != '/tmp/tmpaomC0l/installation/lib/python'
4# - change searchpath order so /usr/lib* is before /usr/share
5# - kill lib-tk from searchpath
6# - kill BR: file requirement from lib64 patch
390a4bf0 7#
9ef7b464 8# Conditional build:
d6b7073f 9%bcond_without tkinter # disables tkinter module building
10%bcond_without tests # disables Python testing
26f84c7d 11%bcond_with verbose_tests # runs tests in verbose mode
390a4bf0 12#
ca0308fd
JK
13# tests which will not work on 64-bit platforms
14%define no64bit_tests test_audioop test_rgbimg test_imageop
15# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
0070b9d1 16%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
390a4bf0 17# tests which fail because of some unknown/unresolved reason (this list should be empty)
72dcf1e0 18%define broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport test_distutils
72dcf1e0 19
20%define py_ver 2.4
21%define py_prefix %{_prefix}
22%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
23%define py_incdir %{_includedir}/python%{py_ver}
24%define py_sitedir %{py_libdir}/site-packages
25%define py_dyndir %{py_libdir}/lib-dynload
a9ce5112 26
5b13880d 27Summary: Very high level scripting language with X interface
57ffb4c2 28Summary(es): Lenguaje script de alto nivel con interfaz X
fb6664e1 29