]> git.pld-linux.org Git - packages/python-gevent.git/blame - python-gevent.spec
local proxy settings should not cause test failures
[packages/python-gevent.git] / python-gevent.spec
CommitLineData
11497ff2
JK
1
2# TODO:
3# - investigate some of the failing tests
4# (now excluded via known_failures-pld.txt)
5
6# Conditional build:
7%bcond_without tests # do not run tests
8
71c03694 9%define module gevent
78f066e6
ER
10Summary: A coroutine-based Python networking library
11Name: python-%{module}
3cc54920 12Version: 1.0
78f066e6
ER
13Release: 1
14License: MIT
15Group: Development/Languages
16URL: http://www.gevent.org/
17Source0: http://pypi.python.org/packages/source/g/gevent/%{module}-%{version}.tar.gz
3cc54920 18# Source0-md5: 33aef51a06268f5903fea378e1388e4d
11497ff2 19Source1: known_failures-pld.txt
78f066e6
ER
20BuildRequires: libevent-devel >= 1.4.0
21BuildRequires: python-devel
7c3f7ce6 22%if %{with tests}
73d3206b
JK
23BuildRequires: python-greenlet >= 0.3.2
24BuildRequires: python-test
25BuildRequires: python-devel-src
26BuildRequires: rpm-build-macros >= 1.688
7c3f7ce6 27%endif
78f066e6 28BuildRequires: rpm-pythonprov
27ee9f05 29Requires: python-greenlet >= 0.3.2
78f066e6 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71c03694
ER
31
32%description
33gevent is a coroutine-based Python networking library that uses
34greenlet to provide a high-level synchronous API on top of libevent
35event loop.
36
37Features include:
38 - convenient API around greenlets
39 - familiar synchronization primitives (gevent.event, gevent.queue)
40 - socket module that cooperates
41 - WSGI server on top of libevent-http
42 - DNS requests done through libevent-dns
43 - monkey patching utility to get pure Python modules to cooperate
44
45%prep
46%setup -q -n %{module}-%{version}
47
11497ff2
JK
48cat known_failures.txt %{SOURCE1} > known_failures-merged.txt
49
71c03694
ER
50%build
51CC="%{__cc}" \
52CFLAGS="%{rpmcflags}" \
53%{__python} setup.py build
54
31e6d75d
JK
55%if %{with tests}
56cd greentest
57PYTHONPATH=.. python testrunner.py --expected ../known_failures-merged.txt
58cd ..
59%endif
60
71c03694
ER
61%install
62rm -rf $RPM_BUILD_ROOT
63%{__python} setup.py install \
64 --skip-build \
65 --optimize=2 \
66 --root=$RPM_BUILD_ROOT
67
68%py_postclean
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%files
74%defattr(644,root,root,755)
75%doc LICENSE README.rst
78f066e6 76%dir %{py_sitedir}/%{module}
71c03694 77%{py_sitedir}/%{module}/*.py[co]
0f612c0f
JK
78%attr(755,root,root) %{py_sitedir}/%{module}/_semaphore.so
79%attr(755,root,root) %{py_sitedir}/%{module}/_util.so
80%attr(755,root,root) %{py_sitedir}/%{module}/ares.so
71c03694
ER
81%attr(755,root,root) %{py_sitedir}/%{module}/core.so
82%if "%{py_ver}" > "2.4"
83%{py_sitedir}/%{module}-%{version}-py%{py_ver}.egg-info
84%endif
This page took 0.033707 seconds and 4 git commands to generate.