]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blame - php-pecl-xdebug.spec
- updated to 2.1.3
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
CommitLineData
266b1c9d
ER
1%define modname xdebug
2%define status stable
266b1c9d
ER
3Summary: %{modname} - provides functions for functions traces and profiling
4Summary(pl.UTF-8): %{modname} - funkcje do śledzenia i profilowania funkcji
5Name: php-pecl-%{modname}
ac4ed85d 6Version: 2.1.3
3f436407 7Release: 1
82a74d97 8License: BSD style
d6c5cc9f 9Group: Development/Languages/PHP
472e26b5 10Source0: http://www.xdebug.org/files/xdebug-%{version}.tgz
ac4ed85d 11# Source0-md5: 601128a91dea4f315330ce3f7ddcc3d8
336ff3f6 12Source1: %{name}.ini
6d9ef3e4 13URL: http://www.xdebug.org/
e8a9b5ad 14BuildRequires: libedit-devel
aba255b5 15BuildRequires: libtool
7c227a4b
ER
16BuildRequires: php-devel >= 4:5.3.0
17BuildRequires: rpmbuild(macros) >= 1.579
3464b421 18%{?requires_zend_extension}
022c051a 19Conflicts: ZendOptimizer
d6c5cc9f
AG
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
d6c5cc9f 22%description
cc7edbad
JB
23The Xdebug extension helps you debugging your script by providing a
24lot of valuable debug information. The debug information that Xdebug
25can provide includes the following:
82a74d97
AG
26
27- stack and function traces in error messages with:
20519407
ER
28 - full parameter display for user defined functions
29 - function name, file name and line indications
30 - support for member functions memory allocation
82a74d97
AG
31- protection for infinite recursions
32
33Xdebug also provides:
d6c5cc9f 34
82a74d97
AG
35- profiling information for PHP scripts
36- script execution analysis
37- capabilities to debug your scripts interactively with a debug client
98b3abb8 38
266b1c9d 39In PECL status of this package is: %{status}.
98b3abb8 40
2c8c4667
JR
41%description -l pl.UTF-8
42Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
43dużo wartościowych informacji. Informacje przydatne do śledzenia,
44które może zapewnić Xdebug, obejmują:
cc7edbad 45
2c8c4667
JR
46- śledzenie stosu i funkcji w komunikatach błędów wraz z:
47 - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
48 użytkownika
49 - nazwami funkcji, nazwami plików i numerami linii
50 - obsługą metod klas
51- przydzielanie pamięci
52- zabezpieczenie przed nieskończoną rekurencją
cc7edbad 53
2c8c4667 54Xdebug dostarcza także:
cc7edbad 55
2c8c4667
JR
56- informacje do profilowania skryptów PHP
57- analizę wywołań skryptu
58- możliwość śledzenia skryptów interaktywnie przy pomocy klienta
cc7edbad
JB
59 odpluskwiacza
60
266b1c9d 61To rozszerzenie ma w PECL status: %{status}.
d6c5cc9f
AG
62
63%prep
266b1c9d
ER
64%setup -qc
65mv %{modname}-%{version}*/* .
aba255b5 66chmod +x debugclient/configure
d6c5cc9f 67
7c227a4b 68%{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
50d01b8c 69
aba255b5 70%build
dcaafe35 71# libtool 2.2 build fix
266b1c9d
ER
72if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
73 cat %{_aclocaldir}/ltsugar.m4 >> config.m4
74 cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
75
76 cat %{_aclocaldir}/ltversion.m4 >> config.m4
77 cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
78
79 cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
80 cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
81
82 cat %{_aclocaldir}/ltoptions.m4 >> config.m4
83 cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
84
85 cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
dcaafe35 86fi
50d01b8c 87
d6c5cc9f
AG
88phpize
89%configure
90%{__make}
e8a9b5ad 91cd debugclient
b79d4446 92install /usr/share/automake/{config.*,depcomp} .
aba255b5 93%{__libtoolize}
e8a9b5ad
AM
94%{__aclocal}
95%{__autoconf}
96%configure \
97 --with-libedit
98%{__make}
d6c5cc9f
AG
99
100%install
101rm -rf $RPM_BUILD_ROOT
266b1c9d 102install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
d6c5cc9f 103
266b1c9d
ER
104install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}-debugclient
105install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
106cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
d6c5cc9f
AG
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post
bc9b2fd3 112%php_webserver_restart
d6c5cc9f 113
eb5447da
AG
114%postun
115if [ "$1" = 0 ]; then
bc9b2fd3 116 %php_webserver_restart
d6c5cc9f
AG
117fi
118
119%files
120%defattr(644,root,root,755)
472e26b5 121%doc README NEWS Changelog CREDITS contrib/xt.vim
266b1c9d
ER
122%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
123%attr(755,root,root) %{php_extensiondir}/%{modname}.so
124%attr(755,root,root) %{_bindir}/xdebug-debugclient
This page took 0.057517 seconds and 4 git commands to generate.