]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blame - php-pecl-ssh2.spec
add patch from alpine to build for php 7.3/7.4
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
CommitLineData
47fc9518 1%define php_name php%{?php_suffix}
0f92866c 2%define modname ssh2
0f92866c
ER
3Summary: %{modname} - bindings for the libssh2 library
4Summary(pl.UTF-8): %{modname} - dowiązania do biblioteki libssh2
47fc9518 5Name: %{php_name}-pecl-%{modname}
50d4685f 6Version: 1.1.2
f1df9327 7Release: 2
2903db35 8License: PHP
45ecaa2e 9Group: Development/Languages/PHP
50d4685f
ER
10Source0: https://pecl.php.net/get/%{modname}-%{version}.tgz
11# Source0-md5: 0bb1b02ae6d1d1a86134959e9b45ae69
f1df9327
ER
12Patch0: https://raw.githubusercontent.com/alpinelinux/aports/c2a8a93cc1e328aca81df7e284aceeacb23c78f5/community/php7-pecl-ssh2/fix-php-7x.patch
13# Patch0-md5: 806cf16dd2fe4727f1922b4f30de9df0
c179bae3 14URL: https://pecl.php.net/package/ssh2
f75baa62 15BuildRequires: %{php_name}-devel >= 4:7.0.0
8fae05b2 16BuildRequires: libssh2-devel >= 1.2.9
2903db35 17BuildRequires: openssl-devel >= 0.9.7d
47fc9518 18BuildRequires: rpmbuild(macros) >= 1.650
5486253a 19%{?requires_php_extension}
2db4ed43 20Provides: php(%{modname}) = %{version}
fd4940c0 21Obsoletes: php-pecl-ssh2 < 0.12-4
45ecaa2e
AG
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
45ecaa2e
AG
24%description
25Provides bindings to the functions of libssh2 which implements the
26SSH2 protocol.
27
0313d4ea
JR
28%description -l pl.UTF-8
29Dostarcza dowiązań do różnych funkcji biblioteki libssh2
30implementującej protokół SSH2.
45ecaa2e 31
45ecaa2e 32%prep
0f92866c
ER
33%setup -qc
34mv %{modname}-%{version}/* .
f1df9327 35%patch0 -p1
45ecaa2e
AG
36
37%build
45ecaa2e
AG
38phpize
39%configure
40%{__make}
41
42%install
43rm -rf $RPM_BUILD_ROOT
890c59dd 44install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
0f92866c 45install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
0fcbc989 46cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/00_%{modname}.ini
0f92866c
ER
47; Enable %{modname} extension module
48extension=%{modname}.so
5486253a 49EOF
45ecaa2e
AG
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%post
890c59dd 55%php_webserver_restart
45ecaa2e 56
5486253a
ER
57%postun
58if [ "$1" = 0 ]; then
890c59dd 59 %php_webserver_restart
45ecaa2e
AG
60fi
61
62%files
63%defattr(644,root,root,755)
0fcbc989 64%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/*_%{modname}.ini
0f92866c 65%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.192377 seconds and 4 git commands to generate.