]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- up to rereleased (the real release) opera 8.01
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
6239047a 3#
ec0c336f
AM
4%bcond_without shared # static or shared version
5%bcond_without distributable # distributable or not
6%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 7%bcond_with snap # snap version
09f2d772 8
1b3f992f 9%ifarch sparc64 sparc
08bc83d7 10%undefine with_shared
1b3f992f 11%endif
12
e56cf118 13%if %{with snap}
a78f0dac 14%define ver 8.01
7ad274ec 15%define sver %{ver}
6fe34fc1 16%define fix %{nil}
a78f0dac
AM
17%define dirrel 20050509
18%define reltype Preview-1
e56cf118 19%else
de81cf52
AM
20%define ver 8.01
21%define sver 8.01
94132831 22%define fix %{nil}
9b787f15 23%define dirrel 20050615
94132831 24%define reltype final
e56cf118
AM
25%endif
26
6fe34fc1 27%define shver %(echo %{ver} | tr -d .)%{fix}
9b787f15 28%define x86_shared_rel %{dirrel}.5
655debcb 29%define x86_static_rel %{dirrel}.1
30%define sparc_shared_rel %{dirrel}.2
31%define sparc_static_rel %{dirrel}.1
a8b8cbf5 32%define ppc_shared_rel %{dirrel}.3
655debcb 33%define ppc_static_rel %{dirrel}.1
09f2d772 34%if %{with shared}
655debcb 35%define type shared
0d0211ae 36# We should be able to build src.rpm also on not supported archs
655debcb 37%define rel %{x86_shared_rel}
7edc0e0c 38%ifarch sparc64 sparc
a034ff51 39#%%define rel %{sparc_shared_rel}
40%define rel %{sparc_static_rel}
7edc0e0c
AM
41%endif
42%ifarch ppc
655debcb 43%define rel %{ppc_shared_rel}
7edc0e0c 44%endif
09f2d772 45%else
655debcb 46%define type static
655debcb 47%define rel %{x86_static_rel}
7edc0e0c 48%ifarch sparc sparc64
655debcb 49%define rel %{sparc_static_rel}
7edc0e0c
AM
50%endif
51%ifarch ppc
655debcb 52%define rel %{ppc_static_rel}
09f2d772 53%endif
7edc0e0c 54%endif
2dbc1636 55
b6dbc9f6
AM
56# define to 0 and then redefine to avoid
57# not defined macros
cbb8dbd3 58%define need_ix86_shared_snap 0
59%define need_sparc_shared_snap 0
60%define need_ppc_shared_snap 0
61%define need_ix86_static_snap 0
62%define need_sparc_static_snap 0
63%define need_ppc_static_snap 0
b6dbc9f6 64
cbb8dbd3 65%define need_ix86_shared 0
66%define need_sparc_shared 0
67%define need_ppc_shared 0
68%define need_ix86_static 0
69%define need_sparc_static 0
70%define need_ppc_static 0
b6dbc9f6 71
40d43d2d 72%if %{with incall}
73# with incall? [if]
74%if %{with snap}
75# with snap? [if]
76%if %{with shared}
77# with shared? [if]
78%define need_ix86_shared_snap 1
cbb8dbd3 79%define need_sparc_shared_snap 1
40d43d2d 80%define need_ppc_shared_snap 1
042a9712 81%else
40d43d2d 82# with shared: [else]
83%define need_ix86_static_snap 1
cbb8dbd3 84%define need_sparc_static_snap 1
40d43d2d 85%define need_ppc_static_snap 1
042a9712 86%endif
40d43d2d 87# with shared; [endif]
88%else
89# with snap: [else]
90%if %{with shared}
91# with shared? [if]
92%define need_ix86_shared 1
a034ff51 93#%%define need_sparc_shared 1
94%define need_sparc_static 1
40d43d2d 95%define need_ppc_shared 1
96%else
97# with shared: [else]
98%define need_ix86_static 1
cbb8dbd3 99%define need_sparc_static 1
40d43d2d 100%define need_ppc_static 1
2dbc1636 101%endif
40d43d2d 102# with shared; [endif]
ec0c336f 103%endif
40d43d2d 104# with snap; [endif]
105%else
106# with incall: [else]
107%ifarch %{ix86}
108# is ix86? [if]
109%if %{with snap}
110# with snap? [if]
111%if %{with shared}
112# with shared? [if]
113%define need_ix86_shared_snap 1
042a9712 114%else
40d43d2d 115# with shared: [else]
116%define need_ix86_static_snap 1
042a9712 117%endif
40d43d2d 118# with shared; [endif]
119%else
120# with snap: [else]
121%if %{with shared}
122# with shared? [if]
123%define need_ix86_shared 1
124%else
125# with shared: [else]
126%define need_ix86_static 1
2dbc1636 127%endif
40d43d2d 128# with shared; [endif]
ec0c336f 129%endif
40d43d2d 130# with snap; [endif]
131%endif
132# is ix86; [endif]
133%ifarch sparc sparc64
134# is sparc? [if]
135%if %{with snap}
136# with snap? [if]
137%if %{with shared}
138# with shared? [if]
139%define need_sparc_shared_snap 1
042a9712 140%else
40d43d2d 141# with shared: [else]
142%define need_sparc_static_snap 1
2dbc1636 143%endif
40d43d2d 144# with shared; [endif]
2dbc1636 145%else
40d43d2d 146# with snap: [else]
147%if %{with shared}
148# with shared? [if]
a034ff51 149#%%define need_sparc_shared 1
150%define need_sparc_static 1
042a9712 151%else
40d43d2d 152# with shared: [else]
153%define need_sparc_static 1
042a9712 154%endif
40d43d2d 155# with shared; [endif]
2dbc1636 156%endif
40d43d2d 157# with snap; [endif]
ec0c336f 158%endif
40d43d2d 159# is sparc; [endif]
160%ifarch ppc
161# is ppc? [if]
162%if %{with snap}
163# with snap? [if]
164%if %{with shared}
165# with shared? [if]
166%define need_ppc_shared_snap 1
042a9712 167%else
40d43d2d 168# with shared: [else]
169%define need_ppc_static_snap 1
042a9712 170%endif
40d43d2d 171# with shared; [endif]
172%else
173# with snap: [else]
174%if %{with shared}
175# with shared? [if]
176%define need_ppc_shared 1
177%else
178# with shared: [else]
179%define need_ppc_static 1
2dbc1636 180%endif
40d43d2d 181# with shared; [endif
ec0c336f 182%endif
40d43d2d 183# with snap; [endif
2dbc1636 184%endif
40d43d2d 185# is ppc; [endif]
2dbc1636 186%endif
40d43d2d 187# with incall; [endif]
188
189Summary: World fastest web browser
190