]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- we have to use static version on sparc...
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
6239047a 3#
ec0c336f
AM
4%bcond_without shared # static or shared version
5%bcond_without distributable # distributable or not
6%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 7%bcond_with snap # snap version
09f2d772 8
1b3f992f 9%ifarch sparc64 sparc
10%undefine shared
11%endif
12
e56cf118 13%if %{with snap}
a78f0dac 14%define ver 8.01
7ad274ec 15%define sver %{ver}
6fe34fc1 16%define fix %{nil}
a78f0dac
AM
17%define dirrel 20050509
18%define reltype Preview-1
e56cf118 19%else
7ad274ec
AM
20%define ver 8.00
21%define sver 8.0
94132831
AM
22%define fix %{nil}
23%define dirrel 20050415
24%define reltype final
e56cf118
AM
25%endif
26
6fe34fc1
AM
27%define shver %(echo %{ver} | tr -d .)%{fix}
28%define x86_shared_rel %{dirrel}.4
655debcb 29%define x86_static_rel %{dirrel}.1
30%define sparc_shared_rel %{dirrel}.2
31%define sparc_static_rel %{dirrel}.1
a8b8cbf5 32%define ppc_shared_rel %{dirrel}.3
655debcb 33%define ppc_static_rel %{dirrel}.1
09f2d772 34%if %{with shared}
655debcb 35%define type shared
0d0211ae 36# We should be able to build src.rpm also on not supported archs
655debcb 37%define rel %{x86_shared_rel}
7edc0e0c 38%ifarch sparc64 sparc
655debcb 39%define rel %{sparc_shared_rel}
7edc0e0c
AM
40%endif
41%ifarch ppc
655debcb 42%define rel %{ppc_shared_rel}
7edc0e0c 43%endif
09f2d772 44%else
655debcb 45%define type static
655debcb 46%define rel %{x86_static_rel}
7edc0e0c 47%ifarch sparc sparc64
655debcb 48%define rel %{sparc_static_rel}
7edc0e0c
AM
49%endif
50%ifarch ppc
655debcb 51%define rel %{ppc_static_rel}
09f2d772 52%endif
7edc0e0c 53%endif
2dbc1636 54
b6dbc9f6
AM
55# define to 0 and then redefine to avoid
56# not defined macros
cbb8dbd3 57%define need_ix86_shared_snap 0
58%define need_sparc_shared_snap 0
59%define need_ppc_shared_snap 0
60%define need_ix86_static_snap 0
61%define need_sparc_static_snap 0
62%define need_ppc_static_snap 0
b6dbc9f6 63
cbb8dbd3 64%define need_ix86_shared 0
65%define need_sparc_shared 0
66%define need_ppc_shared 0
67%define need_ix86_static 0
68%define need_sparc_static 0
69%define need_ppc_static 0
b6dbc9f6 70
40d43d2d 71%if %{with incall}
72# with incall? [if]
73%if %{with snap}
74# with snap? [if]
75%if %{with shared}
76# with shared? [if]
77%define need_ix86_shared_snap 1
cbb8dbd3 78%define need_sparc_shared_snap 1
40d43d2d 79%define need_ppc_shared_snap 1
042a9712 80%else
40d43d2d 81# with shared: [else]
82%define need_ix86_static_snap 1
cbb8dbd3 83%define need_sparc_static_snap 1
40d43d2d 84%define need_ppc_static_snap 1
042a9712 85%endif
40d43d2d 86# with shared; [endif]
87%else
88# with snap: [else]
89%if %{with shared}
90# with shared? [if]
91%define need_ix86_shared 1
cbb8dbd3 92%define need_sparc_shared 1
40d43d2d 93%define need_ppc_shared 1
94%else
95# with shared: [else]
96%define need_ix86_static 1
cbb8dbd3 97%define need_sparc_static 1
40d43d2d 98%define need_ppc_static 1
2dbc1636 99%endif
40d43d2d 100# with shared; [endif]
ec0c336f 101%endif
40d43d2d 102# with snap; [endif]
103%else
104# with incall: [else]
105%ifarch %{ix86}
106# is ix86? [if]
107%if %{with snap}
108# with snap? [if]
109%if %{with shared}
110# with shared? [if]
111%define need_ix86_shared_snap 1
042a9712 112%else
40d43d2d 113# with shared: [else]
114%define need_ix86_static_snap 1
042a9712 115%endif
40d43d2d 116# with shared; [endif]
117%else
118# with snap: [else]
119%if %{with shared}
120# with shared? [if]
121%define need_ix86_shared 1
122%else
123# with shared: [else]
124%define need_ix86_static 1
2dbc1636 125%endif
40d43d2d 126# with shared; [endif]
ec0c336f 127%endif
40d43d2d 128# with snap; [endif]
129%endif
130# is ix86; [endif]
131%ifarch sparc sparc64
132# is sparc? [if]
133%if %{with snap}
134# with snap? [if]
135%if %{with shared}
136# with shared? [if]
137%define need_sparc_shared_snap 1
042a9712 138%else
40d43d2d 139# with shared: [else]
140%define need_sparc_static_snap 1
2dbc1636 141%endif
40d43d2d 142# with shared; [endif]
2dbc1636 143%else
40d43d2d 144# with snap: [else]
145%if %{with shared}
146# with shared? [if]
147%define need_sparc_shared 1
042a9712 148%else
40d43d2d 149# with shared: [else]
150%define need_sparc_static 1
042a9712 151%endif
40d43d2d 152# with shared; [endif]
2dbc1636 153%endif
40d43d2d 154# with snap; [endif]
ec0c336f 155%endif
40d43d2d 156# is sparc; [endif]
157%ifarch ppc
158# is ppc? [if]
159%if %{with snap}
160# with snap? [if]
161%if %{with shared}
162# with shared? [if]
163%define need_ppc_shared_snap 1
042a9712 164%else
40d43d2d 165# with shared: [else]
166%define need_ppc_static_snap 1
042a9712 167%endif
40d43d2d 168# with shared; [endif]
169%else
170# with snap: [else]
171%if %{with shared}
172# with shared? [if]
173%define need_ppc_shared 1
174%else
175# with shared: [else]
176%define need_ppc_static 1
2dbc1636 177%endif
40d43d2d 178# with shared; [endif
ec0c336f 179%endif
40d43d2d 180# with snap; [endif
2dbc1636 181%endif
40d43d2d 182# is ppc; [endif]
2dbc1636 183%endif
40d43d2d 184# with incall; [endif]
185
186Summary: World fastest web browser
187