]> git.pld-linux.org Git - packages/opera.git/blame - opera.spec
- update todo
[packages/opera.git] / opera.spec
CommitLineData
11dece16 1# TODO:
da8a77bf 2# - move translations into a separate, noarch package
0fa176b6 3# - opera wrapper contains: OPERA_SCRIPT_PATH=/home/users/builder/rpm/BUILD/opera-9.02-20060919.5-shared-qt.i386-en-434/$0
6239047a 4#
ec0c336f
AM
5%bcond_without shared # static or shared version
6%bcond_without distributable # distributable or not
7%bcond_without incall # include all tarballs into src.rpm (but splitted into shared/static)
e56cf118 8%bcond_with snap # snap version
7f13a385 9%bcond_with weekly # weekly snapshot version
09f2d772 10
1b3f992f 11%ifarch sparc64 sparc
08bc83d7 12%undefine with_shared
1b3f992f 13%endif
14
7f13a385 15%if %{with weekly}
9ff5352e 16%define ver 9.10
7f13a385
KK
17%define sver %{ver}
18%define fix %{nil}
877b7a46
KK
19%define dirrel 20061103
20%define magicstr 478
7f13a385
KK
21%define with_snap 1
22%else
e56cf118 23%if %{with snap}
b28972ca 24%define ver 9.0
7ad274ec 25%define sver %{ver}
6fe34fc1 26%define fix %{nil}
3a879908
AM
27%define dirrel 20060206
28%define reltype Preview-2
b28972ca 29%define magicstr %{nil}
e56cf118 30%else
b08d96bc
AM
31%define ver 9.02
32%define sver 9.02
94132831 33%define fix %{nil}
b08d96bc 34%define dirrel 20060919
6f7271b8 35%define reltype final
b08d96bc 36%define magicstr 434
e56cf118 37%endif
7f13a385 38%endif
e56cf118 39
6fe34fc1 40%define shver %(echo %{ver} | tr -d .)%{fix}
9b787f15 41%define x86_shared_rel %{dirrel}.5
655debcb 42%define x86_static_rel %{dirrel}.1
43%define sparc_shared_rel %{dirrel}.2
44%define sparc_static_rel %{dirrel}.1
a8b8cbf5 45%define ppc_shared_rel %{dirrel}.3
655debcb 46%define ppc_static_rel %{dirrel}.1
09f2d772 47%if %{with shared}
655debcb 48%define type shared
0d0211ae 49# We should be able to build src.rpm also on not supported archs
655debcb 50%define rel %{x86_shared_rel}
7edc0e0c 51%ifarch sparc64 sparc
a034ff51 52#%%define rel %{sparc_shared_rel}
53%define rel %{sparc_static_rel}
7edc0e0c
AM
54%endif
55%ifarch ppc
655debcb 56%define rel %{ppc_shared_rel}
7edc0e0c 57%endif
09f2d772 58%else
655debcb 59%define type static
655debcb 60%define rel %{x86_static_rel}
7edc0e0c 61%ifarch sparc sparc64
655debcb 62%define rel %{sparc_static_rel}
7edc0e0c
AM
63%endif
64%ifarch ppc
655debcb 65%define rel %{ppc_static_rel}
09f2d772 66%endif
7edc0e0c 67%endif
2dbc1636 68
b6dbc9f6
AM
69# define to 0 and then redefine to avoid
70# not defined macros
cbb8dbd3 71%define need_ix86_shared_snap 0
72%define need_sparc_shared_snap 0
73%define need_ppc_shared_snap 0
74%define need_ix86_static_snap 0
75%define need_sparc_static_snap 0
76%define need_ppc_static_snap 0
b6dbc9f6 77
cbb8dbd3 78%define need_ix86_shared 0
79%define need_sparc_shared 0
80%define need_ppc_shared 0
81%define need_ix86_static 0
82%define need_sparc_static 0
83%define need_ppc_static 0
b6dbc9f6 84
40d43d2d 85%if %{with incall}
86# with incall? [if]
87%if %{with snap}
88# with snap? [if]
89%if %{with shared}
90# with shared? [if]
91%define need_ix86_shared_snap 1
b28972ca 92%define need_sparc_shared_snap 0
40d43d2d 93%define need_ppc_shared_snap 1
042a9712 94%else
40d43d2d 95# with shared: [else]
96%define need_ix86_static_snap 1
7f13a385 97%define need_sparc_static_snap 1
40d43d2d 98%define need_ppc_static_snap 1
042a9712 99%endif
40d43d2d 100# with shared; [endif]
101%else
102# with snap: [else]
103%if %{with shared}
104# with shared? [if]
105%define need_ix86_shared 1
a034ff51 106#%%define need_sparc_shared 1
107%define need_sparc_static 1
40d43d2d 108%define need_ppc_shared 1
109%else
110# with shared: [else]
111%define need_ix86_static 1
cbb8dbd3 112%define need_sparc_static 1
40d43d2d 113%define need_ppc_static 1
2dbc1636 114%endif
40d43d2d 115# with shared; [endif]
ec0c336f 116%endif
40d43d2d 117# with snap; [endif]
118%else
119# with incall: [else]
120%ifarch %{ix86}
121# is ix86? [if]
122%if %{with snap}
123# with snap? [if]
124%if %{with shared}
125# with shared? [if]
126%define need_ix86_shared_snap 1
042a9712 127%else
40d43d2d 128# with shared: [else]
129%define need_ix86_static_snap 1
042a9712 130%endif
40d43d2d 131# with shared; [endif]
132%else
133# with snap: [else]
134%if %{with shared}
135# with shared? [if]
136%define need_ix86_shared 1
137%else
138# with shared: [else]
139%define need_ix86_static 1
2dbc1636 140%endif
40d43d2d 141# with shared; [endif]
ec0c336f 142%endif
40d43d2d 143# with snap; [endif]
144%endif
145# is ix86; [endif]
146%ifarch sparc sparc64
147# is sparc? [if]
148%if %{with snap}
149# with snap? [if]
150%if %{with shared}
151# with shared? [if]
152%define need_sparc_shared_snap 1
042a9712 153%else
40d43d2d 154# with shared: [else]
155%define need_sparc_static_snap 1
2dbc1636 156%endif
40d43d2d 157# with shared; [endif]
2dbc1636 158%else
40d43d2d 159# with snap: [else]
160%if %{with shared}
161# with shared? [if]
a034ff51 162#%%define need_sparc_shared 1
163%define need_sparc_static 1
042a9712 164%else
40d43d2d 165# with shared: [else]
166%define need_sparc_static 1
042a9712 167%endif
40d43d2d 168# with shared; [endif]
2dbc1636 169%endif
40d43d2d 170# with snap; [endif]
ec0c336f 171%endif
40d43d2d 172# is sparc; [endif]
173%ifarch ppc
174# is ppc? [if]
175%if %{with snap}
176# with snap? [if]
177%if %{with shared}
178# with shared? [if]
179%define need_ppc_shared_snap 1
042a9712 180%else
40d43d2d 181# with shared: [else]
182%define need_ppc_static_snap 1
042a9712 183%endif
40d43d2d 184# with shared; [endif]
185%else
186# with snap: [else]
187%if %{with shared}
188# with shared? [if]
189%define need_ppc_shared 1
190%else
191# with shared: [else]
192%define need_ppc_static 1
2dbc1636 193%endif
40d43d2d 194# with shared; [endif
ec0c336f 195%endif
40d43d2d 196# with snap; [endif
2dbc1636 197%endif
40d43d2d 198# is ppc; [endif]
2dbc1636 199%endif
40d43d2d 200# with incall; [endif]
201
202Summary: World fastest web browser
203