]> git.pld-linux.org Git - packages/nodejs.git/blame - nodejs.spec
- remove outdated patches, shame aria
[packages/nodejs.git] / nodejs.spec
CommitLineData
12a49d35
ER
1# TODO:
2# - use system waf
210abff9 3
4# For the 1.2 branch, we use 0s here
5# For 1.3+, we use the three digit versions
6%define somajor 2
7%define sominor 1
8%define sobuild 2
9%define sover %{somajor}.%{sominor}.%{sobuild}
10
210abff9 11Summary: Asynchronous JavaScript Engine
12Name: nodejs
08fd0f57 13Version: 0.1.96
210abff9 14Release: 0
15License: BSD
16Group: Libraries
17URL: http://nodejs.org/
18Source0: http://nodejs.org/dist/node-v%{version}.tar.gz
08fd0f57 19# Source0-md5: 5e83341afe2b5edf0595e92f96ceed09
210abff9 20Source1: http://www.crockford.com/javascript/jsmin.py.txt
21# Source1-md5: 0521ddcf3e52457223c6e0d602486a89
12a49d35 22BuildRequires: gcc >= 5:4.0
210abff9 23BuildRequires: libeio-devel
24BuildRequires: libev-devel >= 3.90
25BuildRequires: libstdc++-devel
26BuildRequires: python
12a49d35 27BuildRequires: rpm >= 4.4.9-56
210abff9 28BuildRequires: udns-devel
08fd0f57 29BuildRequires: c-ares-devel >= 1.7.1-0.20100523.0
30BuildRequires: v8-devel >= 2.2.8
210abff9 31ExclusiveArch: %{ix86} %{x8664} arm
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Node's goal is to provide an easy way to build scalable network
36programs. In the above example, the two second delay does not prevent
37the server from handling new requests. Node tells the operating system
38(through epoll, kqueue, /dev/poll, or select) that it should be
39notified when the 2 seconds are up or if a new connection is made --
40then it goes to sleep. If someone new connects, then it executes the
41callback, if the timeout expires, it executes the inner callback. Each
42connection is only a small heap allocation.
43
210abff9 44%package devel
12a49d35 45Summary: Development headers for nodejs
210abff9 46Group: Development/Libraries
210abff9 47
48%description devel
12a49d35 49Development headers for nodejs.
210abff9 50
51%prep
52%setup -q -n node-v%{version}
210abff9 53
54%build
55# build library
56
57CFLAGS="%{rpmcflags}"
58CXXFLAGS="%{rpmcxxflags}"
59LDFLAGS="%{rpmcflags}"
60%if "%{pld_release}" == "ac"
61CC=%{__cc}4
62CXX=%{__cxx}4
63%else
64CC=%{__cc}
65CXX=%{__cxx}
66%endif
67export CFLAGS LDFLAGS CXXFLAGS CC CXX
68
69tools/waf-light configure \
c6be74cc 70 --system \
210abff9 71 --prefix=%{_prefix}
72
73tools/waf-light build
74
75%install
76rm -rf $RPM_BUILD_ROOT
c6be74cc 77install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}/node/libraries}
210abff9 78
79tools/waf-light install \
80 --destdir=$RPM_BUILD_ROOT
81
c6be74cc 82install lib/*.js $RPM_BUILD_ROOT%{_libdir}/node/libraries/
83
210abff9 84%clean
85rm -rf $RPM_BUILD_ROOT
86
210abff9 87%files
88%defattr(644,root,root,755)
89%doc AUTHORS ChangeLog LICENSE
90%attr(755,root,root) %{_bindir}/node
91%attr(755,root,root) %{_bindir}/node-repl
92%dir %{_libdir}/node
93%dir %{_libdir}/node/libraries
94%{_libdir}/node/libraries/*.js
95%{_mandir}/man1/node.1*
96
210abff9 97%files devel
98%defattr(644,root,root,755)
12a49d35 99%dir %{_includedir}/node
c6be74cc 100%{_includedir}/node/*.h
101%attr(755,root,root) %{_bindir}/node-waf
102%{_libdir}/node/wafadmin/
This page took 0.094708 seconds and 4 git commands to generate.