]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- added
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8d734bed 1#
8c865192 2# TODO:
0ab57655 3# - test ldap and mysql (failed at this time)
fcae54a7 4# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
05f8c491 5#
4f968063 6# Conditional build for lighttpd:
ce8f06ab 7%bcond_without xattr # without support of extended attributes
1da5e2ed 8%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
dae5a344
ER
9# use it if you have 2.4 kernel to get sendfile() support,
10# and don't need > 2GB file requests,
11# see http://article.gmane.org/gmane.comp.web.lighttpd:722
1da5e2ed 12%bcond_without largefile # without largefile support
1da5e2ed 13%bcond_without ssl # disable ssl support
ce8f06ab
KK
14%bcond_with mysql # with mysql
15%bcond_with ldap # with ldap
f0f1c74c 16%bcond_with valgrind # compile code with valgrind support.
dae5a344 17%bcond_with dirhide # with 'hide from dirlisting' hack
d20e182e 18#
2abd0792 19# Prerelease snapshot: DATE-TIME
c1b34484 20##define _snap 20050116-1743
2abd0792
ER
21
22%if 0%{?_snap}
23%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
24%else
25%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
26%endif
27
8c865192 28%define _rel 1
2abd0792 29
027853cc 30Summary: Fast and light HTTP server
31Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 32Name: lighttpd
8c865192 33Version: 1.3.14
2abd0792 34Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
bee4f74e 35Group: Networking/Daemons
4241e769 36License: BSD
2abd0792 37Source0: %{_source}
8c865192 38# Source0-md5: 16d9f8c40bcb5638ee452fa23b21e346
bee4f74e 39Source1: %{name}.init
2f7162ab
AM
40Source2: %{name}.conf
41Source3: %{name}.user
607835c0 42Source4: %{name}.logrotate
c54ca3d2 43Source5: %{name}.sysconfig
e22eff1c 44Patch0: http://minghetti.ch/blob/dirlist-hide.patch
dae5a344 45Patch1: %{name}-fcgi-verbose.patch
70373b58 46URL: http://www.lighttpd.net/
1a75d3e1
JB
47BuildRequires: autoconf
48BuildRequires: automake
49BuildRequires: bzip2-devel
50BuildRequires: libtool
49163762 51%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 52BuildRequires: pcre-devel
e68efba2 53BuildRequires: rpmbuild(macros) >= 1.159
1a75d3e1 54BuildRequires: zlib-devel
d20e182e 55%if %{with xattr}
56BuildRequires: attr-devel
57%endif
05f8c491
ER
58%{?with_ldap:BuildRequires: openldap-devel}
59%{?with_mysql:BuildRequires: mysql-devel}
dae5a344 60%{?debug:BuildRequires: valgrind}
417e0665 61BuildRequires: rpmbuild(macros) >= 1.202
bee4f74e
AM
62PreReq: rc-scripts
63Requires(pre): sh-utils
64Requires(pre): /bin/id
65Requires(pre): /usr/bin/getgid
66Requires(pre): /usr/sbin/groupadd
67Requires(pre): /usr/sbin/useradd
68Requires(post,preun): /sbin/chkconfig
bee4f74e 69Requires(postun): /usr/sbin/groupdel
e68efba2 70Requires(postun): /usr/sbin/userdel
71Provides: group(lighttpd)
1a75d3e1 72Provides: httpd
e68efba2 73Provides: user(lighttpd)
1a75d3e1 74Provides: webserver
bee4f74e
AM
75BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 78%define _lighttpddir /home/services/%{name}
bee4f74e
AM
79%define _sysconfdir /etc/%{name}
80
81%description
f655b1fd 82lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
83which has been optimized for high-performance environments. It has a
84very low memory footprint compared to other webservers and takes care
85of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
86Output-Compression, URL-Rewriting and many more) make lighttpd the
87perfect webserver-software for every server that is suffering load
88problems.
89
f655b1fd
MC
90%description -l pl
91lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 92