]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blame - libtorrent-rasterbar.spec
- rel 2
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
CommitLineData
2e00201e
ZU
1Summary: A C++ BitTorrent library
2Summary(hu.UTF-8): C++ BitTorrent könyvtár
3Summary(pl.UTF-8): Biblioteka BitTorrenta napisana w C++
4Name: libtorrent-rasterbar
71a9e0b4 5Version: 0.14.1
2aa6bbd6 6Release: 2
2e00201e
ZU
7License: BSD
8Group: Libraries
9Source0: http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
71a9e0b4 10# Source0-md5: 6aa0ed4da604b8b160bf12bcd41d5055
2e00201e
ZU
11URL: http://www.rasterbar.com/products/libtorrent/
12BuildRequires: autoconf
13BuildRequires: automake
14BuildRequires: boost-devel >= 1.35.0
15BuildRequires: libstdc++-devel
d412ac15
ZU
16BuildRequires: libtool
17BuildRequires: openssl-devel
2e00201e 18BuildRequires: sed >= 4.0
d412ac15
ZU
19BuildRequires: which
20BuildRequires: util-linux-ng
2e00201e 21BuildRequires: zlib-devel
d412ac15 22Obsoletes: rb_libtorrent
2e00201e
ZU
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26libtorrent-rasterbar is a C++ library that aims to be a good
27alternative to all the other BitTorrent implementations around. It is
28a library and not a full featured client, although it comes with a
29working example client.
30
31Its main goals are to be very efficient (in terms of CPU and memory
32usage) as well as being very easy to use both as a user and developer.
33
34%description -l hu.UTF-8
35libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
36kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
37egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
38működő példa-klienst.
39
40A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
41könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
42
43%description -l pl.UTF-8
44libtorrent-rasterbar jest biblioteką napisaną w C++ która aspiruje do
45bycia dobrą alternatywą dla wszystkich innych implementacji
46BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, jakkolwiek
47pakiet zawiera działającego przykładowego klienta.
48
49Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
50wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
51dla użytkownika, jak i programisty.
52
53%package devel
54Summary: Header files for %{name} library
55Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
56License: BSD, zlib/libpng License, Boost Software License
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: boost-devel
60Requires: openssl-devel
d412ac15 61Obsoletes: rb_libtorrent-devel
2e00201e
ZU
62
63%description devel
64The libtorrent-rasterbar-devel package contains libraries and header
65files for developing applications that use libtorrent-rasterbar.
66
67The various source and header files included in this package are
68licensed under the revised BSD, zlib/libpng, and Boost Public
69licenses.
70
71%description devel -l hu.UTF-8
72A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
73fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
74alkalmazásokat fejleszthetsz.
75
76%description devel -l pl.UTF-8
77Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
78rozwijania aplikacji używających libtorrent-rasterbar.
79
80Różne pliki źródłowe i nagłówki dostarcozne z tym pakietem są
81licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public.
82
83%package static
84Summary: Static %{name} library
85Summary(pl.UTF-8): Statyczna biblioteka %{name}
86Group: Development/Libraries
87Requires: %{name}-devel = %{version}-%{release}
d412ac15 88Obsoletes: rb_libtorrent-static
2e00201e
ZU
89
90%description static
91Static libtorrent-rasterbar library.
92
93%description static -l hu.UTF-8
94Statikus libtorrent-rasterbar könyvtár.
95
96%description static -l pl.UTF-8
97Statyczna biblioteka libtorrent-rasterbar.
98
99%prep
100%setup -q
d412ac15 101
2e00201e
ZU
102## Some of the sources and docs are executable, which makes rpmlint against
103## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
104find src docs -type f | xargs chmod a-x
105find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
106## The RST files are the sources used to create the final HTML files; and are
107## not needed.
108rm -f docs/*.rst
2e00201e
ZU
109
110%build
111%{__aclocal} -I m4
112%{__libtoolize}
113%{__autoconf}
114%{__automake}
115%configure \
d412ac15
ZU
116 --with-boost-system=boost_system \
117 --with-boost-filesystem=boost_filesystem \
118 --with-boost-thread=boost_thread \
119 --with-boost-regex=boost_regex \
120 --with-boost-program-options=boost_program_options \
121 --with-{asio,zlib}=system \
122 --with-ssl
2e00201e 123
086e6387 124%{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
2e00201e
ZU
125
126%install
127rm -rf $RPM_BUILD_ROOT
128## Ensure that we preserve our timestamps properly.
129#export CPPROG="%{__cp} -p"
130#make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
131%{__make} install \
132 DESTDIR=$RPM_BUILD_ROOT
133
134## Do the renaming due to the somewhat limited %{_bindir} namespace.
135rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%post -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
142
143%files
144%defattr(644,root,root,755)
145%doc AUTHORS ChangeLog COPYING README
146%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
147
148%files devel
149%defattr(644,root,root,755)
150%doc docs/
151%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
152%{_libdir}/libtorrent-rasterbar.la
153%{_pkgconfigdir}/libtorrent-rasterbar.pc
154%{_includedir}/libtorrent
155
156%files static
157%defattr(644,root,root,755)
158%{_libdir}/libtorrent-rasterbar.a
This page took 0.079188 seconds and 4 git commands to generate.