]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blame - kde4-kdeplasma-addons.spec
- up to 4.8.4
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
CommitLineData
32c4451f 1# TODO:
2# Lancelot: installed - cmake unimplemented because not found
3# * XRender - Lancelot compositing support
4# * Eigen2 - Eigen2 enables the Mandelbrot wallpaper plugin.
c73f6b0c 5
6%bcond_without marble # don't build marble plasma support
7
32c4451f 8%define orgname kdeplasma-addons
9%define _state stable
72b0adaa 10%define qtver 4.8.1
1cf65df3 11
12Summary: KDE4 Plasmoids
b4bc4746 13Summary(pl.UTF-8): Plazmoidy dla KDE4
1cf65df3 14Name: kde4-kdeplasma-addons
72b0adaa 15Version: 4.8.4
e250f604 16Release: 1
1cf65df3 17License: GPL v2
18Group: X11/Applications
225618b5 19Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
72b0adaa 20# Source0-md5: 3b290c368e8000c2c6d40a8cc2244480
9baaa66a 21Patch100: %{name}-branch.diff
28096eda 22Patch0: %{name}-pastebinpld.patch
7ab2d436 23URL: http://www.kde.org/
22957f69 24BuildRequires: OpenGL-GLU-devel
ae48935e 25BuildRequires: OpenGL-devel
32c4451f 26BuildRequires: QtNetwork-devel >= %{qtver}
27f59e66 27BuildRequires: attica-devel
28096eda 28BuildRequires: automoc4 >= 0.9.88
27f59e66 29BuildRequires: boost-devel
32c4451f 30BuildRequires: cmake >= 2.8.0
cae2d48b 31BuildRequires: eigen >= 1:2.0.12-3
27f59e66 32BuildRequires: glibc-misc
1cf65df3 33BuildRequires: kde4-kdebase-workspace-devel >= %{version}
27f59e66 34BuildRequires: kde4-kdebase-workspace-kwin >= %{version}
1cf65df3 35BuildRequires: kde4-kdelibs-devel >= %{version}
36BuildRequires: kde4-kdepimlibs-devel >= %{version}
e250f604
AM
37BuildRequires: kde4-libkexiv2-devel >= %{version}
38%{?with_marble:BuildRequires: kde4-marble-devel >= %{version}}
27f59e66 39BuildRequires: libdbusmenu-qt-devel
e250f604 40BuildRequires: libqalculate-devel
05a0aa81 41BuildRequires: phonon-devel >= 4.4.1
0915a2df 42BuildRequires: pkgconfig
43BuildRequires: python
fd153232 44BuildRequires: qca-devel >= 2.0.2
64ed9cbc 45BuildRequires: qimageblitz-devel >= 0.0.6
32c4451f 46BuildRequires: qt4-build >= %{qtver}
47BuildRequires: qt4-qmake >= %{qtver}
b86025ef 48BuildRequires: qwt-devel
50c904e6 49BuildRequires: rpmbuild(macros) >= 1.600
6352f2c4 50BuildRequires: scim-devel
05a0aa81 51BuildRequires: shared-desktop-ontologies-devel >= 0.5
27f59e66 52BuildRequires: shared-mime-info
05a0aa81 53BuildRequires: soprano-devel >= 2.4.64
54BuildRequires: strigi-devel >= 0.7.2
32c4451f 55BuildRequires: xorg-lib-libXcomposite-devel
56BuildRequires: xorg-lib-libXdamage-devel
57BuildRequires: xorg-lib-libXrender-devel
75f86cc0 58BuildRequires: xorg-lib-libXtst-devel
1cf65df3 59Obsoletes: kde4-kdeplasmoids
60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62%description
b4bc4746 63KDE4 plasmoids.
1cf65df3 64
65%description -l pl.UTF-8
b4bc4746 66Plazmoidy dla KDE4.
1cf65df3 67
28096eda 68%package lancelot
69Summary: Lancelot Desktop Theme
72db3ff2 70Summary(pl.UTF-8): Motyw pulpitu Lancelot
28096eda 71Group: X11/Applications
72Requires: kde4-kdebase-workspace >= %{version}
73
74%description lancelot
75Lancelot Desktop Theme.
76
77%description lancelot -l pl.UTF-8
72db3ff2 78Motyw pulpitu Lancelot.
28096eda 79
c73f6b0c 80%package devel
81Summary: Development files for KDE4 Plasmoids
82Summary(pl.UTF-8): Pliki nagłówkowe bibliotek plazmoidów dla KDE4
83Group: X11/Development/Libraries
84Requires: %{name} = %{version}-%{release}
0e26ec14 85Requires: kde4-kdebase-workspace-devel >= %{version}
0e26ec14 86Requires: kde4-kdelibs-devel >= %{version}
87Requires: kde4-kdepimlibs-devel >= %{version}
c73f6b0c 88
89%description devel
90This package contains header files needed if you wish to build
91applications based on KDE4 Plasmoids.
92
93%description devel -l pl.UTF-8
94Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
95opartych na plazmoidach dla KDE4.
96
1cf65df3 97%prep
98%setup -q -n %{orgname}-%{version}
508bd1fc 99#%patch100 -p0
db617da2 100#%patch0 -p1
1cf65df3 101
102%build
103install -d build
104cd build
105%cmake \
1cf65df3 106 ../
107
108%{__make}
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113%{__make} -C build install \
114 DESTDIR=$RPM_BUILD_ROOT
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
28096eda 122%post lancelot -p /sbin/ldconfig
123%postun lancelot -p /sbin/ldconfig
124
1cf65df3 125%files
126%defattr(644,root,root,755)
127%attr(755,root,root) %{_libdir}/kde4/krunner_*.so
28096eda 128%attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
05fc8ea2
RT
129%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bball.so
130%attr(755,root,root) %{_libdir}/kde4/plasma_applet_binaryclock.so
131%attr(755,root,root) %{_libdir}/kde4/plasma_applet_blackboard.so
132%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bookmarks.so
133%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bubblemon.so
134%attr(755,root,root) %{_libdir}/kde4/plasma_applet_calculator.so
135%attr(755,root,root) %{_libdir}/kde4/plasma_applet_charselect.so
136%attr(755,root,root) %{_libdir}/kde4/plasma_applet_comic.so
137%attr(755,root,root) %{_libdir}/kde4/plasma_applet_dict.so
138%attr(755,root,root) %{_libdir}/kde4/plasma_applet_eyes.so
139%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fifteenPuzzle.so
140%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fileWatcher.so
141%attr(755,root,root) %{_libdir}/kde4/plasma_applet_frame.so
142%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fuzzy_clock.so
143%attr(755,root,root) %{_libdir}/kde4/plasma_applet_incomingmsg.so
50c904e6 144%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kdeobservatory.so
05fc8ea2
RT
145%attr(755,root,root) %{_libdir}/kde4/plasma_applet_knowledgebase.so
146%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kolourpicker.so
147%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konqprofiles.so
148%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konsoleprofiles.so
149%attr(755,root,root) %{_libdir}/kde4/plasma_applet_leavenote.so
150%attr(755,root,root) %{_libdir}/kde4/plasma_applet_life.so
151%attr(755,root,root) %{_libdir}/kde4/plasma_applet_luna.so
152%attr(755,root,root) %{_libdir}/kde4/plasma_applet_magnifique.so
153%attr(755,root,root) %{_libdir}/kde4/plasma_applet_mediaplayer.so
154%attr(755,root,root) %{_libdir}/kde4/plasma_applet_microblog.so
155%attr(755,root,root) %{_libdir}/kde4/plasma_applet_news.so
156%attr(755,root,root) %{_libdir}/kde4/plasma_applet_notes.so
157%attr(755,root,root) %{_libdir}/kde4/plasma_applet_nowplaying.so
158%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop.so
159%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop_activities.so
160%attr(755,root,root) %{_libdir}/kde4/plasma_applet_paste.so
161%attr(755,root,root) %{_libdir}/kde4/plasma_applet_pastebin.so
162%attr(755,root,root) %{_libdir}/kde4/plasma_applet_plasmaboard.so
163%attr(755,root,root) %{_libdir}/kde4/plasma_applet_previewer.so
e250f604 164%attr(755,root,root) %{_libdir}/kde4/plasma_applet_qalculate.so
05fc8ea2
RT
165%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rssnow.so
166%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rtm.so
167%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdashboard.so
168%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdesktop.so
169%attr(755,root,root) %{_libdir}/kde4/plasma_applet_spellcheck.so
170%attr(755,root,root) %{_libdir}/kde4/plasma_applet_timer.so
171%attr(755,root,root) %{_libdir}/kde4/plasma_applet_unitconverter.so
172%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weather.so
173%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weatherstation.so
174%attr(755,root,root) %{_libdir}/kde4/plasma_applet_webslice.so
1cf65df3 175%attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
176%attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
28096eda 177%attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
1cf65df3 178%attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
179%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
c73f6b0c 180%attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
181%attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
182%attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
183%attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
184%attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
185%attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
85896f2c 186%attr(755,root,root) %{_libdir}/kde4/plasma_runner_datetime.so
c73f6b0c 187%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
db617da2 188%attr(755,root,root) %{_libdir}/kde4/kcm_plasma_runner_events.so
827324c8
AM
189%attr(755,root,root) %{_libdir}/kde4/plasma_applet_icontasks.so
190%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kimpanel.so
191%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_potd.so
db617da2 192%attr(755,root,root) %{_libdir}/kde4/plasma_containment_griddesktop.so
193%attr(755,root,root) %{_libdir}/kde4/plasma_containment_groupingdesktop.so
194%attr(755,root,root) %{_libdir}/kde4/plasma_containment_groupingpanel.so
195%attr(755,root,root) %{_libdir}/kde4/plasma_runner_events.so
c73f6b0c 196%if %{with marble}
197%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
198%endif
199%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
200%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
201%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
c73f6b0c 202%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
203%attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
204%attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
205%attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
206%attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
207%attr(755,root,root) %ghost %{_libdir}/librtm.so.?
208%attr(755,root,root) %{_libdir}/librtm.so.*.*.*
db617da2 209%attr(755,root,root) %ghost %{_libdir}/libplasma_groupingcontainment.so.?
210%attr(755,root,root) %{_libdir}/libplasma_groupingcontainment.so.*.*.*
827324c8 211%attr(755,root,root) %{_libdir}/kde4/libexec/kimpanel-scim-panel
1cf65df3 212%{_datadir}/apps/desktoptheme/Aya
64098ef7 213%{_datadir}/apps/desktoptheme/Androbit
db617da2 214#%{_datadir}/apps/desktoptheme/Elegance
64098ef7 215%{_datadir}/apps/desktoptheme/Produkt
db617da2 216#%{_datadir}/apps/desktoptheme/Silicon
64098ef7 217%{_datadir}/apps/desktoptheme/Tibanna
28096eda 218%dir %{_datadir}/apps/desktoptheme/default/stylesheets
219%{_datadir}/apps/desktoptheme/default/stylesheets/*
220%dir %{_datadir}/apps/desktoptheme/default/weatherstation
221%{_datadir}/apps/desktoptheme/default/weatherstation/*
c73f6b0c 222%dir %{_datadir}/apps/desktoptheme/default/weather/
223%{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
1cf65df3 224%{_datadir}/apps/desktoptheme/default/widgets/*
db617da2 225#%{_datadir}/apps/desktoptheme/heron
1cf65df3 226%{_datadir}/apps/desktoptheme/slim-glow
e250f604 227%{_datadir}/apps/kdeplasma-addons
05fc8ea2
RT
228%{_datadir}/kde4/services/CharRunner_config.desktop
229%{_datadir}/kde4/services/CharacterRunner.desktop
230%{_datadir}/kde4/services/apodprovider.desktop
231%{_datadir}/kde4/services/browserhistory.desktop
232%{_datadir}/kde4/services/epodprovider.desktop
233%{_datadir}/kde4/services/flickrprovider.desktop
234%{_datadir}/kde4/services/katesessions.desktop
235%{_datadir}/kde4/services/konquerorsessions.desktop
236%{_datadir}/kde4/services/konsolesessions.desktop
237%{_datadir}/kde4/services/oseiprovider.desktop
238%{_datadir}/kde4/services/plasma-applet-bball.desktop
239%{_datadir}/kde4/services/plasma-applet-binaryclock.desktop
240%{_datadir}/kde4/services/plasma-applet-blackboard.desktop
241%{_datadir}/kde4/services/plasma-applet-bookmarks.desktop
242%{_datadir}/kde4/services/plasma-applet-bubblemon.desktop
243%{_datadir}/kde4/services/plasma-applet-calculator.desktop
244%{_datadir}/kde4/services/plasma-applet-charselect.desktop
245%{_datadir}/kde4/services/plasma-applet-eyes.desktop
246%{_datadir}/kde4/services/plasma-applet-fifteenPuzzle.desktop
247%{_datadir}/kde4/services/plasma-applet-incomingmsg.desktop
50c904e6 248%{_datadir}/kde4/services/plasma-applet-kdeobservatory.desktop
05fc8ea2
RT
249%{_datadir}/kde4/services/plasma-applet-knowledgebase.desktop
250%{_datadir}/kde4/services/plasma-applet-konqprofiles.desktop
251%{_datadir}/kde4/services/plasma-applet-konsoleprofiles.desktop
252%{_datadir}/kde4/services/plasma-applet-leavenote.desktop
253%{_datadir}/kde4/services/plasma-applet-life.desktop
254%{_datadir}/kde4/services/plasma-applet-luna.desktop
255%{_datadir}/kde4/services/plasma-applet-magnifique.desktop
256%{_datadir}/kde4/services/plasma-applet-mediaplayer.desktop
257%{_datadir}/kde4/services/plasma-applet-microblog.desktop
258%{_datadir}/kde4/services/plasma-applet-news.desktop
259%{_datadir}/kde4/services/plasma-applet-nowplaying.desktop
260%{_datadir}/kde4/services/plasma-applet-opendesktop-activities.desktop
261%{_datadir}/kde4/services/plasma-applet-opendesktop.desktop
262%{_datadir}/kde4/services/plasma-applet-paste.desktop
263%{_datadir}/kde4/services/plasma-applet-pastebin.desktop
264%{_datadir}/kde4/services/plasma-applet-previewer.desktop
251ccf39 265#%{_datadir}/kde4/services/plasma-applet-qalculate.desktop
05fc8ea2
RT
266%{_datadir}/kde4/services/plasma-applet-rememberthemilk.desktop
267%{_datadir}/kde4/services/plasma-applet-rssnow.desktop
268%{_datadir}/kde4/services/plasma-applet-showdashboard.desktop
269%{_datadir}/kde4/services/plasma-applet-showdesktop.desktop
270%{_datadir}/kde4/services/plasma-applet-spellcheck.desktop
271%{_datadir}/kde4/services/plasma-applet-systemloadviewer.desktop
272%{_datadir}/kde4/services/plasma-applet-timer.desktop
273%{_datadir}/kde4/services/plasma-applet-unitconverter.desktop
274%{_datadir}/kde4/services/plasma-applet-weather.desktop
275%{_datadir}/kde4/services/plasma-applet-weatherstation.desktop
276%{_datadir}/kde4/services/plasma-applet-webslice.desktop
277%{_datadir}/kde4/services/plasma-clock-fuzzy.desktop
278%{_datadir}/kde4/services/plasma-comic-default.desktop
279%{_datadir}/kde4/services/plasma-dataengine-comic.desktop
280%{_datadir}/kde4/services/plasma-dataengine-microblog.desktop
281%{_datadir}/kde4/services/plasma-dataengine-ocs.desktop
282%{_datadir}/kde4/services/plasma-dataengine-potd.desktop
283%{_datadir}/kde4/services/plasma-dict-default.desktop
284%{_datadir}/kde4/services/plasma-engine-kdeobservatory.desktop
db617da2 285#%{_datadir}/kde4/services/plasma-engine-pastebin.desktop
05fc8ea2
RT
286%{_datadir}/kde4/services/plasma-engine-rtm.desktop
287%{_datadir}/kde4/services/plasma-fileWatcher-default.desktop
288%{_datadir}/kde4/services/plasma-frame-default.desktop
289%{_datadir}/kde4/services/plasma-kolourpicker-default.desktop
290%{_datadir}/kde4/services/plasma-notes-default.desktop
291%{_datadir}/kde4/services/plasma-packagestructure-comic.desktop
292%{_datadir}/kde4/services/plasma-runner-audioplayercontrol.desktop
293%{_datadir}/kde4/services/plasma-runner-audioplayercontrol_config.desktop
294%{_datadir}/kde4/services/plasma-runner-contacts.desktop
295%{_datadir}/kde4/services/plasma-runner-converter.desktop
296%{_datadir}/kde4/services/plasma-runner-datetime.desktop
297%{_datadir}/kde4/services/plasma-runner-kopete.desktop
298%{_datadir}/kde4/services/plasma-runner-spellchecker.desktop
299%{_datadir}/kde4/services/plasma-runner-spellchecker_config.desktop
300%{_datadir}/kde4/services/plasma-runner-techbase.desktop
301%{_datadir}/kde4/services/plasma-runner-wikipedia.desktop
302%{_datadir}/kde4/services/plasma-runner-wikitravel.desktop
303%{_datadir}/kde4/services/plasma-wallpaper-mandelbrot.desktop
304%{_datadir}/kde4/services/plasma-wallpaper-marble.desktop
305%{_datadir}/kde4/services/plasma-wallpaper-pattern.desktop
306%{_datadir}/kde4/services/plasma-wallpaper-virus.desktop
307%{_datadir}/kde4/services/plasma-wallpaper-weather.desktop
308%{_datadir}/kde4/services/plasma_applet_plasmaboard.desktop
309%{_datadir}/kde4/services/wcpotdprovider.desktop
1cf65df3 310%{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
c73f6b0c 311%{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
28096eda 312%{_datadir}/config/comic.knsrc
27f59e66 313%{_datadir}/config/pastebin.knsrc
32c4451f 314%{_datadir}/config/plasmaweather.knsrc
c73f6b0c 315%{_datadir}/config/virus_wallpaper.knsrc
e250f604 316%{_datadir}/config.kcfg/kimpanelconfig.kcfg
27f59e66
KK
317%{_datadir}/apps/desktoptheme/default/bubblemon
318%{_datadir}/apps/desktoptheme/default/fifteenPuzzle
319%{_datadir}/apps/desktoptheme/default/icontasks
320%{_datadir}/apps/desktoptheme/default/rssnow
32c4451f 321%{_iconsdir}/hicolor/scalable/apps/accessories-dictionary.svgz
322%{_iconsdir}/hicolor/scalable/apps/bball.svgz
27f59e66
KK
323%{_iconsdir}/hicolor/scalable/apps/eyes.svgz
324%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
325%{_iconsdir}/hicolor/scalable/apps/kdeobservatory.svgz
326%{_iconsdir}/hicolor/scalable/apps/lifegame.svgz
e250f604 327%{_iconsdir}/hicolor/*x*/apps/qalculate-applet.png
85896f2c 328%{_iconsdir}/hicolor/*x*/apps/plasmaapplet-shelf.png
5d543186
AM
329%{_iconsdir}/hicolor/*x*/apps/eyes.png
330%{_iconsdir}/hicolor/*x*/apps/kdeobservatory.png
331%{_iconsdir}/hicolor/*x*/apps/lifegame.png
332%{_iconsdir}/hicolor/*x*/apps/luna.png
28096eda 333%dir %{_datadir}/apps/rssnow
334%{_datadir}/apps/rssnow/feeds
335%{_iconsdir}/*/*x*/apps/previewer.png
28096eda 336%{_datadir}/kde4/services/ServiceMenus/preview.desktop
337%dir %{_datadir}/apps/bball
338%{_datadir}/apps/bball/bball.svgz
32c4451f 339%{_iconsdir}/*/*x*/apps/bball.png
28096eda 340%{_datadir}/apps/bball/bounce.ogg
341%{_datadir}/apps/bball/football.svgz
c73f6b0c 342%{_datadir}/apps/plasma
85896f2c 343%{_datadir}/apps/plasmaboard
c73f6b0c 344%{_datadir}/apps/plasma-applet-opendesktop
32c4451f 345%{_datadir}/apps/plasma-applet-opendesktop-activities
346%{_datadir}/apps/plasma-applet-frame
c73f6b0c 347%{_datadir}/apps/plasma_pastebin
348%{_datadir}/apps/plasma_wallpaper_pattern
db617da2 349%{_datadir}/kde4/services/lancelot.desktop
350%{_datadir}/kde4/services/plasma-containment-griddesktop.desktop
351%{_datadir}/kde4/services/plasma-containment-groupingdesktop.desktop
352%{_datadir}/kde4/services/plasma-containment-groupingpanel.desktop
353%{_datadir}/kde4/services/plasma-runner-events.desktop
354%{_datadir}/kde4/services/plasma-runner-events_config.desktop
e250f604
AM
355%{_datadir}/kde4/services/plasma-applet-icontasks.desktop
356%{_datadir}/kde4/services/plasma-applet-kimpanel.desktop
357%{_datadir}/kde4/services/plasma-applet-qalculate.desktop
358%{_datadir}/kde4/services/plasma-dataengine-kimpanel.desktop
359%{_datadir}/kde4/services/plasma-wallpaper-potd.desktop
28096eda 360
361%files lancelot
362%defattr(644,root,root,755)
363%attr(755,root,root) %{_bindir}/lancelot
364%attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
365%attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
05fc8ea2
RT
366%attr(755,root,root) %{_libdir}/liblancelot.so
367%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.?
368%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.*.*.*
369%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_launcher.so
370%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_part.so
28096eda 371%{_datadir}/apps/desktoptheme/default/lancelot
32c4451f 372%{_datadir}/apps/desktoptheme/oxygen/lancelot
05fc8ea2
RT
373%{_datadir}/kde4/services/plasma-applet-lancelot-launcher.desktop
374%{_datadir}/kde4/services/plasma-applet-lancelot-part.desktop
db617da2 375#%{_datadir}/dbus-1/services/org.kde.lancelot.service
28096eda 376%{_datadir}/mime/packages/lancelotpart-mime.xml
c73f6b0c 377%{_datadir}/apps/lancelot
28096eda 378%{_iconsdir}/hicolor/*x*/apps/lancelot.png
85896f2c 379%{_iconsdir}/hicolor/*x*/apps/lancelot-start.png
c73f6b0c 380
381%files devel
382%defattr(644,root,root,755)
383%attr(755,root,root) %{_libdir}/*.so
05fc8ea2
RT
384%{_includedir}/KDE/Lancelot
385%{_includedir}/lancelot-datamodels
c73f6b0c 386%{_includedir}/lancelot
40f03c32 387%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.110821 seconds and 4 git commands to generate.