]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blame - kde4-kdeplasma-addons.spec
- up to 4.7.0 but fails to build
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
CommitLineData
32c4451f 1# TODO:
2# Lancelot: installed - cmake unimplemented because not found
3# * XRender - Lancelot compositing support
4# * Eigen2 - Eigen2 enables the Mandelbrot wallpaper plugin.
c73f6b0c 5
6%bcond_without marble # don't build marble plasma support
7
32c4451f 8%define orgname kdeplasma-addons
9%define _state stable
c054b3a8 10%define qtver 4.7.3
1cf65df3 11
12Summary: KDE4 Plasmoids
b4bc4746 13Summary(pl.UTF-8): Plazmoidy dla KDE4
1cf65df3 14Name: kde4-kdeplasma-addons
943224af
AM
15Version: 4.7.0
16Release: 0.1
1cf65df3 17License: GPL v2
18Group: X11/Applications
19Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
943224af 20# Source0-md5: f7152ffd214d96b01fab0b112ce4def6
9baaa66a 21Patch100: %{name}-branch.diff
28096eda 22Patch0: %{name}-pastebinpld.patch
7ab2d436 23URL: http://www.kde.org/
22957f69 24BuildRequires: OpenGL-GLU-devel
ae48935e 25BuildRequires: OpenGL-devel
32c4451f 26BuildRequires: QtNetwork-devel >= %{qtver}
28096eda 27BuildRequires: automoc4 >= 0.9.88
32c4451f 28BuildRequires: cmake >= 2.8.0
cae2d48b 29BuildRequires: eigen >= 1:2.0.12-3
1cf65df3 30BuildRequires: kde4-kdebase-workspace-devel >= %{version}
31BuildRequires: kde4-kdelibs-devel >= %{version}
32BuildRequires: kde4-kdepimlibs-devel >= %{version}
943224af
AM
33%{?with_marble:BuildRequires: libkdeedu-devel >= %{version}}
34BuildRequires: libkexiv2-devel >= %{version}
35BuildRequires: marble-devel >= 4.7.0
05a0aa81 36BuildRequires: phonon-devel >= 4.4.1
0915a2df 37BuildRequires: pkgconfig
38BuildRequires: python
fd153232 39BuildRequires: qca-devel >= 2.0.2
943224af 40BuildRequires: qimageblitz-devel
64ed9cbc 41BuildRequires: qimageblitz-devel >= 0.0.6
32c4451f 42BuildRequires: qt4-build >= %{qtver}
43BuildRequires: qt4-qmake >= %{qtver}
b86025ef 44BuildRequires: qwt-devel
50c904e6 45BuildRequires: rpmbuild(macros) >= 1.600
6352f2c4 46BuildRequires: scim-devel
05a0aa81 47BuildRequires: shared-desktop-ontologies-devel >= 0.5
48BuildRequires: soprano-devel >= 2.4.64
49BuildRequires: strigi-devel >= 0.7.2
32c4451f 50BuildRequires: xorg-lib-libXcomposite-devel
51BuildRequires: xorg-lib-libXdamage-devel
52BuildRequires: xorg-lib-libXrender-devel
75f86cc0 53BuildRequires: xorg-lib-libXtst-devel
1cf65df3 54Obsoletes: kde4-kdeplasmoids
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57%description
b4bc4746 58KDE4 plasmoids.
1cf65df3 59
60%description -l pl.UTF-8
b4bc4746 61Plazmoidy dla KDE4.
1cf65df3 62
28096eda 63%package lancelot
64Summary: Lancelot Desktop Theme
72db3ff2 65Summary(pl.UTF-8): Motyw pulpitu Lancelot
28096eda 66Group: X11/Applications
67Requires: kde4-kdebase-workspace >= %{version}
68
69%description lancelot
70Lancelot Desktop Theme.
71
72%description lancelot -l pl.UTF-8
72db3ff2 73Motyw pulpitu Lancelot.
28096eda 74
c73f6b0c 75%package devel
76Summary: Development files for KDE4 Plasmoids
77Summary(pl.UTF-8): Pliki nagłówkowe bibliotek plazmoidów dla KDE4
78Group: X11/Development/Libraries
79Requires: %{name} = %{version}-%{release}
0e26ec14 80Requires: kde4-kdebase-workspace-devel >= %{version}
81Requires: kde4-kdegraphics-devel >= %{version}
82Requires: kde4-kdelibs-devel >= %{version}
83Requires: kde4-kdepimlibs-devel >= %{version}
c73f6b0c 84
85%description devel
86This package contains header files needed if you wish to build
87applications based on KDE4 Plasmoids.
88
89%description devel -l pl.UTF-8
90Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
91opartych na plazmoidach dla KDE4.
92
1cf65df3 93%prep
94%setup -q -n %{orgname}-%{version}
508bd1fc 95#%patch100 -p0
db617da2 96#%patch0 -p1
1cf65df3 97
98%build
99install -d build
100cd build
101%cmake \
1cf65df3 102 ../
103
104%{__make}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%{__make} -C build install \
110 DESTDIR=$RPM_BUILD_ROOT
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
28096eda 118%post lancelot -p /sbin/ldconfig
119%postun lancelot -p /sbin/ldconfig
120
1cf65df3 121%files
122%defattr(644,root,root,755)
522d5a47 123%attr(755,root,root) %{_bindir}/kimpanel
1cf65df3 124%attr(755,root,root) %{_libdir}/kde4/krunner_*.so
28096eda 125%attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
05fc8ea2
RT
126%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bball.so
127%attr(755,root,root) %{_libdir}/kde4/plasma_applet_binaryclock.so
128%attr(755,root,root) %{_libdir}/kde4/plasma_applet_blackboard.so
129%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bookmarks.so
130%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bubblemon.so
131%attr(755,root,root) %{_libdir}/kde4/plasma_applet_calculator.so
132%attr(755,root,root) %{_libdir}/kde4/plasma_applet_charselect.so
133%attr(755,root,root) %{_libdir}/kde4/plasma_applet_comic.so
134%attr(755,root,root) %{_libdir}/kde4/plasma_applet_dict.so
135%attr(755,root,root) %{_libdir}/kde4/plasma_applet_eyes.so
136%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fifteenPuzzle.so
137%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fileWatcher.so
138%attr(755,root,root) %{_libdir}/kde4/plasma_applet_frame.so
139%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fuzzy_clock.so
140%attr(755,root,root) %{_libdir}/kde4/plasma_applet_incomingmsg.so
50c904e6 141%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kdeobservatory.so
522d5a47 142%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kimpanel.so
05fc8ea2
RT
143%attr(755,root,root) %{_libdir}/kde4/plasma_applet_knowledgebase.so
144%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kolourpicker.so
145%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konqprofiles.so
146%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konsoleprofiles.so
147%attr(755,root,root) %{_libdir}/kde4/plasma_applet_leavenote.so
148%attr(755,root,root) %{_libdir}/kde4/plasma_applet_life.so
149%attr(755,root,root) %{_libdir}/kde4/plasma_applet_luna.so
150%attr(755,root,root) %{_libdir}/kde4/plasma_applet_magnifique.so
151%attr(755,root,root) %{_libdir}/kde4/plasma_applet_mediaplayer.so
152%attr(755,root,root) %{_libdir}/kde4/plasma_applet_microblog.so
153%attr(755,root,root) %{_libdir}/kde4/plasma_applet_news.so
154%attr(755,root,root) %{_libdir}/kde4/plasma_applet_notes.so
155%attr(755,root,root) %{_libdir}/kde4/plasma_applet_nowplaying.so
156%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop.so
157%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop_activities.so
158%attr(755,root,root) %{_libdir}/kde4/plasma_applet_paste.so
159%attr(755,root,root) %{_libdir}/kde4/plasma_applet_pastebin.so
160%attr(755,root,root) %{_libdir}/kde4/plasma_applet_plasmaboard.so
161%attr(755,root,root) %{_libdir}/kde4/plasma_applet_previewer.so
162%attr(755,root,root) %{_libdir}/kde4/plasma_applet_qalculate.so
163%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rssnow.so
164%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rtm.so
165%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdashboard.so
166%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdesktop.so
167%attr(755,root,root) %{_libdir}/kde4/plasma_applet_spellcheck.so
168%attr(755,root,root) %{_libdir}/kde4/plasma_applet_timer.so
169%attr(755,root,root) %{_libdir}/kde4/plasma_applet_unitconverter.so
170%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weather.so
171%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weatherstation.so
172%attr(755,root,root) %{_libdir}/kde4/plasma_applet_webslice.so
1cf65df3 173%attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
174%attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
28096eda 175%attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
1cf65df3 176%attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
177%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
c73f6b0c 178%attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
179%attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
180%attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
181%attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
182%attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
183%attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
85896f2c 184%attr(755,root,root) %{_libdir}/kde4/plasma_runner_datetime.so
c73f6b0c 185%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
db617da2 186%attr(755,root,root) %{_libdir}/kde4/kcm_plasma_runner_events.so
187%attr(755,root,root) %{_libdir}/kde4/plasma_containment_griddesktop.so
188%attr(755,root,root) %{_libdir}/kde4/plasma_containment_groupingdesktop.so
189%attr(755,root,root) %{_libdir}/kde4/plasma_containment_groupingpanel.so
190%attr(755,root,root) %{_libdir}/kde4/plasma_runner_events.so
c73f6b0c 191%if %{with marble}
192%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
193%endif
194%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
195%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
196%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
522d5a47 197%attr(755,root,root) %{_libdir}/libkimpanelruntime.so.?
c73f6b0c 198%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
199%attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
200%attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
201%attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
202%attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
203%attr(755,root,root) %ghost %{_libdir}/librtm.so.?
204%attr(755,root,root) %{_libdir}/librtm.so.*.*.*
db617da2 205%attr(755,root,root) %ghost %{_libdir}/libplasma_groupingcontainment.so.?
206%attr(755,root,root) %{_libdir}/libplasma_groupingcontainment.so.*.*.*
522d5a47
AM
207%attr(755,root,root) %{_libdir}/scim-*/scim-panel-dbus
208%{_datadir}/config.kcfg/kimpanelconfig.kcfg
209%{_datadir}/dbus-1/interfaces/org.kde.impanel.xml
1cf65df3 210%{_datadir}/apps/desktoptheme/Aya
db617da2 211#%{_datadir}/apps/desktoptheme/Elegance
212#%{_datadir}/apps/desktoptheme/Silicon
28096eda 213%dir %{_datadir}/apps/desktoptheme/default/stylesheets
214%{_datadir}/apps/desktoptheme/default/stylesheets/*
215%dir %{_datadir}/apps/desktoptheme/default/weatherstation
216%{_datadir}/apps/desktoptheme/default/weatherstation/*
c73f6b0c 217%dir %{_datadir}/apps/desktoptheme/default/weather/
218%{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
1cf65df3 219%{_datadir}/apps/desktoptheme/default/widgets/*
db617da2 220#%{_datadir}/apps/desktoptheme/heron
1cf65df3 221%{_datadir}/apps/desktoptheme/slim-glow
05fc8ea2
RT
222%{_datadir}/kde4/services/CharRunner_config.desktop
223%{_datadir}/kde4/services/CharacterRunner.desktop
224%{_datadir}/kde4/services/apodprovider.desktop
225%{_datadir}/kde4/services/browserhistory.desktop
226%{_datadir}/kde4/services/epodprovider.desktop
227%{_datadir}/kde4/services/flickrprovider.desktop
228%{_datadir}/kde4/services/katesessions.desktop
229%{_datadir}/kde4/services/konquerorsessions.desktop
230%{_datadir}/kde4/services/konsolesessions.desktop
231%{_datadir}/kde4/services/oseiprovider.desktop
232%{_datadir}/kde4/services/plasma-applet-bball.desktop
233%{_datadir}/kde4/services/plasma-applet-binaryclock.desktop
234%{_datadir}/kde4/services/plasma-applet-blackboard.desktop
235%{_datadir}/kde4/services/plasma-applet-bookmarks.desktop
236%{_datadir}/kde4/services/plasma-applet-bubblemon.desktop
237%{_datadir}/kde4/services/plasma-applet-calculator.desktop
238%{_datadir}/kde4/services/plasma-applet-charselect.desktop
239%{_datadir}/kde4/services/plasma-applet-eyes.desktop
240%{_datadir}/kde4/services/plasma-applet-fifteenPuzzle.desktop
241%{_datadir}/kde4/services/plasma-applet-incomingmsg.desktop
50c904e6 242%{_datadir}/kde4/services/plasma-applet-kdeobservatory.desktop
522d5a47 243%{_datadir}/kde4/services/plasma-applet-kimpanel.desktop
05fc8ea2
RT
244%{_datadir}/kde4/services/plasma-applet-knowledgebase.desktop
245%{_datadir}/kde4/services/plasma-applet-konqprofiles.desktop
246%{_datadir}/kde4/services/plasma-applet-konsoleprofiles.desktop
247%{_datadir}/kde4/services/plasma-applet-leavenote.desktop
248%{_datadir}/kde4/services/plasma-applet-life.desktop
249%{_datadir}/kde4/services/plasma-applet-luna.desktop
250%{_datadir}/kde4/services/plasma-applet-magnifique.desktop
251%{_datadir}/kde4/services/plasma-applet-mediaplayer.desktop
252%{_datadir}/kde4/services/plasma-applet-microblog.desktop
253%{_datadir}/kde4/services/plasma-applet-news.desktop
254%{_datadir}/kde4/services/plasma-applet-nowplaying.desktop
255%{_datadir}/kde4/services/plasma-applet-opendesktop-activities.desktop
256%{_datadir}/kde4/services/plasma-applet-opendesktop.desktop
257%{_datadir}/kde4/services/plasma-applet-paste.desktop
258%{_datadir}/kde4/services/plasma-applet-pastebin.desktop
259%{_datadir}/kde4/services/plasma-applet-previewer.desktop
260%{_datadir}/kde4/services/plasma-applet-qalculate.desktop
261%{_datadir}/kde4/services/plasma-applet-rememberthemilk.desktop
262%{_datadir}/kde4/services/plasma-applet-rssnow.desktop
263%{_datadir}/kde4/services/plasma-applet-showdashboard.desktop
264%{_datadir}/kde4/services/plasma-applet-showdesktop.desktop
265%{_datadir}/kde4/services/plasma-applet-spellcheck.desktop
266%{_datadir}/kde4/services/plasma-applet-systemloadviewer.desktop
267%{_datadir}/kde4/services/plasma-applet-timer.desktop
268%{_datadir}/kde4/services/plasma-applet-unitconverter.desktop
269%{_datadir}/kde4/services/plasma-applet-weather.desktop
270%{_datadir}/kde4/services/plasma-applet-weatherstation.desktop
271%{_datadir}/kde4/services/plasma-applet-webslice.desktop
272%{_datadir}/kde4/services/plasma-clock-fuzzy.desktop
273%{_datadir}/kde4/services/plasma-comic-default.desktop
274%{_datadir}/kde4/services/plasma-dataengine-comic.desktop
275%{_datadir}/kde4/services/plasma-dataengine-microblog.desktop
276%{_datadir}/kde4/services/plasma-dataengine-ocs.desktop
277%{_datadir}/kde4/services/plasma-dataengine-potd.desktop
278%{_datadir}/kde4/services/plasma-dict-default.desktop
279%{_datadir}/kde4/services/plasma-engine-kdeobservatory.desktop
db617da2 280#%{_datadir}/kde4/services/plasma-engine-pastebin.desktop
05fc8ea2
RT
281%{_datadir}/kde4/services/plasma-engine-rtm.desktop
282%{_datadir}/kde4/services/plasma-fileWatcher-default.desktop
283%{_datadir}/kde4/services/plasma-frame-default.desktop
284%{_datadir}/kde4/services/plasma-kolourpicker-default.desktop
285%{_datadir}/kde4/services/plasma-notes-default.desktop
286%{_datadir}/kde4/services/plasma-packagestructure-comic.desktop
287%{_datadir}/kde4/services/plasma-runner-audioplayercontrol.desktop
288%{_datadir}/kde4/services/plasma-runner-audioplayercontrol_config.desktop
289%{_datadir}/kde4/services/plasma-runner-contacts.desktop
290%{_datadir}/kde4/services/plasma-runner-converter.desktop
291%{_datadir}/kde4/services/plasma-runner-datetime.desktop
292%{_datadir}/kde4/services/plasma-runner-kopete.desktop
293%{_datadir}/kde4/services/plasma-runner-spellchecker.desktop
294%{_datadir}/kde4/services/plasma-runner-spellchecker_config.desktop
295%{_datadir}/kde4/services/plasma-runner-techbase.desktop
296%{_datadir}/kde4/services/plasma-runner-wikipedia.desktop
297%{_datadir}/kde4/services/plasma-runner-wikitravel.desktop
298%{_datadir}/kde4/services/plasma-wallpaper-mandelbrot.desktop
299%{_datadir}/kde4/services/plasma-wallpaper-marble.desktop
300%{_datadir}/kde4/services/plasma-wallpaper-pattern.desktop
301%{_datadir}/kde4/services/plasma-wallpaper-virus.desktop
302%{_datadir}/kde4/services/plasma-wallpaper-weather.desktop
303%{_datadir}/kde4/services/plasma_applet_plasmaboard.desktop
304%{_datadir}/kde4/services/wcpotdprovider.desktop
1cf65df3 305%{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
c73f6b0c 306%{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
28096eda 307%{_datadir}/config/comic.knsrc
32c4451f 308%{_datadir}/config/plasmaweather.knsrc
c73f6b0c 309%{_datadir}/config/virus_wallpaper.knsrc
28096eda 310%dir %{_datadir}/apps/desktoptheme/default/rssnow
311%{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
312%{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
313%{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
314%{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
c73f6b0c 315%dir %{_datadir}/apps/desktoptheme/default/bubblemon
316%{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
317%dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
32c4451f 318%{_datadir}/apps/desktoptheme/default/fifteenPuzzle/blanksquare.svg
c73f6b0c 319%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
32c4451f 320%{_iconsdir}/hicolor/scalable/apps/accessories-dictionary.svgz
321%{_iconsdir}/hicolor/scalable/apps/bball.svgz
544dba0a 322%{_iconsdir}/hicolor/*x*/apps/qalculate-applet.png
85896f2c 323%{_iconsdir}/hicolor/*x*/apps/plasmaapplet-shelf.png
5d543186
AM
324%{_iconsdir}/hicolor/*x*/apps/eyes.png
325%{_iconsdir}/hicolor/*x*/apps/kdeobservatory.png
326%{_iconsdir}/hicolor/*x*/apps/lifegame.png
327%{_iconsdir}/hicolor/*x*/apps/luna.png
db617da2 328%{_datadir}/config/pastebin.knsrc
28096eda 329%dir %{_datadir}/apps/rssnow
330%{_datadir}/apps/rssnow/feeds
331%{_iconsdir}/*/*x*/apps/previewer.png
28096eda 332%{_datadir}/kde4/services/ServiceMenus/preview.desktop
333%dir %{_datadir}/apps/bball
334%{_datadir}/apps/bball/bball.svgz
32c4451f 335%{_iconsdir}/*/*x*/apps/bball.png
28096eda 336%{_datadir}/apps/bball/bounce.ogg
337%{_datadir}/apps/bball/football.svgz
c73f6b0c 338%{_datadir}/apps/plasma
85896f2c 339%{_datadir}/apps/plasmaboard
c73f6b0c 340%{_datadir}/apps/plasma-applet-opendesktop
32c4451f 341%{_datadir}/apps/plasma-applet-opendesktop-activities
342%{_datadir}/apps/plasma-applet-frame
c73f6b0c 343%{_datadir}/apps/plasma_pastebin
344%{_datadir}/apps/plasma_wallpaper_pattern
db617da2 345%{_datadir}/kde4/services/lancelot.desktop
346%{_datadir}/kde4/services/plasma-containment-griddesktop.desktop
347%{_datadir}/kde4/services/plasma-containment-groupingdesktop.desktop
348%{_datadir}/kde4/services/plasma-containment-groupingpanel.desktop
349%{_datadir}/kde4/services/plasma-runner-events.desktop
350%{_datadir}/kde4/services/plasma-runner-events_config.desktop
28096eda 351
352%files lancelot
353%defattr(644,root,root,755)
354%attr(755,root,root) %{_bindir}/lancelot
355%attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
356%attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
05fc8ea2
RT
357%attr(755,root,root) %{_libdir}/liblancelot.so
358%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.?
359%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.*.*.*
360%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_launcher.so
361%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_part.so
28096eda 362%{_datadir}/apps/desktoptheme/default/lancelot
32c4451f 363%{_datadir}/apps/desktoptheme/oxygen/lancelot
05fc8ea2
RT
364%{_datadir}/kde4/services/plasma-applet-lancelot-launcher.desktop
365%{_datadir}/kde4/services/plasma-applet-lancelot-part.desktop
db617da2 366#%{_datadir}/dbus-1/services/org.kde.lancelot.service
28096eda 367%{_datadir}/mime/packages/lancelotpart-mime.xml
c73f6b0c 368%{_datadir}/apps/lancelot
28096eda 369%{_iconsdir}/hicolor/*x*/apps/lancelot.png
85896f2c 370%{_iconsdir}/hicolor/*x*/apps/lancelot-start.png
c73f6b0c 371
372%files devel
373%defattr(644,root,root,755)
374%attr(755,root,root) %{_libdir}/*.so
05fc8ea2
RT
375%{_includedir}/KDE/Lancelot
376%{_includedir}/lancelot-datamodels
c73f6b0c 377%{_includedir}/lancelot
40f03c32 378%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.146973 seconds and 4 git commands to generate.