]> git.pld-linux.org Git - packages/john.git/blame - john.spec
- add optflags patch, cosmetics
[packages/john.git] / john.spec
CommitLineData
94f3ed69 1#
d502d3d5 2# Conditional build:
9da9f6f0 3%bcond_with jumbopatch # This patch integrates lots of contributed
3443e32b
ER
4 # patches adding support for over 30
5 # of additional hash types, and more.
d502d3d5 6
532ea34a
JB
7%ifarch i586 i686 athlon pentium2 pentium3 pentium4
8%define do_mmx 1
9%else
10%define do_mmx 0
11%endif
12%ifarch i586 i686
13%define do_mmxfb 1
14%define optmmxfb -DCPU_FALLBACK=1
15%else
16%define do_mmxfb 0
17%undefine optmmxfb
d940cdff 18%endif
00a4c442 19Summary: Password cracker
25772a4c 20Summary(pl.UTF-8): Łamacz haseł
00a4c442 21Name: john
eea2a06f 22Version: 1.7.6
dc236676 23Release: 1
e73a58f8 24License: GPL
94f3ed69 25Group: Applications/System
255a377d 26Source0: http://www.openwall.com/john/g/%{name}-%{version}.tar.bz2
eea2a06f 27# Source0-md5: 321ac0793f1aa4f0603b33a393133756
18fb1460 28Patch0: %{name}-mailer.patch
3443e32b
ER
29Patch1: optflags.patch
30%{?with_jumbopatch:Patch1: http://www.openwall.com/john/contrib/%{name}-%{version}-jumbo-2.diff.gz}
ad326883 31URL: http://www.openwall.com/john/
3443e32b 32%{?with_jumbopatch:BuildRequires: openssl-devel >= 0.9.7}
4380352b 33BuildRequires: rpmbuild(macros) >= 1.213
53d2a984 34Requires: words
fbb20392 35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
00a4c442 36
37%description
8e3a118d
JB
38John the Ripper is a fast password cracker, currently available for
39many flavors of Unix (11 are officially supported, not counting
40different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
41requires a contributed patch). Its primary purpose is to detect weak
42Unix passwords. Besides several crypt(3) password hash types most
43commonly found on various Unix flavors, supported out of the box are
44Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
45contributed patches.
e73a58f8 46
15ea9c6b
JR
47%description -l pl.UTF-8
48John The Ripper jest szybkim "łamaczem" haseł dostępnym dla wielu
49rodzajów uniksów (oficjalnie obsługiwanych jest 11, nie licząc różnych
8e3a118d 50architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
15ea9c6b
JR
51łaty). Głównym zastosowaniem jest wykrywanie słabych haseł uniksowych.
52Oprócz różnych rodzajów skrótów haseł crypt(3) najczęściej używanych
53na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
54Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
e73a58f8 55
00a4c442 56%prep
51da11ae 57%setup -q
00a4c442 58%patch0 -p1
3443e32b 59%patch1 -p1
9da9f6f0 60%{?with_jumbopatch:%patch1 -p1}
18fb1460 61
3443e32b
ER
62rm -f doc/INSTALL
63
00a4c442 64%build
65cd src
94f3ed69 66
532ea34a
JB
67%if %{do_mmxfb}
68%{__make} linux-x86-any \
3443e32b
ER
69 CC="%{__cc}" \
70 OPTFLAGS="%{rpmcflags} -DJOHN_SYSTEMWIDE=1"
532ea34a
JB
71mv ../run/john ../run/john-non-mmx
72%{__make} clean
73%endif
74
3443e32b 75TARG=generic
94f3ed69 76%ifarch %{ix86}
532ea34a 77 %if %{do_mmx}
1f693868 78 TARG=linux-x86-mmx
94f3ed69 79 %else
1f693868 80 TARG=linux-x86-any
94f3ed69 81 %endif
3443e32b
ER
82%endif
83%ifarch alpha
84 TARG=linux-alpha
85%endif
86%ifarch sparc sparcv9
87 TARG=linux-sparc
88%endif
89%ifarch %{x8664}
90 TARG=linux-x86-64
94f3ed69
JB
91%endif
92
c4418ed8 93%{__make} $TARG \
3443e32b
ER
94 CC="%{__cc}" \
95 OPTFLAGS="%{rpmcflags} -DJOHN_SYSTEMWIDE=1 -DJOHN_SYSTEMWIDE_EXEC=\\\"%{_libdir}/john\\\" %{?optmmxfb}"
94f3ed69 96
00a4c442 97%install
98rm -rf $RPM_BUILD_ROOT
18fb1460 99install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
3443e32b
ER
100cp -a run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
101install -p run/john $RPM_BUILD_ROOT%{_bindir}
532ea34a
JB
102%if %{do_mmxfb}
103install -d $RPM_BUILD_ROOT%{_libdir}/john
3443e32b 104install -p run/john-non-mmx $RPM_BUILD_ROOT%{_libdir}/john
532ea34a 105%endif
d940cdff 106
3443e32b
ER
107ln -sf john $RPM_BUILD_ROOT%{_bindir}/unafs
108ln -sf john $RPM_BUILD_ROOT%{_bindir}/unique
109ln -sf john $RPM_BUILD_ROOT%{_bindir}/unshadow
00a4c442 110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files
115%defattr(644,root,root,755)
1f693868 116%doc doc/* run/mailer
3443e32b
ER
117%attr(755,root,root) %{_bindir}/john
118%attr(755,root,root) %{_bindir}/unafs
119%attr(755,root,root) %{_bindir}/unique
120%attr(755,root,root) %{_bindir}/unshadow
532ea34a
JB
121%if %{do_mmxfb}
122%dir %{_libdir}/john
123%attr(755,root,root) %{_libdir}/john/john-non-mmx
124%endif
18fb1460 125%{_datadir}/john
This page took 0.123482 seconds and 4 git commands to generate.