]> git.pld-linux.org Git - packages/john.git/blame - john.spec
- s/path/patch/
[packages/john.git] / john.spec
CommitLineData
94f3ed69 1#
d502d3d5 2# Conditional build:
9da9f6f0 3%bcond_with jumbopatch # This patch integrates lots of contributed
d502d3d5
KG
4 # patches adding support for over 30
5 # of additional hash types, and more.
6
532ea34a
JB
7%ifarch i586 i686 athlon pentium2 pentium3 pentium4
8%define do_mmx 1
9%else
10%define do_mmx 0
11%endif
12%ifarch i586 i686
13%define do_mmxfb 1
14%define optmmxfb -DCPU_FALLBACK=1
15%else
16%define do_mmxfb 0
17%undefine optmmxfb
d940cdff 18%endif
00a4c442 19Summary: Password cracker
25772a4c 20Summary(pl.UTF-8): Łamacz haseł
00a4c442 21Name: john
5d62d856 22Version: 1.7.3.4
d502d3d5 23Release: 2
e73a58f8 24License: GPL
94f3ed69 25Group: Applications/System
255a377d 26Source0: http://www.openwall.com/john/g/%{name}-%{version}.tar.bz2
5d62d856 27# Source0-md5: 2f2310c49961c3edea6f92b8dcd45ff4
18fb1460 28Patch0: %{name}-mailer.patch
9da9f6f0 29%{?with_jumbopatch:Patch1: http://www.openwall.com/john/contrib/john-%{version}-jumbo-2.diff.gz}
ad326883 30URL: http://www.openwall.com/john/
4380352b 31BuildRequires: rpmbuild(macros) >= 1.213
9da9f6f0 32%{?with_jumbopatch:BuildRequires: openssl-devel >= 0.9.7}
53d2a984 33Requires: words
fbb20392 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
00a4c442 35
36%description
8e3a118d
JB
37John the Ripper is a fast password cracker, currently available for
38many flavors of Unix (11 are officially supported, not counting
39different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
40requires a contributed patch). Its primary purpose is to detect weak
41Unix passwords. Besides several crypt(3) password hash types most
42commonly found on various Unix flavors, supported out of the box are
43Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
44contributed patches.
e73a58f8 45
15ea9c6b
JR
46%description -l pl.UTF-8
47John The Ripper jest szybkim "łamaczem" haseł dostępnym dla wielu
48rodzajów uniksów (oficjalnie obsługiwanych jest 11, nie licząc różnych
8e3a118d 49architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
15ea9c6b
JR
50łaty). Głównym zastosowaniem jest wykrywanie słabych haseł uniksowych.
51Oprócz różnych rodzajów skrótów haseł crypt(3) najczęściej używanych
52na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
53Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
e73a58f8 54
00a4c442 55%prep
51da11ae 56%setup -q
00a4c442 57%patch0 -p1
9da9f6f0 58%{?with_jumbopatch:%patch1 -p1}
18fb1460 59
00a4c442 60%build
61cd src
94f3ed69 62
532ea34a
JB
63%if %{do_mmxfb}
64%{__make} linux-x86-any \
65 CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1" \
66 CC="%{__cc}"
67mv ../run/john ../run/john-non-mmx
68%{__make} clean
69%endif
70
94f3ed69 71%ifarch %{ix86}
532ea34a 72 %if %{do_mmx}
1f693868 73 TARG=linux-x86-mmx
94f3ed69 74 %else
1f693868 75 TARG=linux-x86-any
94f3ed69
JB
76 %endif
77%else
78 %ifarch alpha
79 TARG=linux-alpha
80 %else
cd675709 81 %ifarch sparc sparcv9
94f3ed69
JB
82 TARG=linux-sparc
83 %else
4380352b 84 %ifarch %{x8664}
b2ee9acd 85 TARG=linux-x86-64
86 %else
87 TARG=generic
51da11ae 88 %endif
94f3ed69
JB
89 %endif
90 %endif
91%endif
92
c4418ed8 93%{__make} $TARG \
532ea34a 94 CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1 -DJOHN_SYSTEMWIDE_EXEC=\\\"%{_libdir}/john\\\" %{?optmmxfb}" \
c4418ed8 95 CC="%{__cc}"
94f3ed69 96
00a4c442 97%install
98rm -rf $RPM_BUILD_ROOT
18fb1460 99
100install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
101install run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
90d33dbc 102install run/john $RPM_BUILD_ROOT%{_bindir}
532ea34a
JB
103%if %{do_mmxfb}
104install -d $RPM_BUILD_ROOT%{_libdir}/john
105install run/john-non-mmx $RPM_BUILD_ROOT%{_libdir}/john
106%endif
d940cdff 107
368eb044 108rm -f doc/INSTALL
00a4c442 109
90d33dbc 110cd $RPM_BUILD_ROOT%{_bindir}
94f3ed69
JB
111ln -sf john unafs
112ln -sf john unique
113ln -sf john unshadow
00a4c442 114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files
119%defattr(644,root,root,755)
1f693868 120%doc doc/* run/mailer
90d33dbc 121%attr(755,root,root) %{_bindir}/*
532ea34a
JB
122%if %{do_mmxfb}
123%dir %{_libdir}/john
124%attr(755,root,root) %{_libdir}/john/john-non-mmx
125%endif
18fb1460 126%{_datadir}/john
This page took 0.041978 seconds and 4 git commands to generate.