]> git.pld-linux.org Git - packages/hhvm.git/blame - hhvm.spec
- one more gcc fix
[packages/hhvm.git] / hhvm.spec
CommitLineData
fd4a736f
ER
1#
2# Conditional build:
3%bcond_without system_dconv # system double-conversion
4%bcond_without system_sqlite # system sqlite3
5%bcond_without system_lz4 # system lz4
e494b5cb 6%bcond_without system_fastlz # system fastlz
934d354b 7%bcond_with system_libafdt # system libafdt
c19fc9d9 8%bcond_without system_libzip # system libzip
8041f44b
ER
9# cotire breaks sqlite3 on builders: https://github.com/facebook/hhvm/issues/4524
10%bcond_with cotire # cotire (compile time reducer): Speed up the build by precompiling headers
fd4a736f 11
b682fdb1
ER
12# TODO
13# - system xhp
14# - system proxygen
15# - system thrift
16
89ad59aa
ER
17# NOTES:
18# - hphp/runtime/base/runtime-option.cpp evalJitDefault enables jit if /.hhvm-jit exists (yes, in filesystem root)
b682fdb1 19
d9b6cc98
ER
20# must be in sync with source. extra check ensuring that it is so is done in %%build
21%define hhvm_api_version 20140829
af2b6c94
ER
22# hphp/system/idl/constants.idl.json defines it as 5.6.99-hhvm, but use some saner value
23%define php_version 5.6.0
24
ffc743bc
ER
25# git show HHVM-3.3.7
26%define githash e0344cb6ab126e50e611332f03f447f586cc763a
b682fdb1 27# these hashes are git submodules (be sure to check them on proper branch)
e7f30897
ER
28# GIT_DIR=third-party/.git git log -1
29%define thirdparty bf581f8
e7f30897 30# GIT_DIR=third-party/folly/src/.git git log -1
b682fdb1 31%define folly 6e46d46
ed14b19f 32Summary: Virtual Machine, Runtime, and JIT for PHP
aa7908cc 33Name: hhvm
d84d6344
ER
34# we prefer LTS versions
35# see http://hhvm.com/blog/6083/hhvm-long-term-support
ffc743bc 36Version: 3.3.7
32057e92 37Release: 9
6135817a 38License: PHP 3.01 and BSD
ac2930bc 39Group: Development/Languages
aa7908cc 40Source0: https://github.com/facebook/hhvm/archive/HHVM-%{version}.tar.gz
ffc743bc 41# Source0-md5: 8df12eef8702515498d6a6caab6e4b7d
20de90ba
ER
42Source2: https://github.com/facebook/folly/archive/%{folly}/folly-3.2-%{folly}.tar.gz
43# Source2-md5: c4bdbea4c0ffe0650d12d9ff370b8255
745db304 44Source3: https://github.com/hhvm/hhvm-third-party/archive/%{thirdparty}/third_party-%{thirdparty}.tar.gz
e7f30897 45# Source3-md5: 17210db0b2211c63d911076e02aab487
6135817a
ER
46Source5: %{name}-fcgi.init
47Source6: %{name}-fcgi.sysconfig
48Source7: php.ini
991b3017 49Source100: get-source.sh
449902dc 50Patch1: no-debug.patch
e66c75f6 51Patch2: hphpize.patch
3e79618f 52Patch3: MAX.patch
142dde19 53Patch4: system-thirdparty.patch
a46def0c 54Patch5: cmake.patch
c77f551c 55Patch6: libvpx2.patch
b343400f 56Patch7: gcc5.patch
83ff8dfd 57Patch8: cxx.patch
199131a5 58Patch9: gcc6.patch
ff452300 59URL: https://github.com/facebook/hhvm/wiki
f7556a8c 60BuildRequires: ImageMagick-devel
9256e518 61BuildRequires: a52dec-libs-devel
b05f3896
ER
62BuildRequires: apr-devel
63BuildRequires: autoconf
3f49543c 64BuildRequires: binutils-devel
6135817a
ER
65# CMake/HPHPFindLibs.cmake:364 - FIND_LIBRARY (BFD_LIB libbfd.a)
66BuildRequires: binutils-static
ed14b19f 67BuildRequires: boost-devel >= 1.50
745db304 68BuildRequires: cmake >= 2.8.5
ed14b19f 69BuildRequires: curl-devel >= 7.29.0
fd4a736f 70%{?with_system_dconv:BuildRequires: double-conversion-devel >= 1.1.1}
ed14b19f 71BuildRequires: elfutils-devel
3f49543c 72BuildRequires: expat-devel
e494b5cb 73%{?with_system_fastlz:BuildRequires: fastlz-devel >= 0.1.0-0.r12}
5c61d46f 74BuildRequires: gcc >= 6:4.6.0
3f49543c 75BuildRequires: gd-devel
ed14b19f
ER
76BuildRequires: glog-devel >= 0.3.2
77BuildRequires: imap-devel >= 1:2007
991b3017 78#BuildRequires: jemalloc-devel >= 3.0.0
e494b5cb 79%{?with_system_libafdt:BuildRequires: libafdt-devel >= 0.1.0}
3f49543c 80BuildRequires: libcap-devel
04f13235 81BuildRequires: libdwarf-devel >= 20130729
ac2930bc 82BuildRequires: libicu-devel >= 4.2
be373886 83#BuildRequires: libmbfl-devel
ed14b19f 84BuildRequires: libmcrypt-devel
e883c14f 85BuildRequires: libmemcached-devel >= 1.0.4
491a5eb9 86BuildRequires: libstdc++-devel >= 6:4.8
ed14b19f 87BuildRequires: libunwind-devel
ac2930bc 88BuildRequires: libxml2-devel
9256e518 89BuildRequires: libxslt-devel
ca0d5750 90%{?with_system_libzip:BuildRequires: libzip-devel >= 0.11.2}
fd4a736f 91%{?with_system_lz4:BuildRequires: lz4-devel >= 0.0-1.r119}
3f49543c 92BuildRequires: mysql-devel
04f13235 93BuildRequires: ocaml-findlib
ac2930bc 94BuildRequires: oniguruma-devel
3f49543c 95BuildRequires: openssl-devel
fd4a736f 96BuildRequires: pcre-devel >= 8.32
ed14b19f 97#BuildRequires: php-xhp-devel >= 1.3.9-6
ed14b19f 98BuildRequires: readline-devel
89ad59aa 99BuildRequires: rpmbuild(macros) >= 1.675
fd4a736f 100%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7.15.2}
ed14b19f 101BuildRequires: tbb-devel >= 4.0.6000
3f49543c 102BuildRequires: zlib-devel
21df9de7
ER
103# check later, seem unused
104#BuildRequires: bison >= 2.3
105#BuildRequires: flex >= 2.5.35
ca0d5750 106BuildRequires: libafdt-devel >= 0.1.0
21df9de7 107#BuildRequires: re2c >= 0.13.0
87330af7 108Provides: %{name}(api) = %{hhvm_api_version}
c91d719c
ER
109Provides: php(core) = %{php_version}
110# foreach (get_loaded_extensions() as $ext) printf("Provides:\tphp(%s)\n", strtolower($ext));
206caaaf
ER
111Provides: php(apc)
112Provides: php(bcmath)
991b3017 113Provides: php(bz2)
745db304 114Provides: php(calendar)
206caaaf
ER
115Provides: php(ctype)
116Provides: php(curl)
117Provides: php(date)
9c2504b3 118Provides: php(debugger)
206caaaf 119Provides: php(dom)
c91d719c 120Provides: php(enum)
206caaaf
ER
121Provides: php(exif)
122Provides: php(fb)
991b3017 123Provides: php(fileinfo)
206caaaf 124Provides: php(filter)
745db304 125Provides: php(ftp)
206caaaf 126Provides: php(gd)
745db304 127Provides: php(gettext)
c91d719c 128Provides: php(gmp)
206caaaf 129Provides: php(hash)
9c2504b3
ER
130Provides: php(hh)
131Provides: php(hhvm.debugger)
132Provides: php(hhvm.ini)
206caaaf
ER
133Provides: php(hotprofiler)
134Provides: php(iconv)
206caaaf 135Provides: php(idn)
9c2504b3 136Provides: php(imagick)
206caaaf 137Provides: php(imap)
9c2504b3 138Provides: php(intl)
206caaaf
ER
139Provides: php(json)
140Provides: php(ldap)
9c2504b3 141Provides: php(libxml)
c91d719c
ER
142Provides: php(mail)
143Provides: php(mailparse)
206caaaf
ER
144Provides: php(mbstring)
145Provides: php(mcrypt)
146Provides: php(memcache)
147Provides: php(memcached)
148Provides: php(mysql)
9c2504b3 149Provides: php(mysqli)
745db304 150Provides: php(oauth)
206caaaf
ER
151Provides: php(openssl)
152Provides: php(pcntl)
153Provides: php(pcre)
745db304 154Provides: php(pcre_zend_compat)
206caaaf
ER
155Provides: php(pdo)
156Provides: php(pdo_mysql)
157Provides: php(pdo_sqlite)
158Provides: php(phar)
159Provides: php(posix)
9c2504b3 160Provides: php(redis)
206caaaf
ER
161Provides: php(reflection)
162Provides: php(server)
163Provides: php(session)
164Provides: php(simplexml)
165Provides: php(soap)
166Provides: php(sockets)
167Provides: php(spl)
168Provides: php(sqlite3)
745db304
ER
169Provides: php(standard)
170Provides: php(standard_zend_compat)
9c2504b3 171Provides: php(stream)
206caaaf
ER
172Provides: php(sysvmsg)
173Provides: php(sysvsem)
174Provides: php(sysvshm)
175Provides: php(thread)
176Provides: php(thrift_protocol)
177Provides: php(tokenizer)
9c2504b3 178Provides: php(url)
745db304
ER
179Provides: php(wddx)
180Provides: php(xenon)
206caaaf
ER
181Provides: php(xhprof)
182Provides: php(xml)
183Provides: php(xmlreader)
184Provides: php(xmlwriter)
9c2504b3 185Provides: php(xsl)
745db304 186Provides: php(yaml)
991b3017 187Provides: php(zip)
206caaaf 188Provides: php(zlib)
991b3017 189Obsoletes: hiphop-php < 2.3.2-0.2
17c75ade 190ExclusiveArch: %{x8664}
65446f6c
ER
191BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
192
c171e0ff 193
6135817a
ER
194%define hhvm_extensiondir %{_libdir}/hhvm
195
65446f6c 196%description
aa7908cc
ER
197HHVM (aka the HipHop Virtual Machine) is a new open-source virtual
198machine designed for executing programs written in PHP. HHVM uses a
199just-in-time compilation approach to achieve superior performance
200while maintaining the flexibility that PHP developers are accustomed
201to. To date, HHVM (and its predecessor HPHPc before it) has realized
202over a 9x increase in web request throughput and over a 5x reduction
203in memory consumption for Facebook compared with the Zend PHP 5.2
204engine + APC.
205
206HHVM can be run as a standalone webserver (i.e. without the Apache
207webserver and the "mod_php" extension). HHVM can also be used together
208with a FastCGI-based webserver, and work is in progress to make HHVM
209work smoothly with Apache.
65446f6c 210
2347c3ae
ER
211%package fcgi
212Summary: Init script to start HHVM as FastCGI daemon
213Group: Development/Languages/PHP
214Requires: %{name} = %{version}-%{release}
215Provides: php(fcgi)
216Requires(post,preun): /sbin/chkconfig
217Requires: rc-scripts
218
219%description fcgi
220Init script to start HHVM as FastCGI daemon
221
3234b364
ER
222%package program
223Summary: /usr/bin/php symlink
224Summary(pl.UTF-8): Dowiązanie symboliczne /usr/bin/php
225Group: Development/Languages/PHP
226Requires: %{name} = %{version}-%{release}
227Obsoletes: /usr/bin/php
228
229%description program
230Package providing /usr/bin/php symlink to PHP CLI.
231
232%description program -l pl.UTF-8
233Pakiet dostarczający dowiązanie symboliczne /usr/bin/php do PHP CLI.
234
c6264399
ER
235%package devel
236Summary: Files for HHVM modules development
237Group: Development/Languages/PHP
238URL: https://github.com/facebook/hhvm/wiki/Extension-API
f6ea7eef 239Requires: boost-devel >= 1.50
c6264399 240Requires: cmake >= 2.8.5
f6ea7eef 241Requires: glog-devel >= 0.3.2
e7779ee6 242Requires: libstdc++-devel >= 6:4.3
f6ea7eef
ER
243Requires: tbb-devel >= 4.0.6000
244Requires: zlib-devel
c6264399
ER
245
246%description devel
247HHVM provides a set of APIs for adding built-in functionality to the
248runtime either by way of pure PHP code, or a combination of PHP and
249C++.
250
65446f6c 251%prep
20de90ba 252%setup -q -n %{name}-HHVM-%{version} -a2 -a3
991b3017 253
745db304
ER
254# handle git submodules
255rmdir third-party
256mv hhvm-third-party-* third-party
257rmdir third-party/folly/src
258mv folly-* third-party/folly/src
f8472382 259
449902dc 260%patch1 -p1
e66c75f6 261%patch2 -p1
3e79618f 262%patch3 -p1
142dde19 263%patch4 -p1
52bf161a 264#%patch5 -p1
c77f551c 265%patch6 -p1
b343400f 266%patch7 -p1
83ff8dfd 267%patch8 -p1
199131a5 268%patch9 -p1
ed14b19f 269
c6264399 270# prefer ones from system
20e9b450 271rm CMake/FindBISON.cmake
20e9b450 272rm CMake/FindFLEX.cmake
b17fa9dd 273rm CMake/FindFreetype.cmake
ed14b19f 274
40280c0c
ER
275# ensure system libs get used
276cd third-party
277rm -r pcre \
3889faa2 278 %{?with_system_sqlite:libsqlite3} \
40280c0c
ER
279 %{?with_system_lz4:lz4} \
280 %{?with_system_dconv:double-conversion} \
281 %{?with_system_fastlz:fastlz} \
282 %{?with_system_libafdt:libafdt} \
c19fc9d9 283 %{?with_system_libzip:libzip} \
40280c0c
ER
284 %{nil}
285
ac2930bc 286%build
c171e0ff
ER
287# also in: hphp/tools/hphpize/hphpize.cmake
288API=$(awk '/#define HHVM_API_VERSION/{v=$3; sub(/L$/, "", v); print v}' hphp/runtime/ext/extension.h)
289
290if [ $API != %{hhvm_api_version} ]; then
291 echo "Set %%define hhvm_api_version to $API and re-run."
292 exit 1
293fi
294
dd925321 295export CXXFLAGS="%{rpmcxxflags} -fpermissive -I/usr/include/lz4"
32057e92 296
20de90ba
ER
297# out of dir build broken (can't find it's tools, or headers)
298#install -d build
299#cd build
449902dc
ER
300
301# handle cmake & ccache
8dff2648 302# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
449902dc
ER
303# ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
304if [[ "%{__cc}" = *ccache* ]]; then
305 cc="%{__cc}"
306 cxx="%{__cxx}"
307 ccache="
308 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
309 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
310 -DCMAKE_ASM_COMPILER="${cc#ccache }" \
311 "
312fi
e883c14f 313
ef07ca95 314%cmake \
449902dc 315 $ccache \
ef07ca95 316 -DCMAKE_PREFIX_PATH=%{_prefix} \
6135817a 317 -DHHVM_DYNAMIC_EXTENSION_DIR=%{hhvm_extensiondir} \
a0922d01 318 -DUSE_JEMALLOC=OFF \
be373886 319 -DUSE_TCMALLOC=OFF \
97e4fa4e 320 -DTEST_BIN=OFF \
2e505d70 321 -DENABLE_COTIRE=%{!?with_cotire:OFF}%{?with_cotire:ON} \
20de90ba 322 .
ac3c6624 323
c513fdf6
ER
324# setup COMPILER_ID/HHVM_REPO_SCHEMA so it doesn't look it up from our package git repo
325# see hphp/util/generate-buildinfo.sh
ac3c6624 326export COMPILER_ID=HHVM-%{version}-%{release}-g%{githash}
c513fdf6
ER
327export HHVM_REPO_SCHEMA=$(date +%N_%s)
328
ac2930bc
ER
329%{__make}
330
65446f6c 331%install
745db304
ER
332# make install relinks all outputs which is very slow,
333# so to speedup rebuild, use timestamps to record states
334#test %{_specdir}/%{name}.spec -nt makeinstall.stamp && %{__rm} -f makeinstall.stamp
335if [ ! -f makeinstall.stamp -o ! -d $RPM_BUILD_ROOT ]; then
336 rm -rf makeinstall.stamp installed.stamp $RPM_BUILD_ROOT
8d9f731f 337
8dff2648 338 %{__make} install \
745db304
ER
339 DESTDIR=$RPM_BUILD_ROOT
340
341 touch makeinstall.stamp
342fi
343
344rm -rf $RPM_BUILD_ROOT%{_docdir}
345if [ ! -f installed.stamp ]; then
745db304 346# begin install block
9c2504b3 347
883526f7
ER
348# fix broken cmake rules
349# TODO: fix cmake rules
350if [ -d $RPM_BUILD_ROOT%{_prefix}/usr ]; then
351 cp -a $RPM_BUILD_ROOT%{_prefix}/usr/* $RPM_BUILD_ROOT%{_prefix}
352 rm -rf $RPM_BUILD_ROOT%{_prefix}/usr
353fi
354
073742e0 355install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}}
6135817a 356cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
c3ecb766 357
3234b364
ER
358ln -s hhvm $RPM_BUILD_ROOT%{_bindir}/php
359ln -s hhvm $RPM_BUILD_ROOT%{_bindir}/hphp
360
44fcba3e 361install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/hdf
17307be4 362cp -p hphp/doc/mime.hdf $RPM_BUILD_ROOT%{_datadir}/%{name}/hdf/static.mime-types.hdf
44fcba3e 363
2347c3ae
ER
364# install fastcgi initscript
365install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
6135817a
ER
366cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fcgi
367cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-fcgi
2347c3ae 368
ac3c6624
ER
369install -p hphp/hack/bin/hh_{server,client} $RPM_BUILD_ROOT%{_bindir}
370
745db304
ER
371# end of install block
372touch installed.stamp; fi
f6ea7eef 373
65446f6c
ER
374%clean
375rm -rf $RPM_BUILD_ROOT
376
8d9f731f
ER
377%post -p /sbin/ldconfig
378%postun -p /sbin/ldconfig
379
2347c3ae
ER
380%post fcgi
381/sbin/chkconfig --add %{name}-fcgi
382%service %{name}-fcgi restart
383
384%preun fcgi
385if [ "$1" = "0" ]; then
386 %service -q %{name}-fcgi stop
387 /sbin/chkconfig --del %{name}-fcgi
388fi
389
65446f6c
ER
390%files
391%defattr(644,root,root,755)
1c0ae000 392%doc README.md hphp/NEWS
349ae084 393%dir %{_sysconfdir}/%{name}
c3ecb766 394%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/php.ini
8d9f731f 395%attr(755,root,root) %{_bindir}/hhvm
3234b364 396%attr(755,root,root) %{_bindir}/hphp
ac3c6624
ER
397%attr(755,root,root) %{_bindir}/hh_client
398%attr(755,root,root) %{_bindir}/hh_server
44fcba3e
ER
399
400%dir %{_datadir}/%{name}
401%dir %{_datadir}/%{name}/hdf
402%{_datadir}/%{name}/hdf/static.mime-types.hdf
3234b364 403
073742e0
ER
404# dir for extensions
405%dir %{_libdir}/%{name}
406
2347c3ae
ER
407%files fcgi
408%defattr(644,root,root,755)
409%attr(754,root,root) /etc/rc.d/init.d/%{name}-fcgi
410%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}-fcgi
411
3234b364
ER
412%files program
413%defattr(644,root,root,755)
414%attr(755,root,root) %{_bindir}/php
c6264399
ER
415
416%files devel
417%defattr(644,root,root,755)
418%attr(755,root,root) %{_bindir}/hphpize
419%{_includedir}/hphp
e35a4289
ER
420%dir %{_libdir}/hhvm
421%{_libdir}/hhvm/CMake
422%{_libdir}/hhvm/hphpize
This page took 0.099235 seconds and 4 git commands to generate.