]> git.pld-linux.org Git - packages/hhvm.git/blame - hhvm.spec
- icu&boost rebuild
[packages/hhvm.git] / hhvm.spec
CommitLineData
fd4a736f
ER
1#
2# Conditional build:
3%bcond_without system_dconv # system double-conversion
4%bcond_without system_sqlite # system sqlite3
5%bcond_without system_lz4 # system lz4
e494b5cb 6%bcond_without system_fastlz # system fastlz
934d354b 7%bcond_with system_libafdt # system libafdt
c19fc9d9 8%bcond_without system_libzip # system libzip
8041f44b
ER
9# cotire breaks sqlite3 on builders: https://github.com/facebook/hhvm/issues/4524
10%bcond_with cotire # cotire (compile time reducer): Speed up the build by precompiling headers
fd4a736f 11
b682fdb1
ER
12# TODO
13# - system xhp
14# - system proxygen
15# - system thrift
16
89ad59aa
ER
17# NOTES:
18# - hphp/runtime/base/runtime-option.cpp evalJitDefault enables jit if /.hhvm-jit exists (yes, in filesystem root)
b682fdb1 19
d9b6cc98
ER
20# must be in sync with source. extra check ensuring that it is so is done in %%build
21%define hhvm_api_version 20140829
af2b6c94
ER
22# hphp/system/idl/constants.idl.json defines it as 5.6.99-hhvm, but use some saner value
23%define php_version 5.6.0
24
d2187d4f
ER
25# git show HHVM-3.3.5
26%define githash b2856c601e317b6d66fd1861c4cc889ae91d9f6f
b682fdb1 27# these hashes are git submodules (be sure to check them on proper branch)
e7f30897
ER
28# GIT_DIR=third-party/.git git log -1
29%define thirdparty bf581f8
30# 6e46d468cf2876dd59c7a4dddcb4e37abf070b7a
31# GIT_DIR=third-party/folly/src/.git git log -1
b682fdb1 32%define folly 6e46d46
ed14b19f 33Summary: Virtual Machine, Runtime, and JIT for PHP
aa7908cc 34Name: hhvm
d84d6344
ER
35# we prefer LTS versions
36# see http://hhvm.com/blog/6083/hhvm-long-term-support
d2187d4f 37Version: 3.3.5
47e79e0f 38Release: 3
6135817a 39License: PHP 3.01 and BSD
ac2930bc 40Group: Development/Languages
aa7908cc 41Source0: https://github.com/facebook/hhvm/archive/HHVM-%{version}.tar.gz
d2187d4f 42# Source0-md5: 57af76be5b4a10e35cb6eb705e0ff663
20de90ba
ER
43Source2: https://github.com/facebook/folly/archive/%{folly}/folly-3.2-%{folly}.tar.gz
44# Source2-md5: c4bdbea4c0ffe0650d12d9ff370b8255
745db304 45Source3: https://github.com/hhvm/hhvm-third-party/archive/%{thirdparty}/third_party-%{thirdparty}.tar.gz
e7f30897 46# Source3-md5: 17210db0b2211c63d911076e02aab487
6135817a
ER
47Source5: %{name}-fcgi.init
48Source6: %{name}-fcgi.sysconfig
49Source7: php.ini
991b3017 50Source100: get-source.sh
449902dc 51Patch1: no-debug.patch
e66c75f6 52Patch2: hphpize.patch
3e79618f 53Patch3: MAX.patch
142dde19 54Patch4: system-thirdparty.patch
a46def0c 55Patch5: cmake.patch
c77f551c 56Patch6: libvpx2.patch
ff452300 57URL: https://github.com/facebook/hhvm/wiki
f7556a8c 58BuildRequires: ImageMagick-devel
9256e518 59BuildRequires: a52dec-libs-devel
b05f3896
ER
60BuildRequires: apr-devel
61BuildRequires: autoconf
3f49543c 62BuildRequires: binutils-devel
6135817a
ER
63# CMake/HPHPFindLibs.cmake:364 - FIND_LIBRARY (BFD_LIB libbfd.a)
64BuildRequires: binutils-static
ed14b19f 65BuildRequires: boost-devel >= 1.50
745db304 66BuildRequires: cmake >= 2.8.5
ed14b19f 67BuildRequires: curl-devel >= 7.29.0
fd4a736f 68%{?with_system_dconv:BuildRequires: double-conversion-devel >= 1.1.1}
ed14b19f 69BuildRequires: elfutils-devel
3f49543c 70BuildRequires: expat-devel
e494b5cb 71%{?with_system_fastlz:BuildRequires: fastlz-devel >= 0.1.0-0.r12}
5c61d46f 72BuildRequires: gcc >= 6:4.6.0
3f49543c 73BuildRequires: gd-devel
ed14b19f
ER
74BuildRequires: glog-devel >= 0.3.2
75BuildRequires: imap-devel >= 1:2007
991b3017 76#BuildRequires: jemalloc-devel >= 3.0.0
e494b5cb 77%{?with_system_libafdt:BuildRequires: libafdt-devel >= 0.1.0}
3f49543c 78BuildRequires: libcap-devel
04f13235 79BuildRequires: libdwarf-devel >= 20130729
ac2930bc 80BuildRequires: libicu-devel >= 4.2
be373886 81#BuildRequires: libmbfl-devel
ed14b19f 82BuildRequires: libmcrypt-devel
e883c14f 83BuildRequires: libmemcached-devel >= 1.0.4
491a5eb9 84BuildRequires: libstdc++-devel >= 6:4.8
ed14b19f 85BuildRequires: libunwind-devel
ac2930bc 86BuildRequires: libxml2-devel
9256e518 87BuildRequires: libxslt-devel
ca0d5750 88%{?with_system_libzip:BuildRequires: libzip-devel >= 0.11.2}
fd4a736f 89%{?with_system_lz4:BuildRequires: lz4-devel >= 0.0-1.r119}
3f49543c 90BuildRequires: mysql-devel
04f13235 91BuildRequires: ocaml-findlib
ac2930bc 92BuildRequires: oniguruma-devel
3f49543c 93BuildRequires: openssl-devel
fd4a736f 94BuildRequires: pcre-devel >= 8.32
ed14b19f 95#BuildRequires: php-xhp-devel >= 1.3.9-6
ed14b19f 96BuildRequires: readline-devel
89ad59aa 97BuildRequires: rpmbuild(macros) >= 1.675
fd4a736f 98%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7.15.2}
ed14b19f 99BuildRequires: tbb-devel >= 4.0.6000
3f49543c 100BuildRequires: zlib-devel
21df9de7
ER
101# check later, seem unused
102#BuildRequires: bison >= 2.3
103#BuildRequires: flex >= 2.5.35
ca0d5750 104BuildRequires: libafdt-devel >= 0.1.0
21df9de7 105#BuildRequires: re2c >= 0.13.0
87330af7 106Provides: %{name}(api) = %{hhvm_api_version}
c91d719c
ER
107Provides: php(core) = %{php_version}
108# foreach (get_loaded_extensions() as $ext) printf("Provides:\tphp(%s)\n", strtolower($ext));
206caaaf
ER
109Provides: php(apc)
110Provides: php(bcmath)
991b3017 111Provides: php(bz2)
745db304 112Provides: php(calendar)
206caaaf
ER
113Provides: php(ctype)
114Provides: php(curl)
115Provides: php(date)
9c2504b3 116Provides: php(debugger)
206caaaf 117Provides: php(dom)
c91d719c 118Provides: php(enum)
206caaaf
ER
119Provides: php(exif)
120Provides: php(fb)
991b3017 121Provides: php(fileinfo)
206caaaf 122Provides: php(filter)
745db304 123Provides: php(ftp)
206caaaf 124Provides: php(gd)
745db304 125Provides: php(gettext)
c91d719c 126Provides: php(gmp)
206caaaf 127Provides: php(hash)
9c2504b3
ER
128Provides: php(hh)
129Provides: php(hhvm.debugger)
130Provides: php(hhvm.ini)
206caaaf
ER
131Provides: php(hotprofiler)
132Provides: php(iconv)
206caaaf 133Provides: php(idn)
9c2504b3 134Provides: php(imagick)
206caaaf 135Provides: php(imap)
9c2504b3 136Provides: php(intl)
206caaaf
ER
137Provides: php(json)
138Provides: php(ldap)
9c2504b3 139Provides: php(libxml)
c91d719c
ER
140Provides: php(mail)
141Provides: php(mailparse)
206caaaf
ER
142Provides: php(mbstring)
143Provides: php(mcrypt)
144Provides: php(memcache)
145Provides: php(memcached)
146Provides: php(mysql)
9c2504b3 147Provides: php(mysqli)
745db304 148Provides: php(oauth)
206caaaf
ER
149Provides: php(openssl)
150Provides: php(pcntl)
151Provides: php(pcre)
745db304 152Provides: php(pcre_zend_compat)
206caaaf
ER
153Provides: php(pdo)
154Provides: php(pdo_mysql)
155Provides: php(pdo_sqlite)
156Provides: php(phar)
157Provides: php(posix)
9c2504b3 158Provides: php(redis)
206caaaf
ER
159Provides: php(reflection)
160Provides: php(server)
161Provides: php(session)
162Provides: php(simplexml)
163Provides: php(soap)
164Provides: php(sockets)
165Provides: php(spl)
166Provides: php(sqlite3)
745db304
ER
167Provides: php(standard)
168Provides: php(standard_zend_compat)
9c2504b3 169Provides: php(stream)
206caaaf
ER
170Provides: php(sysvmsg)
171Provides: php(sysvsem)
172Provides: php(sysvshm)
173Provides: php(thread)
174Provides: php(thrift_protocol)
175Provides: php(tokenizer)
9c2504b3 176Provides: php(url)
745db304
ER
177Provides: php(wddx)
178Provides: php(xenon)
206caaaf
ER
179Provides: php(xhprof)
180Provides: php(xml)
181Provides: php(xmlreader)
182Provides: php(xmlwriter)
9c2504b3 183Provides: php(xsl)
745db304 184Provides: php(yaml)
991b3017 185Provides: php(zip)
206caaaf 186Provides: php(zlib)
991b3017 187Obsoletes: hiphop-php < 2.3.2-0.2
17c75ade 188ExclusiveArch: %{x8664}
65446f6c
ER
189BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
190
c171e0ff 191
6135817a
ER
192%define hhvm_extensiondir %{_libdir}/hhvm
193
65446f6c 194%description
aa7908cc
ER
195HHVM (aka the HipHop Virtual Machine) is a new open-source virtual
196machine designed for executing programs written in PHP. HHVM uses a
197just-in-time compilation approach to achieve superior performance
198while maintaining the flexibility that PHP developers are accustomed
199to. To date, HHVM (and its predecessor HPHPc before it) has realized
200over a 9x increase in web request throughput and over a 5x reduction
201in memory consumption for Facebook compared with the Zend PHP 5.2
202engine + APC.
203
204HHVM can be run as a standalone webserver (i.e. without the Apache
205webserver and the "mod_php" extension). HHVM can also be used together
206with a FastCGI-based webserver, and work is in progress to make HHVM
207work smoothly with Apache.
65446f6c 208
2347c3ae
ER
209%package fcgi
210Summary: Init script to start HHVM as FastCGI daemon
211Group: Development/Languages/PHP
212Requires: %{name} = %{version}-%{release}
213Provides: php(fcgi)
214Requires(post,preun): /sbin/chkconfig
215Requires: rc-scripts
216
217%description fcgi
218Init script to start HHVM as FastCGI daemon
219
3234b364
ER
220%package program
221Summary: /usr/bin/php symlink
222Summary(pl.UTF-8): Dowiązanie symboliczne /usr/bin/php
223Group: Development/Languages/PHP
224Requires: %{name} = %{version}-%{release}
225Obsoletes: /usr/bin/php
226
227%description program
228Package providing /usr/bin/php symlink to PHP CLI.
229
230%description program -l pl.UTF-8
231Pakiet dostarczający dowiązanie symboliczne /usr/bin/php do PHP CLI.
232
c6264399
ER
233%package devel
234Summary: Files for HHVM modules development
235Group: Development/Languages/PHP
236URL: https://github.com/facebook/hhvm/wiki/Extension-API
f6ea7eef 237Requires: boost-devel >= 1.50
c6264399 238Requires: cmake >= 2.8.5
f6ea7eef 239Requires: glog-devel >= 0.3.2
e7779ee6 240Requires: libstdc++-devel >= 6:4.3
f6ea7eef
ER
241Requires: tbb-devel >= 4.0.6000
242Requires: zlib-devel
c6264399
ER
243
244%description devel
245HHVM provides a set of APIs for adding built-in functionality to the
246runtime either by way of pure PHP code, or a combination of PHP and
247C++.
248
65446f6c 249%prep
20de90ba 250%setup -q -n %{name}-HHVM-%{version} -a2 -a3
991b3017 251
745db304
ER
252# handle git submodules
253rmdir third-party
254mv hhvm-third-party-* third-party
255rmdir third-party/folly/src
256mv folly-* third-party/folly/src
f8472382 257
449902dc 258%patch1 -p1
e66c75f6 259%patch2 -p1
3e79618f 260%patch3 -p1
142dde19 261%patch4 -p1
52bf161a 262#%patch5 -p1
c77f551c 263%patch6 -p1
ed14b19f 264
c6264399 265# prefer ones from system
20e9b450 266rm CMake/FindBISON.cmake
20e9b450 267rm CMake/FindFLEX.cmake
b17fa9dd 268rm CMake/FindFreetype.cmake
ed14b19f 269
40280c0c
ER
270# ensure system libs get used
271cd third-party
272rm -r pcre \
3889faa2 273 %{?with_system_sqlite:libsqlite3} \
40280c0c
ER
274 %{?with_system_lz4:lz4} \
275 %{?with_system_dconv:double-conversion} \
276 %{?with_system_fastlz:fastlz} \
277 %{?with_system_libafdt:libafdt} \
c19fc9d9 278 %{?with_system_libzip:libzip} \
40280c0c
ER
279 %{nil}
280
ac2930bc 281%build
c171e0ff
ER
282# also in: hphp/tools/hphpize/hphpize.cmake
283API=$(awk '/#define HHVM_API_VERSION/{v=$3; sub(/L$/, "", v); print v}' hphp/runtime/ext/extension.h)
284
285if [ $API != %{hhvm_api_version} ]; then
286 echo "Set %%define hhvm_api_version to $API and re-run."
287 exit 1
288fi
289
20de90ba
ER
290# out of dir build broken (can't find it's tools, or headers)
291#install -d build
292#cd build
449902dc
ER
293
294# handle cmake & ccache
8dff2648 295# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmake
449902dc
ER
296# ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
297if [[ "%{__cc}" = *ccache* ]]; then
298 cc="%{__cc}"
299 cxx="%{__cxx}"
300 ccache="
301 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
302 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
303 -DCMAKE_ASM_COMPILER="${cc#ccache }" \
304 "
305fi
e883c14f 306
ef07ca95 307%cmake \
449902dc 308 $ccache \
ef07ca95 309 -DCMAKE_PREFIX_PATH=%{_prefix} \
6135817a 310 -DHHVM_DYNAMIC_EXTENSION_DIR=%{hhvm_extensiondir} \
a0922d01 311 -DUSE_JEMALLOC=OFF \
be373886 312 -DUSE_TCMALLOC=OFF \
97e4fa4e 313 -DTEST_BIN=OFF \
2e505d70 314 -DENABLE_COTIRE=%{!?with_cotire:OFF}%{?with_cotire:ON} \
20de90ba 315 .
ac3c6624 316
c513fdf6
ER
317# setup COMPILER_ID/HHVM_REPO_SCHEMA so it doesn't look it up from our package git repo
318# see hphp/util/generate-buildinfo.sh
ac3c6624 319export COMPILER_ID=HHVM-%{version}-%{release}-g%{githash}
c513fdf6
ER
320export HHVM_REPO_SCHEMA=$(date +%N_%s)
321
ac2930bc
ER
322%{__make}
323
65446f6c 324%install
745db304
ER
325# make install relinks all outputs which is very slow,
326# so to speedup rebuild, use timestamps to record states
327#test %{_specdir}/%{name}.spec -nt makeinstall.stamp && %{__rm} -f makeinstall.stamp
328if [ ! -f makeinstall.stamp -o ! -d $RPM_BUILD_ROOT ]; then
329 rm -rf makeinstall.stamp installed.stamp $RPM_BUILD_ROOT
8d9f731f 330
8dff2648 331 %{__make} install \
745db304
ER
332 DESTDIR=$RPM_BUILD_ROOT
333
334 touch makeinstall.stamp
335fi
336
337rm -rf $RPM_BUILD_ROOT%{_docdir}
338if [ ! -f installed.stamp ]; then
745db304 339# begin install block
9c2504b3 340
883526f7
ER
341# fix broken cmake rules
342# TODO: fix cmake rules
343if [ -d $RPM_BUILD_ROOT%{_prefix}/usr ]; then
344 cp -a $RPM_BUILD_ROOT%{_prefix}/usr/* $RPM_BUILD_ROOT%{_prefix}
345 rm -rf $RPM_BUILD_ROOT%{_prefix}/usr
346fi
347
073742e0 348install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}}
6135817a 349cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
c3ecb766 350
3234b364
ER
351ln -s hhvm $RPM_BUILD_ROOT%{_bindir}/php
352ln -s hhvm $RPM_BUILD_ROOT%{_bindir}/hphp
353
44fcba3e 354install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/hdf
17307be4 355cp -p hphp/doc/mime.hdf $RPM_BUILD_ROOT%{_datadir}/%{name}/hdf/static.mime-types.hdf
44fcba3e 356
2347c3ae
ER
357# install fastcgi initscript
358install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
6135817a
ER
359cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fcgi
360cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-fcgi
2347c3ae 361
ac3c6624
ER
362install -p hphp/hack/bin/hh_{server,client} $RPM_BUILD_ROOT%{_bindir}
363
745db304
ER
364# end of install block
365touch installed.stamp; fi
f6ea7eef 366
65446f6c
ER
367%clean
368rm -rf $RPM_BUILD_ROOT
369
8d9f731f
ER
370%post -p /sbin/ldconfig
371%postun -p /sbin/ldconfig
372
2347c3ae
ER
373%post fcgi
374/sbin/chkconfig --add %{name}-fcgi
375%service %{name}-fcgi restart
376
377%preun fcgi
378if [ "$1" = "0" ]; then
379 %service -q %{name}-fcgi stop
380 /sbin/chkconfig --del %{name}-fcgi
381fi
382
65446f6c
ER
383%files
384%defattr(644,root,root,755)
1c0ae000 385%doc README.md hphp/NEWS
349ae084 386%dir %{_sysconfdir}/%{name}
c3ecb766 387%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/php.ini
8d9f731f 388%attr(755,root,root) %{_bindir}/hhvm
3234b364 389%attr(755,root,root) %{_bindir}/hphp
ac3c6624
ER
390%attr(755,root,root) %{_bindir}/hh_client
391%attr(755,root,root) %{_bindir}/hh_server
44fcba3e
ER
392
393%dir %{_datadir}/%{name}
394%dir %{_datadir}/%{name}/hdf
395%{_datadir}/%{name}/hdf/static.mime-types.hdf
3234b364 396
073742e0
ER
397# dir for extensions
398%dir %{_libdir}/%{name}
399
2347c3ae
ER
400%files fcgi
401%defattr(644,root,root,755)
402%attr(754,root,root) /etc/rc.d/init.d/%{name}-fcgi
403%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}-fcgi
404
3234b364
ER
405%files program
406%defattr(644,root,root,755)
407%attr(755,root,root) %{_bindir}/php
c6264399
ER
408
409%files devel
410%defattr(644,root,root,755)
411%attr(755,root,root) %{_bindir}/hphpize
412%{_includedir}/hphp
e35a4289
ER
413%dir %{_libdir}/hhvm
414%{_libdir}/hhvm/CMake
415%{_libdir}/hhvm/hphpize
This page took 0.128986 seconds and 4 git commands to generate.