]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
noarch bash completions
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
f97cafb4 9#
90feddde 10# Conditional build:
1536aaf2 11%bcond_with grubemu # build grub-emu debugging utility
b06c130d 12%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
13%bcond_without pc # do not build for PC BIOS platform
14%bcond_without efi # do not build for EFI platform
b06c130d 15
feaacba3
JB
16%ifnarch %{ix86} %{x8664}
17%undefine with_pc
18%endif
19%ifnarch %{ix86} %{x8664} ia64
20%undefine with_efi
21%endif
22
2d8da575
AM
23%ifnarch %{x8664}
24# non-x86_64 arch doesn't support this
25%undefine with_efiemu
26%endif
27
1536aaf2 28# the 'most natural' platform should go last
feaacba3 29%ifarch %{ix86} %{x8664} ia64
1536aaf2 30%define platforms %{?with_efi:efi} %{?with_pc:pc}
feaacba3
JB
31%endif
32%ifarch ppc ppc64 sparc64
33%define platforms ieee1275
34%endif
35%ifarch mips
36%define platforms arc
37%endif
38%ifarch mipsel
39%define platforms loongson
40%endif
1536aaf2 41
afe8504a 42Summary: GRand Unified Bootloader
c8155f7f 43Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 44Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
45Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
46Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
139b6f37 47%define beta beta2
afe8504a 48Name: grub2
b876d99a 49Version: 2.02
139b6f37 50Release: 0.%{beta}.2
2e4bec6f 51License: GPL v2
afe8504a 52Group: Base
5bafb558 53# git://git.savannah.gnu.org/grub.git
b876d99a
JK
54# git checkout %{version}~%{beta} ; make dist
55Source0: grub-%{version}~%{beta}.tar.gz
56# Source0-md5: ca6c18f6c5f1ed05b7444017a40573d9
22909ca1
ER
57Source1: update-grub
58Source2: update-grub.8
b46589aa 59Source3: grub.sysconfig
e2964b87 60Source4: grub-custom.cfg
5bafb558
JK
61# ./linguas.sh
62# TS=$(date +'%Y%m%d') ; tar cjvf grub-po-2.00.git$TS.tar.bz2 po/*.po po/LINGUAS
139b6f37 63Source5: grub-po-%{version}.git20140104.tar.bz2
b876d99a 64# Source5-md5: aeef3e636178093cf9d780d92da7afdb
b46589aa 65Patch1: pld-sysconfdir.patch
872700b0 66Patch2: grub-garbage.patch
c9273ffc
JK
67Patch3: grub-lvmdevice.patch
68Patch4: pld-mkconfigdir.patch
69Patch5: grub-mkconfig-diagnostics.patch
668ecb01
JK
70Patch6: posix.patch
71Patch7: %{name}-fonts_path.patch
72Patch8: add-vlan-tag-support.patch
73Patch9: just-say-linux.patch
74Patch10: ignore-kernel-symlinks.patch
75Patch11: choose-preferred-initrd.patch
76Patch12: %{name}-cfg.patch
feaacba3 77URL: http://www.gnu.org/software/grub/
27550907
ER
78BuildRequires: autoconf >= 2.53
79BuildRequires: automake >= 1:1.11.1-1
8b781299 80BuildRequires: bison
06df59fd 81BuildRequires: device-mapper-devel
feaacba3 82BuildRequires: flex >= 2.5.35
26996aed 83BuildRequires: fonts-TTF-DejaVu
feaacba3 84BuildRequires: freetype-devel >= 2
12fd19f5 85BuildRequires: gawk
63e45785 86BuildRequires: gettext-devel
5bafb558 87BuildRequires: glibc-localedb-all
feaacba3 88BuildRequires: glibc-static
1349ebb8 89BuildRequires: help2man
42985b0d 90BuildRequires: libfuse-devel
afe8504a 91BuildRequires: libtool
feaacba3 92BuildRequires: ncurses-devel
5bafb558
JK
93BuildRequires: python
94BuildRequires: python-modules
feaacba3
JB
95BuildRequires: rpm >= 4.4.9-56
96BuildRequires: rpmbuild(macros) >= 1.213
97BuildRequires: sed >= 4.0
98BuildRequires: tar >= 1:1.22
81a7e0ba 99BuildRequires: texinfo
feaacba3
JB
100BuildRequires: xz
101BuildRequires: xz-devel
c668211a
ER
102%ifarch %{x8664}
103BuildRequires: /usr/lib/libc.so
8905dae4
ER
104%if "%{pld_release}" == "ac"
105BuildRequires: libgcc32
106%else
797addca 107BuildRequires: gcc-multilib
c668211a 108%endif
dee0d6f5 109%endif
feaacba3 110Requires: %{name}-platform = %{version}-%{release}
a5138d8d 111Requires: pld-release
dc6928bc 112Requires: which
feaacba3
JB
113%ifarch %{ix86} %{x8664}
114Suggests: %{name}-platform-pc
115%endif
190cc685 116Suggests: cdrkit-mkisofs
97ee543c 117Suggests: os-prober
afe8504a 118Provides: bootloader
fc835b5e 119Conflicts: grub
feaacba3 120ExclusiveArch: %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
afe8504a
SP
121BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123%define _sbindir /sbin
4a00f3b7 124%define _bindir %{_sbindir}
1536aaf2 125%define _libdir /lib
e6fbd304 126%define _datadir %{_libdir}
26e757db 127%define _libexecdir %{_libdir}/grub
1536aaf2 128%define _grubdir /boot/grub
da9b7cf9 129%define _localedir /usr/share/locale
9d44d75e 130
0e2cbb94
JK
131# part of grub code is not relocable (these are not Linux libs)
132# stack protector also breaks non-Linux binaries
8c5e5aa2
JR
133# any kind of forced optimizations makes grub2 unreliable (random
134# reboots and hangs on boot menu screen)
5bc5d891 135%define filterout_c -fPIC -O.
5967241e 136%undefine _ssp_cflags
5bc5d891 137%undefine _fortify_cflags
0e2cbb94 138
afe8504a
SP
139%description
140GRUB is a GPLed bootloader intended to unify bootloading across x86
141operating systems. In addition to loading the Linux and *BSD kernels,
142it implements the Multiboot standard, which allows for flexible
143loading of multiple boot images (needed for modular kernels such as
144the GNU Hurd).
145
211df1ed
ER
146GRUB 2 is derived from PUPA which was a research project to
147investigate the next generation of GRUB. GRUB 2 has been rewritten
148from scratch to clean up everything for modularity and portability.
149
150GRUB 2 targets at the following goals:
151- Scripting support, such as conditionals, loops, variables and
152 functions.
153- Graphical interface.
154- Dynamic loading of modules in order to extend itself at the run time
155 rather than at the build time.
156- Portability for various architectures.
157- Internationalization. This includes support for non-ASCII character
158 code, message catalogs like gettext, fonts, graphics console, and so
159 on.
160- Real memory management, to make GNU GRUB more extensible.
161- Modular, hierarchical, object-oriented framework for file systems,
162 files, devices, drives, terminals, commands, partition tables and OS
163 loaders.
164- Cross-platform installation which allows for installing GRUB from a
165 different architecture.
166- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
167- Fix design mistakes in GRUB Legacy, which could not be solved for
168 backward-compatibility, such as the way of numbering partitions.
169
6b0aefbf 170%description -l de.UTF-8
afe8504a
SP
171GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
172Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 173läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
174
175GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
176und wird unter der GPL vertrieben. Aufgrund seiner höheren
177Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
178traditionellen Boot-Loader LILO.
179
f97cafb4
ZU
180%description -l hu.UTF-8
181GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
182betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
183teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
184GNU Hurd).
185
186GRUB2 céljai a következők:
187- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
188 függvények.
189- grafikus felület
190- modulok dinamikus betöltése futási időben
191- hordozhatóság több architektúrára
192- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
193 mint gettext, betűtípusok, grafikus konzolon, és így tovább
194- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
195- moduláris, hierarchikus, objektum-orientált keretrendszer
196 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
197 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
198
6b0aefbf
JR
199%description -l es.UTF-8
200Éste es GRUB - Grand Unified Boot Loader - un administrador de
201inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 202operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 203también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
204PC.
205
206El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
207usuarios conmás experiencia y que deseen obtener más recursos de su
208cargador de inicialización (boot loader).
afe8504a 209
6b0aefbf 210%description -l pl.UTF-8
feaacba3 211GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
6b0aefbf 212procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
feaacba3 213Linuksa i *BSD: posiada również implementację standardu Multiboot,
6b0aefbf
JR
214który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
215(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 216
6b0aefbf
JR
217%description -l pt_BR.UTF-8
218Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
219capaz de entrar na maioria dos sistemas operacionais livres - Linux,
220FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
221operacionais comerciais para PC.
222
6b0aefbf
JR
223O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
224avançados e que querem mais recursos de seu boot loader.
afe8504a 225
565fe2e3
ER
226%package -n bash-completion-%{name}
227Summary: bash-completion for GRUB
feaacba3 228Summary(pl.UTF-8): Bashowe uzupełnianie nazw dla GRUB-a
565fe2e3
ER
229Group: Applications/Shells
230Requires: bash-completion
d28207fb
ER
231%if "%{_rpmversion}" >= "5"
232BuildArch: noarch
233%endif
565fe2e3
ER
234
235%description -n bash-completion-%{name}
236This package provides bash-completion for GRUB.
237
238%description -n bash-completion-%{name} -l pl.UTF-8
feaacba3 239Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
565fe2e3 240
6d8475a4 241%package platform-pc
62081337 242Summary: PC BIOS platform support for GRUB
feaacba3 243Summary(pl.UTF-8): Obsługa platformy PC BIOS dla GRUB-a
62081337 244Group: Base
6d8475a4 245Provides: %{name}-platform = %{version}-%{release}
1536aaf2 246
6d8475a4 247%description platform-pc
62081337 248PC BIOS platform support for GRUB.
1536aaf2 249
feaacba3
JB
250%description platform-pc -l pl.UTF-8
251Obsługa platformy PC BIOS dla GRUB-a.
252
6d8475a4 253%package platform-efi
1536aaf2 254Summary: (U)EFI platform support for GRUB
feaacba3 255Summary(pl.UTF-8): Obsługa platformy (U)EFI dla GRUB-a
1536aaf2 256Group: Base
6e81e1fe 257Suggests: efibootmgr
6d8475a4 258Provides: %{name}-platform = %{version}-%{release}
1536aaf2 259
6d8475a4 260%description platform-efi
1536aaf2
JK
261(U)EFI platform support for GRUB.
262
feaacba3
JB
263%description platform-efi -l pl.UTF-8
264Obsługa platformy (U)EFI dla GRUB-a.
265
7615a862
JK
266%package mkfont
267Summary: GRUB font files converter
feaacba3 268Summary(pl.UTF-8): Konwerter plików fontów GRUB-a
7615a862
JK
269Group: Base
270
271%description mkfont
272Converts common font file formats into PF2.
273
feaacba3
JB
274%description mkfont -l pl.UTF-8
275Program do konwersji popularnych formatów plików fontów do PF2.
276
8ac8605d
JK
277%package theme-starfield
278Summary: starfield theme for GRUB
feaacba3 279Summary(pl.UTF-8): Motyw starfield dla GRUB-a
8ac8605d
JK
280Group: Base
281
282%description theme-starfield
283starfield theme for GRUB.
284
feaacba3
JB
285%description theme-starfield -l pl.UTF-8
286Motyw starfield dla GRUB-a.
287
afe8504a 288%prep
b876d99a 289%setup -q -n grub-%{version}~%{beta} -a5
b46589aa 290%patch1 -p1
872700b0 291%patch2 -p1
f951fcbe 292%patch3 -p1
aec70abd 293%patch4 -p1
f7ae30d0 294%patch5 -p1
668ecb01
JK
295%patch6 -p1
296%patch7 -p1
61d105fa 297%patch8 -p1
668ecb01 298%patch9 -p1
26996aed 299%patch10 -p1
668ecb01
JK
300%patch11 -p1
301%patch12 -p0
5bafb558
JK
302
303# we don't have C.utf-8 and need an UTF-8 locale for build
304sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
afe8504a
SP
305
306%build
928eb9c1 307# if gold is used then grub doesn't even boot
9bc7aab3
AM
308# https://savannah.gnu.org/bugs/?34539
309# http://sourceware.org/bugzilla/show_bug.cgi?id=14196
7a73b7a5 310install -d our-ld
70fd3248 311ln -f -s /usr/bin/ld.bfd our-ld/ld
7a73b7a5 312export PATH=$(pwd)/our-ld:$PATH
928eb9c1 313
b876d99a
JK
314## not only the typicall autotools stuff
315#./autogen.sh
316
317%{__gettextize}
318%{__aclocal} -I m4
319%{__autoconf}
320%{__autoheader}
321%{__automake}
12fd19f5 322
1536aaf2 323for platform in %{platforms} ; do
fc490c3e
JK
324 install -d build-${platform}
325 cd build-${platform}
0e2cbb94
JK
326
327 if [ "$platform" != "efi" ] ; then
feaacba3 328 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
0e2cbb94
JK
329 else
330 platform_opts=""
331 fi
332
55d67ca1 333 ln -f -s ../configure .
1536aaf2
JK
334 # mawk stalls at ./genmoddep.awk, so force gawk
335 AWK=gawk \
336 %configure \
337 --with-platform=${platform} \
338 --disable-werror \
339 %if %{with grubemu}
340 --enable-grub-emu-usb \
341 --enable-grub-emu-sdl \
342 --enable-grub-emu-pci \
343 %endif
0e2cbb94 344 $platform_opts \
1536aaf2
JK
345 TARGET_LDFLAGS=-static
346
ec98fb4c 347 %{__make} -j1 -C po update-gmo
1536aaf2
JK
348 %{__make}
349 cd ..
350done
0fb8b1a5 351
afe8504a
SP
352%install
353rm -rf $RPM_BUILD_ROOT
afe8504a 354
1536aaf2 355for platform in %{platforms} ; do
fc490c3e 356 cd build-${platform}
1536aaf2
JK
357 %{__make} install \
358 pkgdatadir=%{_libexecdir} \
359 pkglibdir=%{_libexecdir} \
360 DESTDIR=$RPM_BUILD_ROOT
361 cd ..
362done
afe8504a 363
7615a862
JK
364# not in Th (?)
365%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
366%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
367
f951fcbe
AM
368%find_lang grub
369
bcd6a47e
ER
370# this must be after 'make install'
371install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
372
1536aaf2
JK
373install -d $RPM_BUILD_ROOT%{_grubdir}
374cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
375
7b6caae9 376# grub.d/41_custom
1536aaf2 377cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
378%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
379
22909ca1 380install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
381cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
382
383install -d $RPM_BUILD_ROOT/etc/sysconfig
384cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
385
386# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 387rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 388
feaacba3
JB
389# platform specific, unnecessarily always installed
390%ifnarch %{ix86} %{x8664}
391%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
392%endif
393%ifnarch sparc64
394%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
395%endif
396
cbd79801 397# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
398touch $RPM_BUILD_ROOT%{_grubdir}/core.img
399touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 400
8b5c394b
ER
401# needs to be exactly 1KiB
402# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 403dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 404
afe8504a
SP
405%clean
406rm -rf $RPM_BUILD_ROOT
407
5028d8c9 408%post -p %{_sbindir}/postshell
fc58858a 409-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 410
5028d8c9 411%postun -p %{_sbindir}/postshell
fc58858a 412-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 413
8c5e5aa2
JR
414%triggerpostun -- %{name} < 2.00-2
415# Note this trigger on version upgrade needed only for upgrade from
416# old grub2 packages which contained modules in /boot/grub
417# or were built with optimizations enabled
92904505
ER
418# don't do anything on --downgrade
419if [ $1 -le 1 ]; then
420 exit 0
421fi
422echo "Grub was upgraded, trying to setup it to boot sector"
423/sbin/grub-install '(hd0)' || :
424
7b6caae9
ER
425%triggerpostun -- %{name} < 1.99-7.3
426# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
427if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
428 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
429 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
430fi
431
f951fcbe 432%files -f grub.lang
afe8504a 433%defattr(644,root,root,755)
2e4bec6f 434%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 435%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
71c933c0 436%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 437%attr(755,root,root) %{_sbindir}/grub-fstest
5bafb558
JK
438%attr(755,root,root) %{_sbindir}/grub-file
439%attr(755,root,root) %{_sbindir}/grub-glue-efi
e9d73181 440%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 441%attr(755,root,root) %{_sbindir}/grub-install
5bafb558 442%attr(755,root,root) %{_sbindir}/grub-macbless
e9d73181 443%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 444%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
445%attr(755,root,root) %{_sbindir}/grub-mklayout
446%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
447%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
448%attr(755,root,root) %{_sbindir}/grub-mkrelpath
449%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
450%attr(755,root,root) %{_sbindir}/grub-mkstandalone
451%attr(755,root,root) %{_sbindir}/grub-mount
452%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0 453%attr(755,root,root) %{_sbindir}/grub-reboot
5bafb558 454%attr(755,root,root) %{_sbindir}/grub-render-label
71c933c0
ER
455%attr(755,root,root) %{_sbindir}/grub-script-check
456%attr(755,root,root) %{_sbindir}/grub-set-default
5bafb558 457%attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
22909ca1 458%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a 459%ifarch %{ix86} %{x8664}
feaacba3
JB
460%attr(755,root,root) %{_sbindir}/grub-bios-setup
461%{_mandir}/man8/grub-bios-setup.8*
462%endif
463%ifarch %{ix86} %{x8664}
76be4c4a 464%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 465%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
466%else
467%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 468%{_mandir}/man8/grub-probe.8*
76be4c4a 469%endif
feaacba3
JB
470%ifarch sparc64
471%attr(755,root,root) %{_sbindir}/grub-sparc64-setup
472%{_mandir}/man8/grub-sparc64-setup.8*
473%endif
71c933c0 474%{_mandir}/man1/grub-editenv.1*
5bafb558 475%{_mandir}/man1/grub-file.1*
3ea0c40e 476%{_mandir}/man1/grub-fstest.1*
5bafb558 477%{_mandir}/man1/grub-glue-efi.1*
7615a862 478%{_mandir}/man1/grub-kbdcomp.1*
5bafb558 479%{_mandir}/man1/grub-macbless.1*
e9d73181 480%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 481%{_mandir}/man1/grub-mklayout.1*
5bafb558 482%{_mandir}/man1/grub-mknetdir.1*
71c933c0 483%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 484%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 485%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
486%{_mandir}/man1/grub-mkstandalone.1*
487%{_mandir}/man1/grub-mount.1*
5bafb558 488%{_mandir}/man1/grub-render-label.1*
71c933c0 489%{_mandir}/man1/grub-script-check.1*
5bafb558 490%{_mandir}/man1/grub-syslinux2cfg.1*
71c933c0 491%{_mandir}/man8/grub-install.8*
fc835b5e 492%{_mandir}/man8/grub-mkconfig.8*
7615a862 493%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
494%{_mandir}/man8/grub-reboot.8*
495%{_mandir}/man8/grub-set-default.8*
22909ca1 496%{_mandir}/man8/update-grub.8*
797addca 497%if %{with grubemu}
8fcee4aa
ER
498%attr(755,root,root) %{_sbindir}/grub-emu
499%{_mandir}/man8/grub-emu.8*
797addca 500%endif
e6fbd304 501%{_libexecdir}/grub-mkconfig_lib
aec70abd 502
1536aaf2 503%dir %{_grubdir}
26e757db 504%dir %{_libexecdir}
bcd6a47e 505# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 506
bcd6a47e 507%dir %{_libexecdir}/locale
1536aaf2
JK
508%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
509%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 510
cbd79801 511# generated by grub at runtime
1536aaf2
JK
512%ghost %{_grubdir}/device.map
513%ghost %{_grubdir}/core.img
514%ghost %{_grubdir}/grubenv
cbd79801 515
e2964b87
ER
516%dir /lib/grub.d
517%doc /lib/grub.d/README
518%attr(755,root,root) /lib/grub.d/00_header
519%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 520%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 521%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 522%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 523
b876d99a
JK
524# these are now installed only on matching hosts
525#%attr(755,root,root) /lib/grub.d/10_hurd
526#%attr(755,root,root) /lib/grub.d/10_illumos
527#%attr(755,root,root) /lib/grub.d/10_kfreebsd
528#%attr(755,root,root) /lib/grub.d/10_netbsd
529#%attr(755,root,root) /lib/grub.d/10_xnu
530
1e58ef6c 531%ifarch %{ix86} %{x8664}
1ffaf1f6 532%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 533%{_mandir}/man8/grub-probe.8*
4a00f3b7 534%endif
aec70abd 535
f4604ef8 536%{_infodir}/grub*.info*
565fe2e3 537
8ac8605d
JK
538%dir %{_datadir}/grub/themes
539
1536aaf2 540%if %{with pc}
6d8475a4 541%files platform-pc
1536aaf2
JK
542%defattr(644,root,root,755)
543%dir %{_libexecdir}/*-pc
544%{_libexecdir}/*-pc/modinfo.sh
545%{_libexecdir}/*-pc/*.exec
546%{_libexecdir}/*-pc/*.image
547%{_libexecdir}/*-pc/*.lst
548%{_libexecdir}/*-pc/*.mod
549%{_libexecdir}/*-pc/*.module
550%{_libexecdir}/*-pc/lzma_decompress.img
551%{_libexecdir}/*-pc/config.h
552%{_libexecdir}/*-pc/gdb_grub
553%{_libexecdir}/*-pc/gmodule.pl
554%if %{with efiemu}
1536aaf2
JK
555%{_libexecdir}/*-pc/efiemu*.o
556%endif
1536aaf2
JK
557%{_libexecdir}/*-pc/kernel.img
558%ifarch %{ix86} %{x8664} sparc sparc64
559%{_libexecdir}/*-pc/boot.img
5bafb558 560%{_libexecdir}/*-pc/boot_hybrid.img
1536aaf2
JK
561%{_libexecdir}/*-pc/cdboot.img
562%{_libexecdir}/*-pc/diskboot.img
563%{_libexecdir}/*-pc/lnxboot.img
564%{_libexecdir}/*-pc/pxeboot.img
565%endif
566%endif
567
568%if %{with efi}
6d8475a4 569%files platform-efi
1536aaf2
JK
570%defattr(644,root,root,755)
571%dir %{_libexecdir}/*-efi
572%{_libexecdir}/*-efi/modinfo.sh
573%{_libexecdir}/*-efi/*.exec
574%{_libexecdir}/*-efi/*.lst
575%{_libexecdir}/*-efi/*.mod
576%{_libexecdir}/*-efi/*.module
577%{_libexecdir}/*-efi/config.h
578%{_libexecdir}/*-efi/gdb_grub
579%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
580%{_libexecdir}/*-efi/kernel.img
581%endif
582
7615a862
JK
583%files mkfont
584%defattr(644,root,root,755)
7615a862 585%attr(755,root,root) %{_sbindir}/grub-mkfont
feaacba3 586%{_mandir}/man1/grub-mkfont.1*
7615a862 587
8ac8605d
JK
588%files theme-starfield
589%defattr(644,root,root,755)
590%{_datadir}/grub/themes/starfield
591
565fe2e3
ER
592%files -n bash-completion-%{name}
593%defattr(644,root,root,755)
594/etc/bash_completion.d/grub
This page took 0.231778 seconds and 4 git commands to generate.