]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
- import patches from fedora, descriptions inside
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
f97cafb4 9#
90feddde 10# Conditional build:
1536aaf2 11%bcond_with grubemu # build grub-emu debugging utility
b06c130d 12%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
13%bcond_without pc # do not build for PC BIOS platform
14%bcond_without efi # do not build for EFI platform
b06c130d
ER
15
16%if "%{cc_version}" < "3.4"
17# cc does not support:
18# cc1: sorry, unimplemented: code model `large' not supported yet
19%undefine with_efiemu
20%endif
21
feaacba3
JB
22%ifnarch %{ix86} %{x8664}
23%undefine with_pc
24%endif
25%ifnarch %{ix86} %{x8664} ia64
26%undefine with_efi
27%endif
28
2d8da575
AM
29%ifnarch %{x8664}
30# non-x86_64 arch doesn't support this
31%undefine with_efiemu
32%endif
33
1536aaf2 34# the 'most natural' platform should go last
feaacba3 35%ifarch %{ix86} %{x8664} ia64
1536aaf2 36%define platforms %{?with_efi:efi} %{?with_pc:pc}
feaacba3
JB
37%endif
38%ifarch ppc ppc64 sparc64
39%define platforms ieee1275
40%endif
41%ifarch mips
42%define platforms arc
43%endif
44%ifarch mipsel
45%define platforms loongson
46%endif
1536aaf2 47
afe8504a 48Summary: GRand Unified Bootloader
c8155f7f 49Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 50Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
51Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
52Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 53Name: grub2
7615a862 54Version: 2.00
3c36d441 55Release: 0.5
2e4bec6f 56License: GPL v2
afe8504a 57Group: Base
f951fcbe 58Source0: http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
7615a862 59# Source0-md5: a1043102fbc7bcedbf53e7ee3d17ab91
22909ca1
ER
60Source1: update-grub
61Source2: update-grub.8
b46589aa 62Source3: grub.sysconfig
e2964b87 63Source4: grub-custom.cfg
5028d8c9 64Patch0: pld-initrd.patch
b46589aa 65Patch1: pld-sysconfdir.patch
872700b0 66Patch2: grub-garbage.patch
c9273ffc
JK
67Patch3: grub-lvmdevice.patch
68Patch4: pld-mkconfigdir.patch
69Patch5: grub-mkconfig-diagnostics.patch
70Patch6: ppc.patch
71Patch7: %{name}-awk.patch
72Patch8: posix.patch
73Patch9: %{name}-gets.patch
26996aed 74Patch10: %{name}-fonts_path.patch
55de8afc 75Patch11: %{name}-tftp_fix.patch
50fb4025
JR
76Patch12: add-vlan-tag-support.patch
77Patch13: just-say-linux.patch
78Patch14: add-GRUB-DISABLE-SUBMENU-option.patch
79Patch15: add-X-option-to-printf-functions.patch
80Patch16: dhcp-client-id-and-uuid-options-added.patch
81Patch17: fix-http-crash.patch
82Patch18: Issue-separate-DNS-queries-for-ipv4-and-ipv6.patch
83Patch19: search-for-specific-config-file-for-netboot.patch
feaacba3 84URL: http://www.gnu.org/software/grub/
27550907
ER
85BuildRequires: autoconf >= 2.53
86BuildRequires: automake >= 1:1.11.1-1
8b781299 87BuildRequires: bison
06df59fd 88BuildRequires: device-mapper-devel
feaacba3 89BuildRequires: flex >= 2.5.35
26996aed 90BuildRequires: fonts-TTF-DejaVu
feaacba3 91BuildRequires: freetype-devel >= 2
12fd19f5 92BuildRequires: gawk
63e45785 93BuildRequires: gettext-devel
feaacba3 94BuildRequires: glibc-static
1349ebb8 95BuildRequires: help2man
42985b0d 96BuildRequires: libfuse-devel
afe8504a 97BuildRequires: libtool
feaacba3
JB
98BuildRequires: ncurses-devel
99BuildRequires: rpm >= 4.4.9-56
100BuildRequires: rpmbuild(macros) >= 1.213
101BuildRequires: sed >= 4.0
102BuildRequires: tar >= 1:1.22
81a7e0ba 103BuildRequires: texinfo
feaacba3
JB
104BuildRequires: xz
105BuildRequires: xz-devel
c668211a
ER
106%ifarch %{x8664}
107BuildRequires: /usr/lib/libc.so
8905dae4
ER
108%if "%{pld_release}" == "ac"
109BuildRequires: libgcc32
110%else
797addca 111BuildRequires: gcc-multilib
c668211a 112%endif
dee0d6f5 113%endif
feaacba3 114Requires: %{name}-platform = %{version}-%{release}
dc6928bc 115Requires: which
feaacba3
JB
116%ifarch %{ix86} %{x8664}
117Suggests: %{name}-platform-pc
118%endif
190cc685 119Suggests: cdrkit-mkisofs
97ee543c 120Suggests: os-prober
afe8504a 121Provides: bootloader
fc835b5e 122Conflicts: grub
feaacba3 123ExclusiveArch: %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
afe8504a
SP
124BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126%define _sbindir /sbin
4a00f3b7 127%define _bindir %{_sbindir}
1536aaf2 128%define _libdir /lib
e6fbd304 129%define _datadir %{_libdir}
26e757db 130%define _libexecdir %{_libdir}/grub
1536aaf2 131%define _grubdir /boot/grub
da9b7cf9 132%define _localedir /usr/share/locale
9d44d75e 133
0e2cbb94
JK
134# part of grub code is not relocable (these are not Linux libs)
135# stack protector also breaks non-Linux binaries
5967241e
PS
136%define filterout_c -fPIC
137%undefine _ssp_cflags
0e2cbb94 138
afe8504a
SP
139%description
140GRUB is a GPLed bootloader intended to unify bootloading across x86
141operating systems. In addition to loading the Linux and *BSD kernels,
142it implements the Multiboot standard, which allows for flexible
143loading of multiple boot images (needed for modular kernels such as
144the GNU Hurd).
145
211df1ed
ER
146GRUB 2 is derived from PUPA which was a research project to
147investigate the next generation of GRUB. GRUB 2 has been rewritten
148from scratch to clean up everything for modularity and portability.
149
150GRUB 2 targets at the following goals:
151- Scripting support, such as conditionals, loops, variables and
152 functions.
153- Graphical interface.
154- Dynamic loading of modules in order to extend itself at the run time
155 rather than at the build time.
156- Portability for various architectures.
157- Internationalization. This includes support for non-ASCII character
158 code, message catalogs like gettext, fonts, graphics console, and so
159 on.
160- Real memory management, to make GNU GRUB more extensible.
161- Modular, hierarchical, object-oriented framework for file systems,
162 files, devices, drives, terminals, commands, partition tables and OS
163 loaders.
164- Cross-platform installation which allows for installing GRUB from a
165 different architecture.
166- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
167- Fix design mistakes in GRUB Legacy, which could not be solved for
168 backward-compatibility, such as the way of numbering partitions.
169
6b0aefbf 170%description -l de.UTF-8
afe8504a
SP
171GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
172Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 173läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
174
175GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
176und wird unter der GPL vertrieben. Aufgrund seiner höheren
177Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
178traditionellen Boot-Loader LILO.
179
f97cafb4
ZU
180%description -l hu.UTF-8
181GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
182betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
183teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
184GNU Hurd).
185
186GRUB2 céljai a következők:
187- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
188 függvények.
189- grafikus felület
190- modulok dinamikus betöltése futási időben
191- hordozhatóság több architektúrára
192- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
193 mint gettext, betűtípusok, grafikus konzolon, és így tovább
194- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
195- moduláris, hierarchikus, objektum-orientált keretrendszer
196 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
197 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
198
6b0aefbf
JR
199%description -l es.UTF-8
200Éste es GRUB - Grand Unified Boot Loader - un administrador de
201inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 202operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 203también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
204PC.
205
206El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
207usuarios conmás experiencia y que deseen obtener más recursos de su
208cargador de inicialización (boot loader).
afe8504a 209
6b0aefbf 210%description -l pl.UTF-8
feaacba3 211GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
6b0aefbf 212procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
feaacba3 213Linuksa i *BSD: posiada również implementację standardu Multiboot,
6b0aefbf
JR
214który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
215(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 216
6b0aefbf
JR
217%description -l pt_BR.UTF-8
218Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
219capaz de entrar na maioria dos sistemas operacionais livres - Linux,
220FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
221operacionais comerciais para PC.
222
6b0aefbf
JR
223O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
224avançados e que querem mais recursos de seu boot loader.
afe8504a 225
565fe2e3
ER
226%package -n bash-completion-%{name}
227Summary: bash-completion for GRUB
feaacba3 228Summary(pl.UTF-8): Bashowe uzupełnianie nazw dla GRUB-a
565fe2e3
ER
229Group: Applications/Shells
230Requires: bash-completion
231
232%description -n bash-completion-%{name}
233This package provides bash-completion for GRUB.
234
235%description -n bash-completion-%{name} -l pl.UTF-8
feaacba3 236Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
565fe2e3 237
6d8475a4 238%package platform-pc
62081337 239Summary: PC BIOS platform support for GRUB
feaacba3 240Summary(pl.UTF-8): Obsługa platformy PC BIOS dla GRUB-a
62081337 241Group: Base
6d8475a4 242Provides: %{name}-platform = %{version}-%{release}
1536aaf2 243
6d8475a4 244%description platform-pc
62081337 245PC BIOS platform support for GRUB.
1536aaf2 246
feaacba3
JB
247%description platform-pc -l pl.UTF-8
248Obsługa platformy PC BIOS dla GRUB-a.
249
6d8475a4 250%package platform-efi
1536aaf2 251Summary: (U)EFI platform support for GRUB
feaacba3 252Summary(pl.UTF-8): Obsługa platformy (U)EFI dla GRUB-a
1536aaf2 253Group: Base
6e81e1fe 254Suggests: efibootmgr
6d8475a4 255Provides: %{name}-platform = %{version}-%{release}
1536aaf2 256
6d8475a4 257%description platform-efi
1536aaf2
JK
258(U)EFI platform support for GRUB.
259
feaacba3
JB
260%description platform-efi -l pl.UTF-8
261Obsługa platformy (U)EFI dla GRUB-a.
262
7615a862
JK
263%package mkfont
264Summary: GRUB font files converter
feaacba3 265Summary(pl.UTF-8): Konwerter plików fontów GRUB-a
7615a862
JK
266Group: Base
267
268%description mkfont
269Converts common font file formats into PF2.
270
feaacba3
JB
271%description mkfont -l pl.UTF-8
272Program do konwersji popularnych formatów plików fontów do PF2.
273
8ac8605d
JK
274%package theme-starfield
275Summary: starfield theme for GRUB
feaacba3 276Summary(pl.UTF-8): Motyw starfield dla GRUB-a
8ac8605d
JK
277Group: Base
278
279%description theme-starfield
280starfield theme for GRUB.
281
feaacba3
JB
282%description theme-starfield -l pl.UTF-8
283Motyw starfield dla GRUB-a.
284
afe8504a 285%prep
f951fcbe 286%setup -q -n grub-%{version}
5028d8c9 287%patch0 -p1
b46589aa 288%patch1 -p1
872700b0 289%patch2 -p1
f951fcbe 290%patch3 -p1
aec70abd 291%patch4 -p1
f7ae30d0 292%patch5 -p1
e2964b87 293%patch6 -p1
449dde54 294%patch7 -p1
61d105fa 295%patch8 -p1
4c7bb96e 296%patch9 -p1
26996aed 297%patch10 -p1
55de8afc 298%patch11 -p1
50fb4025
JR
299%patch12 -p1
300%patch13 -p1
301%patch14 -p1
302%patch15 -p1
303%patch16 -p1
304%patch17 -p1
305%patch18 -p1
306%patch19 -p1
afe8504a 307
71c933c0 308%if "%{cc_version}" < "3.4"
dea0c850
ER
309grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
310%{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
71c933c0
ER
311%endif
312
afe8504a 313%build
928eb9c1
AM
314# if gold is used then grub doesn't even boot
315install -d our-ld
316ln -s /usr/bin/ld.bfd our-ld/ld
317export PATH=$(pwd)/our-ld:$PATH
318
3ff87e8a 319cp -f /usr/share/automake/config.sub .
afe8504a 320%{__libtoolize}
e9d73181 321%{__aclocal} -I m4
afe8504a 322%{__autoheader}
b1a4846d 323echo timestamp > stamp-h.in
afe8504a 324%{__autoconf}
80936b4a 325%{__automake}
53c50f89 326export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
12fd19f5 327
1536aaf2 328for platform in %{platforms} ; do
fc490c3e
JK
329 install -d build-${platform}
330 cd build-${platform}
0e2cbb94
JK
331
332 if [ "$platform" != "efi" ] ; then
feaacba3 333 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
0e2cbb94
JK
334 else
335 platform_opts=""
336 fi
337
1536aaf2
JK
338 ln -s ../configure .
339 # mawk stalls at ./genmoddep.awk, so force gawk
340 AWK=gawk \
341 %configure \
342 --with-platform=${platform} \
343 --disable-werror \
344 %if %{with grubemu}
345 --enable-grub-emu-usb \
346 --enable-grub-emu-sdl \
347 --enable-grub-emu-pci \
348 %endif
0e2cbb94 349 $platform_opts \
1536aaf2
JK
350 TARGET_LDFLAGS=-static
351
352 %{__make}
353 cd ..
354done
0fb8b1a5 355
afe8504a
SP
356%install
357rm -rf $RPM_BUILD_ROOT
afe8504a 358
1536aaf2 359for platform in %{platforms} ; do
fc490c3e 360 cd build-${platform}
1536aaf2
JK
361 %{__make} install \
362 pkgdatadir=%{_libexecdir} \
363 pkglibdir=%{_libexecdir} \
364 DESTDIR=$RPM_BUILD_ROOT
365 cd ..
366done
afe8504a 367
7615a862
JK
368# not in Th (?)
369%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
370%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
371
f951fcbe
AM
372%find_lang grub
373
bcd6a47e
ER
374# this must be after 'make install'
375install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
376
1536aaf2
JK
377install -d $RPM_BUILD_ROOT%{_grubdir}
378cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
379
7b6caae9 380# grub.d/41_custom
1536aaf2 381cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
382%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
383
22909ca1 384install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
385cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
386
387install -d $RPM_BUILD_ROOT/etc/sysconfig
388cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
389
390# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 391rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 392
feaacba3
JB
393# platform specific, unnecessarily always installed
394%ifnarch %{ix86} %{x8664}
395%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
396%endif
397%ifnarch sparc64
398%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
399%endif
400
cbd79801 401# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
402touch $RPM_BUILD_ROOT%{_grubdir}/core.img
403touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 404
8b5c394b
ER
405# needs to be exactly 1KiB
406# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 407dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 408
afe8504a
SP
409%clean
410rm -rf $RPM_BUILD_ROOT
411
5028d8c9 412%post -p %{_sbindir}/postshell
fc58858a 413-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 414
5028d8c9 415%postun -p %{_sbindir}/postshell
fc58858a 416-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 417
287a39cc 418%triggerpostun -- %{name} < 2.00-0.1
a7bef3b9 419# Note this trigger on version upgrade
287a39cc
JK
420# needed only for upgrade from old grub2 packages
421# which contained modules in /boot/grub
92904505
ER
422# don't do anything on --downgrade
423if [ $1 -le 1 ]; then
424 exit 0
425fi
426echo "Grub was upgraded, trying to setup it to boot sector"
427/sbin/grub-install '(hd0)' || :
428
7b6caae9
ER
429%triggerpostun -- %{name} < 1.99-7.3
430# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
431if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
432 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
433 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
434fi
435
f951fcbe 436%files -f grub.lang
afe8504a 437%defattr(644,root,root,755)
2e4bec6f 438%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 439%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
71c933c0 440%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 441%attr(755,root,root) %{_sbindir}/grub-fstest
e9d73181 442%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 443%attr(755,root,root) %{_sbindir}/grub-install
e9d73181 444%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 445%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
446%attr(755,root,root) %{_sbindir}/grub-mklayout
447%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
448%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
449%attr(755,root,root) %{_sbindir}/grub-mkrelpath
450%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
451%attr(755,root,root) %{_sbindir}/grub-mkstandalone
452%attr(755,root,root) %{_sbindir}/grub-mount
453%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0
ER
454%attr(755,root,root) %{_sbindir}/grub-reboot
455%attr(755,root,root) %{_sbindir}/grub-script-check
456%attr(755,root,root) %{_sbindir}/grub-set-default
22909ca1 457%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a 458%ifarch %{ix86} %{x8664}
feaacba3
JB
459%attr(755,root,root) %{_sbindir}/grub-bios-setup
460%{_mandir}/man8/grub-bios-setup.8*
461%endif
462%ifarch %{ix86} %{x8664}
76be4c4a 463%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 464%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
465%else
466%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 467%{_mandir}/man8/grub-probe.8*
76be4c4a 468%endif
feaacba3
JB
469%ifarch sparc64
470%attr(755,root,root) %{_sbindir}/grub-sparc64-setup
471%{_mandir}/man8/grub-sparc64-setup.8*
472%endif
71c933c0 473%{_mandir}/man1/grub-editenv.1*
3ea0c40e 474%{_mandir}/man1/grub-fstest.1*
7615a862 475%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 476%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 477%{_mandir}/man1/grub-mklayout.1*
71c933c0 478%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 479%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 480%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
481%{_mandir}/man1/grub-mkstandalone.1*
482%{_mandir}/man1/grub-mount.1*
71c933c0
ER
483%{_mandir}/man1/grub-script-check.1*
484%{_mandir}/man8/grub-install.8*
fc835b5e 485%{_mandir}/man8/grub-mkconfig.8*
e9d73181 486%{_mandir}/man8/grub-mknetdir.8*
7615a862 487%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
488%{_mandir}/man8/grub-reboot.8*
489%{_mandir}/man8/grub-set-default.8*
22909ca1 490%{_mandir}/man8/update-grub.8*
797addca 491%if %{with grubemu}
8fcee4aa
ER
492%attr(755,root,root) %{_sbindir}/grub-emu
493%{_mandir}/man8/grub-emu.8*
797addca 494%endif
e6fbd304 495%{_libexecdir}/grub-mkconfig_lib
aec70abd 496
1536aaf2 497%dir %{_grubdir}
26e757db 498%dir %{_libexecdir}
bcd6a47e 499# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 500
bcd6a47e 501%dir %{_libexecdir}/locale
1536aaf2
JK
502%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
503%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 504
cbd79801 505# generated by grub at runtime
1536aaf2
JK
506%ghost %{_grubdir}/device.map
507%ghost %{_grubdir}/core.img
508%ghost %{_grubdir}/grubenv
cbd79801 509
e2964b87
ER
510%dir /lib/grub.d
511%doc /lib/grub.d/README
512%attr(755,root,root) /lib/grub.d/00_header
513%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 514%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 515%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 516%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 517
1e58ef6c 518%ifarch %{ix86} %{x8664}
1ffaf1f6 519%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 520%{_mandir}/man8/grub-probe.8*
4a00f3b7 521%endif
aec70abd 522
f4604ef8 523%{_infodir}/grub*.info*
565fe2e3 524
8ac8605d
JK
525%dir %{_datadir}/grub/themes
526
1536aaf2 527%if %{with pc}
6d8475a4 528%files platform-pc
1536aaf2
JK
529%defattr(644,root,root,755)
530%dir %{_libexecdir}/*-pc
531%{_libexecdir}/*-pc/modinfo.sh
532%{_libexecdir}/*-pc/*.exec
533%{_libexecdir}/*-pc/*.image
534%{_libexecdir}/*-pc/*.lst
535%{_libexecdir}/*-pc/*.mod
536%{_libexecdir}/*-pc/*.module
537%{_libexecdir}/*-pc/lzma_decompress.img
538%{_libexecdir}/*-pc/config.h
539%{_libexecdir}/*-pc/gdb_grub
540%{_libexecdir}/*-pc/gmodule.pl
541%if %{with efiemu}
1536aaf2
JK
542%{_libexecdir}/*-pc/efiemu*.o
543%endif
1536aaf2
JK
544%{_libexecdir}/*-pc/kernel.img
545%ifarch %{ix86} %{x8664} sparc sparc64
546%{_libexecdir}/*-pc/boot.img
547%{_libexecdir}/*-pc/cdboot.img
548%{_libexecdir}/*-pc/diskboot.img
549%{_libexecdir}/*-pc/lnxboot.img
550%{_libexecdir}/*-pc/pxeboot.img
551%endif
552%endif
553
554%if %{with efi}
6d8475a4 555%files platform-efi
1536aaf2
JK
556%defattr(644,root,root,755)
557%dir %{_libexecdir}/*-efi
558%{_libexecdir}/*-efi/modinfo.sh
559%{_libexecdir}/*-efi/*.exec
560%{_libexecdir}/*-efi/*.lst
561%{_libexecdir}/*-efi/*.mod
562%{_libexecdir}/*-efi/*.module
563%{_libexecdir}/*-efi/config.h
564%{_libexecdir}/*-efi/gdb_grub
565%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
566%{_libexecdir}/*-efi/kernel.img
567%endif
568
7615a862
JK
569%files mkfont
570%defattr(644,root,root,755)
7615a862 571%attr(755,root,root) %{_sbindir}/grub-mkfont
feaacba3 572%{_mandir}/man1/grub-mkfont.1*
7615a862 573
8ac8605d
JK
574%files theme-starfield
575%defattr(644,root,root,755)
576%{_datadir}/grub/themes/starfield
577
565fe2e3
ER
578%files -n bash-completion-%{name}
579%defattr(644,root,root,755)
580/etc/bash_completion.d/grub
This page took 2.079902 seconds and 4 git commands to generate.