]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
grub-mount BR: libfuse-devel.
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
659f8cfc 9# - warning: Installed (but unpackaged) file(s) found:
1536aaf2
JK
10# /sbin/grub-sparc64-setup
11# /usr/share/man/man8/grub-sparc64-setup.8.gz
12
659f8cfc
ER
13# /boot/grub/config.h
14# /etc/bash_completion.d/grub
7615a862
JK
15# /sbin/grub-sparc64-setup
16# /boot/grub/gdb_grub
17# /boot/grub/gmodule.pl
18# /sbin/grub-sparc64-setup
f97cafb4 19#
90feddde 20# Conditional build:
1536aaf2 21%bcond_with grubemu # build grub-emu debugging utility
b06c130d 22%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
23%bcond_without pc # do not build for PC BIOS platform
24%bcond_without efi # do not build for EFI platform
b06c130d
ER
25
26%if "%{cc_version}" < "3.4"
27# cc does not support:
28# cc1: sorry, unimplemented: code model `large' not supported yet
29%undefine with_efiemu
30%endif
31
2d8da575
AM
32%ifnarch %{x8664}
33# non-x86_64 arch doesn't support this
34%undefine with_efiemu
35%endif
36
1536aaf2
JK
37# the 'most natural' platform should go last
38%define platforms %{?with_efi:efi} %{?with_pc:pc}
39
afe8504a 40Summary: GRand Unified Bootloader
c8155f7f 41Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 42Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
43Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
44Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 45Name: grub2
7615a862 46Version: 2.00
e2506058 47Release: 0.3
2e4bec6f 48License: GPL v2
afe8504a 49Group: Base
f951fcbe 50Source0: http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
7615a862 51# Source0-md5: a1043102fbc7bcedbf53e7ee3d17ab91
22909ca1
ER
52Source1: update-grub
53Source2: update-grub.8
b46589aa 54Source3: grub.sysconfig
e2964b87 55Source4: grub-custom.cfg
695ab3a5 56URL: http://www.gnu.org/software/grub/
5028d8c9 57Patch0: pld-initrd.patch
b46589aa 58Patch1: pld-sysconfdir.patch
872700b0 59Patch2: grub-garbage.patch
c9273ffc
JK
60Patch3: grub-lvmdevice.patch
61Patch4: pld-mkconfigdir.patch
62Patch5: grub-mkconfig-diagnostics.patch
63Patch6: ppc.patch
64Patch7: %{name}-awk.patch
65Patch8: posix.patch
66Patch9: %{name}-gets.patch
26996aed 67Patch10: %{name}-fonts_path.patch
55de8afc 68Patch11: %{name}-tftp_fix.patch
27550907
ER
69BuildRequires: autoconf >= 2.53
70BuildRequires: automake >= 1:1.11.1-1
8b781299 71BuildRequires: bison
06df59fd 72BuildRequires: device-mapper-devel
26996aed 73BuildRequires: fonts-TTF-DejaVu
013b927c 74BuildRequires: freetype-devel
12fd19f5 75BuildRequires: gawk
63e45785 76BuildRequires: gettext-devel
1349ebb8 77BuildRequires: help2man
42985b0d 78BuildRequires: libfuse-devel
afe8504a 79BuildRequires: libtool
81a7e0ba 80BuildRequires: texinfo
c668211a
ER
81%ifarch %{x8664}
82BuildRequires: /usr/lib/libc.so
8905dae4
ER
83%if "%{pld_release}" == "ac"
84BuildRequires: libgcc32
85%else
797addca 86BuildRequires: gcc-multilib
c668211a 87%endif
dee0d6f5 88%endif
6b675158 89BuildRequires: glibc-static
565fe2e3 90BuildRequires: ncurses-devel
8905dae4 91BuildRequires: rpm >= 4.4.9-56
403e7b01 92BuildRequires: rpmbuild(macros) >= 1.213
565fe2e3 93BuildRequires: sed >= 4.0
dc6928bc 94Requires: which
190cc685 95Suggests: cdrkit-mkisofs
97ee543c 96Suggests: os-prober
afe8504a 97Provides: bootloader
fc835b5e 98Conflicts: grub
6d8475a4 99Requires: %{name}-platform = %{version}-%{release}
58a823d7 100ExclusiveArch: %{ix86} %{x8664} ppc sparc64
afe8504a
SP
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103%define _sbindir /sbin
4a00f3b7 104%define _bindir %{_sbindir}
1536aaf2 105%define _libdir /lib
e6fbd304 106%define _datadir %{_libdir}
26e757db 107%define _libexecdir %{_libdir}/grub
1536aaf2 108%define _grubdir /boot/grub
da9b7cf9 109%define _localedir /usr/share/locale
9d44d75e 110
0e2cbb94
JK
111# part of grub code is not relocable (these are not Linux libs)
112# stack protector also breaks non-Linux binaries
5967241e
PS
113%define filterout_c -fPIC
114%undefine _ssp_cflags
0e2cbb94 115
afe8504a
SP
116%description
117GRUB is a GPLed bootloader intended to unify bootloading across x86
118operating systems. In addition to loading the Linux and *BSD kernels,
119it implements the Multiboot standard, which allows for flexible
120loading of multiple boot images (needed for modular kernels such as
121the GNU Hurd).
122
211df1ed
ER
123GRUB 2 is derived from PUPA which was a research project to
124investigate the next generation of GRUB. GRUB 2 has been rewritten
125from scratch to clean up everything for modularity and portability.
126
127GRUB 2 targets at the following goals:
128- Scripting support, such as conditionals, loops, variables and
129 functions.
130- Graphical interface.
131- Dynamic loading of modules in order to extend itself at the run time
132 rather than at the build time.
133- Portability for various architectures.
134- Internationalization. This includes support for non-ASCII character
135 code, message catalogs like gettext, fonts, graphics console, and so
136 on.
137- Real memory management, to make GNU GRUB more extensible.
138- Modular, hierarchical, object-oriented framework for file systems,
139 files, devices, drives, terminals, commands, partition tables and OS
140 loaders.
141- Cross-platform installation which allows for installing GRUB from a
142 different architecture.
143- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
144- Fix design mistakes in GRUB Legacy, which could not be solved for
145 backward-compatibility, such as the way of numbering partitions.
146
6b0aefbf 147%description -l de.UTF-8
afe8504a
SP
148GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
149Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 150läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
151
152GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
153und wird unter der GPL vertrieben. Aufgrund seiner höheren
154Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
155traditionellen Boot-Loader LILO.
156
f97cafb4
ZU
157%description -l hu.UTF-8
158GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
159betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
160teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
161GNU Hurd).
162
163GRUB2 céljai a következők:
164- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
165 függvények.
166- grafikus felület
167- modulok dinamikus betöltése futási időben
168- hordozhatóság több architektúrára
169- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
170 mint gettext, betűtípusok, grafikus konzolon, és így tovább
171- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
172- moduláris, hierarchikus, objektum-orientált keretrendszer
173 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
174 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
175
6b0aefbf
JR
176%description -l es.UTF-8
177Éste es GRUB - Grand Unified Boot Loader - un administrador de
178inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 179operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 180también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
181PC.
182
183El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
184usuarios conmás experiencia y que deseen obtener más recursos de su
185cargador de inicialización (boot loader).
afe8504a 186
6b0aefbf
JR
187%description -l pl.UTF-8
188GRUB jest bootloaderem na licencji GNU, mającym na celu unifikację
189procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
190Linuksa i *BSD: posiada również implementacje standardu Multiboot,
191który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
192(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 193
6b0aefbf
JR
194%description -l pt_BR.UTF-8
195Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
196capaz de entrar na maioria dos sistemas operacionais livres - Linux,
197FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
198operacionais comerciais para PC.
199
6b0aefbf
JR
200O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
201avançados e que querem mais recursos de seu boot loader.
afe8504a 202
565fe2e3
ER
203%package -n bash-completion-%{name}
204Summary: bash-completion for GRUB
205Summary(pl.UTF-8): bashowe uzupełnianie nazw dla GRUB
206Group: Applications/Shells
207Requires: bash-completion
208
209%description -n bash-completion-%{name}
210This package provides bash-completion for GRUB.
211
212%description -n bash-completion-%{name} -l pl.UTF-8
213Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB.
214
6d8475a4 215%package platform-pc
62081337
ER
216Summary: PC BIOS platform support for GRUB
217Group: Base
6d8475a4 218Provides: %{name}-platform = %{version}-%{release}
1536aaf2 219
6d8475a4 220%description platform-pc
62081337 221PC BIOS platform support for GRUB.
1536aaf2 222
6d8475a4 223%package platform-efi
1536aaf2
JK
224Summary: (U)EFI platform support for GRUB
225Group: Base
6d8475a4 226Provides: %{name}-platform = %{version}-%{release}
1536aaf2 227
6d8475a4 228%description platform-efi
1536aaf2
JK
229(U)EFI platform support for GRUB.
230
7615a862
JK
231%package mkfont
232Summary: GRUB font files converter
233Group: Base
234
235%description mkfont
236Converts common font file formats into PF2.
237
8ac8605d
JK
238%package theme-starfield
239Summary: starfield theme for GRUB
240Group: Base
241
242%description theme-starfield
243starfield theme for GRUB.
244
afe8504a 245%prep
f951fcbe 246%setup -q -n grub-%{version}
5028d8c9 247%patch0 -p1
b46589aa 248%patch1 -p1
872700b0 249%patch2 -p1
f951fcbe 250%patch3 -p1
aec70abd 251%patch4 -p1
f7ae30d0 252%patch5 -p1
e2964b87 253%patch6 -p1
449dde54 254%patch7 -p1
61d105fa 255%patch8 -p1
4c7bb96e 256%patch9 -p1
26996aed 257%patch10 -p1
55de8afc 258%patch11 -p1
afe8504a 259
71c933c0 260%if "%{cc_version}" < "3.4"
dea0c850
ER
261grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
262%{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
71c933c0
ER
263%endif
264
afe8504a 265%build
928eb9c1
AM
266# if gold is used then grub doesn't even boot
267install -d our-ld
268ln -s /usr/bin/ld.bfd our-ld/ld
269export PATH=$(pwd)/our-ld:$PATH
270
3ff87e8a 271cp -f /usr/share/automake/config.sub .
afe8504a 272%{__libtoolize}
e9d73181 273%{__aclocal} -I m4
afe8504a 274%{__autoheader}
b1a4846d 275echo timestamp > stamp-h.in
afe8504a 276%{__autoconf}
53c50f89 277export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
12fd19f5 278
1536aaf2 279for platform in %{platforms} ; do
fc490c3e
JK
280 install -d build-${platform}
281 cd build-${platform}
0e2cbb94
JK
282
283 if [ "$platform" != "efi" ] ; then
284 platform_opts="--%{!?with_efiemu:dis}%{?with_efiemu:en}able-efiemu"
285 else
286 platform_opts=""
287 fi
288
1536aaf2
JK
289 ln -s ../configure .
290 # mawk stalls at ./genmoddep.awk, so force gawk
291 AWK=gawk \
292 %configure \
293 --with-platform=${platform} \
294 --disable-werror \
295 %if %{with grubemu}
296 --enable-grub-emu-usb \
297 --enable-grub-emu-sdl \
298 --enable-grub-emu-pci \
299 %endif
0e2cbb94 300 $platform_opts \
1536aaf2
JK
301 TARGET_LDFLAGS=-static
302
303 %{__make}
304 cd ..
305done
0fb8b1a5 306
afe8504a
SP
307%install
308rm -rf $RPM_BUILD_ROOT
afe8504a 309
1536aaf2 310for platform in %{platforms} ; do
fc490c3e 311 cd build-${platform}
1536aaf2
JK
312 %{__make} install \
313 pkgdatadir=%{_libexecdir} \
314 pkglibdir=%{_libexecdir} \
315 DESTDIR=$RPM_BUILD_ROOT
316 cd ..
317done
afe8504a 318
7615a862
JK
319# not in Th (?)
320%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
321%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
322
f951fcbe
AM
323%find_lang grub
324
bcd6a47e
ER
325# this must be after 'make install'
326install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
327
1536aaf2
JK
328install -d $RPM_BUILD_ROOT%{_grubdir}
329cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
330
7b6caae9 331# grub.d/41_custom
1536aaf2 332cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
333%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
334
22909ca1 335install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
336cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
337
338install -d $RPM_BUILD_ROOT/etc/sysconfig
339cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
340
341# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 342rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 343
cbd79801 344# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
345touch $RPM_BUILD_ROOT%{_grubdir}/core.img
346touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 347
8b5c394b
ER
348# needs to be exactly 1KiB
349# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 350dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 351
afe8504a
SP
352%clean
353rm -rf $RPM_BUILD_ROOT
354
5028d8c9 355%post -p %{_sbindir}/postshell
fc58858a 356-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 357
5028d8c9 358%postun -p %{_sbindir}/postshell
fc58858a 359-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 360
92904505 361%triggerpostun -- %{name} < %{version}-0
a7bef3b9 362# Note this trigger on version upgrade
92904505
ER
363# don't do anything on --downgrade
364if [ $1 -le 1 ]; then
365 exit 0
366fi
367echo "Grub was upgraded, trying to setup it to boot sector"
368/sbin/grub-install '(hd0)' || :
369
7b6caae9
ER
370%triggerpostun -- %{name} < 1.99-7.3
371# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
372if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
373 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
374 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
375fi
376
f951fcbe 377%files -f grub.lang
afe8504a 378%defattr(644,root,root,755)
2e4bec6f 379%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 380%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
7615a862 381%attr(755,root,root) %{_sbindir}/grub-bios-setup
71c933c0 382%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 383%attr(755,root,root) %{_sbindir}/grub-fstest
e9d73181 384%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 385%attr(755,root,root) %{_sbindir}/grub-install
e9d73181 386%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 387%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
388%attr(755,root,root) %{_sbindir}/grub-mklayout
389%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
390%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
391%attr(755,root,root) %{_sbindir}/grub-mkrelpath
392%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
393%attr(755,root,root) %{_sbindir}/grub-mkstandalone
394%attr(755,root,root) %{_sbindir}/grub-mount
395%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0
ER
396%attr(755,root,root) %{_sbindir}/grub-reboot
397%attr(755,root,root) %{_sbindir}/grub-script-check
398%attr(755,root,root) %{_sbindir}/grub-set-default
22909ca1 399%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a
AM
400%ifarch %{ix86} %{x8664}
401%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 402%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
403%else
404%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 405%{_mandir}/man8/grub-probe.8*
76be4c4a 406%endif
71c933c0 407%{_mandir}/man1/grub-editenv.1*
3ea0c40e 408%{_mandir}/man1/grub-fstest.1*
7615a862 409%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 410%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 411%{_mandir}/man1/grub-mklayout.1*
71c933c0 412%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 413%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 414%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
415%{_mandir}/man1/grub-mkstandalone.1*
416%{_mandir}/man1/grub-mount.1*
71c933c0 417%{_mandir}/man1/grub-script-check.1*
7615a862 418%{_mandir}/man8/grub-bios-setup.8*
71c933c0 419%{_mandir}/man8/grub-install.8*
fc835b5e 420%{_mandir}/man8/grub-mkconfig.8*
e9d73181 421%{_mandir}/man8/grub-mknetdir.8*
7615a862 422%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
423%{_mandir}/man8/grub-reboot.8*
424%{_mandir}/man8/grub-set-default.8*
22909ca1 425%{_mandir}/man8/update-grub.8*
797addca 426%if %{with grubemu}
8fcee4aa
ER
427%attr(755,root,root) %{_sbindir}/grub-emu
428%{_mandir}/man8/grub-emu.8*
797addca 429%endif
e6fbd304 430%{_libexecdir}/grub-mkconfig_lib
aec70abd 431
1536aaf2 432%dir %{_grubdir}
26e757db 433%dir %{_libexecdir}
bcd6a47e 434# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 435
bcd6a47e 436%dir %{_libexecdir}/locale
1536aaf2
JK
437%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
438%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 439
cbd79801 440# generated by grub at runtime
1536aaf2
JK
441%ghost %{_grubdir}/device.map
442%ghost %{_grubdir}/core.img
443%ghost %{_grubdir}/grubenv
cbd79801 444
e2964b87
ER
445%dir /lib/grub.d
446%doc /lib/grub.d/README
447%attr(755,root,root) /lib/grub.d/00_header
448%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 449%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 450%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 451%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 452
1e58ef6c 453%ifarch %{ix86} %{x8664}
1ffaf1f6 454%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 455%{_mandir}/man8/grub-probe.8*
4a00f3b7 456%endif
aec70abd 457
f4604ef8 458%{_infodir}/grub*.info*
565fe2e3 459
8ac8605d
JK
460%dir %{_datadir}/grub/themes
461
1536aaf2 462%if %{with pc}
6d8475a4 463%files platform-pc
1536aaf2
JK
464%defattr(644,root,root,755)
465%dir %{_libexecdir}/*-pc
466%{_libexecdir}/*-pc/modinfo.sh
467%{_libexecdir}/*-pc/*.exec
468%{_libexecdir}/*-pc/*.image
469%{_libexecdir}/*-pc/*.lst
470%{_libexecdir}/*-pc/*.mod
471%{_libexecdir}/*-pc/*.module
472%{_libexecdir}/*-pc/lzma_decompress.img
473%{_libexecdir}/*-pc/config.h
474%{_libexecdir}/*-pc/gdb_grub
475%{_libexecdir}/*-pc/gmodule.pl
476%if %{with efiemu}
477%ifarch %{x8664}
478%{_libexecdir}/*-pc/efiemu*.o
479%endif
480%endif
481%{_libexecdir}/*-pc/kernel.img
482%ifarch %{ix86} %{x8664} sparc sparc64
483%{_libexecdir}/*-pc/boot.img
484%{_libexecdir}/*-pc/cdboot.img
485%{_libexecdir}/*-pc/diskboot.img
486%{_libexecdir}/*-pc/lnxboot.img
487%{_libexecdir}/*-pc/pxeboot.img
488%endif
489%endif
490
491%if %{with efi}
6d8475a4 492%files platform-efi
1536aaf2
JK
493%defattr(644,root,root,755)
494%dir %{_libexecdir}/*-efi
495%{_libexecdir}/*-efi/modinfo.sh
496%{_libexecdir}/*-efi/*.exec
497%{_libexecdir}/*-efi/*.lst
498%{_libexecdir}/*-efi/*.mod
499%{_libexecdir}/*-efi/*.module
500%{_libexecdir}/*-efi/config.h
501%{_libexecdir}/*-efi/gdb_grub
502%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
503%{_libexecdir}/*-efi/kernel.img
504%endif
505
7615a862
JK
506%files mkfont
507%defattr(644,root,root,755)
508%{_mandir}/man1/grub-mkfont.1*
509%attr(755,root,root) %{_sbindir}/grub-mkfont
510
8ac8605d
JK
511%files theme-starfield
512%defattr(644,root,root,755)
513%{_datadir}/grub/themes/starfield
514
565fe2e3
ER
515%files -n bash-completion-%{name}
516%defattr(644,root,root,755)
517/etc/bash_completion.d/grub
This page took 0.10967 seconds and 4 git commands to generate.