]> git.pld-linux.org Git - packages/gcc.git/blame - gcc.spec
- added cxx and fortran bconds
[packages/gcc.git] / gcc.spec
CommitLineData
a9e887db
MM
1#
2# Conditional build:
b4e5a90f 3%bcond_without ada # build without ADA support
4bdcc33d
JB
4%bcond_without cxx # build without C++ support
5%bcond_without fortran # build without Fortran77 support
b4e5a90f 6%bcond_without java # build without Java support
d968f64b 7%bcond_without ksi # build without KSI support
b4e5a90f
JB
8%bcond_without objc # build without objc support
9%bcond_with bootstrap # don't BR gcc(ada) (temporary for Ac upgrade bootstrap)
4bdcc33d
JB
10%bcond_with boot64 # 32->64-bit bootstrap (sparc->sparc64, maybe ppc too?)
11%ifarch %{x8664} sparc64
83c89470
JR
12%bcond_without multilib # build without multilib support
13%else
3c46ab80 14%bcond_with multilib # build with multilib support
83c89470 15%endif
3c46ab80 16#
4628f799 17%ifnarch %{x8664} ppc64 s390x sparc64
3c46ab80
JB
18%undefine with_multilib
19%endif
4bdcc33d
JB
20%if %{with boot64}
21%undefine with_ada
22%undefine with_cxx
23%undefine with_fortran
24%undefine with_java
25%undefine with_ksi
26%undefine with_objc
27%endif
15eab706 28#
98d8c419 29%define DASHED_SNAP %{nil}
a9e887db 30%define SNAP %(echo %{DASHED_SNAP} | sed -e "s#-##g")
85d8677d 31%define GCC_VERSION 3.3.6
32a4597e 32%define KSI_VERSION 1.1.0.1567
a9e887db 33
ae2e17eb 34Summary: GNU Compiler Collection: the C compiler and shared files
35