]> git.pld-linux.org Git - packages/gcc.git/blame - gcc.spec
- Release 0.6.
[packages/gcc.git] / gcc.spec
CommitLineData
a9e887db
MM
1#
2# Conditional build:
7fae892c 3# _without_ada - build without ADA support
4# _without_java - build without Java support
5# _without_objc - build without objc support
a9e887db 6#
98d8c419 7%define DASHED_SNAP %{nil}
a9e887db 8%define SNAP %(echo %{DASHED_SNAP} | sed -e "s#-##g")
f9e50bfb 9%define GCC_VERSION 3.2.2
a9e887db
MM
10%define KSI_VERSION pre55
11
927cf182 12Summary: GNU C Compiler
13Summary(pl): Kompilator C GNU
14Summary(pt_BR): C Compilador GNU (GCC)
8fdeb3b2 15Name: gcc
a9e887db 16Version: %{GCC_VERSION}
447ebb6c 17Release: 0.6
927cf182 18Epoch: 5
0ca8a31b 19License: GPL
8fdeb3b2 20Group: Development/Languages
98d8c419 21Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
a9e887db 22Source1: ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
1328be86 23Source2: %{name}-non-english-man-pages.tar.bz2
a9e887db
MM
24Patch0: %{name}-slibdir.patch
25Patch1: %{name}-paths.patch
26Patch2: %{name}-ada-no-addr2line.patch
27Patch3: %{name}-ada-no-prefix.o.patch
28Patch4: %{name}-nolocalefiles.patch
2c24b267 29Patch5: %{name}-gcc-page.c.patch
1328be86 30Patch6: %{name}-info.patch
445e4a00 31Patch7: %{name}-ada-link-new-libgnat.patch
a9e887db
MM
32# -- stolen patches from RH --
33Patch10: gcc32-ada-link.patch
34Patch11: gcc32-attr-visibility.patch
35Patch12: gcc32-attr-visibility2.patch
36Patch13: gcc32-attr-visibility3.patch
37Patch14: gcc32-attr-visibility4.patch
38Patch15: gcc32-attr-visibility5.patch
39Patch16: gcc32-boehm-gc-libs.patch
40Patch17: gcc32-bogus-inline.patch
41Patch18: gcc32-c++-nrv-test.patch
42Patch19: gcc32-c++-pretty_function.patch
7171cd81 43Patch20: gcc32-c++-tsubst-asm.patch
44Patch21: gcc32-cfg-eh.patch
45Patch22: gcc32-debug-pr7241.patch
d7fb7839 46
7171cd81 47Patch24: gcc32-duplicate-decl.patch
7d225235 48Patch25: gcc32-dwarf2-pr6381.patch
7171cd81 49Patch26: gcc32-dwarf2-pr6436-test.patch
7d225235 50Patch27: gcc32-fde-merge-compat.patch
3b79bdf4 51
7171cd81 52Patch29: gcc32-hard-reg-sharing.patch
7d225235 53Patch30: gcc32-hard-reg-sharing2.patch
7171cd81 54Patch31: gcc32-i386-default-momit-leaf-frame-pointer.patch
7d225235 55Patch32: gcc32-i386-memtest-test.patch
7171cd81 56Patch33: gcc32-i386-no-default-momit-leaf-frame-pointer.patch
57Patch34: gcc32-i386-pic-label-thunk.patch
58Patch35: gcc32-i386-profile-olfp.patch
7d225235 59Patch36: gcc32-inline-label.patch
7171cd81 60Patch37: gcc32-java-no-rpath.patch
7d225235 61Patch38: gcc32-pr6842.patch
7171cd81 62Patch39: gcc32-sparc-sll1.patch
7d225235 63Patch40: gcc32-test-rh65771.patch
64Patch41: gcc32-test-rotate.patch
65Patch42: gcc32-tls-dwarf2.patch
66Patch43: gcc32-tls.patch
67Patch44: gcc32-tls2.patch
7171cd81 68Patch45: gcc32-tls3.patch
7d225235 69Patch46: gcc32-tls4.patch
70Patch47: gcc32-tls5.patch
2f0c2c00 71BuildRequires: autoconf
b16f0ea0 72BuildRequires: bison
a9e887db 73BuildRequires: fileutils >= 4.0.41
a9e887db
MM
74BuildRequires: gcc
75%{!?_without_ada:BuildRequires: gcc-ada}
2f0c2c00 76BuildRequires: glibc-devel >= 2.2.5-20
a9e887db 77BuildRequires: perl-devel
2f0c2c00
JB
78BuildRequires: texinfo >= 4.1
79BuildRequires: zlib-devel
392239e7 80BuildRequires: gettext-devel
a9e887db
MM
81Requires: binutils >= 2.12.90.0.4
82Requires: cpp = %{GCC_VERSION}
83Requires: libgcc = %{GCC_VERSION}
84Conflicts: glibc-devel < 2.2.5-20
0ca8a31b 85URL: http://gcc.gnu.org/
878e9862 86BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
d1595fb3 87
a9e887db
MM
88%define _slibdir /lib
89
d1595fb3 90%description
8fdeb3b2
JR
91A compiler aimed at integrating all the optimizations and features
92necessary for a high-performance and stable development environment.
d1595fb3 93
94%description -l pl
8fdeb3b2 95