]> git.pld-linux.org Git - packages/gcc.git/blame - gcc.spec
- it's safer to BR+R binutils 2.14 - gcc chooses its features at build time
[packages/gcc.git] / gcc.spec
CommitLineData
a9e887db
MM
1#
2# Conditional build:
56eae24a 3# _without_ada - build without ADA support
83273597 4# _without_java - build without Java support
5# _without_objc - build without objc support
fe11a44a 6
98d8c419 7%define DASHED_SNAP %{nil}
a9e887db 8%define SNAP %(echo %{DASHED_SNAP} | sed -e "s#-##g")
795d4cce 9%define GCC_VERSION 3.3
32a4597e 10%define KSI_VERSION 1.1.0.1567
a9e887db 11
927cf182 12Summary: GNU C Compiler
13Summary(pl): Kompilator C GNU
14Summary(pt_BR): C Compilador GNU (GCC)
8fdeb3b2 15Name: gcc
a9e887db 16Version: %{GCC_VERSION}
7d999963 17Release: 3
927cf182 18Epoch: 5
0ca8a31b 19License: GPL
8fdeb3b2 20Group: Development/Languages
98d8c419 21Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
6eae0bb0 22# Source0-md5: 39147717455d8dba4d43d1b058ea46e2
a9e887db 23Source1: ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
19f60823 24# Source1-md5: 66f07491b44f06928fd95b0e65bb8cd3
e3089c2c 25Source2: http://ep09.kernel.pl/~djrzulf/gcc33/%{name}-non-english-man-pages.tar.bz2
19f60823 26# Source2-md5: 4736f3422ddfb808423b745629acc321
5708664f 27Patch0: %{name}-info.patch
a9e887db 28Patch1: %{name}-paths.patch
83273597 29Patch2: %{name}-nolocalefiles.patch
30Patch3: %{name}-ada-link-new-libgnat.patch
7d999963 31Patch4: %{name}-PR10849.patch
a9e887db 32# -- stolen patches from RH --
3c74150d 33Patch10: gcc32-ada-link.patch
83273597 34Patch11: gcc32-boehm-gc-libs.patch
35Patch12: gcc32-bogus-inline.patch
36Patch13: gcc32-c++-nrv-test.patch
37Patch14: gcc32-c++-tsubst-asm.patch
38Patch15: gcc32-debug-pr7241.patch
39Patch16: gcc32-duplicate-decl.patch
40Patch17: gcc32-dwarf2-pr6381.patch
41Patch18: gcc32-dwarf2-pr6436-test.patch
42Patch19: gcc32-fde-merge-compat.patch
43Patch20: gcc32-i386-memtest-test.patch
44Patch21: gcc32-inline-label.patch
45Patch22: gcc32-java-no-rpath.patch
46Patch23: gcc32-test-rh65771.patch
47Patch24: gcc32-test-rotate.patch
2f0c2c00 48BuildRequires: autoconf
4232ecfa 49BuildRequires: binutils >= 2.14
b16f0ea0 50BuildRequires: bison
a9e887db 51BuildRequires: fileutils >= 4.0.41
a9e887db 52BuildRequires: gcc
56eae24a 53%{!?_without_ada:BuildRequires: gcc-ada}
2f0c2c00 54BuildRequires: glibc-devel >= 2.2.5-20
a9e887db 55BuildRequires: perl-devel
2f0c2c00
JB
56BuildRequires: texinfo >= 4.1
57BuildRequires: zlib-devel
392239e7 58BuildRequires: gettext-devel
4232ecfa 59Requires: binutils >= 2.14
a9e887db
MM
60Requires: cpp = %{GCC_VERSION}
61Requires: libgcc = %{GCC_VERSION}
62Conflicts: glibc-devel < 2.2.5-20
0ca8a31b 63URL: http://gcc.gnu.org/
878e9862 64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
d1595fb3 65
a9e887db
MM
66%define _slibdir /lib
67
d1595fb3 68%description
8fdeb3b2
JR
69A compiler aimed at integrating all the optimizations and features
70necessary for a high-performance and stable development environment.
d1595fb3 71
72%description -l pl
8fdeb3b2 73