]> git.pld-linux.org Git - packages/gcc.git/blame - gcc.spec
- include lib-org-* java stuff, manpage and info for jar and grepjar
[packages/gcc.git] / gcc.spec
CommitLineData
a9e887db
MM
1#
2# Conditional build:
7fae892c 3# _without_ada - build without ADA support
4# _without_java - build without Java support
5# _without_objc - build without objc support
a9e887db 6#
795d4cce 7# TODO:
795d4cce 8# - fix %%files (separate package for libffi ?)
9#
98d8c419 10%define DASHED_SNAP %{nil}
a9e887db 11%define SNAP %(echo %{DASHED_SNAP} | sed -e "s#-##g")
795d4cce 12%define GCC_VERSION 3.3
32a4597e 13%define KSI_VERSION 1.1.0.1567
a9e887db 14
927cf182 15Summary: GNU C Compiler
16Summary(pl): Kompilator C GNU
17Summary(pt_BR): C Compilador GNU (GCC)
8fdeb3b2 18Name: gcc
a9e887db 19Version: %{GCC_VERSION}
94803eca 20Release: 0.2
927cf182 21Epoch: 5
0ca8a31b 22License: GPL
8fdeb3b2 23Group: Development/Languages
98d8c419 24Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
a9e887db 25Source1: ftp://ftp.pld.org.pl/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
1328be86 26Source2: %{name}-non-english-man-pages.tar.bz2
5708664f 27Patch0: %{name}-info.patch
a9e887db
MM
28Patch1: %{name}-paths.patch
29Patch2: %{name}-ada-no-addr2line.patch
30Patch3: %{name}-ada-no-prefix.o.patch
31Patch4: %{name}-nolocalefiles.patch
2c24b267 32Patch5: %{name}-gcc-page.c.patch
5708664f 33Patch6: %{name}-ada-link-new-libgnat.patch
a9e887db 34# -- stolen patches from RH --
3c74150d 35Patch10: gcc32-ada-link.patch
a9e887db
MM
36Patch16: gcc32-boehm-gc-libs.patch
37Patch17: gcc32-bogus-inline.patch
38Patch18: gcc32-c++-nrv-test.patch
7171cd81 39Patch20: gcc32-c++-tsubst-asm.patch
40Patch21: gcc32-cfg-eh.patch
41Patch22: gcc32-debug-pr7241.patch
d7fb7839 42
7171cd81 43Patch24: gcc32-duplicate-decl.patch
7d225235 44Patch25: gcc32-dwarf2-pr6381.patch
7171cd81 45Patch26: gcc32-dwarf2-pr6436-test.patch
7d225235 46Patch27: gcc32-fde-merge-compat.patch
3b79bdf4 47
7171cd81 48Patch31: gcc32-i386-default-momit-leaf-frame-pointer.patch
7d225235 49Patch32: gcc32-i386-memtest-test.patch
7171cd81 50Patch33: gcc32-i386-no-default-momit-leaf-frame-pointer.patch
51Patch34: gcc32-i386-pic-label-thunk.patch
7d225235 52Patch36: gcc32-inline-label.patch
7171cd81 53Patch37: gcc32-java-no-rpath.patch
7d225235 54Patch40: gcc32-test-rh65771.patch
55Patch41: gcc32-test-rotate.patch
2f0c2c00 56BuildRequires: autoconf
b16f0ea0 57BuildRequires: bison
a9e887db 58BuildRequires: fileutils >= 4.0.41
a9e887db
MM
59BuildRequires: gcc
60%{!?_without_ada:BuildRequires: gcc-ada}
2f0c2c00 61BuildRequires: glibc-devel >= 2.2.5-20
a9e887db 62BuildRequires: perl-devel
2f0c2c00
JB
63BuildRequires: texinfo >= 4.1
64BuildRequires: zlib-devel
392239e7 65BuildRequires: gettext-devel
a9e887db
MM
66Requires: binutils >= 2.12.90.0.4
67Requires: cpp = %{GCC_VERSION}
68Requires: libgcc = %{GCC_VERSION}
69Conflicts: glibc-devel < 2.2.5-20
0ca8a31b 70URL: http://gcc.gnu.org/
878e9862 71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
d1595fb3 72
a9e887db
MM
73%define _slibdir /lib
74
d1595fb3 75%description
8fdeb3b2
JR
76A compiler aimed at integrating all the optimizations and features
77necessary for a high-performance and stable development environment.
d1595fb3 78
79%description -l pl
8fdeb3b2 80