]> git.pld-linux.org Git - packages/gcc.git/blame - gcc.spec
- pr22533 ada patch updated, cosmetics, release 0.2.
[packages/gcc.git] / gcc.spec
CommitLineData
a9e887db 1#
8a9bb03c
JB
2# TODO:
3# - http://gcc.gnu.org/PR11203 (inline-asm)
8a9bb03c
JB
4# - http://gcc.gnu.org/PR20128 (ice with mudflap + profile generate)
5#
a9e887db 6# Conditional build:
b4e5a90f 7%bcond_without ada # build without ADA support
ee2977fa 8%bcond_without cxx # build without C++ support
1a1d3d91 9%bcond_without fortran # build without Fortran support
b4e5a90f 10%bcond_without java # build without Java support
7d320b70
PS
11%bcond_without objc # build without Objective-C support
12%bcond_without objcxx # build without Objective-C++ support
1a1d3d91
PS
13%bcond_with multilib # build with multilib support (it needs glibc[32&64]-devel)
14%bcond_without profiling # build without profiling
15%bcond_without bootstrap # omit 3-stage bootstrap
c48dab66 16%bcond_with tests # torture gcc
1a1d3d91 17
8aa8455e
PS
18# debuginfo not needed for devel snaps.
19%define _enable_debug_packages 0
20
d75833e2
PS
21%if %{with multilib}
22# the latest chrpath(64) can't handle 32-bit binaries :/
23%define _noautochrpath .*/lib/.*\\.so.*
24%endif
25
ee2977fa
PS
26%if %{without cxx}
27%undefine with_java
28%undefine with_objcxx
29%endif
30
c3de157e 31%if %{without objc}
7d320b70
PS
32%undefine with_objcxx
33%endif
34
c3de157e
PS
35%if %{without bootstrap}
36%undefine with_profiling
37%endif
38
ae0daccd 39%ifnarch %{x8664} ppc64 s390x sparc64
23d7249a
JB
40%undefine with_multilib
41%endif
1a1d3d91 42
ae2e17eb 43Summary: GNU Compiler Collection: the C compiler and shared files
8a9bb03c 44