]> git.pld-linux.org Git - packages/gcc.git/blame - gcc.spec
- added bcond for gcc(ada) prov bootstrap on Ac builders
[packages/gcc.git] / gcc.spec
CommitLineData
a9e887db
MM
1#
2# Conditional build:
15eab706
JB
3# _without_ada - build without ADA support
4# _without_java - build without Java support
5# _without_objc - build without objc support
6# _with_bootstrap - don't BR gcc(ada) (temporary for Ac upgrade bootstrap)
7# _with_pp - build with ProPolice
8#
98d8c419 9%define DASHED_SNAP %{nil}
a9e887db 10%define SNAP %(echo %{DASHED_SNAP} | sed -e "s#-##g")
e763db28 11%define GCC_VERSION 3.3.2
32a4597e 12%define KSI_VERSION 1.1.0.1567
a9e887db 13
927cf182 14Summary: GNU C Compiler
15Summary(pl): Kompilator C GNU
16Summary(pt_BR): C Compilador GNU (GCC)
8fdeb3b2 17Name: gcc
a9e887db 18Version: %{GCC_VERSION}
e763db28 19Release: 0.1
927cf182 20Epoch: 5
0ca8a31b 21License: GPL
8fdeb3b2 22Group: Development/Languages
98d8c419 23Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/%{name}-%{GCC_VERSION}.tar.bz2
e763db28 24# Source0-md5: 65999f654102f5438ac8562d13a6eced
9d31815f 25Source1: ftp://ftp.pld-linux.org/people/malekith/ksi/ksi-%{KSI_VERSION}.tar.gz
3a178bac 26# Source1-md5: 66f07491b44f06928fd95b0e65bb8cd3
e3089c2c 27Source2: http://ep09.kernel.pl/~djrzulf/gcc33/%{name}-non-english-man-pages.tar.bz2
e763db28 28# Source2-md5: 4736f3422ddfb808423b745629acc321
5708664f 29Patch0: %{name}-info.patch
a9e887db 30Patch1: %{name}-paths.patch
83273597 31Patch2: %{name}-nolocalefiles.patch
32Patch3: %{name}-ada-link-new-libgnat.patch
a9e887db 33# -- stolen patches from RH --
3c74150d 34Patch10: gcc32-ada-link.patch
83273597 35Patch11: gcc32-boehm-gc-libs.patch
36Patch12: gcc32-bogus-inline.patch
37Patch13: gcc32-c++-nrv-test.patch
38Patch14: gcc32-c++-tsubst-asm.patch
39Patch15: gcc32-debug-pr7241.patch
40Patch16: gcc32-duplicate-decl.patch
41Patch17: gcc32-dwarf2-pr6381.patch
42Patch18: gcc32-dwarf2-pr6436-test.patch
43Patch19: gcc32-fde-merge-compat.patch
44Patch20: gcc32-i386-memtest-test.patch
45Patch21: gcc32-inline-label.patch
46Patch22: gcc32-java-no-rpath.patch
47Patch23: gcc32-test-rh65771.patch
48Patch24: gcc32-test-rotate.patch
4f39ce17 49Patch25: %{name}-3.3.1-propolice.patch
2f0c2c00 50BuildRequires: autoconf
4232ecfa 51BuildRequires: binutils >= 2.14
b16f0ea0 52BuildRequires: bison
a9e887db 53BuildRequires: fileutils >= 4.0.41
a9e887db 54BuildRequires: gcc
15eab706 55%{!?_without_ada:%{!?_with_bootstrap:BuildRequires: gcc(ada)}}
81f8b21f 56%{!?_without_ada:BuildRequires: gcc-ada}
2f0c2c00 57BuildRequires: glibc-devel >= 2.2.5-20
a9e887db 58BuildRequires: perl-devel
2f0c2c00
JB
59BuildRequires: texinfo >= 4.1
60BuildRequires: zlib-devel
392239e7 61BuildRequires: gettext-devel
4232ecfa 62Requires: binutils >= 2.14
ffb5d40e 63Requires: cpp = %{epoch}:%{GCC_VERSION}
64Requires: libgcc = %{epoch}:%{GCC_VERSION}
81f8b21f 65%{!?_without_ada:Provides: gcc(ada)}
a9e887db 66Conflicts: glibc-devel < 2.2.5-20
0ca8a31b 67URL: http://gcc.gnu.org/
878e9862 68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
d1595fb3 69
a9e887db 70%define _slibdir /lib
be17d23f 71%ifarch sparc64
72%define _slibdir64 /lib64
73%define _libdir /usr/lib
ddfc5fb9 74%define rpmcflags -O2 -mtune=ultrasparc
be17d23f 75%endif
a9e887db 76
d1595fb3 77%description
8fdeb3b2
JR
78A compiler aimed at integrating all the optimizations and features
79necessary for a high-performance and stable development environment.
d1595fb3 80
81%description -l pl
8fdeb3b2 82