]> git.pld-linux.org Git - packages/feathercoin.git/blame - feathercoin.spec
- icu/boost rebuild
[packages/feathercoin.git] / feathercoin.spec
CommitLineData
d71863a9
JB
1# NOTE: "portable wallet" wants BDB 4.8
2#
3# Conditional build:
4%bcond_with ccache # use ccache for building
5%bcond_without gui # Qt5 GUI
6
24d61d02
JB
7Summary: Feathercoin - a peer-to-peer currency
8Summary(pl.UTF-8): Feathercoin - waluta peer-to-peer
0f77417f 9Name: feathercoin
d27150c9 10Version: 0.16.3
dedf1203 11Release: 4
d71863a9
JB
12License: MIT
13Group: Applications/Networking
14#Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15Source0: https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
d27150c9
AM
16# Source0-md5: eaecf6f317091f52fae0eff95ac3b7be
17Patch0: lib.patch
24d61d02 18URL: https://www.feathercoin.com/
d71863a9
JB
19%if %{with gui}
20BuildRequires: Qt5Core-devel >= 5
21BuildRequires: Qt5DBus-devel >= 5
22BuildRequires: Qt5Gui-devel >= 5
23BuildRequires: Qt5Network-devel >= 5
24BuildRequires: Qt5PrintSupport-devel >= 5
25BuildRequires: Qt5Test-devel >= 5
26BuildRequires: Qt5Widgets-devel >= 5
27%endif
28BuildRequires: autoconf >= 2.69
29BuildRequires: automake
0f77417f 30BuildRequires: boost-devel
d71863a9
JB
31%{?with_ccache:BuildRequires: ccache}
32BuildRequires: db-cxx-devel >= 4.8
33BuildRequires: gettext-tools
34%{?with_gui:BuildRequires: libpng-devel}
d27150c9 35BuildRequires: libsecp256k1-devel
d71863a9 36BuildRequires: libstdc++-devel
d27150c9
AM
37BuildRequires: libtool
38BuildRequires: libunivalue-devel
0f77417f
AM
39BuildRequires: miniupnpc-devel >= 1.5
40BuildRequires: openssl-devel
d71863a9
JB
41BuildRequires: pkgconfig
42BuildRequires: protobuf-devel
0f77417f 43BuildRequires: qrencode-devel
d71863a9 44%{?with_gui:BuildRequires: qt5-build >= 5}
d71863a9 45%{?with_gui:BuildRequires: zlib-devel}
d27150c9 46BuildRequires: zxing-cpp-devel
0f77417f
AM
47Requires: perl-base
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
24d61d02
JB
51Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
52central authority issues new money or tracks transactions. These tasks
53are managed collectively by the network.
54
55%description -l pl.UTF-8
56Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
57centralnego urzędu, który emituje nowe pieniądze czy śledzi
58transakcje. Zadania te są obsługiwane zespołowo przez sieć.
0f77417f 59
f6a6bc9a
JB
60%package devel
61Summary: Header file for bitcoinconsensus library
62Summary(pl.UTF-8): Plik nagłówkowy biblioteki bitcoinconsensus
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65Requires: openssl-devel
66Conflicts: bitcoin-devel
67
68%description devel
69Header file for bitcoinconsensus library.
70
71%description devel -l pl.UTF-8
72Plik nagłówkowy biblioteki bitcoinconsensus.
73
74%package static
75Summary: Static bitcoinconsensus library
76Summary(pl.UTF-8): Statyczna biblioteka bitcoinconsensus
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79Conflicts: bitcoin-static
80
81%description static
82Static bitcoinconsensus library.
83
84%description static -l pl.UTF-8
85Statyczna biblioteka bitcoinconsensus.
86
0f77417f
AM
87%package qt
88Summary: Qt-based Feathercoin Wallet
24d61d02 89Summary(pl.UTF-8): Oparty na Qt portfel Feathercoin
0f77417f
AM
90Group: X11/Applications
91
92%description qt
93Qt-based Feathercoin Wallet.
94
24d61d02
JB
95%description qt -l pl.UTF-8
96Oparty na Qt portfel Feathercoin.
97
0f77417f 98%prep
d71863a9
JB
99%setup -q -n Feathercoin-%{version}
100%patch0 -p1
0f77417f
AM
101
102%build
d27150c9
AM
103%{__libtoolize}
104%{__aclocal}
d71863a9
JB
105%{__autoconf}
106%{__autoheader}
107%{__automake}
108# --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
109%configure \
110 --enable-ccache%{!?with_ccache:=no} \
111 --disable-silent-rules \
d27150c9 112 --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
f6a6bc9a 113 --with-incompatible-bdb \
d27150c9 114 --with-system-univalue
0f77417f
AM
115
116%{__make}
117
0f77417f
AM
118%install
119rm -rf $RPM_BUILD_ROOT
0f77417f 120
d71863a9
JB
121%{__make} install \
122 DESTDIR=$RPM_BUILD_ROOT
0f77417f 123
f6a6bc9a
JB
124# obsoleted by pkg-config
125%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
126
127install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
d71863a9 128sed -e 's#bitcoin#feathercoin#g;s#Bitcoin#Feathercoin#g' contrib/debian/bitcoin-qt.desktop > $RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
0f77417f
AM
129sed -e 's#bitcoin#feathercoin#g' contrib/debian/bitcoin-qt.protocol > $RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
f6a6bc9a
JB
134%post -p /sbin/ldconfig
135%postun -p /sbin/ldconfig
d27150c9 136
0f77417f
AM
137%files
138%defattr(644,root,root,755)
d71863a9
JB
139%doc COPYING README.md doc/*.txt contrib/debian/examples/bitcoin.conf
140%attr(755,root,root) %{_bindir}/feathercoin-cli
d27150c9 141%attr(755,root,root) %{_bindir}/feathercoin-tx
0f77417f 142%attr(755,root,root) %{_bindir}/feathercoind
d71863a9 143%{_mandir}/man1/feathercoin-cli.1*
d27150c9 144%{_mandir}/man1/feathercoin-tx.1*
d71863a9 145%{_mandir}/man1/feathercoind.1*
f6a6bc9a 146%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
d27150c9 147%attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
f6a6bc9a
JB
148
149%files devel
150%defattr(644,root,root,755)
151%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
152%{_includedir}/bitcoinconsensus.h
153%{_pkgconfigdir}/libbitcoinconsensus.pc
154
155%files static
156%defattr(644,root,root,755)
157%{_libdir}/libbitcoinconsensus.a
0f77417f
AM
158
159%files qt
160%defattr(644,root,root,755)
161%attr(755,root,root) %{_bindir}/feathercoin-qt
162%{_datadir}/kde4/services/feathercoin-qt.protocol
163%{_desktopdir}/feathercoin-qt.desktop
d71863a9 164%{_mandir}/man1/feathercoin-qt.1*
This page took 0.074763 seconds and 4 git commands to generate.