]> git.pld-linux.org Git - packages/efreet.git/blame - efreet.spec
- updated to 20080813 snap
[packages/efreet.git] / efreet.spec
CommitLineData
d470277b
JB
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
adf62b9b 5%define _snap 20080813
6%define ecore_ver 0.9.9.044
07e33737 7
d470277b
JB
8Summary: freedesktop.org standards implementation for the EFL
9Summary(pl.UTF-8): Implementacja standardów freedesktop.org dla EFL
10Name: efreet
adf62b9b 11Version: 0.5.0.045
12Release: 0.%{_snap}.1
d470277b
JB
13License: BSD
14Group: X11/Libraries
adf62b9b 15Source0: %{name}-%{version}-%{_snap}.tar.bz2
16# Source0-md5: 1625909f41a65cd71648c8b87e33b94a
d470277b 17URL: http://enlightenment.org/p.php?p=about/libs/efreet
93cc5570
JB
18BuildRequires: autoconf >= 2.52
19BuildRequires: automake >= 1.6
d470277b 20# ecore-file; ecore-desktop for tests
07e33737 21BuildRequires: ecore-devel >= %{ecore_ver}
d470277b
JB
22BuildRequires: libtool
23BuildRequires: pkgconfig
24BuildRequires: sed >= 4.0
07e33737 25Requires: ecore-file >= %{ecore_ver}
d470277b
JB
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29Efreet is an implementation of the following specifications from
30freedesktop.org:
31 - Base Directory - Locations for system and user specific desktop
32 configuration files,
33 - Desktop Entries - The metadata associated with the applications
34 installed on a system,
35 - Application Menus - The arrangement of available applications into
36 a hierarchical menu,
37 - Icon Themes - A means of associating icons with various objects on
38 the desktop in a themable fashion.
39
40By following these specifications, Enlightenment 0.17 uses the same
41format for describing application launchers, menus and icon themes as
42the GNOME, KDE and XFCE Desktop Environments. A system must only
43provide a single set of this data for use with any of these desktops.
44
45%description -l pl.UTF-8
46Efreet to implementacja następujących specyfikacji z freedesktop.org:
47 - Base Directory - położenie plików konfiguracyjnych środowiska dla
48 systemu i użytkownika,
49 - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
50 systemie,
51 - Application Menus - uporządkowanie dostępnych aplikacji w menu
52 hierarchiczne,
53 - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
54 w sposób pozwalający na ustawianie motywów.
55
56%package devel
57Summary: Efreet header files
58Summary(pl.UTF-8): Pliki nagłówkowe Efreet
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61# ecore-file
07e33737 62BuildRequires: ecore-devel >= %{ecore_ver}
d470277b
JB
63
64%description devel
65Header files for Efreet.
66
67%description devel -l pl.UTF-8
68Pliki nagłówkowe Efreet.
69
70%package static
71Summary: Static Efreet library
72Summary(pl.UTF-8): Statyczna biblioteka Efreet
73Group: Development/Libraries
74Requires: %{name}-devel = %{version}-%{release}
75
76%description static
77Static Efreet library.
78
79%description static -l pl.UTF-8
80Statyczna biblioteka Efreet.
81
82%prep
adf62b9b 83%setup -q -n %{name}-%{version}-%{_snap}
d470277b
JB
84
85sed -i -e 's/-g -O0//' src/lib/Makefile.am
86
87%build
88%{__libtoolize}
89%{__aclocal} -I m4
90%{__autoconf}
91%{__autoheader}
92%{__automake}
93%configure \
94 %{!?with_static_libs:--disable-static}
95%{__make}
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100%{__make} install \
101 DESTDIR=$RPM_BUILD_ROOT
102
103# just tests
58bc5952
BZ
104rm -f $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
105rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/test
d470277b
JB
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post -p /sbin/ldconfig
111%postun -p /sbin/ldconfig
112
113%files
114%defattr(644,root,root,755)
115%doc AUTHORS COPYING README TODO
93cc5570
JB
116%attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
117%attr(755,root,root) %ghost %{_libdir}/libefreet.so.0
118%attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
119%attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.0
adf62b9b 120%attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.0
d470277b
JB
122
123%files devel
124%defattr(644,root,root,755)
93cc5570
JB
125%attr(755,root,root) %{_libdir}/libefreet.so
126%attr(755,root,root) %{_libdir}/libefreet_mime.so
adf62b9b 127%attr(755,root,root) %{_libdir}/libefreet_trash.so
93cc5570
JB
128%{_libdir}/libefreet.la
129%{_libdir}/libefreet_mime.la
adf62b9b 130%{_libdir}/libefreet_trash.la
d470277b 131%{_includedir}/efreet
93cc5570
JB
132%{_pkgconfigdir}/efreet.pc
133%{_pkgconfigdir}/efreet-mime.pc
adf62b9b 134%{_pkgconfigdir}/efreet-trash.pc
d470277b
JB
135
136%if %{with static_libs}
137%files static
138%defattr(644,root,root,755)
93cc5570
JB
139%{_libdir}/libefreet.a
140%{_libdir}/libefreet_mime.a
adf62b9b 141%{_libdir}/libefreet_trash.a
d470277b 142%endif
This page took 0.096884 seconds and 4 git commands to generate.