]> git.pld-linux.org Git - packages/efreet.git/blame - efreet.spec
- R: eina not eina-devel; rel 3
[packages/efreet.git] / efreet.spec
CommitLineData
d470277b
JB
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
173d24b3
JB
5%define ecore_ver 1.1.0
6%define eina_ver 1.1.0
7%define eet_ver 1.5.0
07e33737 8
d470277b
JB
9Summary: freedesktop.org standards implementation for the EFL
10Summary(pl.UTF-8): Implementacja standardów freedesktop.org dla EFL
11Name: efreet
173d24b3 12Version: 1.1.0
8e8b1b65 13Release: 3
04827781 14License: BSD
d470277b 15Group: X11/Libraries
863f344e 16Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
173d24b3 17# Source0-md5: 286b7d66ede62c87f4effef938c2ee7e
9bd7b500 18URL: http://trac.enlightenment.org/e/wiki/Efreet
93cc5570
JB
19BuildRequires: autoconf >= 2.52
20BuildRequires: automake >= 1.6
07e33737 21BuildRequires: ecore-devel >= %{ecore_ver}
04827781
JB
22BuildRequires: ecore-file-devel >= %{ecore_ver}
23BuildRequires: eet-devel >= %{eet_ver}
173d24b3 24BuildRequires: eina-devel >= %{eina_ver}
d470277b 25BuildRequires: libtool
04827781 26BuildRequires: pkgconfig >= 1:0.22
04827781 27Requires: ecore >= %{ecore_ver}
07e33737 28Requires: ecore-file >= %{ecore_ver}
173d24b3 29Requires: eet >= %{eet_ver}
8e8b1b65 30Requires: eina >= %{eina_ver}
d470277b
JB
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Efreet is an implementation of the following specifications from
35freedesktop.org:
36 - Base Directory - Locations for system and user specific desktop
37 configuration files,
38 - Desktop Entries - The metadata associated with the applications
39 installed on a system,
40 - Application Menus - The arrangement of available applications into
41 a hierarchical menu,
42 - Icon Themes - A means of associating icons with various objects on
43 the desktop in a themable fashion.
44
45By following these specifications, Enlightenment 0.17 uses the same
46format for describing application launchers, menus and icon themes as
47the GNOME, KDE and XFCE Desktop Environments. A system must only
48provide a single set of this data for use with any of these desktops.
49
50%description -l pl.UTF-8
51Efreet to implementacja następujących specyfikacji z freedesktop.org:
52 - Base Directory - położenie plików konfiguracyjnych środowiska dla
53 systemu i użytkownika,
54 - Desktop Entries - metadane związane z aplikacjami zainstalowanymi w
55 systemie,
56 - Application Menus - uporządkowanie dostępnych aplikacji w menu
57 hierarchiczne,
58 - Icon Themes - sposób wiązania ikon z różnymi obiektami w środowisku
59 w sposób pozwalający na ustawianie motywów.
60
61%package devel
62Summary: Efreet header files
63Summary(pl.UTF-8): Pliki nagłówkowe Efreet
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
04827781
JB
66Requires: ecore-devel >= %{ecore_ver}
67Requires: ecore-file-devel >= %{ecore_ver}
68Requires: eet-devel >= %{eet_ver}
173d24b3 69Requires: eina-devel >= %{eina_ver}
d470277b
JB
70
71%description devel
72Header files for Efreet.
73
74%description devel -l pl.UTF-8
75Pliki nagłówkowe Efreet.
76
77%package static
78Summary: Static Efreet library
79Summary(pl.UTF-8): Statyczna biblioteka Efreet
80Group: Development/Libraries
81Requires: %{name}-devel = %{version}-%{release}
82
83%description static
84Static Efreet library.
85
86%description static -l pl.UTF-8
87Statyczna biblioteka Efreet.
88
89%prep
863f344e 90%setup -q
d470277b 91
d470277b
JB
92%build
93%{__libtoolize}
94%{__aclocal} -I m4
95%{__autoconf}
96%{__autoheader}
97%{__automake}
98%configure \
04827781 99 --disable-silent-rules \
d470277b 100 %{!?with_static_libs:--disable-static}
04827781 101%{__make}
d470277b
JB
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
108
109# just tests
04827781
JB
110%{__rm} $RPM_BUILD_ROOT%{_bindir}/efreet_{alloc,menu_alloc,test,spec_test,cache_test}
111%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/test
d470277b
JB
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%files
120%defattr(644,root,root,755)
173d24b3
JB
121%doc AUTHORS COPYING ChangeLog NEWS README TODO
122%attr(755,root,root) %{_bindir}/efreet_icon_cache_dump
04827781
JB
123%attr(755,root,root) %{_libdir}/libefreet.so.*.*.*
124%attr(755,root,root) %ghost %{_libdir}/libefreet.so.1
125%attr(755,root,root) %{_libdir}/libefreet_mime.so.*.*.*
126%attr(755,root,root) %ghost %{_libdir}/libefreet_mime.so.1
127%attr(755,root,root) %{_libdir}/libefreet_trash.so.*.*.*
128%attr(755,root,root) %ghost %{_libdir}/libefreet_trash.so.1
129%dir %{_libdir}/efreet
130%attr(755,root,root) %{_libdir}/efreet/efreet_desktop_cache_create
173d24b3 131%attr(755,root,root) %{_libdir}/efreet/efreet_icon_cache_create
d470277b
JB
132
133%files devel
134%defattr(644,root,root,755)
93cc5570
JB
135%attr(755,root,root) %{_libdir}/libefreet.so
136%attr(755,root,root) %{_libdir}/libefreet_mime.so
adf62b9b 137%attr(755,root,root) %{_libdir}/libefreet_trash.so
93cc5570
JB
138%{_libdir}/libefreet.la
139%{_libdir}/libefreet_mime.la
adf62b9b 140%{_libdir}/libefreet_trash.la
04827781 141%{_includedir}/efreet-1
93cc5570
JB
142%{_pkgconfigdir}/efreet.pc
143%{_pkgconfigdir}/efreet-mime.pc
adf62b9b 144%{_pkgconfigdir}/efreet-trash.pc
d470277b
JB
145
146%if %{with static_libs}
147%files static
148%defattr(644,root,root,755)
93cc5570
JB
149%{_libdir}/libefreet.a
150%{_libdir}/libefreet_mime.a
adf62b9b 151%{_libdir}/libefreet_trash.a
d470277b 152%endif
This page took 0.093423 seconds and 4 git commands to generate.