]> git.pld-linux.org Git - packages/eet.git/blame - eet.spec
- release 2 (by relup.sh)
[packages/eet.git] / eet.spec
CommitLineData
bbb25e4e 1# NOTE: for versions >= 1.8 see efl.spec
2fb44219
KK
2#
3# Conditional build:
4%bcond_without static_libs # don't build static library
5#
146ac757 6Summary: Library for speedy data storage, retrieval, and compression
9dd89ee4 7Summary(pl.UTF-8): Biblioteka do szybkiego zapisywania, odtwarzania i kompresji danych
231027b5 8Name: eet
baf4560b 9Version: 1.7.9
53c9df2c 10Release: 2
146ac757 11License: BSD
12Group: Libraries
22cba8c0 13Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
baf4560b 14# Source0-md5: cb2ba528bda53014439481d51c7c4427
2893dd8f 15URL: http://trac.enlightenment.org/e/wiki/Eet
98181c2d
JB
16BuildRequires: autoconf >= 2.52
17BuildRequires: automake >= 1.6
baf4560b
JB
18BuildRequires: eina-devel >= 1.7.9
19BuildRequires: gnutls-devel >= 1.7.6
a6e34d2e 20BuildRequires: libgcrypt-devel
146ac757 21BuildRequires: libjpeg-devel
22BuildRequires: libtool
0c57ecba
JB
23BuildRequires: pkgconfig >= 1:0.22
24BuildRequires: sed >= 4.0
146ac757 25BuildRequires: zlib-devel
baf4560b
JB
26Requires: eina >= 1.7.9
27Requires: gnutls >= 1.7.6
146ac757 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Eet is a tiny library designed to write an arbitary set of chunks of
32data to a file and optionally compress each chunk (very much like a
33zip file) and allow fast random-access reading of the file later on.
34It does not do zip as a zip itself has more complexity than is needed,
35and it was much simpler to implement this once here.
36
37It also can encode and decode data structures in memory, as well as
38image data for saving to eet files or sending across the network to
39other machines, or just writing to arbitary files on the system. All
40data is encoded in a platform independant way and can be written and
41read by any architecture.
42
347bfef3
JR
43%description -l pl.UTF-8
44Eet to mała biblioteka zaprojektowana do zapisu dowolnego zbioru
45porcji danych do pliku i opcjonalnej kompresji każdej porcji (podobnie
46do pliku zip) oraz umożliwienia później szybkiego odczytu pliku ze
47swobodnym dostępem. Nie jest to zip, jako że sam zip jest bardziej
48złożony niż trzeba, a było dużo prościej zaimplementować to tak, jak
2760e594
JB
49jest.
50
347bfef3
JR
51Biblioteka może także kodować i dekodować struktury danych w pamięci,
52a także dane obrazów do zapisu do plików eet lub wysyłania po sieci na
53inne maszyny, lub po prostu zapisywania do dowolnych plików w
54systemie. Wszystkie dane są kodowane w sposób niezależny od platformy
55i mogą być zapisywane i odczytywane na dowolnej architekturze.
2760e594 56
146ac757 57%package devel
2760e594 58Summary: Header files for Eet library
9dd89ee4 59Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Eet
146ac757 60Group: Development/Libraries
2760e594 61Requires: %{name} = %{version}-%{release}
baf4560b
JB
62Requires: eina-devel >= 1.7.9
63Requires: gnutls-devel >= 1.7.6
0c57ecba 64Requires: libgcrypt-devel
f6dec708
KK
65Requires: libjpeg-devel
66Requires: zlib-devel
146ac757 67
68%description devel
2760e594
JB
69Header files for Eet library.
70
347bfef3
JR
71%description devel -l pl.UTF-8
72Pliki nagłówkowe biblioteki Eet.
146ac757 73
74%package static
2760e594 75Summary: Static Eet library
9dd89ee4 76Summary(pl.UTF-8): Statyczna biblioteka Eet
146ac757 77Group: Development/Libraries
2760e594 78Requires: %{name}-devel = %{version}-%{release}
146ac757 79
80%description static
2760e594
JB
81Static Eet library.
82
347bfef3 83%description static -l pl.UTF-8
2760e594 84Statyczna biblioteka Eet.
146ac757 85
86%prep
22cba8c0 87%setup -q
146ac757 88
89%build
f2726464 90%{__libtoolize}
a6e34d2e 91%{__aclocal} -I m4
f2726464 92%{__autoconf}
93%{__autoheader}
94%{__automake}
2fb44219 95%configure \
0c57ecba 96 --disable-silent-rules \
2fb44219 97 %{!?with_static_libs:--disable-static}
0c57ecba 98%{__make}
146ac757 99
100%install
101rm -rf $RPM_BUILD_ROOT
2760e594 102
146ac757 103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
105
e41fe325
JB
106install -d $RPM_BUILD_ROOT%{_examplesdir}
107mv -f $RPM_BUILD_ROOT%{_datadir}/eet/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
108
146ac757 109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post -p /sbin/ldconfig
113%postun -p /sbin/ldconfig
114
115%files
116%defattr(644,root,root,755)
231027b5 117%doc AUTHORS COPYING NEWS README
c3e75f65 118%attr(755,root,root) %{_bindir}/eet
4a540096
JB
119%attr(755,root,root) %{_libdir}/libeet.so.*.*.*
120%attr(755,root,root) %ghost %{_libdir}/libeet.so.1
146ac757 121
122%files devel
123%defattr(644,root,root,755)
146ac757 124%attr(755,root,root) %{_libdir}/libeet.so
125%{_libdir}/libeet.la
2ff37400 126%{_includedir}/eet-1
146ac757 127%{_pkgconfigdir}/eet.pc
e41fe325 128%{_examplesdir}/%{name}-%{version}
146ac757 129
2fb44219 130%if %{with static_libs}
146ac757 131%files static
132%defattr(644,root,root,755)
133%{_libdir}/libeet.a
2fb44219 134%endif
This page took 0.112151 seconds and 4 git commands to generate.