]> git.pld-linux.org Git - packages/dnssec-tools.git/blame - dnssec-tools.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/dnssec-tools.git] / dnssec-tools.spec
CommitLineData
bdde702d
JR
1# TODO:
2# - fix linking, it should link with just built, not with system, libs
b8f9ed2a
JB
3#
4# Conditional build:
5%bcond_without qt # Qt-based GUI tools
6#
d29da4dc
JB
7Summary: DNSSEC tools
8Summary(pl.UTF-8): Narzędzia DNSSEC
9Name: dnssec-tools
cfbf727e 10Version: 2.2.3
9bb65c34 11Release: 3
d29da4dc 12License: BSD
e355058c 13Group: Applications/Networking
cfbf727e
AM
14Source0: https://github.com/DNSSEC-Tools/DNSSEC-Tools/archive/dnssec-tools-2.2.3.tar.gz
15# Source0-md5: 235bfa9bf059b2f5502db2877444646b
d29da4dc 16Patch0: %{name}-link.patch
b8f9ed2a 17Patch1: %{name}-qt.patch
cfbf727e 18Patch2: build.patch
d29da4dc
JB
19URL: http://www.dnssec-tools.org/
20BuildRequires: openssl-devel
21BuildRequires: perl-ExtUtils-MakeMaker
22BuildRequires: perl-Net-DNS
23BuildRequires: perl-Net-DNS-SEC
24BuildRequires: perl-TimeDate
25BuildRequires: perl-base
26BuildRequires: perl-devel >= 1:5.8.0
27BuildRequires: rpm-perlprov >= 4.1-13
b8f9ed2a 28%if %{with qt}
42a2d0d0
JB
29BuildRequires: Qt5Core-devel >= 5
30BuildRequires: Qt5Declarative-devel >= 5
31BuildRequires: Qt5Gui-devel >= 5
32BuildRequires: Qt5Network-devel >= 5
33BuildRequires: Qt5Qml-devel >= 5
34BuildRequires: Qt5Quick-devel >= 5
35BuildRequires: Qt5Svg-devel >= 5
36BuildRequires: Qt5Widgets-devel >= 5
37BuildRequires: Qt5Xml-devel >= 5
38BuildRequires: qt5-qmake >= 5
b8f9ed2a 39%endif
d29da4dc
JB
40Requires: %{name}-libs = %{version}-%{release}
41Requires: perl-%{name} = %{version}-%{release}
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45The goal of the DNSSEC-Tools project is to create a set of tools,
46patches, applications, wrappers, extensions, and plugins that will
47help ease the deployment of DNSSEC-related technologies.
48
49%description -l pl.UTF-8
50Celem projektu DNSSEC-Tools jest stworzenie zbioru narzędzi, łatek,
51aplikacji, wrapperów, rozszerzeń i wtyczek pomagających przy wdrażaniu
52technologii związanych z DNSSEC.
53
b8f9ed2a
JB
54%package gui
55Summary: DNSSEC tools with GUI
56Summary(pl.UTF-8): Narzędzia DNSSEC z GUI
57Group: X11/Applications
58Requires: %{name}-libs = %{version}-%{release}
59
60%description gui
61DNSSEC tools with Qt-based GUI: dnssec-check, dnssec-nodes,
62dnssec-system-tray and lookup.
63
64%description gui -l pl.UTF-8
65Narzędzia DNSSEC z opartym na Qt graficznym interfejsem użytkownika:
66dnssec-check, dnssec-nodes, dnssec-system-tray oraz lookup.
67
d29da4dc
JB
68%package libs
69Summary: DNSSEC libraries
70Summary(pl.UTF-8): Biblioteki DNSSEC
71Group: Libraries
72
73%description libs
74DNSSEC libraries.
75
76%description libs -l pl.UTF-8
77Biblioteki DNSSEC.
78
79%package devel
80Summary: Header files for DNSSEC libraries
81Summary(pl.UTF-8): Pliki nagłówkowe bibliotek DNSSEC
82Group: Development/Libraries
83Requires: %{name}-libs = %{version}-%{release}
84Requires: openssl-devel
85
86%description devel
87Header files for DNSSEC libraries.
88
89%description devel -l pl.UTF-8
90Pliki nagłówkowe bibliotek DNSSEC.
91
92%package static
93Summary: Static DNSSEC libraries
94Summary(pl.UTF-8): Statyczne biblioteki DNSSEC
95Group: Development/Libraries
96Requires: %{name}-devel = %{version}-%{release}
97
98%description static
99Static DNSSEC libraries.
100
101%description static -l pl.UTF-8
102Statyczne biblioteki DNSSEC.
103
104%package -n perl-%{name}
105Summary: Perl modules supporting DNSSEC
106Summary(pl.UTF-8): Moduły Perla wspierające DNSSEC
107Group: Development/Languages/Perl
108Requires: %{name}-libs = %{version}-%{release}
109Requires: perl-Net-DNS
110Requires: perl-Net-DNS-SEC
111
112%description -n perl-%{name}
113Perl modules supporting DNSSEC.
114
115%description -n perl-%{name} -l pl.UTF-8
116Moduły Perla wspierające DNSSEC.
117
118%prep
cfbf727e
AM
119%setup -q -n DNSSEC-Tools-dnssec-tools-%{version}
120cd dnssec-tools
d29da4dc 121%patch0 -p1
b8f9ed2a 122%patch1 -p1
af1a5920 123%patch2 -p1
d29da4dc
JB
124
125%build
cfbf727e 126cd dnssec-tools
d29da4dc 127%configure \
42a2d0d0 128 ac_cv_lib_nsl_inet_ntop=no \
d29da4dc
JB
129 --disable-bind-checks \
130 --with-dlv \
131 --with-ipv6 \
132 --with-nsec3 \
133 --with-perl-build-args='INSTALLDIRS=vendor'
9362a249 134%{__make} -j1
d29da4dc 135
b8f9ed2a
JB
136%if %{with qt}
137cd validator/apps
138for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
139 cd $d
42a2d0d0
JB
140 qmake-qt5 \
141 PREFIX=%{_prefix} \
b8f9ed2a
JB
142 QMAKE_CXX="%{__cxx}" \
143 QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}" \
144 QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
145 %{__make}
146 cd ..
147done
148%endif
149
d29da4dc
JB
150%install
151rm -rf $RPM_BUILD_ROOT
cfbf727e 152cd dnssec-tools
d29da4dc
JB
153%{__make} -j1 install \
154 DESTDIR=$RPM_BUILD_ROOT
155
b8f9ed2a
JB
156%if %{with qt}
157for d in dnssec-check dnssec-nodes dnssec-system-tray lookup ; do
158 %{__make} install -C validator/apps/$d \
42a2d0d0 159 DESTDIR=$RPM_BUILD_ROOT \
b8f9ed2a
JB
160 INSTALL_ROOT=$RPM_BUILD_ROOT
161done
42a2d0d0
JB
162
163# omitted from make install
164install -Dp validator/apps/dnssec-check/images/dnssec-check-32x32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/dnssec-check.png
165install -Dp validator/apps/dnssec-check/images/dnssec-check-48x48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/dnssec-check.png
166install -Dp validator/apps/dnssec-check/images/dnssec-check-64x64.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/64x64/apps/dnssec-check.png
167install -Dp validator/apps/dnssec-check/images/dnssec-check-512.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/512x512/apps/dnssec-check.png
168install -Dp validator/apps/dnssec-check/images/dnssec-check.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/dnssec-check.svg
169sed -e 's,^Exec=.*,Exec=%{_bindir}/dnssec-check,' validator/apps/dnssec-check/dnssec-check.desktop >$RPM_BUILD_ROOT%{_desktopdir}/dnssec-check.desktop
b8f9ed2a
JB
170%endif
171
42a2d0d0
JB
172%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DNS/SEC/examples.pl \
173 $RPM_BUILD_ROOT%{_mandir}/man3/Net::DNS::SEC::examples.3pm
d29da4dc 174find $RPM_BUILD_ROOT%{perl_vendorarch}/auto -name .packlist | xargs -r %{__rm}
9362a249 175find $RPM_BUILD_ROOT%{perl_vendorarch} -name '*.pod' | xargs -r %{__rm}
d29da4dc
JB
176
177%clean
178rm -rf $RPM_BUILD_ROOT
179
180%post libs -p /sbin/ldconfig
181%postun libs -p /sbin/ldconfig
182
183%files
184%defattr(644,root,root,755)
cfbf727e 185%doc dnssec-tools/{COPYING,ChangeLog,NEWS,README.md}
d29da4dc
JB
186%attr(755,root,root) %{_bindir}/blinkenlights
187%attr(755,root,root) %{_bindir}/bubbles
421c53e3
JB
188%attr(755,root,root) %{_bindir}/buildrealms
189%attr(755,root,root) %{_bindir}/check-zone-expiration
d29da4dc
JB
190%attr(755,root,root) %{_bindir}/cleanarch
191%attr(755,root,root) %{_bindir}/cleankrf
192%attr(755,root,root) %{_bindir}/convertar
193%attr(755,root,root) %{_bindir}/dnspktflow
194%attr(755,root,root) %{_bindir}/donuts
195%attr(755,root,root) %{_bindir}/donutsd
196%attr(755,root,root) %{_bindir}/drawvalmap
7c2c9caa 197%attr(755,root,root) %{_bindir}/dt-danechk
421c53e3
JB
198%attr(755,root,root) %{_bindir}/dt-getaddr
199%attr(755,root,root) %{_bindir}/dt-gethost
200%attr(755,root,root) %{_bindir}/dt-getname
201%attr(755,root,root) %{_bindir}/dt-getquery
202%attr(755,root,root) %{_bindir}/dt-getrrset
42a2d0d0 203%attr(755,root,root) %{_bindir}/dt-libval_check_conf
421c53e3 204%attr(755,root,root) %{_bindir}/dt-validate
d29da4dc
JB
205%attr(755,root,root) %{_bindir}/dtck
206%attr(755,root,root) %{_bindir}/dtconf
207%attr(755,root,root) %{_bindir}/dtconfchk
208%attr(755,root,root) %{_bindir}/dtdefs
209%attr(755,root,root) %{_bindir}/dtinitconf
421c53e3 210%attr(755,root,root) %{_bindir}/dtrealms
d29da4dc
JB
211%attr(755,root,root) %{_bindir}/expchk
212%attr(755,root,root) %{_bindir}/fixkrf
213%attr(755,root,root) %{_bindir}/genkrf
d29da4dc
JB
214%attr(755,root,root) %{_bindir}/getdnskeys
215%attr(755,root,root) %{_bindir}/getds
421c53e3 216%attr(755,root,root) %{_bindir}/grandvizier
d29da4dc 217%attr(755,root,root) %{_bindir}/keyarch
421c53e3 218%attr(755,root,root) %{_bindir}/keymod
d29da4dc 219%attr(755,root,root) %{_bindir}/krfcheck
d29da4dc
JB
220%attr(755,root,root) %{_bindir}/lights
221%attr(755,root,root) %{_bindir}/lsdnssec
222%attr(755,root,root) %{_bindir}/lskrf
421c53e3 223%attr(755,root,root) %{_bindir}/lsrealm
d29da4dc
JB
224%attr(755,root,root) %{_bindir}/lsroll
225%attr(755,root,root) %{_bindir}/maketestzone
226%attr(755,root,root) %{_bindir}/mapper
421c53e3
JB
227%attr(755,root,root) %{_bindir}/realmchk
228%attr(755,root,root) %{_bindir}/realmctl
229%attr(755,root,root) %{_bindir}/realminit
230%attr(755,root,root) %{_bindir}/realmset
d29da4dc
JB
231%attr(755,root,root) %{_bindir}/rollchk
232%attr(755,root,root) %{_bindir}/rollctl
233%attr(755,root,root) %{_bindir}/rollerd
234%attr(755,root,root) %{_bindir}/rollinit
235%attr(755,root,root) %{_bindir}/rolllog
236%attr(755,root,root) %{_bindir}/rollrec-editor
237%attr(755,root,root) %{_bindir}/rollset
238%attr(755,root,root) %{_bindir}/signset-editor
239%attr(755,root,root) %{_bindir}/tachk
240%attr(755,root,root) %{_bindir}/timetrans
241%attr(755,root,root) %{_bindir}/trustman
d29da4dc
JB
242%attr(755,root,root) %{_bindir}/zonesigner
243%dir %{_sysconfdir}/dnssec-tools
244%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/dnssec-tools.conf
245%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dnssec-tools/validator-testcases
246%{_datadir}/%{name}
247%{_mandir}/man1/blinkenlights.1p*
421c53e3 248%{_mandir}/man1/buildrealms.1p*
d29da4dc 249%{_mandir}/man1/bubbles.1p*
421c53e3 250%{_mandir}/man1/check-zone-expiration.1p*
d29da4dc
JB
251%{_mandir}/man1/cleanarch.1p*
252%{_mandir}/man1/cleankrf.1p*
253%{_mandir}/man1/convertar.1p*
254%{_mandir}/man1/dnspktflow.1p*
255%{_mandir}/man1/dnssec-tools.1*
256%{_mandir}/man1/donuts.1p*
257%{_mandir}/man1/donutsd.1p*
258%{_mandir}/man1/drawvalmap.1p*
42a2d0d0
JB
259%{_mandir}/man1/dt-danechk.1*
260%{_mandir}/man1/dt-libval_check_conf.1*
421c53e3
JB
261%{_mandir}/man1/dt-getaddr.1*
262%{_mandir}/man1/dt-gethost.1*
263%{_mandir}/man1/dt-getname.1*
264%{_mandir}/man1/dt-getquery.1*
265%{_mandir}/man1/dt-getrrset.1*
266%{_mandir}/man1/dt-validate.1*
d29da4dc
JB
267%{_mandir}/man1/dtck.1p*
268%{_mandir}/man1/dtconf.1p*
269%{_mandir}/man1/dtconfchk.1p*
270%{_mandir}/man1/dtdefs.1p*
271%{_mandir}/man1/dtinitconf.1p*
421c53e3 272%{_mandir}/man1/dtrealms.1p*
d29da4dc
JB
273%{_mandir}/man1/expchk.1p*
274%{_mandir}/man1/fixkrf.1p*
275%{_mandir}/man1/genkrf.1p*
d29da4dc
JB
276%{_mandir}/man1/getdnskeys.1p*
277%{_mandir}/man1/getds.1p*
421c53e3 278%{_mandir}/man1/grandvizier.1p*
d29da4dc 279%{_mandir}/man1/keyarch.1p*
421c53e3 280%{_mandir}/man1/keymod.1p*
d29da4dc 281%{_mandir}/man1/krfcheck.1p*
d29da4dc
JB
282%{_mandir}/man1/lights.1p*
283%{_mandir}/man1/lsdnssec.1p*
284%{_mandir}/man1/lskrf.1p*
421c53e3 285%{_mandir}/man1/lsrealm.1p*
d29da4dc
JB
286%{_mandir}/man1/lsroll.1p*
287%{_mandir}/man1/maketestzone.1p*
288%{_mandir}/man1/mapper.1p*
421c53e3
JB
289%{_mandir}/man1/realmchk.1p*
290%{_mandir}/man1/realmctl.1p*
291%{_mandir}/man1/realminit.1p*
292%{_mandir}/man1/realmset.1p*
d29da4dc
JB
293%{_mandir}/man1/rollchk.1p*
294%{_mandir}/man1/rollctl.1p*
295%{_mandir}/man1/rollerd.1p*
296%{_mandir}/man1/rollinit.1p*
297%{_mandir}/man1/rolllog.1p*
298%{_mandir}/man1/rollrec-editor.1p*
299%{_mandir}/man1/rollset.1p*
300%{_mandir}/man1/signset-editor.1p*
301%{_mandir}/man1/tachk.1p*
302%{_mandir}/man1/timetrans.1p*
303%{_mandir}/man1/trustman.1p*
d29da4dc
JB
304%{_mandir}/man1/zonesigner.1p*
305
b8f9ed2a
JB
306%if %{with qt}
307%files gui
308%defattr(644,root,root,755)
309%attr(755,root,root) %{_bindir}/dnssec-check
310%attr(755,root,root) %{_bindir}/dnssec-nodes
311%attr(755,root,root) %{_bindir}/dnssec-system-tray
312%attr(755,root,root) %{_bindir}/lookup
313%{_desktopdir}/dnssec-check.desktop
42a2d0d0 314%{_desktopdir}/dnssec-nodes.desktop
b8f9ed2a
JB
315%{_desktopdir}/lookup.desktop
316%{_iconsdir}/hicolor/48x48/apps/lookup.png
42a2d0d0
JB
317%{_iconsdir}/hicolor/*x*/apps/dnssec-check.png
318%{_iconsdir}/hicolor/scalable/apps/dnssec-check.svg
b8f9ed2a
JB
319%{_pixmapsdir}/lookup.xpm
320%endif
321
d29da4dc
JB
322%files libs
323%defattr(644,root,root,755)
324%attr(755,root,root) %{_libdir}/libsres.so.*.*.*
42a2d0d0 325%attr(755,root,root) %ghost %{_libdir}/libsres.so.15
d29da4dc 326%attr(755,root,root) %{_libdir}/libval-threads.so.*.*.*
42a2d0d0 327%attr(755,root,root) %ghost %{_libdir}/libval-threads.so.15
d29da4dc 328%attr(755,root,root) %{_libdir}/libval_shim.so.*.*.*
42a2d0d0 329%attr(755,root,root) %ghost %{_libdir}/libval_shim.so.15
d29da4dc
JB
330
331%files devel
332%defattr(644,root,root,755)
333%attr(755,root,root) %{_bindir}/libval-config
334%attr(755,root,root) %{_libdir}/libsres.so
335%attr(755,root,root) %{_libdir}/libval-threads.so
336%attr(755,root,root) %{_libdir}/libval_shim.so
337%{_libdir}/libsres.la
338%{_libdir}/libval-threads.la
339%{_libdir}/libval_shim.la
340%{_includedir}/validator
341%{_mandir}/man3/dnsval.conf.3*
342%{_mandir}/man3/dnsval_conf*.3*
343%{_mandir}/man3/libsres.3*
344%{_mandir}/man3/libval.3*
42a2d0d0 345%{_mandir}/man3/libval_async.3*
d29da4dc
JB
346%{_mandir}/man3/libval_shim.3*
347%{_mandir}/man3/p_ac_status.3*
42a2d0d0 348%{_mandir}/man3/p_dane_error.3*
d29da4dc
JB
349%{_mandir}/man3/p_val_status.3*
350%{_mandir}/man3/resolv_conf_*.3*
351%{_mandir}/man3/root_hints_*.3*
352%{_mandir}/man3/val_*.3*
353
354%files static
355%defattr(644,root,root,755)
356%{_libdir}/libsres.a
357%{_libdir}/libval-threads.a
358%{_libdir}/libval_shim.a
359
360%files -n perl-%{name}
361%defattr(644,root,root,755)
bcaa142b
JB
362%dir %{perl_vendorarch}/Net/DNS
363%dir %{perl_vendorarch}/Net/DNS/SEC
364%{perl_vendorarch}/Net/DNS/SEC/Tools
365%{perl_vendorarch}/Net/DNS/SEC/Validator.pm
366%{perl_vendorarch}/Net/DNS/SEC/defines.pl
367%{perl_vendorarch}/Net/DNS/ZoneFile
d29da4dc 368%{perl_vendorarch}/Net/addrinfo.pm
bcaa142b
JB
369%dir %{perl_vendorarch}/auto/Net/DNS
370%dir %{perl_vendorarch}/auto/Net/DNS/SEC
371%{perl_vendorarch}/auto/Net/DNS/SEC/Tools
372%dir %{perl_vendorarch}/auto/Net/DNS/SEC/Validator
373%{perl_vendorarch}/auto/Net/DNS/SEC/Validator/Validator.so
e355058c 374%dir %{perl_vendorarch}/auto/Net/addrinfo
d29da4dc 375%attr(755,root,root) %{perl_vendorarch}/auto/Net/addrinfo/addrinfo.so
0f538594 376%dir %{perl_vendorlib}/Net/DNS/SEC
d29da4dc
JB
377%{perl_vendorlib}/Net/DNS/SEC/Tools
378%{_mandir}/man3/Net::DNS::SEC::Tools::*.3pm*
379%{_mandir}/man3/Net::DNS::SEC::Validator.3pm*
380%{_mandir}/man3/Net::DNS::ZoneFile::Fast.3pm*
381%{_mandir}/man3/Net::addrinfo.3pm*
This page took 0.075725 seconds and 4 git commands to generate.