]> git.pld-linux.org Git - packages/dnf.git/blame - dnf.spec
- pl for -common
[packages/dnf.git] / dnf.spec
CommitLineData
f637201a
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4#
1abae8cd
JR
5%define hawkey_ver 0.59.0
6%define libcomps_ver 0.1.8
7%define libmodulemd_ver 2.9.3
8%define rpm_ver 4.14.0
9
10Summary: Package manager
11Summary(pl.UTF-8): Zarządca pakietów
feb41732 12Name: dnf
1abae8cd 13Version: 4.6.1
b52c09b0 14Release: 5
feb41732 15Group: Base
a1a5f7dd
JB
16# GPL v2+ with GPL v2 and GPL parts; for a breakdown of the licensing, see PACKAGE-LICENSING
17License: GPL v2 (parts on GPL v2+ or GPL)
1abae8cd
JR
18Source0: https://github.com/rpm-software-management/dnf/archive/%{version}/%{name}-%{version}.tar.gz
19# Source0-md5: 21880d44905d6aa67ab6bee1e86380b3
20Patch0: install.patch
70e5df64 21URL: https://github.com/rpm-software-management/dnf
5aa69e21 22BuildRequires: bash-completion-devel
a1a5f7dd 23BuildRequires: cmake >= 2.4
cebdb6a6 24BuildRequires: gettext-tools
1abae8cd
JR
25BuildRequires: python3
26BuildRequires: python3-gpg
27BuildRequires: python3-hawkey >= %{hawkey_ver}
28BuildRequires: python3-libcomps >= %{libcomps_ver}
29BuildRequires: python3-libdnf >= %{hawkey_ver}
30BuildRequires: python3-modules
31BuildRequires: python3-nose
32BuildRequires: python3-rpm >= %{rpm_ver}
a1b662bf 33BuildRequires: libmodulemd >= %{libmodulemd_ver}
feb41732 34BuildRequires: rpmbuild(macros) >= 1.647
1abae8cd 35BuildRequires: rpm-pythonprov
feb41732
ER
36BuildRequires: sed >= 4.0
37BuildRequires: sphinx-pdg
38BuildRequires: systemd-devel
39Requires(post,preun,postun): systemd-units >= 38
1abae8cd
JR
40Requires: python3-gpg
41Requires: python3-hawkey >= %{hawkey_ver}
42Requires: python3-libcomps >= %{libcomps_ver}
43Requires: python3-libdnf >= %{hawkey_ver}
44Requires: python3-rpm
feb41732 45Requires: systemd-units >= 0.38
a1b662bf 46Requires: libmodulemd >= %{libmodulemd_ver}
1abae8cd
JR
47Recommends: deltarpm
48Recommends: python3-dbus
49Recommends: python3-unbound
50Recommends: rpm-plugin-systemd-inhibit
feb41732
ER
51BuildArch: noarch
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54%description
1abae8cd
JR
55Utility that allows users to manage packages on their systems. It
56supports RPMs, modules and comps groups & environments.
feb41732 57
d3326039 58%description -l pl.UTF-8
1abae8cd
JR
59Marzędzie umożliwiające użytkownikom zarządzanie pakietami w systemie.
60
61%package common
62Summary: Common data and configuration files for DNF
c04001b4 63Summary(pl.UTF-8): Wspólne dane i pliki konfiguracyjne dla DNF-a
1abae8cd
JR
64Requires: libreport-filesystem
65
66%description common
67Common data and configuration files for DNF.
d3326039 68
c04001b4
JB
69%description common -l pl.UTF-8
70Wspólne dane i pliki konfiguracyjne dla DNF-a.
71
70e5df64
ER
72%package automatic
73Summary: Alternative CLI to "dnf upgrade" suitable for automatic, regular execution
d3326039 74Summary(pl.UTF-8): Alternatywny interfejs do "dnf upgrade" nadający się do automatycznego wywoływania
70e5df64 75Group: Base
70e5df64
ER
76Requires(post): systemd
77Requires(preun): systemd
78Requires(postun): systemd
d3326039 79Requires: %{name} = %{version}-%{release}
70e5df64
ER
80
81%description automatic
82Alternative CLI to "dnf upgrade" suitable for automatic, regular
83execution.
84
d3326039
JB
85%description automatic -l pl.UTF-8
86Alternatywny interfejs linii poleceń do "dnf upgrade", nadający się do
87automatycznego, regularnego wywoływania.
88
a1a5f7dd
JB
89%package -n bash-completion-dnf
90Summary: Bash completion for dnf command
91Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla polecenia dnf
92Group: Applications/Shells
93Requires: %{name} = %{version}-%{release}
94Requires: bash-completion
95
96%description -n bash-completion-dnf
97Bash completion for dnf command.
98
99%description -n bash-completion-dnf -l pl.UTF-8
100Bashowe uzupełnianie parametrów dla polecenia dnf.
101
1abae8cd
JR
102%package -n yum
103Summary: Package manager
104Summary(pl.UTF-8): Zarządca pakietów
a1a5f7dd 105Requires: %{name} = %{version}-%{release}
1abae8cd
JR
106Recommends: sqlite3
107Conflicts: yum < 3.4.3-505
a1a5f7dd 108
1abae8cd
JR
109%description -n yum
110Utility that allows users to manage packages on their systems. It
111supports RPMs, modules and comps groups & environments.
a1a5f7dd 112
1abae8cd
JR
113%description -n yum -l pl.UTF-8
114Marzędzie umożliwiające użytkownikom zarządzanie pakietami w systemie.
a1a5f7dd 115
feb41732 116%prep
1abae8cd 117%setup -q
38fbb761 118%patch0 -p1
feb41732 119
feb41732 120%build
1abae8cd
JR
121install -d build
122cd build
a1a5f7dd 123%cmake .. \
1abae8cd
JR
124 -DPYTHON_DESIRED:FILEPATH=%{__python3} \
125 -DPYTHON_INSTALL_DIR:PATH=%{py3_sitescriptdir} \
126 -DDNF_VERSION=%{version} \
a1a5f7dd 127 -DSYSTEMD_DIR=%{systemdunitdir}
feb41732
ER
128
129%{__make}
130%{__make} doc-man
131
feb41732
ER
132%install
133rm -rf $RPM_BUILD_ROOT
748413d4 134install -d $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/{vars,aliases.d,plugins,modules.d,modules.defaults.d},yum} \
747eb767 135 -d $RPM_BUILD_ROOT{%{_localstatedir}/log/,%{_var}/cache/dnf} \
748413d4 136 -d $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf-plugins/__pycache__
a1a5f7dd 137
1abae8cd 138%{__make} -C build install \
feb41732
ER
139 DESTDIR=$RPM_BUILD_ROOT
140
1abae8cd 141touch $RPM_BUILD_ROOT%{_localstatedir}/log/%{name}.log
feb41732 142
1abae8cd
JR
143%{__mv} $RPM_BUILD_ROOT%{_bindir}/dnf-3 $RPM_BUILD_ROOT%{_bindir}/dnf
144%{__mv} $RPM_BUILD_ROOT%{_bindir}/dnf-automatic-3 $RPM_BUILD_ROOT%{_bindir}/dnf-automatic
feb41732 145
1abae8cd 146%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{%{name}-strict.conf,aliases.d/zypper.conf}
a1a5f7dd 147
1abae8cd
JR
148# YUM compat layer
149ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/%{name}.conf,yum.conf}
150ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/plugins,yum/pluginconf.d}
151ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/protected.d,yum/protected.d}
152ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/vars,yum/vars}
153ln -s dnf-3 $RPM_BUILD_ROOT%{_bindir}/yum
a1a5f7dd 154
748413d4
JR
155%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf
156%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf
157
1abae8cd 158%find_lang %{name}
feb41732
ER
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163%post
164%systemd_post dnf-makecache.timer
165
166%preun
167%systemd_preun dnf-makecache.timer
168
169%postun
170%systemd_reload
171
70e5df64 172%post automatic
1abae8cd 173%systemd_post dnf-automatic.timer dnf-automatic-download.timer dnf-automatic-install.timer dnf-automatic-notifyonly.timer
70e5df64
ER
174
175%preun automatic
1abae8cd 176%systemd_preun dnf-automatic.timer dnf-automatic-download.timer dnf-automatic-install.timer dnf-automatic-notifyonly.timer
70e5df64
ER
177
178%postun automatic
179%systemd_reload
180
feb41732
ER
181%files -f %{name}.lang
182%defattr(644,root,root,755)
a1a5f7dd 183%doc AUTHORS PACKAGE-LICENSING README.rst
feb41732
ER
184%attr(755,root,root) %{_bindir}/dnf
185%dir %{_sysconfdir}/%{name}
70e5df64
ER
186%dir %{_sysconfdir}/%{name}/plugins
187%dir %{_sysconfdir}/%{name}/protected.d
feb41732 188%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/dnf.conf
70e5df64 189%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/protected.d/dnf.conf
feb41732
ER
190%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/collect_dnf.conf
191%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
1abae8cd
JR
192%{_mandir}/man5/dnf.conf.5*
193%{_mandir}/man5/dnf-transaction-json.5*
194%{_mandir}/man7/dnf.modularity.7*
feb41732 195%{_mandir}/man8/dnf.8*
1abae8cd 196%{_mandir}/man8/yum2dnf.8*
feb41732
ER
197%{systemdunitdir}/dnf-makecache.service
198%{systemdunitdir}/dnf-makecache.timer
1abae8cd
JR
199%{systemdtmpfilesdir}/dnf.conf
200%{py3_sitescriptdir}/dnf
748413d4 201%{py3_sitescriptdir}/dnf-plugins
1abae8cd 202%exclude %{py3_sitescriptdir}/dnf/automatic
747eb767 203%dir %{_var}/cache/dnf
feb41732 204%ghost %{_localstatedir}/log/%{name}.log
70e5df64
ER
205
206%files automatic
207%defattr(644,root,root,755)
208%attr(755,root,root) %{_bindir}/dnf-automatic
209%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/automatic.conf
1abae8cd
JR
210%{_mandir}/man8/dnf-automatic.8*
211%{systemdunitdir}/dnf-automatic-download.service
212%{systemdunitdir}/dnf-automatic-download.timer
213%{systemdunitdir}/dnf-automatic-install.service
214%{systemdunitdir}/dnf-automatic-install.timer
215%{systemdunitdir}/dnf-automatic-notifyonly.service
216%{systemdunitdir}/dnf-automatic-notifyonly.timer
70e5df64
ER
217%{systemdunitdir}/dnf-automatic.service
218%{systemdunitdir}/dnf-automatic.timer
1abae8cd 219%{py3_sitescriptdir}/dnf/automatic
a1a5f7dd
JB
220
221%files -n bash-completion-dnf
222%defattr(644,root,root,755)
5aa69e21 223%{bash_compdir}/dnf
a1a5f7dd 224
1abae8cd 225%files -n yum
a1a5f7dd 226%defattr(644,root,root,755)
1abae8cd
JR
227%attr(755,root,root) %{_bindir}/yum
228%{_sysconfdir}/yum.conf
3524bf68 229%dir %{_sysconfdir}/yum
1abae8cd
JR
230%{_sysconfdir}/yum/pluginconf.d
231%{_sysconfdir}/yum/protected.d
232%{_sysconfdir}/yum/vars
233%{_mandir}/man8/yum.8*
234%{_mandir}/man5/yum.conf.5.*
235%{_mandir}/man8/yum-shell.8*
236%{_mandir}/man1/yum-aliases.1*
237%config(noreplace) %{_sysconfdir}/%{name}/protected.d/yum.conf
This page took 0.092351 seconds and 4 git commands to generate.