]> git.pld-linux.org Git - packages/dnf.git/blame - dnf.spec
rebuild with python 3.10
[packages/dnf.git] / dnf.spec
CommitLineData
f637201a
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4#
1abae8cd
JR
5%define hawkey_ver 0.59.0
6%define libcomps_ver 0.1.8
7%define libmodulemd_ver 2.9.3
8%define rpm_ver 4.14.0
9
10Summary: Package manager
11Summary(pl.UTF-8): Zarządca pakietów
feb41732 12Name: dnf
1abae8cd 13Version: 4.6.1
7dd04169 14Release: 6
feb41732 15Group: Base
a1a5f7dd
JB
16# GPL v2+ with GPL v2 and GPL parts; for a breakdown of the licensing, see PACKAGE-LICENSING
17License: GPL v2 (parts on GPL v2+ or GPL)
1abae8cd
JR
18Source0: https://github.com/rpm-software-management/dnf/archive/%{version}/%{name}-%{version}.tar.gz
19# Source0-md5: 21880d44905d6aa67ab6bee1e86380b3
20Patch0: install.patch
70e5df64 21URL: https://github.com/rpm-software-management/dnf
5aa69e21 22BuildRequires: bash-completion-devel
a1a5f7dd 23BuildRequires: cmake >= 2.4
cebdb6a6 24BuildRequires: gettext-tools
14ed53ae 25BuildRequires: libmodulemd >= %{libmodulemd_ver}
1abae8cd
JR
26BuildRequires: python3
27BuildRequires: python3-gpg
28BuildRequires: python3-hawkey >= %{hawkey_ver}
29BuildRequires: python3-libcomps >= %{libcomps_ver}
30BuildRequires: python3-libdnf >= %{hawkey_ver}
31BuildRequires: python3-modules
32BuildRequires: python3-nose
33BuildRequires: python3-rpm >= %{rpm_ver}
feb41732 34BuildRequires: rpmbuild(macros) >= 1.647
1abae8cd 35BuildRequires: rpm-pythonprov
feb41732
ER
36BuildRequires: sed >= 4.0
37BuildRequires: sphinx-pdg
38BuildRequires: systemd-devel
39Requires(post,preun,postun): systemd-units >= 38
14ed53ae 40Requires: libmodulemd >= %{libmodulemd_ver}
1abae8cd
JR
41Requires: python3-gpg
42Requires: python3-hawkey >= %{hawkey_ver}
43Requires: python3-libcomps >= %{libcomps_ver}
44Requires: python3-libdnf >= %{hawkey_ver}
45Requires: python3-rpm
feb41732 46Requires: systemd-units >= 0.38
1abae8cd
JR
47Recommends: deltarpm
48Recommends: python3-dbus
49Recommends: python3-unbound
50Recommends: rpm-plugin-systemd-inhibit
feb41732
ER
51BuildArch: noarch
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54%description
1abae8cd
JR
55Utility that allows users to manage packages on their systems. It
56supports RPMs, modules and comps groups & environments.
feb41732 57
d3326039 58%description -l pl.UTF-8
1abae8cd
JR
59Marzędzie umożliwiające użytkownikom zarządzanie pakietami w systemie.
60
61%package common
62Summary: Common data and configuration files for DNF
c04001b4 63Summary(pl.UTF-8): Wspólne dane i pliki konfiguracyjne dla DNF-a
14ed53ae 64Group: Base
1abae8cd
JR
65Requires: libreport-filesystem
66
67%description common
68Common data and configuration files for DNF.
d3326039 69
c04001b4
JB
70%description common -l pl.UTF-8
71Wspólne dane i pliki konfiguracyjne dla DNF-a.
72
70e5df64
ER
73%package automatic
74Summary: Alternative CLI to "dnf upgrade" suitable for automatic, regular execution
d3326039 75Summary(pl.UTF-8): Alternatywny interfejs do "dnf upgrade" nadający się do automatycznego wywoływania
70e5df64 76Group: Base
70e5df64
ER
77Requires(post): systemd
78Requires(preun): systemd
79Requires(postun): systemd
d3326039 80Requires: %{name} = %{version}-%{release}
70e5df64
ER
81
82%description automatic
83Alternative CLI to "dnf upgrade" suitable for automatic, regular
84execution.
85
d3326039
JB
86%description automatic -l pl.UTF-8
87Alternatywny interfejs linii poleceń do "dnf upgrade", nadający się do
88automatycznego, regularnego wywoływania.
89
a1a5f7dd
JB
90%package -n bash-completion-dnf
91Summary: Bash completion for dnf command
92Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla polecenia dnf
93Group: Applications/Shells
94Requires: %{name} = %{version}-%{release}
95Requires: bash-completion
96
97%description -n bash-completion-dnf
98Bash completion for dnf command.
99
100%description -n bash-completion-dnf -l pl.UTF-8
101Bashowe uzupełnianie parametrów dla polecenia dnf.
102
1abae8cd 103%package -n yum
3658ab37
JB
104Summary: Yum compatibility layer for DNF
105Summary(pl.UTF-8): Warstwa zgodności z YUM-em dla DNF-a
14ed53ae 106Group: Base
a1a5f7dd 107Requires: %{name} = %{version}-%{release}
1abae8cd
JR
108Recommends: sqlite3
109Conflicts: yum < 3.4.3-505
a1a5f7dd 110
1abae8cd 111%description -n yum
3658ab37 112Yum compatibility layer for DNF.
a1a5f7dd 113
1abae8cd 114%description -n yum -l pl.UTF-8
3658ab37 115Warstwa zgodności z YUM-em dla DNF-a.
a1a5f7dd 116
feb41732 117%prep
1abae8cd 118%setup -q
38fbb761 119%patch0 -p1
feb41732 120
feb41732 121%build
1abae8cd
JR
122install -d build
123cd build
a1a5f7dd 124%cmake .. \
1abae8cd
JR
125 -DPYTHON_DESIRED:FILEPATH=%{__python3} \
126 -DPYTHON_INSTALL_DIR:PATH=%{py3_sitescriptdir} \
127 -DDNF_VERSION=%{version} \
a1a5f7dd 128 -DSYSTEMD_DIR=%{systemdunitdir}
feb41732
ER
129
130%{__make}
131%{__make} doc-man
132
feb41732
ER
133%install
134rm -rf $RPM_BUILD_ROOT
748413d4 135install -d $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/{vars,aliases.d,plugins,modules.d,modules.defaults.d},yum} \
747eb767 136 -d $RPM_BUILD_ROOT{%{_localstatedir}/log/,%{_var}/cache/dnf} \
748413d4 137 -d $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf-plugins/__pycache__
a1a5f7dd 138
1abae8cd 139%{__make} -C build install \
feb41732
ER
140 DESTDIR=$RPM_BUILD_ROOT
141
1abae8cd 142touch $RPM_BUILD_ROOT%{_localstatedir}/log/%{name}.log
feb41732 143
1abae8cd
JR
144%{__mv} $RPM_BUILD_ROOT%{_bindir}/dnf-3 $RPM_BUILD_ROOT%{_bindir}/dnf
145%{__mv} $RPM_BUILD_ROOT%{_bindir}/dnf-automatic-3 $RPM_BUILD_ROOT%{_bindir}/dnf-automatic
feb41732 146
1abae8cd 147%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{%{name}-strict.conf,aliases.d/zypper.conf}
a1a5f7dd 148
1abae8cd
JR
149# YUM compat layer
150ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/%{name}.conf,yum.conf}
151ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/plugins,yum/pluginconf.d}
152ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/protected.d,yum/protected.d}
153ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/vars,yum/vars}
3658ab37 154ln -s dnf $RPM_BUILD_ROOT%{_bindir}/yum
a1a5f7dd 155
748413d4
JR
156%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf
157%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf
158
1abae8cd 159%find_lang %{name}
feb41732
ER
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164%post
165%systemd_post dnf-makecache.timer
166
167%preun
168%systemd_preun dnf-makecache.timer
169
170%postun
171%systemd_reload
172
70e5df64 173%post automatic
1abae8cd 174%systemd_post dnf-automatic.timer dnf-automatic-download.timer dnf-automatic-install.timer dnf-automatic-notifyonly.timer
70e5df64
ER
175
176%preun automatic
1abae8cd 177%systemd_preun dnf-automatic.timer dnf-automatic-download.timer dnf-automatic-install.timer dnf-automatic-notifyonly.timer
70e5df64
ER
178
179%postun automatic
180%systemd_reload
181
feb41732
ER
182%files -f %{name}.lang
183%defattr(644,root,root,755)
a1a5f7dd 184%doc AUTHORS PACKAGE-LICENSING README.rst
feb41732
ER
185%attr(755,root,root) %{_bindir}/dnf
186%dir %{_sysconfdir}/%{name}
70e5df64
ER
187%dir %{_sysconfdir}/%{name}/plugins
188%dir %{_sysconfdir}/%{name}/protected.d
feb41732 189%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/dnf.conf
70e5df64 190%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/protected.d/dnf.conf
feb41732
ER
191%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/collect_dnf.conf
192%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
1abae8cd
JR
193%{_mandir}/man5/dnf.conf.5*
194%{_mandir}/man5/dnf-transaction-json.5*
195%{_mandir}/man7/dnf.modularity.7*
feb41732 196%{_mandir}/man8/dnf.8*
1abae8cd 197%{_mandir}/man8/yum2dnf.8*
feb41732
ER
198%{systemdunitdir}/dnf-makecache.service
199%{systemdunitdir}/dnf-makecache.timer
1abae8cd
JR
200%{systemdtmpfilesdir}/dnf.conf
201%{py3_sitescriptdir}/dnf
748413d4 202%{py3_sitescriptdir}/dnf-plugins
1abae8cd 203%exclude %{py3_sitescriptdir}/dnf/automatic
747eb767 204%dir %{_var}/cache/dnf
feb41732 205%ghost %{_localstatedir}/log/%{name}.log
70e5df64
ER
206
207%files automatic
208%defattr(644,root,root,755)
209%attr(755,root,root) %{_bindir}/dnf-automatic
210%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/automatic.conf
1abae8cd
JR
211%{_mandir}/man8/dnf-automatic.8*
212%{systemdunitdir}/dnf-automatic-download.service
213%{systemdunitdir}/dnf-automatic-download.timer
214%{systemdunitdir}/dnf-automatic-install.service
215%{systemdunitdir}/dnf-automatic-install.timer
216%{systemdunitdir}/dnf-automatic-notifyonly.service
217%{systemdunitdir}/dnf-automatic-notifyonly.timer
70e5df64
ER
218%{systemdunitdir}/dnf-automatic.service
219%{systemdunitdir}/dnf-automatic.timer
1abae8cd 220%{py3_sitescriptdir}/dnf/automatic
a1a5f7dd
JB
221
222%files -n bash-completion-dnf
223%defattr(644,root,root,755)
5aa69e21 224%{bash_compdir}/dnf
a1a5f7dd 225
1abae8cd 226%files -n yum
a1a5f7dd 227%defattr(644,root,root,755)
1abae8cd
JR
228%attr(755,root,root) %{_bindir}/yum
229%{_sysconfdir}/yum.conf
3524bf68 230%dir %{_sysconfdir}/yum
1abae8cd
JR
231%{_sysconfdir}/yum/pluginconf.d
232%{_sysconfdir}/yum/protected.d
233%{_sysconfdir}/yum/vars
e2633179 234%{_mandir}/man1/yum-aliases.1*
1abae8cd 235%{_mandir}/man5/yum.conf.5.*
e2633179 236%{_mandir}/man8/yum.8*
1abae8cd 237%{_mandir}/man8/yum-shell.8*
1abae8cd 238%config(noreplace) %{_sysconfdir}/%{name}/protected.d/yum.conf
This page took 0.117893 seconds and 4 git commands to generate.