]> git.pld-linux.org Git - packages/devscripts.git/blame - devscripts.spec
- release 6 (by relup.sh)
[packages/devscripts.git] / devscripts.spec
CommitLineData
697e766e
ER
1# TODO
2# - bash-completions subpackage
c46be4b9 3# - some junk installed to root: "/devscripts.*"
bbee6e63
ER
4%include /usr/lib/rpm/macros.perl
5Summary: Scripts for Debian Package maintainers
6Name: devscripts
c46be4b9 7Version: 2.15.7
475438a0 8Release: 6
bbee6e63
ER
9License: GPL v2+
10Group: Development
11Source0: http://ftp.debian.org/debian/pool/main/d/devscripts/%{name}_%{version}.tar.xz
c46be4b9 12# Source0-md5: 1655e2c91e42cd48393c65726bc3faa9
bbee6e63 13Patch0: %{name}_docbook.patch
bbee6e63 14Patch1: %{name}_install-layout.patch
bbee6e63 15Patch2: %{name}_install-man.patch
697e766e 16URL: https://packages.debian.org/unstable/admin/devscripts
b6e96f67 17BuildRequires: docbook-dtd42-xml
bbee6e63
ER
18BuildRequires: docbook-style-xsl
19BuildRequires: dpkg
b6e96f67 20BuildRequires: gettext-tools
bbee6e63 21BuildRequires: libxslt
b6e96f67 22BuildRequires: libxslt-progs
bbee6e63
ER
23BuildRequires: perl-DB_File
24BuildRequires: perl-File-DesktopEntry
bbee6e63
ER
25BuildRequires: perl-base
26BuildRequires: perl-libwww
27BuildRequires: perl-modules
b6e96f67 28BuildRequires: pkgconfig
bbee6e63
ER
29BuildRequires: po4a
30BuildRequires: python3-devel
31BuildRequires: python3-setuptools
32BuildRequires: rpm-perlprov >= 4.1-13
b6e96f67 33BuildRequires: rpm-pythonprov
bbee6e63
ER
34BuildRequires: tar >= 1:1.22
35BuildRequires: xz
36# man for manpage-alert
37Requires: %{_bindir}/man
38Requires: checkbashisms = %{version}-%{release}
39#Requires: dpkg-dev
409c9e24 40#Requires: sensible-utils
bbee6e63
ER
41Conflicts: rpmdevtools < 8.4
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45Scripts to make the life of a Debian Package maintainer easier.
46
47%package -n checkbashisms
48Summary: Check shell scripts for common bash-specific contructs
3843500c
ER
49Group: Development
50%if "%{_rpmversion}" >= "5"
51BuildArch: noarch
52%endif
bbee6e63
ER
53
54%description -n checkbashisms
55checkbashisms checks whether a /bin/sh script contains any common
56bash-specific contructs.
57
58%prep
59%setup -q
60%patch0 -p1
61%patch1 -p1
62%patch2 -p1
63
409c9e24
ER
64# PLD package names
65# grep -r 'you must have the.*package installed' .
66%{__sed} -i -e 's/liburi-perl/perl-URI/g' scripts/*.pl
67%{__sed} -i -e 's/liblwp-protocol-https-perl/perl-LWP-Protocol-https/g' scripts/*.pl
68%{__sed} -i -e 's/libtimedate-perl/perl-TimeDate/g' scripts/*.pl
69%{__sed} -i -e 's/libfile-desktopentry-perl/perl-File-DesktopEntry/g' scripts/*.pl
70%{__sed} -i -e 's/libwww-perl/perl-libwww/g' scripts/*.pl
71%{__sed} -i -e 's/libdigest-md5-perl/perl-Digest-MD5/g' scripts/*.pl
72
a2e2d5c7
AM
73# python paths
74%{__sed} -i -e 's#setup.py install #setup.py install --prefix=%{_prefix} --install-purelib=%{py3_sitescriptdir} --install-platlib=%{py3_sitedir} #g' scripts/Makefile
75
bbee6e63
ER
76%build
77# LIBDIR determines where libvfork gets installed, see scripts/Makefile for LIBDIR
78%{__make} \
79 LIBDIR=%{_libdir}/%{name} \
80 CFLAGS="$RPM_OPT_FLAGS" \
81 LDFLAGS="$RPM_LD_FLAGS"
82
83%install
84rm -rf $RPM_BUILD_ROOT
a2e2d5c7
AM
85
86install -d $RPM_BUILD_ROOT%{_bindir}
87
697e766e
ER
88%{__make} install \
89 DESTDIR=$RPM_BUILD_ROOT \
bbee6e63
ER
90 LIBDIR=%{_libdir}/%{name}
91
92# Install docs through %doc
3843500c 93rm -r $RPM_BUILD_ROOT%{_docdir}
bbee6e63
ER
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%files
99%defattr(644,root,root,755)
495db905
ER
100%doc README
101%attr(755,root,root) %{_bindir}/add-patch
102%attr(755,root,root) %{_bindir}/annotate-output
103%attr(755,root,root) %{_bindir}/archpath
104%attr(755,root,root) %{_bindir}/bts
105%attr(755,root,root) %{_bindir}/build-rdeps
106%attr(755,root,root) %{_bindir}/chdist
107%attr(755,root,root) %{_bindir}/cowpoke
108%attr(755,root,root) %{_bindir}/cvs-debi
109%attr(755,root,root) %{_bindir}/cvs-debrelease
110%attr(755,root,root) %{_bindir}/cvs-debuild
111%attr(755,root,root) %{_bindir}/dcmd
112%attr(755,root,root) %{_bindir}/dcontrol
113%attr(755,root,root) %{_bindir}/dd-list
114%attr(755,root,root) %{_bindir}/deb-reversion
115%attr(755,root,root) %{_bindir}/debchange
116%attr(755,root,root) %{_bindir}/debcheckout
117%attr(755,root,root) %{_bindir}/debclean
118%attr(755,root,root) %{_bindir}/debcommit
119%attr(755,root,root) %{_bindir}/debdiff
120%attr(755,root,root) %{_bindir}/debi
121%attr(755,root,root) %{_bindir}/debpkg
122%attr(755,root,root) %{_bindir}/debrelease
123%attr(755,root,root) %{_bindir}/debrsign
124%attr(755,root,root) %{_bindir}/debsign
125%attr(755,root,root) %{_bindir}/debsnap
126%attr(755,root,root) %{_bindir}/debuild
127%attr(755,root,root) %{_bindir}/dep3changelog
128%attr(755,root,root) %{_bindir}/desktop2menu
129%attr(755,root,root) %{_bindir}/dget
130%attr(755,root,root) %{_bindir}/diff2patches
131%attr(755,root,root) %{_bindir}/dpkg-depcheck
132%attr(755,root,root) %{_bindir}/dpkg-genbuilddeps
133%attr(755,root,root) %{_bindir}/dscextract
134%attr(755,root,root) %{_bindir}/dscverify
135%attr(755,root,root) %{_bindir}/edit-patch
136%attr(755,root,root) %{_bindir}/getbuildlog
137%attr(755,root,root) %{_bindir}/grep-excuses
138%attr(755,root,root) %{_bindir}/licensecheck
139%attr(755,root,root) %{_bindir}/list-unreleased
140%attr(755,root,root) %{_bindir}/manpage-alert
141%attr(755,root,root) %{_bindir}/mass-bug
142%attr(755,root,root) %{_bindir}/mergechanges
143%attr(755,root,root) %{_bindir}/mk-build-deps
144%attr(755,root,root) %{_bindir}/mk-origtargz
145%attr(755,root,root) %{_bindir}/namecheck
146%attr(755,root,root) %{_bindir}/nmudiff
147%attr(755,root,root) %{_bindir}/origtargz
148%attr(755,root,root) %{_bindir}/plotchangelog
149%attr(755,root,root) %{_bindir}/pts-subscribe
150%attr(755,root,root) %{_bindir}/rc-alert
151%attr(755,root,root) %{_bindir}/rmadison
152%attr(755,root,root) %{_bindir}/sadt
153%attr(755,root,root) %{_bindir}/suspicious-source
154%attr(755,root,root) %{_bindir}/svnpath
155%attr(755,root,root) %{_bindir}/tagpending
156%attr(755,root,root) %{_bindir}/transition-check
157%attr(755,root,root) %{_bindir}/uscan
158%attr(755,root,root) %{_bindir}/uupdate
159%attr(755,root,root) %{_bindir}/what-patch
160%attr(755,root,root) %{_bindir}/who-permits-upload
161%attr(755,root,root) %{_bindir}/who-uploads
162%attr(755,root,root) %{_bindir}/whodepends
163%attr(755,root,root) %{_bindir}/wnpp-alert
164%attr(755,root,root) %{_bindir}/wnpp-check
165%attr(755,root,root) %{_bindir}/wrap-and-sort
166%{_mandir}/man1/add-patch.1
167%{_mandir}/man1/annotate-output.1*
168%{_mandir}/man1/archpath.1*
169%{_mandir}/man1/bts.1*
170%{_mandir}/man1/build-rdeps.1*
171%{_mandir}/man1/chdist.1*
172%{_mandir}/man1/cowpoke.1*
173%{_mandir}/man1/cvs-debc.1*
174%{_mandir}/man1/cvs-debi.1*
175%{_mandir}/man1/cvs-debrelease.1*
176%{_mandir}/man1/cvs-debuild.1*
177%{_mandir}/man1/dcmd.1*
178%{_mandir}/man1/dcontrol.1*
179%{_mandir}/man1/dd-list.1*
180%{_mandir}/man1/deb-reversion.1*
181%{_mandir}/man1/debc.1*
182%{_mandir}/man1/debchange.1*
183%{_mandir}/man1/debcheckout.1*
184%{_mandir}/man1/debclean.1*
185%{_mandir}/man1/debcommit.1*
186%{_mandir}/man1/debdiff.1*
187%{_mandir}/man1/debi.1*
188%{_mandir}/man1/debpkg.1*
189%{_mandir}/man1/debrelease.1*
190%{_mandir}/man1/debrsign.1*
191%{_mandir}/man1/debsign.1*
192%{_mandir}/man1/debsnap.1*
193%{_mandir}/man1/debuild.1*
194%{_mandir}/man1/dep3changelog.1*
195%{_mandir}/man1/desktop2menu.1*
196%{_mandir}/man1/devscripts.1*
197%{_mandir}/man1/dget.1*
198%{_mandir}/man1/diff2patches.1*
199%{_mandir}/man1/dpkg-depcheck.1*
200%{_mandir}/man1/dpkg-genbuilddeps.1*
201%{_mandir}/man1/dscextract.1*
202%{_mandir}/man1/dscverify.1*
203%{_mandir}/man1/edit-patch.1*
204%{_mandir}/man1/getbuildlog.1*
205%{_mandir}/man1/grep-excuses.1*
206%{_mandir}/man1/licensecheck.1*
207%{_mandir}/man1/list-unreleased.1*
208%{_mandir}/man1/manpage-alert.1*
209%{_mandir}/man1/mass-bug.1*
210%{_mandir}/man1/mergechanges.1*
211%{_mandir}/man1/mk-build-deps.1*
212%{_mandir}/man1/mk-origtargz.1*
213%{_mandir}/man1/namecheck.1*
214%{_mandir}/man1/nmudiff.1*
215%{_mandir}/man1/origtargz.1*
216%{_mandir}/man1/plotchangelog.1*
217%{_mandir}/man1/pts-subscribe.1*
218%{_mandir}/man1/rc-alert.1*
219%{_mandir}/man1/rmadison.1*
220%{_mandir}/man1/sadt.1*
221%{_mandir}/man1/suspicious-source.1*
222%{_mandir}/man1/svnpath.1*
223%{_mandir}/man1/tagpending.1*
224%{_mandir}/man1/transition-check.1*
225%{_mandir}/man1/uscan.1*
226%{_mandir}/man1/uupdate.1*
227%{_mandir}/man1/what-patch.1*
228%{_mandir}/man1/who-permits-upload.1*
229%{_mandir}/man1/who-uploads.1*
230%{_mandir}/man1/whodepends.1*
231%{_mandir}/man1/wnpp-alert.1*
232%{_mandir}/man1/wnpp-check.1*
233%{_mandir}/man1/wrap-and-sort.1*
bbee6e63
ER
234%{py3_sitescriptdir}/%{name}
235%{py3_sitescriptdir}/%{name}*.egg-info
236%{_datadir}/%{name}
c46be4b9 237%{perl_vendorlib}/Devscripts
bbee6e63
ER
238
239%files -n checkbashisms
240%defattr(644,root,root,755)
241%attr(755,root,root) %{_bindir}/checkbashisms
242%{_mandir}/man1/checkbashisms.1*
This page took 0.095967 seconds and 4 git commands to generate.