]> git.pld-linux.org Git - packages/dash.git/blame - dash.spec
- avoid copy-pastos
[packages/dash.git] / dash.spec
CommitLineData
d71c985a
ER
1Summary: POSIX-compliant implementation of /bin/sh
2Name: dash
3Version: 0.5.3
4Release: 0.1
5License: GPL v2+
6Group: Applications/Shells
7Source0: http://gondor.apana.org.au/~herbert/dash/files/%{name}-%{version}.tar.gz
8# Source0-md5: 1a3cd6669459be4344ec55ec9d4914f8
9URL: http://gondor.apana.org.au/~herbert/dash/
10BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12%define _bindir /bin
043b23ba 13%define _shell %{_bindir}/%{name}
d71c985a
ER
14
15%description
16DASH is a POSIX-compliant implementation of /bin/sh that aims to be as
17small as possible. It does this without sacrificing speed where
18possible. In fact, it is significantly faster than bash (the GNU
19Bourne-Again SHell) for most tasks.
20
21DASH is a direct descendant of the NetBSD version of ash (the Almquist
22SHell)
23
24%prep
25%setup -q
26
27%build
28%configure
29%{__make}
30
31%install
32rm -rf $RPM_BUILD_ROOT
33
34%{__make} install \
35 DESTDIR=$RPM_BUILD_ROOT
36
37%clean
38rm -rf $RPM_BUILD_ROOT
39
40%post
41if [ ! -f /etc/shells ]; then
42 umask 022
43 echo '%{_shell}' > /etc/shells
44else
45 grep -q '^%{_shell}$' /etc/shells || echo '%{_shell}' >> /etc/shells
46fi
47
48%preun
49if [ "$1" = "0" ]; then
50 %{__sed} -i -e '/^%(echo %{_shell} | sed -e 's,/,\\/,g')$/d' /etc/shells
51fi
52
53%files
54%defattr(644,root,root,755)
55%attr(755,root,root) %{_bindir}/dash
56%{_mandir}/man1/dash.1*
This page took 0.046872 seconds and 4 git commands to generate.