]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
up to 7.71.1
[packages/curl.git] / curl.spec
CommitLineData
8a9e937b 1# TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
195ea5a8
JB
2#
3# Conditional build:
358ad66a
JB
4%bcond_without ssh # SSH support
5%bcond_without ssl # SSL support
6%bcond_with gnutls # GnuTLS instead of OpenSSL
7%bcond_without kerberos5 # Heimdal Kerberos 5 support
8%bcond_without ldap # LDAP support
8424568c 9%bcond_without http2 # HTTP/2.0 support (nghttp2 based)
358ad66a 10%bcond_without metalink # metalink support
de17b215 11%if "%{pld_release}" != "ac"
358ad66a
JB
12%bcond_without ares # c-ares (asynchronous DNS operations) library support
13%bcond_without rtmp # Real Time Media Protocol support
de17b215 14%else
358ad66a
JB
15%bcond_with ares # c-ares (asynchronous DNS operations) library support
16%bcond_with rtmp # Real Time Media Protocol support
de17b215
ER
17%endif
18
f7f276d9 19Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
20Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
24Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 25Name: curl
e37f03dc 26Version: 7.71.1
d1d43e0c 27Release: 1
c091c0ac 28License: MIT-like
5767e1a7 29Group: Applications/Networking
d8be0059 30Source0: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
e37f03dc 31# Source0-md5: b54b386057846ce3edd3584b19741569
d0cec3a8
JB
32Patch0: %{name}-ac.patch
33Patch1: %{name}-krb5flags.patch
4557544f 34URL: http://curl.haxx.se/
c091c0ac 35BuildRequires: autoconf >= 2.57
66cf63f1 36BuildRequires: automake
7c7ffb45 37%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
f73c4120 38%{?with_kerberos5:BuildRequires: heimdal-devel}
8a129a6b 39BuildRequires: libbrotli-devel >= 1.0.0
04f3f89d 40BuildRequires: libidn2-devel
e80259d2
JB
41%{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
42BuildRequires: libpsl-devel
9defadab 43%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 44%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 45BuildRequires: libtool
0f90f9c0 46BuildRequires: nettle-devel
e37f03dc 47%{?with_http2:BuildRequires: nghttp2-devel >= 1.12.0}
588be88f 48%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 49BuildRequires: pkgconfig
de17b215 50BuildRequires: rpm >= 4.4.9-56
838a6eda 51BuildRequires: rpmbuild(macros) >= 1.527
5559a124
AM
52%if %{with ssl}
53%if %{with gnutls}
e37f03dc 54BuildRequires: gnutls-devel >= 3.1.10
5559a124 55%else
549c5328 56BuildRequires: openssl-devel >= 1.0.1
5559a124
AM
57%endif
58%endif
d04a5e91 59BuildRequires: tar >= 1:1.22
6903f0dc 60BuildRequires: zlib-devel
3fb47407 61Requires: %{name}-libs = %{version}-%{release}
cfa95fc0 62Obsoletes: libcurl2
8aa4e5ec 63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 64
65%description
655b91ad 66cURL is a tool for getting files with URL syntax, supporting FTP,
67HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
68POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
69cookies, user+password authentication and a busload of other useful
70tricks. The main use for curl is when you want to get or send files
71automatically to or from a site using one of the supported protocols.
72
73cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74Dict servers, using any of the supported protocols. cURL is designed
75to work without user interaction or any kind of interactivity. cURL
76offers many useful capabilities, like proxy support, user
e566d906 77authentication, FTP upload, HTTP post, and file transfer resume.
81714278 78
d63bcf1b
JR
79%description -l pl.UTF-8
80cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
81HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
82HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 83oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
84użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
85się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
86pliki z/na serwer używając jednego z dostępnych protokołów.
87%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 88
d63bcf1b
JR
89%description -l pt_BR.UTF-8
90Curl é um cliente para baixar/enviar arquivos de/para servidores
91usando um dos protocolos suportados. É projetado para funcionar sem a
92interação do usuário.
1310544e 93
d63bcf1b
JR
94Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
95continuar transferências interrompidas, e mais...
1310544e 96
d63bcf1b
JR
97%description -l ru.UTF-8
98curl - это клиент с множеством поддерживаемых протоколов для получения
99файлов с серверов, спроектированный для работы как в неинтерактивном
100режиме, так и с возможностью диалога с пользователем.
f05b825f 101
d63bcf1b
JR
102curl поддерживает много полезных возможностей, среди которых поддержка
103прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
104POST, восстановление прерванной пересылки и многое другое.
f05b825f 105
d63bcf1b
JR
106curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
107файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
108режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 109
d63bcf1b
JR
110curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
111прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
112в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 113
814b6f7d
JB
114%package libs
115Summary: curl library
ce380d80 116Summary(pl.UTF-8): Biblioteka curl
814b6f7d 117Group: Libraries
de17b215 118%{?with_ares:Requires: c-ares >= 1.7.0}
e37f03dc 119%{?with_gnutls:Requires: gnutls-libs >= 3.1.10}
549c5328 120%{?with_ssh:Requires: libssh2 >= 1.2.8}
e37f03dc 121%{?with_http2:Requires: nghttp2-libs >= 1.12.0}
fddc44fa 122%if %{with ssl} && %{without gnutls}
00b2a6eb 123Requires: libbrotli >= 1.0.0
549c5328 124Requires: openssl >= 1.0.1
fddc44fa 125%endif
dfeb0d8d
PG
126Suggests: ca-certificates
127Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
128
129%description libs
130curl library.
131
d63bcf1b 132%description libs -l pl.UTF-8
814b6f7d
JB
133Biblioteka curl.
134
1f54b511 135%package devel
136Summary: Header files and development documentation for curl library
ce380d80
ER
137Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
138Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
139Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
140Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 141Group: Development/Libraries
3fb47407 142Requires: %{name}-libs = %{version}-%{release}
bd2c841c 143%{?with_ares:Requires: c-ares-devel}
f73c4120 144%{?with_kerberos5:Requires: heimdal-devel}
72fe5a16 145Requires: libbrotli-devel >= 1.0.0
04f3f89d 146Requires: libidn2-devel
e80259d2 147Requires: libpsl-devel
70778617 148%{?with_rtmp:Requires: librtmp-devel}
b83a223e 149%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
e37f03dc 150%{?with_http2:Requires: nghttp2-devel >= 1.12.0}
588be88f 151%{?with_ldap:Requires: openldap-devel}
5559a124
AM
152%if %{with ssl}
153%if %{with gnutls}
e37f03dc 154Requires: gnutls-devel >= 3.1.10
5559a124
AM
155%else
156Requires: openssl-devel >= 0.9.7c
157%endif
158%endif
5e1699d5 159Requires: zlib-devel
cfa95fc0 160Obsoletes: libcurl2-devel
1f54b511 161
162%description devel
163Header files and development documentation for curl library.
164
d63bcf1b
JR
165%description devel -l pl.UTF-8
166Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 167
d63bcf1b
JR
168%description devel -l pt_BR.UTF-8
169Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 170
d63bcf1b
JR
171%description devel -l ru.UTF-8
172Этот пакет содержит файлы, необходимые для разработки программ с
173использованием библиотеки curl.
f05b825f 174
d63bcf1b
JR
175%description devel -l uk.UTF-8
176Цей пакет містить файли, необхідні для розробки програм з
177використанням бібліотеки curl.
f05b825f 178
1f54b511 179%package static
180Summary: Static version of curl library
ce380d80
ER
181Summary(pl.UTF-8): Statyczna wersja biblioteki curl
182Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
183Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
184Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 185Group: Development/Libraries
6e6a5186 186Requires: %{name}-devel = %{version}-%{release}
1f54b511 187
188%description static
d06d2fe1 189Static version of curl library.
1f54b511 190
d63bcf1b 191%description static -l pl.UTF-8
cec38cdf 192Statyczna wersja biblioteki curl.
b73e2a73 193
d63bcf1b
JR
194%description static -l pt_BR.UTF-8
195Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 196
d63bcf1b
JR
197%description static -l ru.UTF-8
198Этот пакет содержит статическую библиотеку для разработки программ с
199использованием библиотеки curl.
f05b825f 200
d63bcf1b
JR
201%description static -l uk.UTF-8
202Цей пакет містить статичну бібліотеку для розробки програм з
203використанням бібліотеки curl.
f05b825f 204
8a62d0ef
AG
205%package -n fish-completion-%{name}
206Summary: Fish completion for curl command
207Summary(pl.UTF-8): Dopełnianie parametrów w fish dla polecenia curl
208Group: Applications/Shells
209Requires: %{name} = %{version}-%{release}
210Requires: fish
211
212%description -n fish-completion-%{name}
213Fish completion for curl command.
214
215%description -n fish-completion-%{name} -l pl.UTF-8
216Dopełnianie parametrów w fish dla polecenia curl.
217
e80259d2
JB
218%package -n zsh-completion-curl
219Summary: ZSH completion for curl command
220Summary(pl.UTF-8): Dopełnianianie parametrów w ZSH dla polecenia curl
221Group: Applications/Shells
222Requires: %{name} = %{version}-%{release}
223Requires: zsh
224
225%description -n zsh-completion-curl
226ZSH completion for curl command.
227
228%description -n zsh-completion-curl -l pl.UTF-8
229Dopełnianianie parametrów w ZSH dla polecenia curl.
230
81714278 231%prep
13caa23a 232%setup -q
d0cec3a8 233%patch0 -p1
d4dc980e 234%patch1 -p1
81714278 235
358ad66a 236%{__rm} m4/lt*.m4 m4/libtool.m4
36cd7270 237
81714278 238%build
c091c0ac 239%{__libtoolize}
03613829 240%{__aclocal} -I m4
d4dc980e
AM
241%{__autoconf}
242%{__autoheader}
c091c0ac 243%{__automake}
e566d906 244%configure \
ef822e11 245 ac_cv_header_gss_h=no \
e80259d2
JB
246 %{__enable_disable ares} \
247 --enable-ipv6 \
248 %{__enable_disable ldap} \
249 %{__enable_disable ldap ldaps} \
250 --disable-silent-rules \
5559a124 251%if %{with ssl}
03613829 252 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 253%if %{with gnutls}
28c87603 254 --with-gnutls --without-ssl \
5559a124
AM
255%else
256 --with-ssl=%{_prefix} \
257%endif
0eee87e5
AM
258%else
259 --without-ssl --without-gnutls \
5559a124 260%endif
8a62d0ef 261 --with-fish-functions-dir=%{fish_compdir} \
838a6eda
JK
262 %{__with_without kerberos5 gssapi %{_prefix}} \
263 %{__with_without metalink libmetalink} \
264 %{__with_without rtmp librtmp} \
265 %{__with_without http2 nghttp2} \
e80259d2 266 %{__with_without ssh libssh2}
a436679a 267
c2167492 268%{__make}
81714278 269
270%install
5767e1a7 271rm -rf $RPM_BUILD_ROOT
56f17d66
AM
272%{__make} install \
273 DESTDIR=$RPM_BUILD_ROOT
274
4f6d4393
JB
275%{__make} -C scripts install \
276 DESTDIR=$RPM_BUILD_ROOT
277
34ca770a 278# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
279[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
280echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 281
81714278 282%clean
283rm -rf $RPM_BUILD_ROOT
81714278 284
3fb47407
ER
285%post libs -p /sbin/ldconfig
286%postun libs -p /sbin/ldconfig
1f54b511 287
81714278 288%files
5767e1a7 289%defattr(644,root,root,755)
d1d43e0c 290%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
c091c0ac 291%attr(755,root,root) %{_bindir}/curl
c091c0ac 292%{_mandir}/man1/curl.1*
1f54b511 293
814b6f7d
JB
294%files libs
295%defattr(644,root,root,755)
296%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 297%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 298
1f54b511 299%files devel
300%defattr(644,root,root,755)
f319ccdb 301%doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
c091c0ac
JB
302%attr(755,root,root) %{_bindir}/curl-config
303%attr(755,root,root) %{_libdir}/libcurl.so
304%{_libdir}/libcurl.la
305%{_includedir}/curl
8ad78925 306%{_pkgconfigdir}/libcurl.pc
1399f3ff 307%{_aclocaldir}/libcurl.m4
c091c0ac 308%{_mandir}/man1/curl-config.1*
b3964ccb
JB
309%{_mandir}/man3/curl_*.3*
310%{_mandir}/man3/libcurl*.3*
0efd10e8 311%{_mandir}/man3/CURLINFO_*.3*
67744768 312%{_mandir}/man3/CURLOPT_*.3*
eb7a78c8 313%{_mandir}/man3/CURLMOPT_*.3*
1f54b511 314
315%files static
316%defattr(644,root,root,755)
c091c0ac 317%{_libdir}/libcurl.a
e80259d2 318
8a62d0ef
AG
319%files -n fish-completion-%{name}
320%defattr(644,root,root,755)
321%{fish_compdir}/%{name}.fish
322
e80259d2
JB
323%files -n zsh-completion-curl
324%defattr(644,root,root,755)
325%{_datadir}/zsh/site-functions/_curl
This page took 0.201148 seconds and 4 git commands to generate.