]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
- cve notes for 7.24.0 (rev 1.204)
[packages/curl.git] / curl.spec
CommitLineData
195ea5a8
JB
1#
2# Conditional build:
120855f9
JB
3%bcond_without ssh # without SSH support
4%bcond_without ssl # without SSL support
f73c4120 5%bcond_without kerberos5 # without Heimdal Kerberos 5 support
588be88f 6%bcond_without ldap # without LDAP support
de17b215
ER
7%if "%{pld_release}" != "ac"
8%bcond_without ares # with c-ares (asynchronous DNS operations) library
9%bcond_without gnutls # use GnuTLS instead of OpenSSL
10%bcond_without rtmp # without Real Time Media Protocol
11%else
12%bcond_with ares # with c-ares (asynchronous DNS operations) library
13%bcond_with gnutls # use GnuTLS instead of OpenSSL
14%bcond_with rtmp # without Real Time Media Protocol
15%endif
16
f7f276d9 17Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
18Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
19Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
20Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
21Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
22Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 23Name: curl
fb9c1b4f 24Version: 7.24.0
456a69d5 25Release: 1
c091c0ac 26License: MIT-like
5767e1a7 27Group: Applications/Networking
0307878f 28Source0: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
fb9c1b4f 29# Source0-md5: 713d7d7cbc5cfaabd785a2ff905096f2
88a42c9f 30Patch0: %{name}-no_strip.patch
d4dc980e 31Patch1: %{name}-ac.patch
bb86f73b 32Patch2: %{name}-pc.patch
ba3cad93 33Patch3: %{name}-krb5flags.patch
de17b215 34Patch4: lib%{name}.fb-changes.diff
7704f3e0 35Patch5: gnutls3.patch
4557544f 36URL: http://curl.haxx.se/
c091c0ac 37BuildRequires: autoconf >= 2.57
66cf63f1 38BuildRequires: automake
7c7ffb45 39%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
f73c4120 40%{?with_kerberos5:BuildRequires: heimdal-devel}
5d94786d 41BuildRequires: libidn-devel >= 0.4.1
9defadab 42%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 43%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 44BuildRequires: libtool
588be88f 45%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 46BuildRequires: pkgconfig
de17b215
ER
47BuildRequires: rpm >= 4.4.9-56
48BuildRequires: rpmbuild(macros) >= 1.453
5559a124
AM
49%if %{with ssl}
50%if %{with gnutls}
51BuildRequires: gnutls-devel
52%else
53BuildRequires: openssl-devel >= 0.9.7d
54%endif
55%endif
d04a5e91 56BuildRequires: tar >= 1:1.22
6903f0dc 57BuildRequires: zlib-devel
3fb47407 58Requires: %{name}-libs = %{version}-%{release}
5d94786d 59Requires: libidn >= 0.4.1
b83a223e 60%{?with_ssh:Requires: libssh2 >= 1.2.8}
cfa95fc0 61Obsoletes: libcurl2
8aa4e5ec 62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 63
64%description
655b91ad 65cURL is a tool for getting files with URL syntax, supporting FTP,
66HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
67POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
68cookies, user+password authentication and a busload of other useful
69tricks. The main use for curl is when you want to get or send files
70automatically to or from a site using one of the supported protocols.
71
72cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
73Dict servers, using any of the supported protocols. cURL is designed
74to work without user interaction or any kind of interactivity. cURL
75offers many useful capabilities, like proxy support, user
e566d906 76authentication, FTP upload, HTTP post, and file transfer resume.
81714278 77
d63bcf1b
JR
78%description -l pl.UTF-8
79cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
80HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
81HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 82oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
83użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
84się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
85pliki z/na serwer używając jednego z dostępnych protokołów.
86%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 87
d63bcf1b
JR
88%description -l pt_BR.UTF-8
89Curl é um cliente para baixar/enviar arquivos de/para servidores
90usando um dos protocolos suportados. É projetado para funcionar sem a
91interação do usuário.
1310544e 92
d63bcf1b
JR
93Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
94continuar transferências interrompidas, e mais...
1310544e 95
d63bcf1b
JR
96%description -l ru.UTF-8
97curl - это клиент с множеством поддерживаемых протоколов для получения
98файлов с серверов, спроектированный для работы как в неинтерактивном
99режиме, так и с возможностью диалога с пользователем.
f05b825f 100
d63bcf1b
JR
101curl поддерживает много полезных возможностей, среди которых поддержка
102прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
103POST, восстановление прерванной пересылки и многое другое.
f05b825f 104
d63bcf1b
JR
105curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
106файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
107режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 108
d63bcf1b
JR
109curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
110прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
111в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 112
814b6f7d
JB
113%package libs
114Summary: curl library
ce380d80 115Summary(pl.UTF-8): Biblioteka curl
814b6f7d 116Group: Libraries
de17b215 117%{?with_ares:Requires: c-ares >= 1.7.0}
dfeb0d8d
PG
118Suggests: ca-certificates
119Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
120
121%description libs
122curl library.
123
d63bcf1b 124%description libs -l pl.UTF-8
814b6f7d
JB
125Biblioteka curl.
126
1f54b511 127%package devel
128Summary: Header files and development documentation for curl library
ce380d80
ER
129Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
130Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
131Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
132Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 133Group: Development/Libraries
3fb47407 134Requires: %{name}-libs = %{version}-%{release}
bd2c841c 135%{?with_ares:Requires: c-ares-devel}
f73c4120 136%{?with_kerberos5:Requires: heimdal-devel}
5d94786d 137Requires: libidn-devel >= 0.4.1
70778617 138%{?with_rtmp:Requires: librtmp-devel}
b83a223e 139%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
588be88f 140%{?with_ldap:Requires: openldap-devel}
5559a124
AM
141%if %{with ssl}
142%if %{with gnutls}
143Requires: gnutls-devel
144%else
145Requires: openssl-devel >= 0.9.7c
146%endif
147%endif
5e1699d5 148Requires: zlib-devel
cfa95fc0 149Obsoletes: libcurl2-devel
1f54b511 150
151%description devel
152Header files and development documentation for curl library.
153
d63bcf1b
JR
154%description devel -l pl.UTF-8
155Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 156
d63bcf1b
JR
157%description devel -l pt_BR.UTF-8
158Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 159
d63bcf1b
JR
160%description devel -l ru.UTF-8
161Этот пакет содержит файлы, необходимые для разработки программ с
162использованием библиотеки curl.
f05b825f 163
d63bcf1b
JR
164%description devel -l uk.UTF-8
165Цей пакет містить файли, необхідні для розробки програм з
166використанням бібліотеки curl.
f05b825f 167
1f54b511 168%package static
169Summary: Static version of curl library
ce380d80
ER
170Summary(pl.UTF-8): Statyczna wersja biblioteki curl
171Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
172Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
173Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 174Group: Development/Libraries
6e6a5186 175Requires: %{name}-devel = %{version}-%{release}
1f54b511 176
177%description static
d06d2fe1 178Static version of curl library.
1f54b511 179
d63bcf1b 180%description static -l pl.UTF-8
cec38cdf 181Statyczna wersja biblioteki curl.
b73e2a73 182
d63bcf1b
JR
183%description static -l pt_BR.UTF-8
184Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 185
d63bcf1b
JR
186%description static -l ru.UTF-8
187Этот пакет содержит статическую библиотеку для разработки программ с
188использованием библиотеки curl.
f05b825f 189
d63bcf1b
JR
190%description static -l uk.UTF-8
191Цей пакет містить статичну бібліотеку для розробки програм з
192використанням бібліотеки curl.
f05b825f 193
81714278 194%prep
13caa23a 195%setup -q
b925d2fe 196%patch0 -p1
d4dc980e 197%patch1 -p1
bb86f73b 198%patch2 -p1
ba3cad93 199%patch3 -p1
3d27ae30 200%patch4 -p1
7704f3e0 201%patch5 -p1
81714278 202
36cd7270
ER
203%{__rm} -v m4/lt*.m4 m4/libtool.m4
204
81714278 205%build
c091c0ac 206%{__libtoolize}
03613829 207%{__aclocal} -I m4
d4dc980e
AM
208%{__autoconf}
209%{__autoheader}
c091c0ac 210%{__automake}
e566d906 211%configure \
ef822e11 212 ac_cv_header_gss_h=no \
5559a124 213%if %{with ssl}
03613829 214 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 215%if %{with gnutls}
28c87603 216 --with-gnutls --without-ssl \
5559a124
AM
217%else
218 --with-ssl=%{_prefix} \
219%endif
220%endif
7d46ac1d 221 %{?with_kerberos5:--with-gssapi=%{_prefix}} \
28c87603
JB
222 %{?with_rtmp:--with-librtmp} \
223 %{?with_ares:--enable-ares} \
588be88f
JK
224 %{?with_ldap:--enable-ldaps} \
225 %{!?with_ldap:--disable-ldap} \
8dd62861 226 --enable-ipv6
a436679a 227
c2167492 228%{__make}
81714278 229
230%install
5767e1a7 231rm -rf $RPM_BUILD_ROOT
e566d906 232
56f17d66
AM
233%{__make} install \
234 DESTDIR=$RPM_BUILD_ROOT
235
34ca770a 236# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
237[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
238echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 239
81714278 240%clean
241rm -rf $RPM_BUILD_ROOT
81714278 242
3fb47407
ER
243%post libs -p /sbin/ldconfig
244%postun libs -p /sbin/ldconfig
1f54b511 245
81714278 246%files
5767e1a7 247%defattr(644,root,root,755)
c091c0ac
JB
248%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
249%attr(755,root,root) %{_bindir}/curl
c091c0ac 250%{_mandir}/man1/curl.1*
1f54b511 251
814b6f7d
JB
252%files libs
253%defattr(644,root,root,755)
254%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 255%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 256
1f54b511 257%files devel
258%defattr(644,root,root,755)
c091c0ac
JB
259%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
260%attr(755,root,root) %{_bindir}/curl-config
261%attr(755,root,root) %{_libdir}/libcurl.so
262%{_libdir}/libcurl.la
263%{_includedir}/curl
8ad78925 264%{_pkgconfigdir}/libcurl.pc
c091c0ac 265%{_mandir}/man1/curl-config.1*
b3964ccb
JB
266%{_mandir}/man3/curl_*.3*
267%{_mandir}/man3/libcurl*.3*
1f54b511 268
269%files static
270%defattr(644,root,root,755)
c091c0ac 271%{_libdir}/libcurl.a
This page took 0.131095 seconds and 4 git commands to generate.