]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
- BR: nettle-devel
[packages/curl.git] / curl.spec
CommitLineData
195ea5a8
JB
1#
2# Conditional build:
120855f9
JB
3%bcond_without ssh # without SSH support
4%bcond_without ssl # without SSL support
f73c4120 5%bcond_without kerberos5 # without Heimdal Kerberos 5 support
588be88f 6%bcond_without ldap # without LDAP support
de17b215
ER
7%if "%{pld_release}" != "ac"
8%bcond_without ares # with c-ares (asynchronous DNS operations) library
9%bcond_without gnutls # use GnuTLS instead of OpenSSL
10%bcond_without rtmp # without Real Time Media Protocol
11%else
12%bcond_with ares # with c-ares (asynchronous DNS operations) library
13%bcond_with gnutls # use GnuTLS instead of OpenSSL
14%bcond_with rtmp # without Real Time Media Protocol
15%endif
16
f7f276d9 17Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
18Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
19Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
20Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
21Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
22Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 23Name: curl
fb9c1b4f 24Version: 7.24.0
456a69d5 25Release: 1
c091c0ac 26License: MIT-like
5767e1a7 27Group: Applications/Networking
0307878f 28Source0: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
fb9c1b4f 29# Source0-md5: 713d7d7cbc5cfaabd785a2ff905096f2
88a42c9f 30Patch0: %{name}-no_strip.patch
d4dc980e 31Patch1: %{name}-ac.patch
bb86f73b 32Patch2: %{name}-pc.patch
ba3cad93 33Patch3: %{name}-krb5flags.patch
de17b215 34Patch4: lib%{name}.fb-changes.diff
7704f3e0 35Patch5: gnutls3.patch
4557544f 36URL: http://curl.haxx.se/
c091c0ac 37BuildRequires: autoconf >= 2.57
66cf63f1 38BuildRequires: automake
7c7ffb45 39%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
f73c4120 40%{?with_kerberos5:BuildRequires: heimdal-devel}
5d94786d 41BuildRequires: libidn-devel >= 0.4.1
9defadab 42%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 43%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 44BuildRequires: libtool
0f90f9c0 45BuildRequires: nettle-devel
588be88f 46%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 47BuildRequires: pkgconfig
de17b215
ER
48BuildRequires: rpm >= 4.4.9-56
49BuildRequires: rpmbuild(macros) >= 1.453
5559a124
AM
50%if %{with ssl}
51%if %{with gnutls}
52BuildRequires: gnutls-devel
53%else
54BuildRequires: openssl-devel >= 0.9.7d
55%endif
56%endif
d04a5e91 57BuildRequires: tar >= 1:1.22
6903f0dc 58BuildRequires: zlib-devel
3fb47407 59Requires: %{name}-libs = %{version}-%{release}
5d94786d 60Requires: libidn >= 0.4.1
b83a223e 61%{?with_ssh:Requires: libssh2 >= 1.2.8}
cfa95fc0 62Obsoletes: libcurl2
8aa4e5ec 63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 64
65%description
655b91ad 66cURL is a tool for getting files with URL syntax, supporting FTP,
67HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
68POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
69cookies, user+password authentication and a busload of other useful
70tricks. The main use for curl is when you want to get or send files
71automatically to or from a site using one of the supported protocols.
72
73cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74Dict servers, using any of the supported protocols. cURL is designed
75to work without user interaction or any kind of interactivity. cURL
76offers many useful capabilities, like proxy support, user
e566d906 77authentication, FTP upload, HTTP post, and file transfer resume.
81714278 78
d63bcf1b
JR
79%description -l pl.UTF-8
80cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
81HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
82HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 83oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
84użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
85się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
86pliki z/na serwer używając jednego z dostępnych protokołów.
87%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 88
d63bcf1b
JR
89%description -l pt_BR.UTF-8
90Curl é um cliente para baixar/enviar arquivos de/para servidores
91usando um dos protocolos suportados. É projetado para funcionar sem a
92interação do usuário.
1310544e 93
d63bcf1b
JR
94Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
95continuar transferências interrompidas, e mais...
1310544e 96
d63bcf1b
JR
97%description -l ru.UTF-8
98curl - это клиент с множеством поддерживаемых протоколов для получения
99файлов с серверов, спроектированный для работы как в неинтерактивном
100режиме, так и с возможностью диалога с пользователем.
f05b825f 101
d63bcf1b
JR
102curl поддерживает много полезных возможностей, среди которых поддержка
103прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
104POST, восстановление прерванной пересылки и многое другое.
f05b825f 105
d63bcf1b
JR
106curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
107файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
108режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 109
d63bcf1b
JR
110curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
111прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
112в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 113
814b6f7d
JB
114%package libs
115Summary: curl library
ce380d80 116Summary(pl.UTF-8): Biblioteka curl
814b6f7d 117Group: Libraries
de17b215 118%{?with_ares:Requires: c-ares >= 1.7.0}
dfeb0d8d
PG
119Suggests: ca-certificates
120Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
121
122%description libs
123curl library.
124
d63bcf1b 125%description libs -l pl.UTF-8
814b6f7d
JB
126Biblioteka curl.
127
1f54b511 128%package devel
129Summary: Header files and development documentation for curl library
ce380d80
ER
130Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
131Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
132Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
133Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 134Group: Development/Libraries
3fb47407 135Requires: %{name}-libs = %{version}-%{release}
bd2c841c 136%{?with_ares:Requires: c-ares-devel}
f73c4120 137%{?with_kerberos5:Requires: heimdal-devel}
5d94786d 138Requires: libidn-devel >= 0.4.1
70778617 139%{?with_rtmp:Requires: librtmp-devel}
b83a223e 140%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
588be88f 141%{?with_ldap:Requires: openldap-devel}
5559a124
AM
142%if %{with ssl}
143%if %{with gnutls}
144Requires: gnutls-devel
145%else
146Requires: openssl-devel >= 0.9.7c
147%endif
148%endif
5e1699d5 149Requires: zlib-devel
cfa95fc0 150Obsoletes: libcurl2-devel
1f54b511 151
152%description devel
153Header files and development documentation for curl library.
154
d63bcf1b
JR
155%description devel -l pl.UTF-8
156Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 157
d63bcf1b
JR
158%description devel -l pt_BR.UTF-8
159Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 160
d63bcf1b
JR
161%description devel -l ru.UTF-8
162Этот пакет содержит файлы, необходимые для разработки программ с
163использованием библиотеки curl.
f05b825f 164
d63bcf1b
JR
165%description devel -l uk.UTF-8
166Цей пакет містить файли, необхідні для розробки програм з
167використанням бібліотеки curl.
f05b825f 168
1f54b511 169%package static
170Summary: Static version of curl library
ce380d80
ER
171Summary(pl.UTF-8): Statyczna wersja biblioteki curl
172Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
173Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
174Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 175Group: Development/Libraries
6e6a5186 176Requires: %{name}-devel = %{version}-%{release}
1f54b511 177
178%description static
d06d2fe1 179Static version of curl library.
1f54b511 180
d63bcf1b 181%description static -l pl.UTF-8
cec38cdf 182Statyczna wersja biblioteki curl.
b73e2a73 183
d63bcf1b
JR
184%description static -l pt_BR.UTF-8
185Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 186
d63bcf1b
JR
187%description static -l ru.UTF-8
188Этот пакет содержит статическую библиотеку для разработки программ с
189использованием библиотеки curl.
f05b825f 190
d63bcf1b
JR
191%description static -l uk.UTF-8
192Цей пакет містить статичну бібліотеку для розробки програм з
193використанням бібліотеки curl.
f05b825f 194
81714278 195%prep
13caa23a 196%setup -q
b925d2fe 197%patch0 -p1
d4dc980e 198%patch1 -p1
bb86f73b 199%patch2 -p1
ba3cad93 200%patch3 -p1
3d27ae30 201%patch4 -p1
7704f3e0 202%patch5 -p1
81714278 203
36cd7270
ER
204%{__rm} -v m4/lt*.m4 m4/libtool.m4
205
81714278 206%build
c091c0ac 207%{__libtoolize}
03613829 208%{__aclocal} -I m4
d4dc980e
AM
209%{__autoconf}
210%{__autoheader}
c091c0ac 211%{__automake}
e566d906 212%configure \
ef822e11 213 ac_cv_header_gss_h=no \
5559a124 214%if %{with ssl}
03613829 215 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 216%if %{with gnutls}
28c87603 217 --with-gnutls --without-ssl \
5559a124
AM
218%else
219 --with-ssl=%{_prefix} \
220%endif
221%endif
7d46ac1d 222 %{?with_kerberos5:--with-gssapi=%{_prefix}} \
28c87603
JB
223 %{?with_rtmp:--with-librtmp} \
224 %{?with_ares:--enable-ares} \
588be88f
JK
225 %{?with_ldap:--enable-ldaps} \
226 %{!?with_ldap:--disable-ldap} \
8dd62861 227 --enable-ipv6
a436679a 228
c2167492 229%{__make}
81714278 230
231%install
5767e1a7 232rm -rf $RPM_BUILD_ROOT
e566d906 233
56f17d66
AM
234%{__make} install \
235 DESTDIR=$RPM_BUILD_ROOT
236
34ca770a 237# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
238[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
239echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 240
81714278 241%clean
242rm -rf $RPM_BUILD_ROOT
81714278 243
3fb47407
ER
244%post libs -p /sbin/ldconfig
245%postun libs -p /sbin/ldconfig
1f54b511 246
81714278 247%files
5767e1a7 248%defattr(644,root,root,755)
c091c0ac
JB
249%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
250%attr(755,root,root) %{_bindir}/curl
c091c0ac 251%{_mandir}/man1/curl.1*
1f54b511 252
814b6f7d
JB
253%files libs
254%defattr(644,root,root,755)
255%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 256%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 257
1f54b511 258%files devel
259%defattr(644,root,root,755)
c091c0ac
JB
260%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
261%attr(755,root,root) %{_bindir}/curl-config
262%attr(755,root,root) %{_libdir}/libcurl.so
263%{_libdir}/libcurl.la
264%{_includedir}/curl
8ad78925 265%{_pkgconfigdir}/libcurl.pc
c091c0ac 266%{_mandir}/man1/curl-config.1*
b3964ccb
JB
267%{_mandir}/man3/curl_*.3*
268%{_mandir}/man3/libcurl*.3*
1f54b511 269
270%files static
271%defattr(644,root,root,755)
c091c0ac 272%{_libdir}/libcurl.a
This page took 0.08591 seconds and 4 git commands to generate.