]> git.pld-linux.org Git - packages/crossmingw32-pangomm.git/blame - crossmingw32-pangomm.spec
remove default stack protector flags
[packages/crossmingw32-pangomm.git] / crossmingw32-pangomm.spec
CommitLineData
d12a0496
JB
1Summary: A C++ interface for pango library - cross MinGW32 version
2Summary(pl.UTF-8): Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32
7ef93766 3Name: crossmingw32-pangomm
accc7186 4Version: 2.28.4
4fe9972e 5Release: 5
7ef93766
JB
6License: LGPL v2+
7Group: Development/Libraries
5e1672ab 8Source0: http://ftp.gnome.org/pub/GNOME/sources/pangomm/2.28/pangomm-%{version}.tar.xz
accc7186 9# Source0-md5: f4fe0905ee56e1ff0205005e61d2a66f
7ef93766
JB
10URL: http://www.gtkmm.org/
11BuildRequires: autoconf >= 2.59
b684277f 12BuildRequires: automake >= 1:1.11
7ef93766
JB
13BuildRequires: crossmingw32-cairomm >= 1.6.3
14BuildRequires: crossmingw32-gcc-c++
d12a0496 15BuildRequires: crossmingw32-glibmm >= 2.22.0
b5bb7627 16BuildRequires: crossmingw32-pango >= 1.24.0
accc7186 17BuildRequires: libtool >= 2:2.0
b775d524 18BuildRequires: mm-common >= 0.9.5
7ef93766 19BuildRequires: pkgconfig >= 1:0.15
b684277f 20BuildRequires: rpmbuild(macros) >= 1.446
5e1672ab
JB
21BuildRequires: tar >= 1:1.22
22BuildRequires: xz
7ef93766 23Requires: crossmingw32-cairomm >= 1.6.3
d02042ea 24Requires: crossmingw32-glibmm >= 2.22.0
b5bb7627 25Requires: crossmingw32-pango >= 1.24.0
7ef93766
JB
26Provides: crossmingw32-gtkmm-pango
27Obsoletes: crossmingw32-gtkmm-pango
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%define no_install_post_strip 1
31
32%define target i386-mingw32
33%define target_platform i386-pc-mingw32
34
35%define _sysprefix /usr
36%define _prefix %{_sysprefix}/%{target}
37%define _libdir %{_prefix}/lib
38%define _pkgconfigdir %{_prefix}/lib/pkgconfig
39%define _dlldir /usr/share/wine/windows/system
40%define __cc %{target}-gcc
41%define __cxx %{target}-g++
42df9968 42%define __pkgconfig_provides %{nil}
0902db15 43%define __pkgconfig_requires %{nil}
7ef93766 44
4fe9972e 45%define _ssp_cflags %{nil}
7ef93766
JB
46%ifnarch %{ix86}
47# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
48%define optflags -O2
49%endif
ab466ace 50# -z options are invalid for mingw linker, most of -f options are Linux-specific
7ef93766 51%define filterout_ld -Wl,-z,.*
ab466ace 52%define filterout_c -f[-a-z0-9=]*
7ef93766
JB
53
54%description
d12a0496 55A C++ interface for pango library - cross MinGW32 version.
7ef93766
JB
56
57%description -l pl.UTF-8
d12a0496 58Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32.
7ef93766
JB
59
60%package static
d12a0496
JB
61Summary: Static pangomm library (cross MinGW32 version)
62Summary(pl.UTF-8): Statyczna biblioteka pangomm (wersja skrośna MinGW32)
7ef93766
JB
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65Provides: crossmingw32-gtkmm-pango-static
66Obsoletes: crossmingw32-gtkmm-pango-static
67
68%description static
d12a0496 69Static pangomm library (cross MinGW32 version).
7ef93766
JB
70
71%description static -l pl.UTF-8
d12a0496 72Statyczna biblioteka pangomm (wersja skrośna MinGW32).
7ef93766
JB
73
74%package dll
75Summary: DLL pangomm library for Windows
76Summary(pl.UTF-8): Biblioteka DLL pangomm dla Windows
77Group: Applications/Emulators
78Requires: crossmingw32-cairomm-dll >= 1.6.3
d02042ea 79Requires: crossmingw32-glibmm-dll >= 2.22.0
b5bb7627 80Requires: crossmingw32-pango-dll >= 1.24.0
7ef93766
JB
81Requires: wine
82Provides: crossmingw32-gtkmm-pango-dll
83Obsoletes: crossmingw32-gtkmm-pango-dll
84
85%description dll
86DLL pangomm library for Windows.
87
88%description dll -l pl.UTF-8
89Biblioteka DLL pangomm dla Windows.
90
91%prep
92%setup -q -n pangomm-%{version}
93
94%build
b684277f 95export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
7ef93766 96%{__libtoolize}
aa1fb165 97%{__aclocal} -I build
7ef93766
JB
98%{__autoconf}
99%{__autoheader}
100%{__automake}
101%configure \
102 --target=%{target} \
103 --host=%{target} \
aa1fb165 104 --disable-documentation \
5a97095e 105 --disable-silent-rules \
7ef93766
JB
106 --enable-static
107
108%{__make}
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113%{__make} install \
114 DESTDIR=$RPM_BUILD_ROOT
115
116install -d $RPM_BUILD_ROOT%{_dlldir}
117mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
118
119%if 0%{!?debug:1}
120%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
121%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
122%endif
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%files
128%defattr(644,root,root,755)
129%doc AUTHORS ChangeLog NEWS README
130%{_libdir}/libpangomm-1.4.dll.a
131%{_libdir}/libpangomm-1.4.la
132%{_libdir}/pangomm-1.4
133%{_includedir}/pangomm-1.4
134%{_pkgconfigdir}/pangomm-1.4.pc
135
136%files static
137%defattr(644,root,root,755)
138%{_libdir}/libpangomm-1.4.a
139
140%files dll
141%defattr(644,root,root,755)
142%{_dlldir}/libpangomm-1.4-*.dll
This page took 0.116792 seconds and 4 git commands to generate.