]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blame - crossmingw32-libsigc++.spec
- updated to 2.2.8
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
CommitLineData
1a9246c6
JB
1Summary: The Typesafe Signal Framework for C++ - MinGW32 cross version
2Summary(pl.UTF-8): Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla MinGW32
67b44d4b
JB
3%define realname libsigc++
4Name: crossmingw32-%{realname}
1a9246c6 5Version: 2.2.8
a656c583 6Release: 1
67b44d4b 7License: LGPL v2.1+
066b4b18 8Group: Development/Libraries
8de0c1f1 9Source0: http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/%{realname}-%{version}.tar.bz2
1a9246c6 10# Source0-md5: 1198425eab9fd605721a278c651b8dd8
dec16728 11URL: http://libsigc.sourceforge.net/
12BuildRequires: autoconf >= 2.59
13BuildRequires: automake >= 1.9
066b4b18 14BuildRequires: crossmingw32-gcc-c++
dec16728 15BuildRequires: libtool
16BuildRequires: m4
1a9246c6 17BuildRequires: mm-common >= 0.7.2
dec16728 18BuildRequires: perl-base
1a9246c6 19BuildRequires: pkgconfig
066b4b18 20Requires: crossmingw32-runtime
dec16728 21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define no_install_post_strip 1
24
25%define target i386-mingw32
26%define target_platform i386-pc-mingw32
dec16728 27
28%define _sysprefix /usr
29%define _prefix %{_sysprefix}/%{target}
6986ab9d
JB
30%define _libdir %{_prefix}/lib
31%define _pkgconfigdir %{_prefix}/lib/pkgconfig
066b4b18 32%define _dlldir /usr/share/wine/windows/system
dec16728 33%define __cc %{target}-gcc
34%define __cxx %{target}-g++
35
96d9454a
JB
36%ifnarch %{ix86}
37# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
38%define optflags -O2
39%endif
40# -z options are invalid for mingw linker
41%define filterout_ld -Wl,-z,.*
42
dec16728 43%description
44This library implements a full callback system for use in widget
45libraries, abstract interfaces, and general programming. Originally
46part of the Gtk-- widget set, libsigc++ is now a seperate library to
47provide for more general use. It is the most complete library of its
48kind with the ablity to connect an abstract callback to a class
49method, function, or function object. It contains adaptor classes for
50connection of dissimilar callbacks and has an ease of use unmatched by
51other C++ callback libraries.
52
1a9246c6 53This package contains cross MinGW32 version.
708b30c2 54
a0719c45
JR
55%description -l pl.UTF-8
56Ta biblioteka jest implementacją pełnego systemu callbacków do
57używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
58ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
59Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
60przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
61łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
62obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
63callbacków.
dec16728 64
1a9246c6 65Ten pakiet zawiera wersję skrośną MinGW32.
708b30c2 66
066b4b18 67%package static
1a9246c6
JB
68Summary: Static libsigc++ library (cross MinGW32 version)
69Summary(pl.UTF-8): Statyczna biblioteka libsigc++ (wersja skrośna MinGW32)
066b4b18
JB
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72
73%description static
1a9246c6 74Static libsigc++ library (cross MinGW32 version).
066b4b18
JB
75
76%description static -l pl.UTF-8
1a9246c6 77Statyczna biblioteka libsigc++ (wersja skrośna MinGW32).
066b4b18
JB
78
79%package dll
80Summary: DLL libsigc++ library for Windows
81Summary(pl.UTF-8): Biblioteka DLL libsigc++ dla Windows
82Group: Applications/Emulators
83Requires: wine
84
85%description dll
86DLL libsigc++ library for Windows.
87
88%description dll -l pl.UTF-8
89Biblioteka DLL libsigc++ dla Windows.
90
dec16728 91%prep
67b44d4b 92%setup -q -n %{realname}-%{version}
dec16728 93
94%build
95%{__libtoolize}
1a9246c6 96%{__aclocal} -I build
dec16728 97%{__autoconf}
98%{__automake}
99%configure \
178e282c 100 --target=%{target} \
101 --host=%{target} \
178e282c 102 --enable-static
103
dec16728 104%{__make} all
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT
111
066b4b18
JB
112install -d $RPM_BUILD_ROOT%{_dlldir}
113mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
114
115%if 0%{!?debug:1}
116%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
117%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
118%endif
119
1a9246c6 120%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{devhelp,doc}
066b4b18 121
dec16728 122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%files
126%defattr(644,root,root,755)
127%doc AUTHORS ChangeLog NEWS README TODO
066b4b18
JB
128%{_libdir}/libsigc-2.0.dll.a
129%{_libdir}/libsigc-2.0.la
130%{_libdir}/sigc++-2.0
723599ec 131%{_includedir}/sigc++-2.0
67b44d4b 132%{_pkgconfigdir}/sigc++-2.0.pc
066b4b18
JB
133
134%files static
135%defattr(644,root,root,755)
136%{_libdir}/libsigc-2.0.a
137
138%files dll
139%defattr(644,root,root,755)
140%{_dlldir}/libsigc-2.0-*.dll
This page took 0.043159 seconds and 4 git commands to generate.