]> git.pld-linux.org Git - packages/crossmingw32-freetype.git/blame - crossmingw32-freetype.spec
- updated to 2.4.11
[packages/crossmingw32-freetype.git] / crossmingw32-freetype.spec
CommitLineData
3294533f 1#
2# Conditional build:
46479e07 3%bcond_without lcd # without LCD subpixel color filtering (Microsoft patents in USA)
1e7243e1 4#
8bddf7fd 5%define realname freetype
7b9bae77
JB
6Summary: TrueType font rasterizer - MinGW32 cross version
7Summary(pl.UTF-8): Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
8bddf7fd 8Name: crossmingw32-%{realname}
1c57a66b 9Version: 2.4.11
3294533f 10Release: 1
b5e35991 11License: GPL v2 or FTL
1e7243e1 12Group: Development/Libraries
46479e07 13Source0: http://downloads.sourceforge.net/freetype/%{realname}-%{version}.tar.bz2
1c57a66b 14# Source0-md5: b93435488942486c8d0ca22e8f768034
3294533f 15URL: http://www.freetype.org/
31924283 16BuildRequires: crossmingw32-bzip2
3c4380bc 17BuildRequires: crossmingw32-gcc
8bddf7fd 18BuildRequires: crossmingw32-zlib >= 1.2.3-2
3294533f 19BuildRequires: python
31924283 20Requires: crossmingw32-bzip2
8bddf7fd 21Requires: crossmingw32-zlib >= 1.2.3-2
3294533f 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%define specflags_ia32 -fomit-frame-pointer
25# see <freetype/internal/ftserv.h>, the real horror
26%define specflags -fno-strict-aliasing
27
28%define no_install_post_strip 1
29
30%define target i386-mingw32
31%define target_platform i386-pc-mingw32
3294533f 32
33%define _sysprefix /usr
34%define _prefix %{_sysprefix}/%{target}
b5aa177c
JB
35%define _libdir %{_prefix}/lib
36%define _pkgconfigdir %{_prefix}/lib/pkgconfig
1e7243e1 37%define _dlldir /usr/share/wine/windows/system
3294533f 38%define __cc %{target}-gcc
39%define __cxx %{target}-g++
40
46479e07
JB
41%ifnarch %{ix86}
42# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43%define optflags -O2
44%endif
45# -z options are invalid for mingw linker
46%define filterout_ld -Wl,-z,.*
47
3294533f 48%description
49The FreeType engine is a free and portable TrueType font rendering
50engine. It has been developed to provide TrueType support to a great
51variety of platforms and environments.
52
53Note that FreeType is a *library*. It is not a font server for your
54favorite platform, even though it was designed to be used in many of
55them. Note also that it is *not* a complete text-rendering library.
56Its purpose is simply to open and manage font files, as well as load,
57hint and render individual glyphs efficiently. You can also see it as
58a "TrueType driver" for a higher-level library, though rendering text
59with it is extremely easy, as demo-ed by the test programs.
60
1e7243e1 61This package contains the cross version for Win32.
3294533f 62
63%description -l pl.UTF-8
64FreeType jest biblioteką służącą do rasteryzacji fontów
65TrueType. Jest to jedynie biblioteka, a nie serwer fontów, chociaż
66została ona zaprojektowana do używania także w takich serwerach.
67Nie jest to też kompletna biblioteka do rasteryzacji tekstu. Jej
68celem jest tylko odczytywanie i zarządzanie plikami z fontami oraz
69wczytywanie i wykonywanie hintingu i rasteryzacji poszczególnych
70glifów. Może być także uważana za "sterownik TrueType" dla
71bibliotek wyższego poziomu, jednak użycie samej biblioteki FreeType
72do rasteryzacji jest bardzo proste, co można zobaczyć w programach
73demonstracyjnych.
74
1e7243e1
JB
75Ten pakiet zawiera wersję skrośną dla Win32.
76
77%package static
7b9bae77
JB
78Summary: Static freetype library (cross MinGW32 version)
79Summary(pl.UTF-8): Statyczna biblioteka freetype (wersja skrośna MinGW32)
1e7243e1
JB
80Group: Development/Libraries
81Requires: %{name} = %{version}-%{release}
82
83%description static
7b9bae77 84Static freetype library (cross MinGW32 version).
1e7243e1
JB
85
86%description static -l pl.UTF-8
7b9bae77 87Statyczna biblioteka freetype (wersja skrośna MinGW32).
1e7243e1
JB
88
89%package dll
90Summary: DLL freetype library for Windows
91Summary(pl.UTF-8): Biblioteka DLL freetype dla Windows
92Group: Applications/Emulators
93Requires: crossmingw32-zlib-dll
94Requires: wine
95
96%description dll
97DLL freetype library for Windows.
98
99%description dll -l pl.UTF-8
100Biblioteka DLL freetype dla Windows.
3294533f 101
102%prep
8bddf7fd 103%setup -q -n %{realname}-%{version}
3294533f 104
105%build
106CFLAGS="%{rpmcflags} \
1c57a66b
JB
107%{?with_lcd:-DFT_CONFIG_OPTION_SUBPIXEL_RENDERING} \
108-DTT_CONFIG_OPTION_SUBPIXEL_HINTING \
109" \
3294533f 110%configure \
3294533f 111 --target=%{target} \
6181c873 112 --build=i686-pc-linux-gnu \
113 --host=%{target} \
114 --enable-shared
3294533f 115
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
3294533f 120
121%{__make} install \
122 DESTDIR=$RPM_BUILD_ROOT
123
1e7243e1 124install -d $RPM_BUILD_ROOT%{_dlldir}
8bddf7fd 125mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
1e7243e1
JB
126
127%if 0%{!?debug:1}
128%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
129%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
130%endif
131
132rm -rf $RPM_BUILD_ROOT%{_datadir}/aclocal
133
3294533f 134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files
138%defattr(644,root,root,755)
0443e0ca 139%doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,TODO,formats.txt,raster.txt}
1e7243e1
JB
140%{_libdir}/libfreetype.dll.a
141%{_libdir}/libfreetype.la
3294533f 142%{_includedir}/freetype2
5bc110d4
JB
143%{_includedir}/ft2build.h
144%{_pkgconfigdir}/freetype2.pc
1e7243e1
JB
145
146%files static
147%defattr(644,root,root,755)
148%{_libdir}/libfreetype.a
149
150%files dll
151%defattr(644,root,root,755)
8bddf7fd 152%{_dlldir}/libfreetype-*.dll
This page took 0.050195 seconds and 4 git commands to generate.