]> git.pld-linux.org Git - packages/crossmingw32-cairo.git/blame - crossmingw32-cairo.spec
- don't use libtool macros namespace
[packages/crossmingw32-cairo.git] / crossmingw32-cairo.spec
CommitLineData
c00b5b7c 1#
2# Conditional build:
3%bcond_with glitz # build with glitz backend
4#
5Summary: Cairo - multi-platform 2D graphics library - cross Mingw32 version
ed706dfc 6Summary(pl.UTF-8): Cairo - wieloplatformowa biblioteka graficzna 2D - skrośna wersja Mingw32
8401d423
JB
7%define realname cairo
8Name: crossmingw32-%{realname}
a41420fa 9Version: 1.4.14
c00b5b7c 10Release: 1
6da4c596 11License: LGPL v2.1 or MPL 1.1
ed706dfc 12Group: Development/Libraries
8401d423 13Source0: http://cairographics.org/releases/%{realname}-%{version}.tar.gz
a41420fa 14# Source0-md5: e8c442ff821c0719a69508fecba9038f
c00b5b7c 15URL: http://cairographics.org/
16BuildRequires: autoconf >= 2.54
17BuildRequires: automake >= 1:1.7
18BuildRequires: crossmingw32-fontconfig
19BuildRequires: crossmingw32-freetype >= 2.1.10
20%{?with_glitz:BuildRequires: crossmingw32-glitz >= 0.5.1}
21BuildRequires: crossmingw32-libpng
c00b5b7c 22BuildRequires: crossmingw32-zlib
23BuildRequires: libtool
36f07f62 24BuildRequires: pkgconfig >= 1:0.15
ed706dfc 25Requires: crossmingw32-fontconfig
c00b5b7c 26Requires: crossmingw32-freetype >= 2.1.10
ed706dfc
JB
27%{?with_glitz:Requires: crossmingw32-glitz >= 0.5.1}
28Requires: crossmingw32-libpng
c00b5b7c 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define no_install_post_strip 1
32
33%define target i386-mingw32
34%define target_platform i386-pc-mingw32
c00b5b7c 35
36%define _sysprefix /usr
37%define _prefix %{_sysprefix}/%{target}
ab6df3fd 38%define _libdir %{_prefix}/lib
c00b5b7c 39%define _pkgconfigdir %{_prefix}/lib/pkgconfig
ed706dfc 40%define _dlldir /usr/share/wine/windows/system
c00b5b7c 41%define __cc %{target}-gcc
42%define __cxx %{target}-g++
43
44%description
45Cairo provides anti-aliased vector-based rendering for X. Paths
46consist of line segments and cubic splines and can be rendered at any
47width with various join and cap styles. All colors may be specified
48with optional translucence (opacity/alpha) and combined using the
49extended Porter/Duff compositing algebra as found in the X Render
50Extension.
51
52Cairo exports a stateful rendering API similar in spirit to the path
53construction, text, and painting operators of PostScript, (with the
54significant addition of translucence in the imaging model). When
55complete, the API is intended to support the complete imaging model of
56PDF 1.4.
57
ed706dfc
JB
58This package contains the cross version for Win32.
59
60%description -l pl.UTF-8
61Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
62Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
63mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
64Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
65(podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
66przy użyciu rozszerzonego algorytmu mieszania Portera-Duffa, który
67można znaleźć w rozszerzeniu X Render.
68
69Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
70konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
71dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
72ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
73
74Ten pakiet zawiera wersję skrośną dla Win32.
75
76%package static
77Summary: Static cairo library (cross mingw32 version)
78Summary(pl.UTF-8): Statyczna biblioteka cairo (wersja skrośna mingw32)
79Group: Development/Libraries
80Requires: %{name} = %{version}-%{release}
81
82%description static
83Static cairo library (cross mingw32 version).
84
85%description static -l pl.UTF-8
86Statyczna biblioteka cairo (wersja skrośna mingw32).
87
88%package dll
89Summary: DLL cairo library for Windows
90Summary(pl.UTF-8): Biblioteka DLL cairo dla Windows
91Group: Applications/Emulators
92Requires: crossmingw32-fontconfig-dll
93Requires: crossmingw32-freetype-dll >= 2.1.10
94%{?with_glitz:Requires: crossmingw32-glitz-dll >= 0.5.1}
95Requires: crossmingw32-libpng-dll
96
97%description dll
98DLL cairo library for Windows.
99
100%description dll -l pl.UTF-8
101Biblioteka DLL cairo dla Windows.
c00b5b7c 102
103%prep
8401d423 104%setup -q -n %{realname}-%{version}
c00b5b7c 105
106%build
36f07f62 107export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
c00b5b7c 108%{__libtoolize}
109%{__aclocal}
110%{__autoheader}
111%{__autoconf}
112%{__automake}
113%configure \
ed706dfc 114 lt_cv_deplibs_check_method=pass_all \
c00b5b7c 115 --target=%{target} \
594215bd 116 --host=%{target} \
594215bd 117 --disable-gtk-doc \
c00b5b7c 118 --disable-xlib \
119 --disable-xlib-render \
594215bd 120 --enable-freetype \
ed706dfc 121 %{?with_glitz:--enable-glitz} \
594215bd 122 --enable-pdf \
123 --enable-png \
124 --enable-ps \
6da4c596
JB
125 --enable-svg \
126 --enable-windows
594215bd 127
c00b5b7c 128%{__make}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132
133%{__make} install \
134 DESTDIR=$RPM_BUILD_ROOT
135
ed706dfc
JB
136install -d $RPM_BUILD_ROOT%{_dlldir}
137mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
138
139%if 0%{!?debug:1}
140%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
141%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
142%endif
143
144rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
145
c00b5b7c 146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%files
150%defattr(644,root,root,755)
151# COPYING contains only notes, not LGPL/MPL texts
152%doc AUTHORS COPYING ChangeLog NEWS README TODO
ed706dfc
JB
153%{_libdir}/libcairo.dll.a
154%{_libdir}/libcairo.la
155%{_includedir}/cairo
6da4c596
JB
156%{_pkgconfigdir}/cairo.pc
157%{_pkgconfigdir}/cairo-ft.pc
158%{_pkgconfigdir}/cairo-pdf.pc
159%{_pkgconfigdir}/cairo-png.pc
160%{_pkgconfigdir}/cairo-ps.pc
161%{_pkgconfigdir}/cairo-svg.pc
162%{_pkgconfigdir}/cairo-win32.pc
ed706dfc
JB
163
164%files static
165%defattr(644,root,root,755)
166%{_libdir}/libcairo.a
167
168%files dll
169%defattr(644,root,root,755)
170%{_dlldir}/libcairo-*.dll
This page took 0.113846 seconds and 4 git commands to generate.