]> git.pld-linux.org Git - packages/crossmingw32-boost.git/blame - crossmingw32-boost.spec
- obsoleted wineprefixcreate replaced
[packages/crossmingw32-boost.git] / crossmingw32-boost.spec
CommitLineData
d97fa3b7
ŁK
1#
2# Conditional build:
3%bcond_with serialization # enable Boost Serialization
4#
28441938 5%define realname boost
3ea966e4
JB
6Summary: The Boost C++ Libraries - MinGW32 cross version
7Summary(pl.UTF-8): Biblioteki C++ "Boost" - wersja skrośna dla MinGW32
28441938 8Name: crossmingw32-%{realname}
3ea966e4 9Version: 1.44.0
670a15d7 10%define fver %(echo %{version} | tr . _)
ff36f437 11Release: 1
28441938 12License: Boost Software License and others
33145f37 13Group: Development/Libraries
3ea966e4
JB
14Source0: http://downloads.sourceforge.net/boost/%{realname}_%{fver}.tar.bz2
15# Source0-md5: f02578f5218f217a9f20e9c30e119c6a
28441938 16URL: http://www.boost.org/
8d134d9a 17BuildRequires: boost-jam >= 3.1.12
a72e6f01 18BuildRequires: crossmingw32-bzip2
28441938 19BuildRequires: crossmingw32-gcc-c++
20BuildRequires: crossmingw32-runtime
21BuildRequires: crossmingw32-w32api
a72e6f01 22BuildRequires: crossmingw32-zlib
d97fa3b7 23%{?with_serialization:BuildRequires: wine-programs}
a72e6f01
ŁK
24Requires: crossmingw32-bzip2
25Requires: crossmingw32-runtime
26Requires: crossmingw32-zlib
28441938 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%define no_install_post_strip 1
30
31%define target i386-mingw32
32%define target_platform i386-pc-mingw32
c66a9041
JB
33
34%define _sysprefix /usr
35%define _prefix %{_sysprefix}/%{target}
36%define _libdir %{_prefix}/lib
37%define _dlldir /usr/share/wine/windows/system
28441938 38
39%define __cc %{target}-gcc
40%define __cxx %{target}-g++
41
c66a9041
JB
42%ifnarch %{ix86}
43# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
28441938 44%define optflags -O2
45%endif
46
47%description
48The Boost web site provides free peer-reviewed portable C++ source
49libraries. The emphasis is on libraries which work well with the C++
50Standard Library. One goal is to establish "existing practice" and
51provide reference implementations so that the Boost libraries are
52suitable for eventual standardization. Some of the libraries have
53already been proposed for inclusion in the C++ Standards Committee's
54upcoming C++ Standard Library Technical Report.
55
241a7e06 56%description -l pl.UTF-8
28441938 57Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
241a7e06
JR
58kodem źródłowym. Nacisk położono na biblioteki, które dobrze
59współpracują ze standardową biblioteką C++. Celem jest ustanowienie
60"istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
61"Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
62już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
05fa162e 63Raporcie Technicznym Biblioteki Standardowej C++.
28441938 64
321d21fc 65%package static
3ea966e4
JB
66Summary: Static Boost libraries (cross MinGW32 version)
67Summary(pl.UTF-8): Statyczne biblioteki Boost (wersja skrośna MinGW32)
321d21fc
JB
68Group: Development/Libraries
69Requires: %{name} = %{version}-%{release}
70
71%description static
3ea966e4 72Static Boost libraries (cross MinGW32 version).
321d21fc
JB
73
74%description static -l pl.UTF-8
3ea966e4 75Statyczne biblioteki Boost (wersja skrośna MinGW32).
321d21fc 76
28441938 77%package dll
c66a9041
JB
78Summary: Boost - DLL libraries for Windows
79Summary(pl.UTF-8): Boost - biblioteki DLL dla Windows
28441938 80Group: Applications/Emulators
670a15d7
JB
81Requires: crossmingw32-bzip2-dll
82Requires: crossmingw32-zlib-dll
83Requires: wine
28441938 84
85%description dll
c66a9041 86Boost - DLL libraries for Windows.
28441938 87
241a7e06 88%description dll -l pl.UTF-8
c66a9041 89Boost - biblioteki DLL dla Windows.
28441938 90
91%prep
670a15d7 92%setup -q -n %{realname}_%{fver}
28441938 93
f8be5c0b
ŁK
94echo 'using gcc : : %{target}-g++ : <cxxflags>"%{rpmcxxflags}"' \
95 '<archiver>%{target}-ar ;' >tools/build/v2/user-config.jam
28441938 96
97%build
d97fa3b7
ŁK
98%if %{with serialization}
99export WINEPREFIX=`pwd`/wineprefix
a8f548ca
ŁK
100install -d wineprefix/drive_c/windows/system32
101install %{_prefix}/bin/mingwm10.dll wineprefix/drive_c/windows/system32/
d97fa3b7
ŁK
102%endif
103
28441938 104bjam \
3ea966e4 105 -d2 \
f8be5c0b 106 --layout=versioned \
0826927f
JB
107 -sBZIP2_BINARY=bzip2 \
108 --toolset=gcc \
109 --without-python \
d97fa3b7 110 %{!?with_serialization:--without-serialization} \
0826927f
JB
111 --without-test \
112 variant=release \
113 debug-symbols=on \
114 inlining=on \
115 link=static,shared \
ff36f437 116 target-os=windows \
0826927f
JB
117 threading=multi \
118 threadapi=win32
28441938 119
28441938 120%if 0%{!?debug:1}
3ea966e4
JB
121%{target}-strip stage/lib/*.dll
122%{target}-strip -g -R.comment -R.note stage/lib/*.a
28441938 123%endif
124
125%install
126rm -rf $RPM_BUILD_ROOT
c66a9041 127install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_dlldir}}
28441938 128
c66a9041 129cp -r boost $RPM_BUILD_ROOT%{_includedir}
3ea966e4
JB
130cp -a stage/lib/*.a $RPM_BUILD_ROOT%{_libdir}
131install stage/lib/*.dll $RPM_BUILD_ROOT%{_dlldir}
28441938 132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%files
137%defattr(644,root,root,755)
3ea966e4
JB
138%{_libdir}/libboost_*-mgw*-mt-1_44.dll.a
139%{_libdir}/libboost_*-mgw*-mt.dll.a
c66a9041 140%{_includedir}/boost
321d21fc
JB
141
142%files static
143%defattr(644,root,root,755)
3ea966e4
JB
144%{_libdir}/libboost_*-mgw*-mt-1_44.a
145%{_libdir}/libboost_*-mgw*-mt.a
28441938 146
147%files dll
148%defattr(644,root,root,755)
3ea966e4 149%{_dlldir}/libboost_*-mgw*-mt-*.dll
This page took 0.896885 seconds and 4 git commands to generate.