]> git.pld-linux.org Git - packages/cobbler.git/blame - cobbler.spec
- pl, cleanup
[packages/cobbler.git] / cobbler.spec
CommitLineData
4abcd8ff 1# TODO
6a99c4df 2# - avoid using defattr() and giving too much dirs/files to http
4abcd8ff 3# - webapps
f6628fdc 4# - FHS in web paths
a649639e 5Summary: Boot server configurator
6a99c4df 6Summary(pl.UTF-8): Konfiguracja serwera startującego
a649639e
ER
7Name: cobbler
8Version: 0.6.4
1d4fba00 9Release: 0.6
6a99c4df
JB
10License: GPL v2+
11Group: Applications/System
4abcd8ff 12Source0: http://cobbler.et.redhat.com/download/%{name}-%{version}.tar.gz
a649639e 13# Source0-md5: 1f46e1860e10b2e250c73ebb2a3d8227
f6628fdc 14Source1: %{name}-apache.conf
6a99c4df
JB
15URL: http://cobbler.et.redhat.com/
16BuildRequires: python-cheetah
17BuildRequires: python-devel
18#BuildRequires: redhat-rpm-config
19Requires(post,preun): /sbin/chkconfig
1d4fba00 20Requires: apache-mod_proxy
4abcd8ff 21Requires: apache-mod_python
a649639e 22Requires: createrepo
a649639e 23Requires: python >= 2.3
1d4fba00 24Requires: python-cheetah >= 2.0
a649639e 25Requires: python-devel
4abcd8ff
ER
26Requires: python-rhpl
27Requires: tftpdaemon
28Requires: webapps
29%ifarch %{ix86} %{x8664}
a649639e
ER
30Requires: syslinux
31%endif
a649639e
ER
32BuildArch: noarch
33ExcludeArch: ppc
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
f6628fdc
ER
36%define _webapps /etc/webapps
37%define _webapp %{name}
4abcd8ff
ER
38%define _appdir /var/www/cobbler
39%define _cgibindir /var/www/cgi-bin
40
41#define _appdir %{_datadir}/%{name}
42#define _cgibindir %{_prefix}/lib/cgi-bin/%{name}
43
a649639e
ER
44%description
45Cobbler is a network boot and update server. Cobbler supports PXE,
46provisioning virtualized images, and reinstalling existing Linux
47machines. The last two modes require a helper tool called 'koan' that
6a99c4df 48integrates with Cobbler. Cobbler's advanced features include importing
a649639e
ER
49distributions from DVDs and rsync mirrors, kickstart templating,
50integrated yum mirroring, and built-in DHCP Management. Cobbler has a
51Python API for integration with other GPL systems management
52applications.
53
6a99c4df
JB
54%description -l pl.UTF-8
55Cobbler to sieciowy serwer do uruchamiania i uaktualniania komputerów.
56Obsługuje PXE, udostępnianie wirtualizowanych obrazów i reinstalowanie
57istniejących maszyn linuksowych. Dwa ostatnie tryby wymagają pakietu
58pomocniczego o nazwie "koan", integrującego się z Cobblerem.
59Zaawansowane możliwości Cobblera obejmują importowanie dystrybucji z
60płyt DVD i mirrorów rsynca, szablony uruchamiania, zintegrowane
61mirrorowanie repozytoriów yuma oraz wbudowane zarządzanie DHCP.
62Cobbler ma API w Pythonie do integracji z innymi aplikacjami
63zarządzającymi na licencji GPL.
64
a649639e
ER
65%prep
66%setup -q
67
68%build
69%{__python} setup.py build
70
71%install
72rm -rf $RPM_BUILD_ROOT
73install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
74%{__python} setup.py install \
75 --optimize=1 \
76 --root=$RPM_BUILD_ROOT
77
f6628fdc 78install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
1d4fba00
ER
79#cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
80#cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
81mv $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/conf.d/cobbler.conf,%{_webapps}/%{_webapp}/apache.conf}
82cp $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/{apache,httpd}.conf
f6628fdc 83
a649639e
ER
84%py_postclean
85
1d4fba00 86mv $RPM_BUILD_ROOT/''etc/{init.d,rc.d/init.d}/cobblerd
a649639e
ER
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post
92cp /var/lib/cobbler/distros* /var/lib/cobbler/backup 2>/dev/null
93cp /var/lib/cobbler/profiles* /var/lib/cobbler/backup 2>/dev/null
94cp /var/lib/cobbler/systems* /var/lib/cobbler/backup 2>/dev/null
95cp /var/lib/cobbler/repos* /var/lib/cobbler/backup 2>/dev/null
96%{_bindir}/cobbler reserialize
97/sbin/chkconfig --add cobblerd
98%service cobblerd restart
99
100%preun
6a99c4df 101if [ "$1" = "0" ]; then
a649639e 102 %service cobblerd stop
4abcd8ff 103 /sbin/chkconfig --del cobblerd
a649639e
ER
104fi
105
f6628fdc
ER
106%triggerin -- apache1 < 1.3.37-3, apache1-base
107%webapp_register apache %{_webapp}
108
109%triggerun -- apache1 < 1.3.37-3, apache1-base
110%webapp_unregister apache %{_webapp}
111
112%triggerin -- apache < 2.2.0, apache-base
113%webapp_register httpd %{_webapp}
114
115%triggerun -- apache < 2.2.0, apache-base
116%webapp_unregister httpd %{_webapp}
117
a649639e
ER
118%files
119%defattr(644,root,root,755)
120%doc AUTHORS CHANGELOG README
f6628fdc
ER
121
122%dir %attr(750,root,http) %{_webapps}/%{_webapp}
123%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
124%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
125
4abcd8ff
ER
126%defattr(755,http,http)
127%dir %{_cgibindir}/cobbler
128%{_cgibindir}/cobbler/findks.cgi
129%{_cgibindir}/cobbler/nopxe.cgi
130%{_cgibindir}/cobbler/webui.cgi
131%defattr(660,http,http)
132%config(noreplace) %{_cgibindir}/cobbler/.htaccess
133%config(noreplace) %{_cgibindir}/cobbler/.htpasswd
134
135%defattr(755,http,http)
f6628fdc 136%dir %{_datadir}/cobbler
a649639e 137%dir %{_datadir}/cobbler/webui_templates
4abcd8ff 138%defattr(444,http,http)
a649639e
ER
139%{_datadir}/cobbler/webui_templates/*.tmpl
140
4abcd8ff 141%defattr(4755,http,http)
a649639e
ER
142%dir /var/log/cobbler
143%dir /var/log/cobbler/kicklog
4abcd8ff
ER
144%dir %{_appdir}
145%dir %{_appdir}/localmirror
146%dir %{_appdir}/kickstarts
147%dir %{_appdir}/kickstarts_sys
148%dir %{_appdir}/repo_mirror
149%dir %{_appdir}/repos_profile
150%dir %{_appdir}/repos_system
151%dir %{_appdir}/ks_mirror
152%dir %{_appdir}/ks_mirror/config
153%dir %{_appdir}/images
154%dir %{_appdir}/distros
155%dir %{_appdir}/profiles
156%dir %{_appdir}/systems
157%dir %{_appdir}/links
158%defattr(755,http,http)
159%dir %{_appdir}/webui
160%defattr(444,http,http)
161%{_appdir}/webui/*.css
162%{_appdir}/webui/*.js
163%{_appdir}/webui/*.png
164%{_appdir}/webui/*.html
a649639e
ER
165%defattr(-,root,root)
166%dir /tftpboot/pxelinux.cfg
167%dir /tftpboot/images
168%attr(755,root,root) %{_bindir}/cobbler
169%attr(755,root,root) %{_bindir}/cobblerd
170%dir %{_sysconfdir}/cobbler
171%config(noreplace) %{_sysconfdir}/cobbler/default.ks
172%config(noreplace) %{_sysconfdir}/cobbler/kickstart_fc5.ks
173%config(noreplace) %{_sysconfdir}/cobbler/kickstart_fc6.ks
174%config(noreplace) %{_sysconfdir}/cobbler/kickstart_fc6_domU.ks
175%config(noreplace) %{_sysconfdir}/cobbler/dhcp.template
176%config(noreplace) %{_sysconfdir}/cobbler/dnsmasq.template
177%config(noreplace) %{_sysconfdir}/cobbler/pxedefault.template
178%config(noreplace) %{_sysconfdir}/cobbler/pxeprofile.template
179%config(noreplace) %{_sysconfdir}/cobbler/pxesystem.template
180%config(noreplace) %{_sysconfdir}/cobbler/pxesystem_ia64.template
181%config(noreplace) %{_sysconfdir}/cobbler/rsync.exclude
182%config(noreplace) /etc/logrotate.d/cobblerd_rotate
183%config(noreplace) %{_sysconfdir}/cobbler/modules.conf
184%config(noreplace) %{_sysconfdir}/cobbler/webui-cherrypy.cfg
185%dir %{py_sitescriptdir}/cobbler
186%dir %{py_sitescriptdir}/cobbler/yaml
187%dir %{py_sitescriptdir}/cobbler/modules
188%dir %{py_sitescriptdir}/cobbler/webui
189%{py_sitescriptdir}/cobbler/*.py[co]
190%{py_sitescriptdir}/cobbler/yaml/*.py[co]
191%{py_sitescriptdir}/cobbler/modules/*.py[co]
192%{py_sitescriptdir}/cobbler/webui/*.py[co]
193%{_mandir}/man1/cobbler.1*
194%attr(754,root,root) /etc/rc.d/init.d/cobblerd
a649639e
ER
195%dir /var/log/cobbler/syslog
196
197%defattr(755,root,root)
198%dir /var/lib/cobbler
6a99c4df
JB
199%dir /var/lib/cobbler/kickstarts
200%dir /var/lib/cobbler/backup
a649639e
ER
201%dir /var/lib/cobbler/triggers/add/distro/pre
202%dir /var/lib/cobbler/triggers/add/distro/post
203%dir /var/lib/cobbler/triggers/add/profile/pre
204%dir /var/lib/cobbler/triggers/add/profile/post
205%dir /var/lib/cobbler/triggers/add/system/pre
206%dir /var/lib/cobbler/triggers/add/system/post
207%dir /var/lib/cobbler/triggers/add/repo/pre
208%dir /var/lib/cobbler/triggers/add/repo/post
209%dir /var/lib/cobbler/triggers/delete/distro/pre
210%dir /var/lib/cobbler/triggers/delete/distro/post
211%dir /var/lib/cobbler/triggers/delete/profile/pre
212%dir /var/lib/cobbler/triggers/delete/profile/post
213%dir /var/lib/cobbler/triggers/delete/system/pre
214%dir /var/lib/cobbler/triggers/delete/system/post
215%dir /var/lib/cobbler/triggers/delete/repo/pre
216%dir /var/lib/cobbler/triggers/delete/repo/post
217%dir /var/lib/cobbler/triggers/sync/pre
218%dir /var/lib/cobbler/triggers/sync/post
6a99c4df 219%dir /var/lib/cobbler/snippets
a649639e
ER
220
221%defattr(744,root,root)
222%config(noreplace) /var/lib/cobbler/triggers/sync/post/restart-services.trigger
223
224%defattr(664,root,root)
225%config(noreplace) /var/lib/cobbler/settings
226%config(noreplace) /var/lib/cobbler/snippets/partition_select
227/var/lib/cobbler/elilo-3.6-ia64.efi
228/var/lib/cobbler/menu.c32
4abcd8ff 229%defattr(660,http,http)
a649639e
ER
230%config(noreplace) %{_sysconfdir}/cobbler/auth.conf
231
232%defattr(664,root,root)
233%config(noreplace) /var/lib/cobbler/cobbler_hosts
This page took 0.075694 seconds and 4 git commands to generate.