]> git.pld-linux.org Git - packages/cobbler.git/blame - cobbler.spec
update to 2.4.0pre5
[packages/cobbler.git] / cobbler.spec
CommitLineData
4abcd8ff 1# TODO
6a99c4df 2# - avoid using defattr() and giving too much dirs/files to http
4abcd8ff 3# - webapps
f6628fdc 4# - FHS in web paths
30a5fd64
ER
5# - bash-completions
6%define subver beta5
7%define rel 0.6
a649639e 8Summary: Boot server configurator
6a99c4df 9Summary(pl.UTF-8): Konfiguracja serwera startującego
a649639e 10Name: cobbler
30a5fd64
ER
11Version: 2.4.0
12Release: 0.%{subver}.%{rel}
6a99c4df
JB
13License: GPL v2+
14Group: Applications/System
30a5fd64
ER
15Source0: https://github.com/cobbler/cobbler/archive/%{name}-%{version}-%{subver}.tar.gz
16# Source0-md5: f0b63f64d679e3ee547de2d97b74e681
f6628fdc 17Source1: %{name}-apache.conf
30a5fd64
ER
18URL: http://www.cobblerd.org/
19BuildRequires: python-PyYAML
6a99c4df
JB
20BuildRequires: python-cheetah
21BuildRequires: python-devel
6a99c4df 22Requires(post,preun): /sbin/chkconfig
30a5fd64
ER
23BuildRequires: python-setuptools
24Requires: apache-mod_wsgi
a649639e 25Requires: createrepo
30a5fd64
ER
26#Requires: genisoimage
27Requires: python-PyYAML
28Requires: python-augeas
29Requires: python-cheetah
30Requires: python-netaddr
31Requires: python-simplejson
32Requires: python-urlgrabber
33Requires: rsync
4abcd8ff 34Requires: tftpdaemon
30a5fd64 35Requires: yum-utils
a649639e 36BuildArch: noarch
a649639e
ER
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
f6628fdc
ER
39%define _webapps /etc/webapps
40%define _webapp %{name}
4abcd8ff
ER
41%define _appdir /var/www/cobbler
42%define _cgibindir /var/www/cgi-bin
43
44#define _appdir %{_datadir}/%{name}
45#define _cgibindir %{_prefix}/lib/cgi-bin/%{name}
46
a649639e
ER
47%description
48Cobbler is a network boot and update server. Cobbler supports PXE,
49provisioning virtualized images, and reinstalling existing Linux
50machines. The last two modes require a helper tool called 'koan' that
6a99c4df 51integrates with Cobbler. Cobbler's advanced features include importing
a649639e
ER
52distributions from DVDs and rsync mirrors, kickstart templating,
53integrated yum mirroring, and built-in DHCP Management. Cobbler has a
54Python API for integration with other GPL systems management
55applications.
56
6a99c4df
JB
57%description -l pl.UTF-8
58Cobbler to sieciowy serwer do uruchamiania i uaktualniania komputerów.
59Obsługuje PXE, udostępnianie wirtualizowanych obrazów i reinstalowanie
60istniejących maszyn linuksowych. Dwa ostatnie tryby wymagają pakietu
61pomocniczego o nazwie "koan", integrującego się z Cobblerem.
62Zaawansowane możliwości Cobblera obejmują importowanie dystrybucji z
63płyt DVD i mirrorów rsynca, szablony uruchamiania, zintegrowane
64mirrorowanie repozytoriów yuma oraz wbudowane zarządzanie DHCP.
65Cobbler ma API w Pythonie do integracji z innymi aplikacjami
66zarządzającymi na licencji GPL.
67
30a5fd64
ER
68%package web
69Summary: Web interface for Cobbler
70Group: Applications/System
71Requires: %{name} = %{version}-%{release}
72Requires: apache-mod_wsgi
73Requires: apache-mod_ssl
74Requires: python-django >= 1.1.2
75
76%description web
77Web interface for Cobbler that allows visiting
78<http://server/cobbler_web> to configure the install server.
79
80%package -n koan
81Summary: Helper tool that performs cobbler orders on remote machines
82Group: Applications/System
83Requires: python-simplejson
84Requires: python-virtinst
85
86%description -n koan
87Koan stands for kickstart-over-a-network and allows for both network
88installation of new virtualized guests and reinstallation of an
89existing system. For use with a boot-server configured with Cobbler
90
a649639e 91%prep
30a5fd64 92%setup -q -n %{name}-%{name}-%{version}-%{subver}
a649639e
ER
93
94%build
95%{__python} setup.py build
96
97%install
98rm -rf $RPM_BUILD_ROOT
99install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
100%{__python} setup.py install \
30a5fd64 101 --optimize=2 \
a649639e
ER
102 --root=$RPM_BUILD_ROOT
103
30a5fd64
ER
104%py_postclean
105
f6628fdc 106install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
1d4fba00
ER
107#cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
108#cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
109mv $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/conf.d/cobbler.conf,%{_webapps}/%{_webapp}/apache.conf}
30a5fd64
ER
110#mv config/cobbler.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
111#mv config/cobbler_web.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
1d4fba00 112cp $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/{apache,httpd}.conf
f6628fdc 113
30a5fd64
ER
114install -d $RPM_BUILD_ROOT/var/lib/tftpboot/images
115mkdir -p $RPM_BUILD_ROOT/var/spool/koan
a649639e 116
1d4fba00 117mv $RPM_BUILD_ROOT/''etc/{init.d,rc.d/init.d}/cobblerd
a649639e
ER
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post
a649639e 123/sbin/chkconfig --add cobblerd
30a5fd64
ER
124# reserialize and restart
125# FIXIT: ?????
126#%{_bindir}/cobbler reserialize
a649639e
ER
127%service cobblerd restart
128
129%preun
30a5fd64 130if [ $1 = 0 ]; then
4abcd8ff 131 /sbin/chkconfig --del cobblerd
30a5fd64 132 %service cobblerd stop
a649639e
ER
133fi
134
30a5fd64 135%if 0
f6628fdc
ER
136%triggerin -- apache1 < 1.3.37-3, apache1-base
137%webapp_register apache %{_webapp}
138
139%triggerun -- apache1 < 1.3.37-3, apache1-base
140%webapp_unregister apache %{_webapp}
141
142%triggerin -- apache < 2.2.0, apache-base
143%webapp_register httpd %{_webapp}
144
145%triggerun -- apache < 2.2.0, apache-base
146%webapp_unregister httpd %{_webapp}
30a5fd64
ER
147%endif
148
149%post web
150# FIXME: this changes on each upgrade -glen
151# Change the SECRET_KEY option in the Django settings.py file
152# required for security reasons, should be unique on all systems
153RAND_SECRET=$(openssl rand -base64 40 | sed 's/\//\\\//g')
154sed -i -e "s/SECRET_KEY = ''/SECRET_KEY = \'$RAND_SECRET\'/" /usr/share/cobbler/web/settings.py
f6628fdc 155
a649639e
ER
156%files
157%defattr(644,root,root,755)
158%doc AUTHORS CHANGELOG README
30a5fd64
ER
159%attr(755,root,root) %{_bindir}/cobbler
160%attr(755,root,root) %{_bindir}/cobbler-ext-nodes
161%attr(755,root,root) %{_bindir}/cobblerd
162%attr(755,root,root) %{_sbindir}/tftpd.py*
163%{_mandir}/man1/cobbler.1*
164%attr(754,root,root) /etc/rc.d/init.d/cobblerd
165
166%dir %{_sysconfdir}/%{name}
167%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
168%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.template
169%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*/*.template
170
171%{py_sitescriptdir}/%{name}
172# XXX why
173#%exclude %{py_sitescriptdir}/%{name}/sub_process.py*
174%{py_sitescriptdir}/%{name}*.egg-info
175
176%{_datadir}/augeas/lenses/cobblersettings.aug
177
178%config(noreplace) /var/lib/cobbler
179%exclude /var/lib/cobbler/webui_sessions
f6628fdc 180
30a5fd64
ER
181%{_appdir}
182/var/log/cobbler
183/var/lib/tftpboot/images
184
185# XXX
186%dir /var/www
187%dir /var/lib/tftpboot
188
189%files web
190%defattr(644,root,root,755)
191%doc AUTHORS CHANGELOG README
f6628fdc
ER
192%dir %attr(750,root,http) %{_webapps}/%{_webapp}
193%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
194%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
195
f6628fdc 196%dir %{_datadir}/cobbler
30a5fd64
ER
197%{_datadir}/cobbler/web
198%dir %attr(700,http,root) /var/lib/cobbler/webui_sessions
199/var/www/cobbler_webui_content
200
201%files -n koan
202%defattr(644,root,root,755)
203%doc AUTHORS CHANGELOG README
204%attr(755,root,root) %{_bindir}/koan
205%attr(755,root,root) %{_bindir}/ovz-install
206%attr(755,root,root) %{_bindir}/cobbler-register
207%{_mandir}/man1/koan.1*
208%{_mandir}/man1/cobbler-register.1*
209%{py_sitescriptdir}/koan
210# XXX why?
211#%exclude %{py_sitescriptdir}/koan/sub_process.py*
212#%exclude %{py_sitescriptdir}/koan/opt_parse.py*
213#%exclude %{py_sitescriptdir}/koan/text_wrap.py*
214
215%dir /var/spool/koan
216%dir /var/lib/koan
217%dir /var/lib/koan/config
218%dir /var/log/koan
This page took 0.091181 seconds and 4 git commands to generate.