]> git.pld-linux.org Git - packages/cloog-isl.git/blame - cloog-isl.spec
- updated to 0.18.4 (for isl 0.15)
[packages/cloog-isl.git] / cloog-isl.spec
CommitLineData
33729bf8
JB
1#
2# Conditional build:
3%bcond_without osl # OpenScop support
4#
ccb5c0fe 5%define isl_ver 0.15
748bb20d
JB
6Summary: The Chunky Loop Generator
7Summary(pl.UTF-8): Chunky Loop Generator - generator pętli cząstkowych
8Name: cloog-isl
ccb5c0fe
JB
9Version: 0.18.4
10Release: 1
748bb20d
JB
11License: LGPL v2.1+
12Group: Development/Tools
ccb5c0fe
JB
13# git clone git://repo.or.cz/cloog.git -b cloog-0.18.4 cloog-0.18.4
14#Source0: http://pkgs.fedoraproject.org/repo/pkgs/cloog/cloog-%{version}.tar.gz/a65195e2f1fe1b91826b18a185d82859/cloog-%{version}.tar.gz
15Source0: http://www.bastoul.net/cloog/pages/download/cloog-%{version}.tar.gz
16# Source0-md5: e531f725244856c92c9bba009ff44faf
748bb20d 17URL: http://www.cloog.org/
b7811175 18BuildRequires: autoconf >= 2.53
748bb20d
JB
19BuildRequires: automake
20BuildRequires: gmp-devel >= 5.0.2
21BuildRequires: gmp-c++-devel >= 5.0.2
2aa1cad6 22BuildRequires: isl-devel >= %{isl_ver}
16fd4dbc 23BuildRequires: libtool
33729bf8 24%{?with_osl:BuildRequires: osl-devel}
16fd4dbc 25BuildRequires: texinfo-texi2dvi
748bb20d
JB
26Requires: %{name}-libs = %{version}-%{release}
27Provides: cloog = %{version}
28Obsoletes: cloog
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32CLooG is a software which generates loops for scanning Z-polyhedra.
33That is, CLooG finds the code or pseudo-code where each integral point
34of one or more parametrized polyhedron or parametrized polyhedra union
35is reached. CLooG is designed to avoid control overhead and to produce
36a very efficient code.
37
38This version is based on isl.
39
40%description -l pl.UTF-8
41CLooG to oprogramowanie generujące pętle do przeszukiwania
42Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
43pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
44sparametryzowanych wielościanów lub sum sparametryzowanych
45wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
46narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
47
48Ta wersja jest oparta na bibliotece isl.
49
50%package libs
51Summary: Chunky Loop Generator shared library - isl based version
52Summary(pl.UTF-8): Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na isl
53Group: Libraries
2aa1cad6 54Requires: isl >= %{isl_ver}
748bb20d
JB
55
56%description libs
57Chunky Loop Generator shared library - isl based version.
58
59%description libs -l pl.UTF-8
60Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na
61isl.
62
63%package devel
64Summary: Header files for the isl based version of Chunky Loop Generator
65Summary(pl.UTF-8): Pliki nagłówkowe opartej na isl wersji Chunky Loop Generatora
66Group: Development/Libraries
67Requires: %{name}-libs = %{version}-%{release}
68Requires: gmp-devel >= 5.0.2
69Requires: gmp-c++-devel >= 5.0.2
2aa1cad6 70Requires: isl-devel >= %{isl_ver}
33729bf8 71%{?with_osl:Requires: osl-devel}
748bb20d
JB
72Provides: cloog-devel = %{version}
73
74%description devel
75The header files for Chunky Loop Generator library.
76
77%description devel -l pl.UTF-8
78Pliki nagłówkowe biblioteki Chunky Loop Generatora.
79
80%package static
81Summary: Static library of isl based version of Chunky Loop Generator
82Summary(pl.UTF-8): Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora
83Group: Development/Libraries
84Requires: %{name}-devel = %{version}-%{release}
85
86%description static
87Static library of isl based version of Chunky Loop Generator.
88
89%description static -l pl.UTF-8
90Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora.
91
92%prep
93%setup -q -n cloog-%{version}
94
95%build
b7811175
JB
96%{__libtoolize}
97%{__aclocal} -I m4
98%{__autoconf}
99%{__automake}
33729bf8 100# with_gmp_exec_prefix=yes avoids adding -L/lib to LDFLAGS
748bb20d
JB
101%configure \
102 --disable-silent-rules \
33729bf8
JB
103 --with-gmp-exec-prefix \
104 --with-isl=system \
105 %{?with_osl:--with-osl=system}
748bb20d
JB
106
107%{__make}
108
16fd4dbc
JB
109%{__make} -C doc cloog.pdf
110
748bb20d
JB
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%{__make} install \
115 DESTDIR=$RPM_BUILD_ROOT
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post libs -p /sbin/ldconfig
121%postun libs -p /sbin/ldconfig
122
123%files
124%defattr(644,root,root,755)
125%attr(755,root,root) %{_bindir}/cloog
126
127%files libs
128%defattr(644,root,root,755)
129%doc ChangeLog README
130%attr(755,root,root) %{_libdir}/libcloog-isl.so.*.*.*
16fd4dbc 131%attr(755,root,root) %ghost %{_libdir}/libcloog-isl.so.4
748bb20d
JB
132
133%files devel
134%defattr(644,root,root,755)
135%doc doc/cloog.pdf
136%attr(755,root,root) %{_libdir}/libcloog-isl.so
137%{_libdir}/libcloog-isl.la
138%dir %{_includedir}/cloog
139%{_includedir}/cloog/*.h
140%{_includedir}/cloog/isl
141%{_includedir}/cloog/matrix
920340c1
JB
142%dir %{_libdir}/cloog-isl
143%{_libdir}/cloog-isl/cloog-isl-config.cmake
144%dir %{_libdir}/isl
145%{_libdir}/isl/isl-config.cmake
748bb20d
JB
146%{_pkgconfigdir}/cloog-isl.pc
147
148%files static
149%defattr(644,root,root,755)
150%{_libdir}/libcloog-isl.a
This page took 0.098175 seconds and 4 git commands to generate.