]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- static projectm bcond, bcond other br
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
2c687024 2# - add missing BRs
f2d911f2
ER
3# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4# -- Building engines: gst
5# -- Skipping engines: vlc xine qt-phonon
6# The following engines are NOT supported by clementine developers:
7# vlc xine qt-phonon
8# - apply patches to libprojectM.spec and use
0b056df0 9# - make engines pluggable not statically linked, then could enable the bconds
2c687024 10#
11# Conditional build:
0b056df0
ER
12%bcond_with engine_xine # without xine engine
13%bcond_with engine_vlc # without vlc engine
14%bcond_with engine_qt_phonon # without qt-phonon engine
2c687024 15%bcond_without engine_gstreamer # without gstreamer engine
742e4e0a 16%bcond_with static_sqlite # with static sqlite3
aca708d9 17%bcond_with static_projectm # with static projectM
0b056df0 18
bf1e6952 19Summary: A music player and library organiser
df3c0ac1 20Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 21Name: clementine
f2d911f2 22Version: 0.4.2
0b056df0 23Release: 0.2
bf1e6952
ER
24License: GPL v3 and GPL v2+
25Group: Applications/Multimedia
26URL: http://code.google.com/p/clementine-player
2c687024 27Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
f2d911f2 28# Source0-md5: c6819b0d2a8324f1d686fb5a3b1d287b
bf1e6952 29Patch0: %{name}-dont-bundle-external-lib.patch
7279ad3f 30Patch2: desktop-install.patch
b6199a83 31BuildRequires: QtCore-devel
32BuildRequires: QtDBus-devel
33BuildRequires: QtGui-devel
f2d911f2 34BuildRequires: QtIOCompressor-devel
b6199a83 35BuildRequires: QtNetwork-devel
36BuildRequires: QtOpenGL-devel
88ca6f4b 37BuildRequires: QtSingleApplication-devel
b6199a83 38BuildRequires: QtSql-devel
aca708d9 39%{?with_tests:BuildRequires: QtTest-devel}
bf1e6952 40BuildRequires: boost-devel
7279ad3f 41BuildRequires: cmake >= 2.6
aca708d9 42#BuildRequires: desktop-file-utils
75ec0859 43BuildRequires: gettext-devel
aca708d9
ER
44%{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
45%{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
bf1e6952
ER
46BuildRequires: gtest-devel
47BuildRequires: liblastfm-devel
48BuildRequires: libnotify-devel
aca708d9
ER
49%{!?with_static_projectm:BuildRequires: libprojectM-devel}
50%{?with_static_projectm:BuildRequires: glew-devel}
51#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
bf1e6952 52BuildRequires: libqxt-devel
f2d911f2 53#BuildRequires: libqxt-devel >= 0.6.0-0.2
bf1e6952 54BuildRequires: notification-daemon
aca708d9 55%{?with_engine_phonon:BuildRequires: phonon-devel}
75ec0859 56BuildRequires: pkgconfig
bf1e6952 57BuildRequires: qt4-build
b6199a83 58BuildRequires: qt4-linguist
59BuildRequires: qt4-qmake
726826ed 60BuildRequires: rpmbuild(macros) >= 1.198
bf1e6952 61BuildRequires: sed >= 4.0
742e4e0a 62%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 63BuildRequires: taglib-devel >= 1.6
aca708d9
ER
64%{?with_engine_vlc:BuildRequires: vlc-devel}
65%{?with_engine_xine:BuildRequires: xine-lib-devel}
726826ed 66Requires(post,postun): desktop-file-utils
742e4e0a 67%{!?with_static_sqlite:Requires: QtSql-sqlite3}
f2d911f2
ER
68# while we do not link (yet), we use datafiles
69Requires: libprojectM
bf1e6952
ER
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
f2d911f2
ER
72# see libprojectM.spec for explanation
73%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
74
bf1e6952
ER
75%description
76Clementine is a modern music player and library organiser. It is
77largely a port of Amarok 1.4, with some features rewritten to take
78advantage of Qt4.
79
df3c0ac1
ZU
80%description -l hu.UTF-8
81Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
82az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
83a Qt4 előnyeit.
84
bf1e6952
ER
85%prep
86%setup -q
f2d911f2 87%patch0 -p1
29df970b 88%patch2 -p1
bf1e6952
ER
89
90# We already don't use these but just to make sure
f2d911f2 91rm -rf 3rdparty/gmock
742e4e0a 92%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
93rm -rf 3rdparty/qtsingleapplication
94rm -rf 3rdparty/qxt
95rm -rf 3rdparty/qtiocompressor
aca708d9 96%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 97
7279ad3f 98# Don't build tests. They require gmock
f2d911f2 99sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
bf1e6952
ER
100
101%build
102install -d build
103cd build
88ca6f4b
ER
104%cmake \
105 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
f2d911f2 106 -DBUNDLE_PROJECTM_PRESETS=OFF \
2c687024 107 -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
108 -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
109 -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
75ec0859 110 -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
742e4e0a 111 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 112 ..
bf1e6952
ER
113%{__make}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117%{__make} -C build install \
118 DESTDIR=$RPM_BUILD_ROOT
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
726826ed
ER
123%post
124%update_desktop_database_post
125
126%postun
127%update_desktop_database_postun
128
bf1e6952
ER
129%files
130%defattr(644,root,root,755)
131%doc Changelog TODO
132%attr(755,root,root) %{_bindir}/clementine
133%{_desktopdir}/clementine.desktop
7279ad3f 134%{_pixmapsdir}/clementine.png
This page took 0.120182 seconds and 4 git commands to generate.