]> git.pld-linux.org Git - packages/clamav.git/blame - clamav.spec
Set rust target explicitly (x32 builds fine now)
[packages/clamav.git] / clamav.spec
CommitLineData
c935072a 1# TODO:
2d42b9d9 2# - verify why system tomsfastmath lib fails to check integrity of database after update (as of 2021-11-17)
c8321415 3# - Make freshclam package (script and daemon)
d06ef0ed 4# - restart amavis in triggers if group membership was modified?
eba74cc1 5#
6# Conditional build:
d1044716 7%bcond_without milter # milter interface subpackage
da430249 8%if "%{pld_release}" == "ac"
d1044716 9%bcond_with llvm # LLVM support
00f337bd 10%else
d1044716 11%bcond_without llvm # LLVM support
da430249 12%endif
d1044716
JB
13%bcond_without system_libmspack # system libmspack library
14%bcond_with system_llvm # system LLVM (< 3.7)
8cdcf5e0 15%bcond_without static_libs # static libraries
da430249
JR
16
17%ifarch x32
18%undefine with_llvm
9279da12 19%endif
b014d766 20Summary: An anti-virus utility for Unix
8618c36b 21Summary(pl.UTF-8): Narzędzie antywirusowe dla Uniksów
e6c034d3 22Name: clamav
6721ff6d
AM
23Version: 0.105.0
24Release: 1
c81b4cf4 25License: GPL v2+
c3cae60d 26Group: Daemons
d1044716 27#Source0Download: http://www.clamav.net/download
9a0add22 28Source0: http://www.clamav.net/downloads/production/%{name}-%{version}.tar.gz
6721ff6d 29# Source0-md5: f9994b5036da80f61d18d5941d49545d
4460ff0b
AM
30Source1: %{name}.init
31Source2: %{name}.sysconfig
eba74cc1 32Source3: %{name}-milter.init
719d471d 33Source4: %{name}-cron-updatedb
4a3f68d7 34Source5: %{name}.logrotate
3e84b306 35Source8: %{name}-post-updatedb
eba74cc1 36Source9: %{name}-milter.sysconfig
24adbaa3 37Source10: %{name}.tmpfiles
09a96373 38Source11: clamd.service
e5b99e12
JK
39Source12: cronjob-clamav.timer
40Source13: cronjob-clamav.service.in
1475e7a3 41Patch0: %{name}-pld_config.patch
1ac1f471 42
0d2709fa 43Patch4: x32.patch
182b1736 44URL: http://www.clamav.net/
c3e2478b 45BuildRequires: bzip2-devel >= 1.0.5
6721ff6d 46BuildRequires: cargo
c3e2478b 47BuildRequires: cmake >= 3.14
4570eb6d 48BuildRequires: check-devel
8cdcf5e0 49BuildRequires: curl-devel >= 7.40
73b401c8 50BuildRequires: gmp-devel
d1044716 51BuildRequires: json-c-devel
bda09b13 52BuildRequires: libltdl-devel
9d42dc39 53%{?with_milter:BuildRequires: libmilter-devel}
d1044716 54%{?with_system_libmspack:BuildRequires: libmspack-devel}
fbdfce83 55BuildRequires: libstdc++-devel >= 5:3.4
dd6d36d5 56%{?with_milter:BuildRequires: libwrap-devel}
d1044716 57BuildRequires: libxml2-devel >= 2
85d2d338 58%{?with_llvm:%{?with_system_llvm:BuildRequires: llvm-devel < 3.7}}
75268608 59BuildRequires: ncurses-devel
d1044716 60BuildRequires: openssl-devel >= 0.9.8
8cdcf5e0 61BuildRequires: pcre2-8-devel >= 10.30
d1044716 62BuildRequires: pkgconfig >= 1:0.16
9e4f09df 63BuildRequires: rpm-build >= 4.6
c3e2478b 64BuildRequires: rpmbuild(macros) >= 1.742
d1044716 65BuildRequires: systemd-devel
7fae6205 66BuildRequires: tomsfastmath-devel >= 0.13.1-2
d1044716 67BuildRequires: zlib-devel >= 1.2.2
dd6d36d5
ER
68Requires(post,preun): /sbin/chkconfig
69Requires(postun): /usr/sbin/groupdel
70Requires(postun): /usr/sbin/userdel
71Requires(postun,pre): /usr/sbin/usermod
0e86f481 72Requires(pre): /bin/id
49797116 73Requires(pre): /usr/bin/getgid
74Requires(pre): /usr/sbin/groupadd
75Requires(pre): /usr/sbin/useradd
28e95a65
ŁK
76Requires(post,preun,postun): systemd-units >= 38
77Requires: systemd-units >= 38
01a1fe23 78Requires(postun): sed >= 4.0
d4117574 79Requires: %{name}-libs = %{epoch}:%{version}-%{release}
dd6d36d5 80Requires: /usr/sbin/usermod
f40f9e2f 81Requires: rc-scripts >= 0.4.1.23
6475233d 82Suggests: clamav-database
4792d085 83Suggests: cronjobs
49797116 84Provides: group(clamav)
85Provides: user(clamav)
d0ecd394 86Conflicts: logrotate < 3.7-4
e6c034d3 87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
e6c034d3 89%description
066e1c29
ER
90Clam AntiVirus is an open source anti-virus toolkit for UNIX, designed
91especially for e-mail scanning on mail gateways. It provides a number
92of utilities including a flexible and scalable multi-threaded daemon,
93a command line scanner and advanced tool for automatic database
94updates. The core of the package is an anti-virus engine available in
693adc85 95a form of shared library (available in clamav-libs).
066e1c29
ER
96
97Here is a list of the main features:
98- command-line scanner
99- fast, multi-threaded daemon with support for on-access scanning
100- milter interface for sendmail
101- advanced database updater with support for scripted updates and
102 digital signatures
103- virus scanner C library
693adc85 104- on-access scanning (Linux and FreeBSD)
066e1c29
ER
105- virus database updated multiple times per day (see home page for
106 total number of signatures)
107- built-in support for various archive formats, including Zip, RAR,
108 Tar, Gzip, Bzip2, OLE2, Cabinet, CHM, BinHex, SIS and others
109- built-in support for almost all mail file formats
110- built-in support for ELF executables and Portable Executable files
111 compressed with UPX, FSG, Petite, NsPack, wwpack32, MEW, Upack and
112 obfuscated with SUE, Y0da Cryptor and others
113- built-in support for popular document formats including MS Office
114 and MacOffice files, HTML, RTF and PDF
e6c034d3 115
d8cf2de3 116%description -l pl.UTF-8
693adc85
JB
117Clam AntiVirus to mające otwarte źródła narzędzie antywirusowe dla
118systemów uniksowych, zaprojektowane szczególnie pod kątem skanowania
119poczty elektronicznej na bramkach pocztowych. Udostępnia wiele
120narzędzi, w tym elastycznego i skalowalnego, multiwątkowego demona,
121skaner działający z linii poleceń oraz zaawansowane narzędzie do
122automatycznej aktualizacji bazy danych. Główna część pakietu to
123silnik antywirusowy dostępny w postaci biblioteki współdzielonej
124(dostępnej w pakiecie clamav-libs).
125
126Lista podstawowych możliwości:
127- skaner działający z linii poleceń
128- szybki, wielowątkowy demon z obsługą skanowania przy odczycie
129- interfejs milter dla sendmaila
130- zaawansowane narzędzie do aktualizacji bazy danych z obsługą
131 aktualizacji oskryptowanych oraz podpisów cyfrowych
132- biblioteka C skanera antywirusowego
133- skanowanie przy odczycie (dla Linuksa i FreeBSD)
134- baza danych wirusów aktualizowana wiele razy dziennie (liczba
135 sygnatur dostępna na stronie projektu)
136- wbudowana obsługa różnych formatów archiwów, w tym Zip, RAR, Tar,
137 Gzip, Bzip2, OLE2, Cabinet, CHM, BinHex, SIS i inne
138- wbudowana obsługa prawie wszystkich formatów plików pocztowych
139- wbudowana obsługa plików wykonywalnych ELF i PE skompresowanych
140 programami UPX, FSG, Petite, NsPack, wwpack32, MEW, Upack oraz
141 zaciemnionych przy użyciu programów SUE, Y0da Cryptor i innych
142- wbudowana obsługa popularnych formatów dokumentów, w tym plików MS
143 Office, MacOffice, HTML, RTF i PDF
e6c034d3 144
4460ff0b 145%package libs
f98d218a 146Summary: Shared libraries for clamav
da5aee7a 147Summary(pl.UTF-8): Biblioteki dzielone clamav
f98d218a 148Group: Libraries
8cdcf5e0
JB
149Requires: bzip2-libs >= 1.0.5
150Requires: curl-libs >= 7.40
151Requires: pcre2-8 >= 10.30
d1044716 152Requires: zlib >= 1.2.2
4460ff0b
AM
153
154%description libs
155Shared libraries for clamav.
156
d8cf2de3 157%description libs -l pl.UTF-8
4460ff0b
AM
158Biblioteki dzielone clamav.
159
486b4f0f
JB
160%package milter
161Summary: ClamAV filter using milter interface
8618c36b 162Summary(pl.UTF-8): Filtr ClamAV korzystający z interfejsu milter
eba74cc1 163Group: Daemons
d4117574 164Requires: %{name} = %{epoch}:%{version}-%{release}
893a866a 165Requires: postfix
7c438a38 166#Requires: sendmail >= 8.11
eba74cc1 167Requires: tcp_wrappers
eba74cc1 168
169%description milter
170ClamAV sendmail filter using MILTER interface.
171
d8cf2de3 172%description milter -l pl.UTF-8
8618c36b 173Filtr ClamAV dla sendmaila korzystający z interfejsu MILTER.
eba74cc1 174
4460ff0b 175%package devel
f98d218a 176Summary: clamav - Development header files and libraries
8618c36b 177Summary(pl.UTF-8): clamav - Pliki nagłówkowe i biblioteki dla programistów
f98d218a 178Group: Development/Libraries
d4117574 179Requires: %{name}-libs = %{epoch}:%{version}-%{release}
8cdcf5e0
JB
180Requires: bzip2-devel >= 1.0.5
181Requires: curl-devel >= 7.40
cc776ef1 182Requires: gmp-devel
d1044716 183Requires: openssl-devel >= 0.9.8
8cdcf5e0 184Requires: pcre2-8-devel >= 10.30
d1044716 185Requires: zlib-devel >= 1.2.2
4460ff0b
AM
186
187%description devel
188This package contains the development header files and libraries
189necessary to develop clamav client applications.
190
d8cf2de3 191%description devel -l pl.UTF-8
8618c36b 192Pliki nagłówkowe i biblioteki konieczne do kompilacji aplikacji
142cc22a 193klienckich clamav.
4460ff0b
AM
194
195%package static
dd6d36d5 196Summary: clamav static libraries
da5aee7a 197Summary(pl.UTF-8): Biblioteki statyczne clamav
f98d218a 198Group: Development/Libraries
d4117574 199Requires: %{name}-devel = %{epoch}:%{version}-%{release}
4460ff0b
AM
200
201%description static
f33eb2df 202clamav static libraries.
4460ff0b 203
d8cf2de3 204%description static -l pl.UTF-8
4460ff0b
AM
205Biblioteki statyczne clamav.
206
c3e2478b
JB
207%package doc
208Summary: ClamAV documentation
209Summary(pl.UTF-8): Dokumentacja do ClamAVa
210Group: Documentation
9e4f09df 211BuildArch: noarch
c3e2478b
JB
212
213%description doc
214ClamAV documentation.
215
216%description doc -l pl.UTF-8
217Dokumentacja do ClamAVa.
218
e6c034d3 219%prep
c81b4cf4 220%setup -q
c935072a 221%patch0 -p1
1ac1f471 222
0d2709fa 223%patch4 -p1
82747f5b 224
e6c034d3 225%build
1ac1f471
AM
226install -d build
227cd build
228%{cmake} \
229 %{cmake_on_off system_libmspack ENABLE_EXTERNAL_MSPACK} \
230 %{cmake_on_off milter ENABLE_MILTER} \
231 %{cmake_on_off static_libs ENABLE_STATIC_LIB} \
232 -DENABLE_APP=ON \
233 -DENABLE_CLAMONACC=ON \
234 -DENABLE_FRESHCLAM_NO_CACHE=ON \
6721ff6d 235 -DENABLE_EXTERNAL_TOMSFASTMATH=ON \
3493e2a2 236 -DRUST_COMPILER_TARGET=%{rust_target} \
1ac1f471
AM
237 -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/%{name} \
238 -DAPP_CONFIG_DIRECTORY=%{_sysconfdir} \
c16cd5f9 239 -DDATABASE_DIRECTORY="/var/lib/%{name}" \
1ac1f471 240 ..
8cdcf5e0 241%{__make}
4d3c9f35 242
e6c034d3 243%install
244rm -rf $RPM_BUILD_ROOT
06e3ab45 245install -d $RPM_BUILD_ROOT/etc/{cron.d,logrotate.d,rc.d/init.d,sysconfig} \
c79a8ed7 246 $RPM_BUILD_ROOT%{_var}/{log,spool/clamav,lib/clamav} \
28e95a65
ŁK
247 $RPM_BUILD_ROOT%{systemdtmpfilesdir} \
248 $RPM_BUILD_ROOT%{systemdunitdir}
92c5ef39 249
1ac1f471 250%{__make} -C build install \
92c5ef39 251 DESTDIR=$RPM_BUILD_ROOT
c3e2478b 252
142cc22a 253%{!?with_milter:rm -f $RPM_BUILD_ROOT%{_mandir}/man8/clamav-milter.8*}
c3e2478b
JB
254# packged as %doc
255%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/html
92c5ef39 256
1ac1f471 257%if %{with static_libs}
c3e2478b
JB
258%{__mv} $RPM_BUILD_ROOT%{_libdir}/libclamav{_static,}.a
259%{__mv} $RPM_BUILD_ROOT%{_libdir}/libfreshclam{_static,}.a
1ac1f471
AM
260%endif
261
d78cc52a 262cat <<'EOF' >$RPM_BUILD_ROOT/etc/cron.d/%{name}
719d471d 2635 * * * * root %{_sbindir}/clamav-cron-updatedb
ca57b115 264EOF
92c5ef39 265
9279da12 266install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/clamd
4381c9a3 267%if %{with milter}
9279da12
ER
268install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/clamav-milter
269cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/clamav-milter
4381c9a3 270%endif
9279da12
ER
271cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/clamd
272install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sbindir}/clamav-cron-updatedb
5dcc5881
AM
273for i in $RPM_BUILD_ROOT%{_sysconfdir}/*.conf.sample; do
274 mv $i ${i%%.sample}
275done
9279da12 276cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
2b9f3e64 277
9279da12 278install -p %{SOURCE8} $RPM_BUILD_ROOT%{_sbindir}
4460ff0b 279
e335899e 280cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
24adbaa3 281
e335899e 282cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
e5b99e12
JK
283cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/cronjob-%{name}.timer
284sed -e's#@sbindir@#%{_sbindir}#' < %{SOURCE13} > $RPM_BUILD_ROOT%{systemdunitdir}/cronjob-%{name}.service
28e95a65 285
c935072a
MK
286# NOTE: clamd uses sane rights to it's clamd.pid file
287# So better keep it dir
288# If it is fixed use of dir will be unecesary
d78cc52a 289install -d $RPM_BUILD_ROOT/var/run/%{name}
c935072a 290
d78cc52a 291:> $RPM_BUILD_ROOT/var/log/freshclam.log
ef21d0fa 292
e6c034d3 293%clean
92c5ef39 294rm -rf $RPM_BUILD_ROOT
e6c034d3 295
c935072a 296%triggerin -- amavis-ng
50d65e20 297%addusertogroup -q clamav amavis
c935072a
MK
298
299%triggerin -- amavisd-new
50d65e20 300%addusertogroup -q clamav amavis
c935072a
MK
301
302%triggerin -- amavisd
50d65e20 303%addusertogroup -q clamav amavis
c935072a 304
e278889f 305%pre
236dddf1
ER
306%groupadd -g 43 clamav
307%useradd -u 43 -d /tmp -s /bin/false -c "Clam Anti Virus Checker" -g clamav clamav
174915c1 308
66d1575d 309%post
66d1575d 310/sbin/chkconfig --add clamd
dd6d36d5 311%service clamd restart "Clam Antivirus daemon"
d78cc52a
ER
312touch /var/log/freshclam.log
313chown clamav:root /var/log/freshclam.log
314chmod 640 /var/log/freshclam.log
e5b99e12 315%systemd_post clamd.service cronjob-clamav.timer
66d1575d 316
66d1575d 317%preun
318if [ "$1" = "0" ]; then
dd6d36d5 319 %service clamd stop
66d1575d 320 /sbin/chkconfig --del clamd
321fi
e5b99e12 322%systemd_preun clamd.service cronjob-clamav.timer
e6c034d3 323
0c8c3ba4 324%postun
174915c1 325if [ "$1" = "0" ]; then
49797116 326 %userremove clamav
327 %groupremove clamav
174915c1 328fi
28e95a65 329%systemd_reload
174915c1 330
01a1fe23 331%triggerpostun -- %{name} < 0.99.2-2
1eab800a 332if [ -f /etc/clamav.conf.rpmsave ]; then
d093ed8c 333 echo "Renaming config to new name /etc/clamd.conf"
334 mv -f /etc/clamd.conf /etc/clamd.conf.rpmnew
335 mv -f /etc/clamav.conf.rpmsave /etc/clamd.conf
d4117574 336 echo "Changing config location in freshclam config"
f12ca2c1
ER
337 %{__sed} -i -e 's/clamav.conf/clamd.conf/' /etc/freshclam.conf
338fi
339
29f80fd8
ER
340%{__cp} -f /etc/clamd.conf{,.rpmsave}
341%{__sed} -i -e '
342 s,^LogSyslog$,& yes,
343 s,^FixStaleSocket$,& yes,
344 s,^AllowSupplementaryGroups$,& yes,
345 s,^ClamukoScanOnOpen$,& yes,
346 s,^ClamukoScanOnClose$,& yes,
347 s,^ClamukoScanOnExec$,& yes,
3bc0b921
AM
348 s,^LogTime$,& yes,
349 s,^ScanPE$,& yes,
29f80fd8
ER
350' /etc/clamd.conf
351%banner -e %{name}-0.90 <<EOF
352ClamAV config was automatically upgraded to 0.90 format. You should review it
353that it's still valid.
354EOF
355#'
356# unfortunately clamd has no configcheck option so we just have to start it
357# once again after config was broken after upgrade
358touch /var/lock/subsys/clamd
359%service -q clamd restart
1eab800a 360
c9909b3e 361%systemd_trigger clamd.service cronjob-clamav.timer
e5b99e12 362
eba74cc1 363%post milter
364/sbin/chkconfig --add clamav-milter
dd6d36d5 365%service clamav-milter restart "Clam Antivirus daemon"
eba74cc1 366
4c570814 367%preun milter
eba74cc1 368if [ "$1" = "0" ]; then
dd6d36d5 369 %service clamav-milter stop
eba74cc1 370 /sbin/chkconfig --del clamav-milter
371fi
fba342ab 372
1475e7a3 373%post libs -p /sbin/ldconfig
374%postun libs -p /sbin/ldconfig
4460ff0b 375
e6c034d3 376%files
377%defattr(644,root,root,755)
a4e64f4e 378%doc ChangeLog.md NEWS.md README.md
79125c5b 379%attr(755,root,root) %{_bindir}/clambc
24f68046 380%attr(755,root,root) %{_bindir}/clamdscan
40002522 381%attr(755,root,root) %{_bindir}/clamdtop
24f68046 382%attr(755,root,root) %{_bindir}/clamscan
d03f44fa 383%attr(755,root,root) %{_bindir}/clamsubmit
24f68046 384%attr(755,root,root) %{_bindir}/freshclam
385%attr(755,root,root) %{_bindir}/sigtool
d78cc52a 386%attr(755,root,root) %{_bindir}/clamconf
24f68046 387%attr(755,root,root) %{_sbindir}/clamav-cron-updatedb
c8321415 388%attr(755,root,root) %{_sbindir}/clamav-post-updatedb
8cdcf5e0
JB
389%attr(755,root,root) %{_sbindir}/clamd
390%attr(755,root,root) %{_sbindir}/clamonacc
839be9e8 391%{systemdtmpfilesdir}/%{name}.conf
8cdcf5e0 392%{systemdunitdir}/clamav-clamonacc.service
f63e74d3
AG
393%{systemdunitdir}/clamav-daemon.service
394%{systemdunitdir}/clamav-daemon.socket
395%{systemdunitdir}/clamav-freshclam.service
09a96373 396%{systemdunitdir}/clamd.service
e5b99e12
JK
397%{systemdunitdir}/cronjob-clamav.service
398%{systemdunitdir}/cronjob-clamav.timer
ca57b115 399%attr(755,clamav,root) %dir /var/lib/%{name}
d78cc52a
ER
400%attr(640,clamav,root) %ghost /var/log/freshclam.log
401%attr(750,clamav,clamav) %dir /var/run/%{name}
c935072a 402
b5177881 403%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
0e86f481
JB
404%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/clamd.conf
405%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freshclam.conf
6586d93d 406
05eb87ef 407%attr(754,root,root) /etc/rc.d/init.d/clamd
7c801993
ER
408%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clamd
409%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/clamav
8cdcf5e0
JB
410%{_mandir}/man1/clambc.1*
411%{_mandir}/man1/clamconf.1*
412%{_mandir}/man1/clamdscan.1*
413%{_mandir}/man1/clamdtop.1*
414%{_mandir}/man1/clamscan.1*
415%{_mandir}/man1/clamsubmit.1*
416%{_mandir}/man1/freshclam.1*
417%{_mandir}/man1/sigtool.1*
418%{_mandir}/man5/clamd.conf.5*
419%{_mandir}/man5/freshclam.conf.5*
420%{_mandir}/man8/clamd.8*
421%{_mandir}/man8/clamonacc.8*
eba74cc1 422
423%if %{with milter}
424%files milter
425%defattr(644,root,root,755)
7c801993 426%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clamav-milter
a2a93243 427%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/clamav-milter.conf
491eb046 428%attr(754,root,root) /etc/rc.d/init.d/clamav-milter
eba74cc1 429#%attr(755,root,root) %{_sysconfdir}/cron.daily/clamav-milter
a2a93243 430%attr(755,root,root) %{_sbindir}/clamav-milter
8cdcf5e0 431%{_mandir}/man5/clamav-milter.conf.5*
eba74cc1 432%{_mandir}/man8/clamav-milter.8*
0e86f481 433%attr(700,clamav,clamav) /var/spool/clamav
eba74cc1 434%endif
4460ff0b
AM
435
436%files libs
437%defattr(644,root,root,755)
418bf14a 438%attr(755,root,root) %{_libdir}/libclamav.so.*.*.*
f63e74d3 439%attr(755,root,root) %ghost %{_libdir}/libclamav.so.9
d1044716 440%if %{without system_libmspack}
a4e64f4e
AM
441%attr(755,root,root) %{_libdir}/libclammspack.*.*.*
442%attr(755,root,root) %ghost %{_libdir}/libclammspack.so.0
d1044716 443%endif
418bf14a 444%attr(755,root,root) %{_libdir}/libclamunrar.so.*.*.*
f63e74d3 445%attr(755,root,root) %ghost %{_libdir}/libclamunrar.so.9
418bf14a 446%attr(755,root,root) %{_libdir}/libclamunrar_iface.so.*.*.*
f63e74d3 447%attr(755,root,root) %ghost %{_libdir}/libclamunrar_iface.so.9
e63bc447
AG
448%attr(755,root,root) %{_libdir}/libfreshclam.so.*.*.*
449%attr(755,root,root) %ghost %{_libdir}/libfreshclam.so.2
4460ff0b
AM
450
451%files devel
452%defattr(644,root,root,755)
24f68046 453%attr(755,root,root) %{_bindir}/clamav-config
418bf14a 454%attr(755,root,root) %{_libdir}/libclamav.so
d1044716 455%if %{without system_libmspack}
a4e64f4e 456%attr(755,root,root) %{_libdir}/libclammspack.so
d1044716 457%endif
418bf14a 458%attr(755,root,root) %{_libdir}/libclamunrar.so
e63bc447 459%attr(755,root,root) %{_libdir}/libfreshclam.so
418bf14a 460%attr(755,root,root) %{_libdir}/libclamunrar_iface.so
0e6f5de4
AG
461%dir %{_includedir}/clamav
462%{_includedir}/clamav/clamav.h
18033221 463%{_includedir}/clamav/clamav-types.h
e63bc447
AG
464%{_includedir}/clamav/clamav-version.h
465%{_includedir}/clamav/libfreshclam.h
418bf14a 466%{_pkgconfigdir}/libclamav.pc
4460ff0b
AM
467
468%files static
469%defattr(644,root,root,755)
418bf14a 470%{_libdir}/libclamav.a
d1044716 471%if %{without system_libmspack}
a4e64f4e 472%{_libdir}/libclammspack.a
d1044716 473%endif
e63bc447 474%{_libdir}/libfreshclam.a
c3e2478b
JB
475
476%files doc
477%defattr(644,root,root,755)
478%doc docs/html/*
This page took 0.16058 seconds and 4 git commands to generate.