]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
fix nacl building
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
2108baf2
ER
3%bcond_without debuginfo # disable debuginfo creation (it is huge)
4%bcond_without ffmpegsumo # build with ffmpegsumo
8171fe68 5%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 6%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ae3fe89f
ER
7%bcond_without cups # with cups
8%bcond_without gconf # with GConf
9%bcond_without pulseaudio # with pulseaudio
5997e180 10%bcond_without nacl # build Native Client support
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
d8ba130c 15%bcond_with tcmalloc # use tcmalloc
2108baf2 16%bcond_with system_sqlite # with system sqlite
32a2443e 17%bcond_without system_flac # with system flac
e8e15592 18%bcond_without system_libwebp # with system libwebp
32a2443e 19%bcond_without system_speex # with system speex
c14cd342 20%bcond_with system_v8 # with system v8
32a2443e 21%bcond_without system_vpx # with system vpx
d617ab39 22%bcond_without system_yasm # with system yasm
2108baf2 23%bcond_without system_zlib # with system zlib
5997e180 24%bcond_without libjpegturbo # use libjpeg-turbo features
2108baf2 25%bcond_with verbose # verbose build (V=1)
0c480b89 26
6d92f81c 27# TODO
f1b276d4 28# - check system sqlite linking problems
2108baf2 29# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 30# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 31# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 32# - use_system_hunspell
32a2443e 33# - use_system_stlport
a3140cd1
ER
34# - other defaults: src/build/common.gypi
35
e53ecfb5 36# NOTES:
4fe038cb
ER
37# - mute BEEP mixer if you do not want to hear horrible system bell when
38# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
39# - build -bp: 1.2G
40# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 41# - build x86_64: ~1.9G
f1b276d4 42# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 43# - to look for new tarball, use update-source.sh script
f1b276d4 44
e68aa7e7 45# NOTE TO USERS:
a3cc7091
ER
46# To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
47# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 48# or:
a3cc7091 49# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
e68aa7e7 50
a3140cd1 51%define gyp_rev 1014
11ad81c4 52Summary: A WebKit powered web browser
05f72ae2 53Name: chromium-browser
dd1509bd 54Version: 21.0.1180.57
c0808220 55Release: 1
05f72ae2 56License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 57Group: X11/Applications/Networking
daa4a66c 58Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.tar.xz
dd1509bd 59# Source0-md5: 15242c061905204e93cd364a5db954cc
37ceaf05 60Source1: %{name}.default
8b53130d
ER
61Source2: %{name}.sh
62Source3: %{name}.desktop
56c6e811
ER
63Source5: find-lang.sh
64Source6: update-source.sh
65Source7: clean-source.sh
836b1cac 66Source8: get-source.sh
48b341f5 67Patch0: system-libs.patch
68Patch1: plugin-searchdirs.patch
69Patch2: gyp-system-minizip.patch
7abc645c 70Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 71Patch4: path-libpdf.patch
48b341f5 72Patch5: options-support.patch
0e5636cb 73Patch6: get-webkit_revision.patch
5aa5df39 74Patch7: dlopen_sonamed_gl.patch
4765ddf1 75Patch8: chromium_useragent.patch.in
c0808220 76Patch9: chromium-ppapi.patch
1347c76c
AM
77# https://bugs.gentoo.org/show_bug.cgi?id=393471
78# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 79Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
80Patch15: nacl-build-irt.patch
81Patch16: nacl-linkingfix.patch
750b48f7 82URL: http://www.chromium.org/Home
ae3fe89f 83%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 84BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
85BuildRequires: alsa-lib-devel
86BuildRequires: atk-devel
87BuildRequires: bison
11ad81c4 88BuildRequires: bzip2-devel
5997e180
ER
89%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
90%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
91%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
92%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.18.0}
ae3fe89f 93%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 94BuildRequires: dbus-glib-devel
77f32fa3 95BuildRequires: expat-devel
d617ab39 96%{?with_system_flac:BuildRequires: flac-devel}
11ad81c4 97BuildRequires: flex
11ad81c4 98BuildRequires: fontconfig-devel
f1b276d4 99BuildRequires: glib2-devel
05f72ae2 100BuildRequires: gperf
8b53130d 101BuildRequires: gtk+2-devel
a3140cd1 102%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 103BuildRequires: hicolor-icon-theme
05f72ae2 104BuildRequires: libevent-devel
7f40f3f4 105%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 106BuildRequires: libicu-devel >= 4.6
39c71b4c 107%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 108%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 109BuildRequires: libpng-devel
e266589e 110%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 111BuildRequires: libstdc++-devel
32a2443e 112%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 113%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 114BuildRequires: libxml2-devel
11ad81c4 115BuildRequires: libxslt-devel
f1b276d4 116BuildRequires: lzma
11ad81c4 117BuildRequires: minizip-devel
05f72ae2 118BuildRequires: nspr-devel
f1b276d4 119BuildRequires: nss-devel >= 1:3.12.3
35902862 120BuildRequires: pam-devel
f1b276d4 121BuildRequires: pango-devel
48b341f5 122BuildRequires: perl-modules
123BuildRequires: pkgconfig
ae3fe89f 124%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 125BuildRequires: python
46cdefee 126#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 127BuildRequires: python-modules
0cad051b 128BuildRequires: rpm >= 4.4.9-56
f1b276d4 129BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 130%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 131BuildRequires: sqlite3-devel >= 3.6.1
89f0dde4 132BuildRequires: subversion
0cad051b 133BuildRequires: tar >= 1:1.22
0a424ee2 134BuildRequires: udev-devel
2303ed45 135BuildRequires: util-linux
c14cd342 136%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 137BuildRequires: which
f1b276d4 138BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
139BuildRequires: xorg-lib-libXt-devel
140BuildRequires: xorg-lib-libXtst-devel
836b1cac 141BuildRequires: xz
a3140cd1 142%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 143%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 144Requires: browser-plugins >= 2.0
0cad051b 145Requires: desktop-file-utils
0eb19b0b 146Requires: hicolor-icon-theme
c1edaafa 147%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 148%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 149Requires: xdg-utils >= 1.0.2-4
e53ecfb5 150Provides: wwwbrowser
c3582150 151Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 152Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 153ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 154BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 155
589d90ea 156%define find_lang sh find-lang.sh %{buildroot}
e7fa0817
ER
157# Usage: gyp_with BCOND_NAME [OPTION_NAME]
158%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 159
6b113615
ER
160%if %{without debuginfo}
161%define _enable_debug_packages 0
162%endif
163
11ad81c4 164%description
80838854
ER
165Chromium is an open-source browser project that aims to build a safer,
166faster, and more stable way for all Internet users to experience the
167web.
168
169Chromium serves as a base for Google Chrome, which is Chromium
170rebranded (name and logo) with very few additions such as usage
171tracking and an auto-updater system.
172
f1b276d4
ER
173%package l10n
174Summary: chromium-browser language packages
175Group: I18n
176Requires: %{name} = %{version}-%{release}
177
178%description l10n
179Chromium is an open-source browser project that aims to build a safer,
180faster, and more stable way for all Internet users to experience the
181web.
182
183This package contains language packages for 50 languages:
184
e7fa0817
ER
185ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
186he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
187pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
188zh-TW
f1b276d4
ER
189
190%prep
836b1cac 191%setup -q
589d90ea 192
05f72ae2
ER
193# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
194# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
195. ./src/chrome/VERSION
196ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
197test "$ver" = %{version}
198
199gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 200test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 201
836b1cac 202v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 203
f1b276d4 204# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
836b1cac 205#echo "%{svnver}" > src/build/LASTCHANGE.in
f1b276d4 206
4765ddf1
ER
207# add chromium and pld to useragent
208%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
209sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
210 -e 's/@BUILD_DIST_NAME@/PLD/g' \
211 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 212 < %{PATCH8} | %{__patch} -p1
4765ddf1 213
56c6e811
ER
214%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
215ln -s %{SOURCE7} src
f1b276d4 216
05f72ae2
ER
217%patch0 -p1
218%patch1 -p1
219%patch2 -p1
7abc645c 220%patch3 -p1
72cb20c1 221%patch4 -p1
05f72ae2 222%patch5 -p1
0e5636cb 223%patch6 -p1
5aa5df39 224%patch7 -p1
77f32fa3 225cd src
c0808220 226%patch9 -p0
f4a8da6a 227%{!?with_libjpegturbo:%patch11 -p0}
5997e180
ER
228%patch15 -p1
229%patch16 -p1
1347c76c 230cd ..
0c480b89 231
828bdd1a 232cd src
f8e29f37 233sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0
164020eb 234
e266589e 235%build
f1b276d4 236cd src
5997e180
ER
237
238%if %{with nacl}
239rm -rf native_client/toolchain/linux_x86_newlib
240# Make symlinks for nacl
241cd native_client/toolchain
242install -d linux_x86_newlib/x86_64-nacl/bin
243install -d linux_x86_newlib/x86_64-nacl/lib
244install -d linux_x86_newlib/x86_64-nacl/lib32
245install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
246install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
247install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
c0808220
ER
248# link newlib toolchain to glibc as well, see gentoo bug #417019
249#ln -s linux_x86_newlib linux_x86
5997e180
ER
250cd linux_x86_newlib/x86_64-nacl/bin
251ln -s %{_bindir}/x86_64-nacl-gcc gcc
252ln -s %{_bindir}/x86_64-nacl-g++ g++
253ln -s %{_bindir}/x86_64-nacl-ar ar
254ln -s %{_bindir}/x86_64-nacl-as as
255ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
256ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
257ln -s %{_bindir}/x86_64-nacl-strip strip
258ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
259ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
260cd ../nacl/include
261for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
262 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
263done
264cd ../../../../../..
265%endif
266
164020eb 267test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
268%ifarch %{ix86}
269 -Dtarget_arch=ia32 \
270%endif
271%ifarch %{x8664}
0c480b89
ER
272 -Dtarget_arch=x64 \
273%endif
7b454a31
AM
274%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
275 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
276%endif
277%if %{with sandboxing}
278 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
279 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
280%endif
281 %{!?debug:-Dwerror=} \
c980b122 282 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 283 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 284 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
285 -Dffmpeg_branding=Chrome \
286 -Dproprietary_codecs=1 \
c0808220
ER
287%if %{with nacl}
288 %{?_:# Disable glibc Native Client toolchain, we don't need it (gentoo bug #417019).} \
289 -Ddisable_glibc=1 \
290%else
291 -Ddisable_nacl=1 \
292%endif
a3140cd1
ER
293 %{!?with_sse2:-Ddisable_sse2=1} \
294 %{?with_selinux:-Dselinux=1} \
e7fa0817
ER
295 %{gyp_with cups} \
296 %{gyp_with flac} \
297 %{gyp_with gconf} \
298 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
299 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
300 %{gyp_with pulseaudio} \
e8e15592 301 %{gyp_with system_libwebp} \
e7fa0817
ER
302 %{gyp_with system_speex} \
303 %{gyp_with system_sqlite} \
304 %{gyp_with system_v8} \
32a2443e 305 %{gyp_with system_vpx} \
e7fa0817
ER
306 %{gyp_with system_yasm} \
307 %{gyp_with system_zlib} \
0c480b89 308 -Duse_system_bzip2=1 \
0b214002 309 -Duse_system_icu=1 \
f1b276d4 310 -Duse_system_libevent=1 \
0c480b89 311 -Duse_system_libjpeg=1 \
f1b276d4
ER
312 -Duse_system_libpng=1 \
313 -Duse_system_libxml=1 \
314 -Duse_system_libxslt=1 \
7f40f3f4 315 -Duse_system_xdg_utils=1 \
d8ba130c 316 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
317 -Dlinux_use_gold_binary=0 \
318 -Dlinux_use_gold_flags=0
11ad81c4 319
f1b276d4
ER
320%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
321 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
322 %{?with_verbose:V=1} \
323 CC="%{__cc}" \
324 CXX="%{__cxx}" \
b7adf6b1 325 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
326 CC.host="%{__cc}" \
327 CXX.host="%{__cxx}" \
b7adf6b1 328 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
329 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
330 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
331
332%install
333rm -rf $RPM_BUILD_ROOT
56c6e811 334install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 335 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 336
f1b276d4 337cd src/out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 338cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
339install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
340%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 341cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 342cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 343install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 344install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 345%if %{with ffmpegsumo}
f1b276d4 346install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 347%endif
e7fa0817 348cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb 349
c0808220
ER
350%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
351
164020eb
ER
352%if %{with nacl}
353# Install Native Client files on platforms that support it.
354install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
355install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
356%ifarch %{x8664}
357install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
358%endif
359%ifarch %{ix86}
360install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
361%endif
362%endif
363
0c480b89
ER
364cd -
365
0eb19b0b
ER
366for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
367 size=${icon##*/product_logo_}
368 size=${size%.png}
369
370 # this will skip non-numeric (22_mono_invert, 22_mono)
371 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
372 test -d "$dir" || continue
373
374 install -d $RPM_BUILD_ROOT$dir
375 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
376done
7f40f3f4 377
13840bc2
AM
378%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
379# http://code.google.com/p/chromium/issues/detail?id=24507
380gecko-mediaplayer*.so
381EOF
11ad81c4 382
589d90ea
ER
383# find locales
384%find_lang %{name}.lang
e7fa0817 385# always package en-US
f1b276d4 386%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 387
11ad81c4
AM
388%clean
389rm -rf $RPM_BUILD_ROOT
390
f1b276d4 391%post
0eb19b0b 392%update_icon_cache hicolor
b7a6e4ee 393%update_desktop_database
f1b276d4
ER
394%update_browser_plugins
395
396%postun
397if [ "$1" = 0 ]; then
0eb19b0b 398 %update_icon_cache hicolor
f1b276d4
ER
399 %update_browser_plugins
400fi
401
589d90ea 402%files -f %{name}.lang
11ad81c4 403%defattr(644,root,root,755)
f1b276d4
ER
404%{_browserpluginsconfdir}/browsers.d/%{name}.*
405%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
406%dir %{_sysconfdir}/%{name}
407%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
f1b276d4
ER
408%attr(755,root,root) %{_bindir}/%{name}
409%{_mandir}/man1/%{name}.1*
11ad81c4 410%{_desktopdir}/*.desktop
0eb19b0b 411%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89
ER
412%dir %{_libdir}/%{name}
413%{_libdir}/%{name}/chrome.pak
c14cd342 414%{_libdir}/%{name}/content_resources.pak
97fac491 415%{_libdir}/%{name}/resources.pak
bbe92394
AM
416%{_libdir}/%{name}/theme_resources_standard.pak
417%{_libdir}/%{name}/ui_resources_standard.pak
589d90ea 418%dir %{_libdir}/%{name}/locales
f1b276d4
ER
419%{_libdir}/%{name}/locales/en-US.pak
420%dir %{_libdir}/%{name}/resources
a3140cd1 421%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
422%dir %{_libdir}/%{name}/themes
423%dir %{_libdir}/%{name}/extensions
424%dir %{_libdir}/%{name}/plugins
425%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 426# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 427%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
428
429# ffmpeg libs
d561483d 430%if %{with ffmpegsumo}
f1b276d4 431%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 432%endif
f1b276d4 433
164020eb
ER
434%if %{with nacl}
435%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
436%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
437%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
438%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
439%endif
440
f1b276d4
ER
441%files l10n -f %{name}.lang
442%defattr(644,root,root,755)
This page took 0.167504 seconds and 4 git commands to generate.