]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
distfiles fix; rel 1
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 8%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 9%bcond_without nacl # build Native Client support
ba685303 10%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
ba685303 15%bcond_without system_flac # system flac
7d0dbc8d 16%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
01b4dc8e 17%bcond_with system_harfbuzz # system harfbuzz
ba685303 18%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
19%bcond_without system_libexif # system libexif
20%bcond_without system_libmtp # system libmtp
ba685303
ER
21%bcond_without system_libusb # system libusb-1
22%bcond_without system_libwebp # system libwebp
4884fc99 23%bcond_without system_libxnvctrl # system libxnvctrl
126ea630 24%bcond_without system_minizip # system minizip
62950103 25%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
75a27c2e 26%bcond_with system_protobuf # system protobuf
ba685303
ER
27%bcond_without system_speex # system speex
28%bcond_with system_sqlite # system sqlite
9bd2659c 29%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 30%bcond_with system_v8 # system v8
4b411ffe 31%bcond_without system_libvpx # system libvpx
ba685303 32%bcond_without system_yasm # system yasm
1c00315b 33%bcond_without system_zlib # system zlib
d2781a31 34%bcond_without tcmalloc # use tcmalloc
7e136323 35%bcond_without verbose # verbose build (V=1)
0c480b89 36
c6325ea2
ER
37%if %{with nacl}
38# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42#14:51:06 @baggins> as-needed will take care of unneeded lib
43#14:52:03 @baggins> -lssp comes with gcc
107b55fe 44%define _ssp_cflags %{nil}
c6325ea2
ER
45%endif
46
6d92f81c 47# TODO
f1b276d4 48# - check system sqlite linking problems
2108baf2 49# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 50# - use_system_ssl (use_openssl: http://crbug.com/62803)
d617ab39 51# - use_system_hunspell
32a2443e 52# - use_system_stlport
a3140cd1
ER
53# - other defaults: src/build/common.gypi
54
e53ecfb5 55# NOTES:
4fe038cb
ER
56# - mute BEEP mixer if you do not want to hear horrible system bell when
57# pressing home/end in url bar or more ^F search results on page.
7c638678 58# - space considerations:
6d877f0c 59# - unpacked sources: ~574MiB
c1ecd31f 60# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 61# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 62# - to look for new tarball, use update-source.sh script
f1b276d4 63
e68aa7e7 64# NOTE TO USERS:
c8b02491 65# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 66# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 67# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 68
2a415062
ER
69%define branch 24.0.1312
70%define basever 52
f73369da 71%define patchver %{nil}
a3140cd1 72%define gyp_rev 1014
11ad81c4 73Summary: A WebKit powered web browser
05f72ae2 74Name: chromium-browser
f73369da
ER
75%if "%{?patchver}" != ""
76Version: %{branch}.%{patchver}
77%else
78Version: %{branch}.%{basever}
79%endif
80Release: 1
05f72ae2 81License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 82Group: X11/Applications/Networking
3c73e180 83Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
24623500 84# Source0-md5: bcc3976e61b9ce715ba9c85d46df72f1
3c73e180
ER
85%if "%{?patchver}" != ""
86Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
d0d8739b 87# Patch0-md5: 2f4e98e37053705fd86ffcb49f1f2247
3c73e180 88%endif
37ceaf05 89Source1: %{name}.default
8b53130d
ER
90Source2: %{name}.sh
91Source3: %{name}.desktop
56c6e811
ER
92Source5: find-lang.sh
93Source6: update-source.sh
94Source7: clean-source.sh
836b1cac 95Source8: get-source.sh
0562b864 96Source9: master_preferences.json
48b341f5 97Patch1: plugin-searchdirs.patch
70258ccd 98#Patch2: system-nspr.patch
7abc645c 99Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 100Patch4: path-libpdf.patch
0e5636cb 101Patch6: get-webkit_revision.patch
5aa5df39 102Patch7: dlopen_sonamed_gl.patch
4765ddf1 103Patch8: chromium_useragent.patch.in
c0808220 104Patch9: chromium-ppapi.patch
8456d676 105Patch10: system-libxnvctrl.patch
1347c76c
AM
106# https://bugs.gentoo.org/show_bug.cgi?id=393471
107# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 108Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
109Patch15: nacl-build-irt.patch
110Patch16: nacl-linkingfix.patch
9516ca97 111Patch18: nacl-no-untar.patch
08b25440 112Patch19: system-jsoncpp.patch
126ea630 113Patch22: pulse_fix-157876.patch
8fb1dc98 114Patch23: no-pnacl.patch
6897926c 115Patch24: nacl-verbose.patch
c5b396f3
ER
116Patch25: gnome3-volume-control.patch
117Patch26: master-prefs-path.patch
d2781a31 118Patch27: tcmalloc-glibc2.16.patch
750b48f7 119URL: http://www.chromium.org/Home
ae3fe89f 120%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 121BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
122BuildRequires: alsa-lib-devel
123BuildRequires: atk-devel
124BuildRequires: bison
11ad81c4 125BuildRequires: bzip2-devel
5997e180
ER
126%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
127%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
128%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 129%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 130%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 131BuildRequires: dbus-glib-devel
77f32fa3 132BuildRequires: expat-devel
7d0dbc8d 133%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 134%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 135BuildRequires: flex
11ad81c4 136BuildRequires: fontconfig-devel
f1b276d4 137BuildRequires: glib2-devel
05f72ae2 138BuildRequires: gperf
bbad64b7 139BuildRequires: gtest-devel
8b53130d 140BuildRequires: gtk+2-devel
01b4dc8e 141%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 142%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 143BuildRequires: hicolor-icon-theme
ed514974 144%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
8456d676 145%{?with_system_libxvnctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 146BuildRequires: libevent-devel
8456d676 147%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 148%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 149BuildRequires: libicu-devel >= 4.6
39c71b4c 150%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 151%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 152%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 153BuildRequires: libpng-devel
e266589e 154%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 155BuildRequires: libstdc++-devel
ba685303 156%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 157%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 158%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 159BuildRequires: libxml2-devel
11ad81c4 160BuildRequires: libxslt-devel
f1b276d4 161BuildRequires: lzma
62950103 162%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 163BuildRequires: nspr-devel
f1b276d4 164BuildRequires: nss-devel >= 1:3.12.3
8456d676 165%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 166BuildRequires: pam-devel
f1b276d4 167BuildRequires: pango-devel
48b341f5 168BuildRequires: perl-modules
169BuildRequires: pkgconfig
75a27c2e 170%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 171%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 172BuildRequires: python
46cdefee 173#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 174BuildRequires: python-modules
0cad051b 175BuildRequires: rpm >= 4.4.9-56
f1b276d4 176BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 177%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 178BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 179%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 180BuildRequires: subversion
0cad051b 181BuildRequires: tar >= 1:1.22
0a424ee2 182BuildRequires: udev-devel
2303ed45 183BuildRequires: util-linux
c14cd342 184%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 185BuildRequires: which
f1b276d4 186BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
187BuildRequires: xorg-lib-libXt-devel
188BuildRequires: xorg-lib-libXtst-devel
836b1cac 189BuildRequires: xz
a3140cd1 190%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 191%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 192Requires: browser-plugins >= 2.0
0cad051b 193Requires: desktop-file-utils
8f5f6775 194%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 195Requires: hicolor-icon-theme
c1edaafa 196%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 197%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
4dc49133 198Requires: xdg-utils >= 1.0.2-4
e53ecfb5 199Provides: wwwbrowser
c3582150 200Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 201Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 202ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 203BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 204
589d90ea 205%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 206
e7fa0817
ER
207# Usage: gyp_with BCOND_NAME [OPTION_NAME]
208%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 209
6b113615
ER
210%if %{without debuginfo}
211%define _enable_debug_packages 0
212%endif
213
11ad81c4 214%description
80838854
ER
215Chromium is an open-source browser project that aims to build a safer,
216faster, and more stable way for all Internet users to experience the
217web.
218
219Chromium serves as a base for Google Chrome, which is Chromium
220rebranded (name and logo) with very few additions such as usage
221tracking and an auto-updater system.
222
f1b276d4
ER
223%package l10n
224Summary: chromium-browser language packages
225Group: I18n
226Requires: %{name} = %{version}-%{release}
227
228%description l10n
229Chromium is an open-source browser project that aims to build a safer,
230faster, and more stable way for all Internet users to experience the
231web.
232
233This package contains language packages for 50 languages:
234
e7fa0817
ER
235ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
236he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
237pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
238zh-TW
f1b276d4
ER
239
240%prep
3c73e180
ER
241%setup -qc
242%if "%{?patchver}" != ""
243cd %{name}-%{branch}.%{basever}
244%patch0 -p1
245cd ..
246%endif
247mv %{name}-%{branch}.%{basever}/src .
589d90ea 248
05f72ae2
ER
249# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
250# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
251. ./src/chrome/VERSION
252ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
253test "$ver" = %{version}
254
255gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 256test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 257
836b1cac 258v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 259
4765ddf1
ER
260# add chromium and pld to useragent
261%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
262sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
263 -e 's/@BUILD_DIST_NAME@/PLD/g' \
264 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 265 < %{PATCH8} | %{__patch} -p1
4765ddf1 266
56c6e811
ER
267%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
268ln -s %{SOURCE7} src
f1b276d4 269
05f72ae2 270%patch1 -p1
7abc645c 271%patch3 -p1
72cb20c1 272%patch4 -p1
0e5636cb 273%patch6 -p1
5aa5df39 274%patch7 -p1
e9abb380 275%patch15 -p1
77f32fa3 276cd src
c0808220 277%patch9 -p0
70258ccd 278#%patch2 -p1
f4a8da6a 279%{!?with_libjpegturbo:%patch11 -p0}
5997e180 280%patch16 -p1
08b25440 281%patch19 -p1
2d6e464b 282%patch22 -p1
c5b396f3 283%patch25 -p1
d2781a31 284%patch27 -p1
1347c76c 285cd ..
9516ca97 286%patch18 -p1
0562b864 287%patch23 -p1
6897926c 288%patch24 -p1
c5b396f3 289%patch26 -p1
0c480b89 290
828bdd1a 291cd src
e9abb380
ER
292
293# Missing gyp files in tarball.
294# https://code.google.com/p/chromium/issues/detail?id=144823
295if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
296 echo "tarball fixed, please remove workaround"
297 exit 1
298fi
299
300install -d chrome/test/data/nacl
301cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
302{
303 'targets': [
304 {
305 'target_name': 'nacl_tests',
306 'type': 'none',
307 },
308 ],
309}
310EOF
311
75a27c2e
ER
312sh -x clean-source.sh \
313 %{!?with_nacl:nacl=0} \
314 %{!?with_system_protobuf:protobuf=0} \
315 %{!?with_system_v8:v8=0} \
316 %{!?with_system_zlib:zlib=0} \
317 %{nil}
fded59be 318
e266589e 319%build
f1b276d4 320cd src
5997e180
ER
321
322%if %{with nacl}
fded59be 323if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b
ER
324# Make symlinks for NaCL
325install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
2e4113fd 326
dcea0d6b 327cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
2e4113fd 328__cc='%{__cc}'
f64e73f6 329if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
330 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
331 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
332 %{__sed} -i -e '1i#!/bin/sh' gcc g++
333 chmod +x gcc g++
334else
335 ln -s %{_bindir}/x86_64-nacl-gcc gcc
336 ln -s %{_bindir}/x86_64-nacl-g++ g++
337fi
5997e180
ER
338ln -s %{_bindir}/x86_64-nacl-ar ar
339ln -s %{_bindir}/x86_64-nacl-as as
340ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
341ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
342ln -s %{_bindir}/x86_64-nacl-strip strip
dcea0d6b
ER
343ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
344ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
345ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
346cd ../../../../..
fded59be 347fi
5997e180
ER
348%endif
349
c5b396f3 350test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
673aee14
ER
351test -e Makefile || %{__python} build/gyp_chromium \
352 --format=make \
353 -Goutput_dir=../out \
354 build/all.gyp \
f1b276d4
ER
355%ifarch %{ix86}
356 -Dtarget_arch=ia32 \
357%endif
358%ifarch %{x8664}
0c480b89
ER
359 -Dtarget_arch=x64 \
360%endif
7b454a31
AM
361%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
362 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
363%endif
364%if %{with sandboxing}
365 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
366 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
367%endif
368 %{!?debug:-Dwerror=} \
c980b122 369 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 370 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 371 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 372 -Dinclude_tests=0 \
c0808220 373%if %{with nacl}
038f76b9 374 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
375 -Ddisable_glibc_untar=1 \
376 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
377 -Ddisable_glibc=1 \
378 -Ddisable_pnacl=1 \
379 -Dbuild_pnacl_newlib=0 \
c0808220 380%else
8fb1dc98 381 -Ddisable_pnacl_untar=1 \
c0808220
ER
382 -Ddisable_nacl=1 \
383%endif
a3140cd1
ER
384 %{!?with_sse2:-Ddisable_sse2=1} \
385 %{?with_selinux:-Dselinux=1} \
e7fa0817 386 %{gyp_with cups} \
8dda6bbc 387 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
388 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
389 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
390 %{gyp_with pulseaudio} \
7d0dbc8d 391 %{gyp_with system_ffmpeg} \
8f5f6775 392 %{gyp_with system_flac} \
01b4dc8e 393 %{gyp_with system_harfbuzz} \
62950103
ER
394 %{gyp_with system_libexif} \
395 %{gyp_with system_libmtp} \
9bd2659c 396 %{gyp_with system_libsrtp} \
581aec44 397 %{gyp_with system_libusb} \
4b411ffe 398 %{gyp_with system_libvpx} \
ba685303 399 %{gyp_with system_libwebp} \
4884fc99 400 %{gyp_with system_libxnvctrl} \
126ea630 401 %{gyp_with system_minizip} \
62950103 402 %{gyp_with system_opus} \
75a27c2e 403 %{gyp_with system_protobuf} \
e7fa0817
ER
404 %{gyp_with system_speex} \
405 %{gyp_with system_sqlite} \
406 %{gyp_with system_v8} \
407 %{gyp_with system_yasm} \
408 %{gyp_with system_zlib} \
0c480b89 409 -Duse_system_bzip2=1 \
62950103 410 -Duse_system_expat=1 \
0b214002 411 -Duse_system_icu=1 \
f1b276d4 412 -Duse_system_libevent=1 \
0c480b89 413 -Duse_system_libjpeg=1 \
f1b276d4
ER
414 -Duse_system_libpng=1 \
415 -Duse_system_libxml=1 \
416 -Duse_system_libxslt=1 \
7f40f3f4 417 -Duse_system_xdg_utils=1 \
d8ba130c 418 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
419 -Dlinux_use_gold_binary=0 \
420 -Dlinux_use_gold_flags=0
11ad81c4 421
48ffbc5e 422%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
423 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
424 %{?with_verbose:V=1} \
425 CC="%{__cc}" \
426 CXX="%{__cxx}" \
b7adf6b1 427 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
428 CC.host="%{__cc}" \
429 CXX.host="%{__cxx}" \
b7adf6b1 430 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
431 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
432 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
433
434%install
435rm -rf $RPM_BUILD_ROOT
56c6e811 436install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 437 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 438
673aee14 439cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 440cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
441install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
442%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 443cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 444cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 445install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 446install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 447%if %{without system_ffmpeg}
f1b276d4 448install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 449%endif
e7fa0817 450cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 451cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 452
c0808220
ER
453%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
454
164020eb
ER
455%if %{with nacl}
456# Install Native Client files on platforms that support it.
457install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
458install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
459%ifarch %{x8664}
460install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
461%endif
462%ifarch %{ix86}
463install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
464%endif
465%endif
466
0c480b89
ER
467cd -
468
0eb19b0b
ER
469for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
470 size=${icon##*/product_logo_}
471 size=${size%.png}
472
473 # this will skip non-numeric (22_mono_invert, 22_mono)
474 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
475 test -d "$dir" || continue
476
477 install -d $RPM_BUILD_ROOT$dir
478 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
479done
7f40f3f4 480
13840bc2
AM
481%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
482# http://code.google.com/p/chromium/issues/detail?id=24507
483gecko-mediaplayer*.so
484EOF
11ad81c4 485
589d90ea
ER
486# find locales
487%find_lang %{name}.lang
e7fa0817 488# always package en-US
f1b276d4 489%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 490
11ad81c4
AM
491%clean
492rm -rf $RPM_BUILD_ROOT
493
f1b276d4 494%post
0eb19b0b 495%update_icon_cache hicolor
b7a6e4ee 496%update_desktop_database
f1b276d4
ER
497%update_browser_plugins
498
499%postun
500if [ "$1" = 0 ]; then
0eb19b0b 501 %update_icon_cache hicolor
f1b276d4
ER
502 %update_browser_plugins
503fi
504
1d2b9616 505%files
11ad81c4 506%defattr(644,root,root,755)
531537e5 507%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
508%{_browserpluginsconfdir}/browsers.d/%{name}.*
509%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
510%dir %{_sysconfdir}/%{name}
511%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 512%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
513%attr(755,root,root) %{_bindir}/%{name}
514%{_mandir}/man1/%{name}.1*
11ad81c4 515%{_desktopdir}/*.desktop
0eb19b0b 516%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 517%dir %{_libdir}/%{name}
e9abb380 518%{_libdir}/%{name}/chrome*.pak
c14cd342 519%{_libdir}/%{name}/content_resources.pak
97fac491 520%{_libdir}/%{name}/resources.pak
589d90ea 521%dir %{_libdir}/%{name}/locales
f1b276d4
ER
522%{_libdir}/%{name}/locales/en-US.pak
523%dir %{_libdir}/%{name}/resources
a3140cd1 524%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
525%dir %{_libdir}/%{name}/themes
526%dir %{_libdir}/%{name}/extensions
527%dir %{_libdir}/%{name}/plugins
528%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 529# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 530%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
531
532# ffmpeg libs
fcc48c19 533%if %{without system_ffmpeg}
f1b276d4 534%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 535%endif
f1b276d4 536
164020eb
ER
537%if %{with nacl}
538%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
539%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
540%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
541%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
542%endif
543
f1b276d4
ER
544%files l10n -f %{name}.lang
545%defattr(644,root,root,755)
This page took 0.139139 seconds and 4 git commands to generate.